Aktualisieren des Microsoft Quantum Development Kit (QDK)Update the Microsoft Quantum Development Kit (QDK)

Erfahren Sie, wie Sie die Microsoft Quantum Development Kit (QDK) auf die neueste Version aktualisieren.Learn how to update the Microsoft Quantum Development Kit (QDK) to the latest version.

In diesem Artikel wird davon ausgegangen, dass Sie das QDK bereits installiert haben.This article assumes that you already have the QDK installed. Wenn Sie zum ersten Mal installieren, finden Sie weitere Informationen im Installationshandbuch.If you are installing for the first time, then please refer to the installation guide.

Es wird empfohlen, mit der neuesten QDK-Version auf dem neuesten Stand zu bleiben.We recommend keeping up to date with the latest QDK release. Führen Sie dieses Update Handbuch aus, um ein Upgrade auf die neueste Version des QDK auszuführen.Follow this update guide to upgrade to the most recent QDK version. Der Prozess besteht aus zwei Teilen:The process consists of two parts:

  1. Aktualisieren vorhandener Q #-Dateien und-Projekte, um Ihren Code mit einer beliebigen aktualisierten Syntax auszurichtenupdating your existing Q# files and projects to align your code with any updated syntax
  2. Das QDK selbst für die ausgewählte Entwicklungsumgebung wird aktualisiert.updating the QDK itself for your chosen development environment

Aktualisieren von f #-ProjektenUpdating Q# Projects

Unabhängig davon, ob Sie c# oder python zum Hosten von q #-Vorgängen verwenden, befolgen Sie diese Anweisungen, um Ihre q #-Projekte zu aktualisieren.Regardless of whether you are using C# or Python to host Q# operations, follow these instructions to update your Q# projects.

  1. Überprüfen Sie zunächst, ob Sie über die neueste Version des .net Core SDK 3,1verfügen.First, check that you have the latest version of the .NET Core SDK 3.1. Führen Sie den folgenden Befehl an der Eingabeaufforderung aus:Run the following command in the command prompt:

    dotnet --version
    

    Überprüfen Sie, ob die Ausgabe 3.1.100 oder höher ist.Verify the output is 3.1.100 or higher. Falls nicht, installieren Sie die neueste Version , und überprüfen Sie Sie erneut.If not, install the latest version and check again. Befolgen Sie dann die Anweisungen unten abhängig von Ihrem Setup (Visual Studio, Visual Studio Code oder direkt über die Befehlszeile).Then follow the instructions below depending on your setup (Visual Studio, Visual Studio Code, or directly the command line).

Aktualisieren von f #-Projekten in Visual StudioUpdate Q# projects in Visual Studio

  1. Ein Update auf die neueste Version von Visual Studio 2019 finden Sie hier .Update to the latest version of Visual Studio 2019, see here for instructions

  2. Öffnen Sie die Projekt Mappe in Visual StudioOpen your solution in Visual Studio

  3. Wählen Sie im Menü Projekt Mappe Erstellen -> Bereinigen aus.From the menu, select Build -> Clean Solution

  4. Aktualisieren Sie in jeder ihrer csproj-Dateien das Ziel Framework auf netcoreapp3.1 (oder, netstandard2.1 Wenn es sich um ein Bibliotheksprojekt handelt).In each of your .csproj files, update the target framework to netcoreapp3.1 (or netstandard2.1 if it is a library project). Das heißt, Sie bearbeiten die Zeilen in der Form:That is, edit lines of the form:

    <TargetFramework>netcoreapp3.1</TargetFramework>
    

    Weitere Informationen zum Angeben von Ziel Frameworks finden Sie hier.You can find more details on specifying target frameworks here.

  5. Speichern und schließen Sie alle Dateien in der Projekt Mappe.Save and close all files in your solution

  6. Tools -> Befehlszeilefür Tools auswählen -> Developer-EingabeaufforderungSelect Tools -> Command Line -> Developer Command Prompt

  7. Führen Sie für jedes Projekt in der Projekt Mappe den folgenden Befehl aus:For each project in the solution, run the following command:

    dotnet add [project_name].csproj package Microsoft.Quantum.Development.Kit
    

    Wenn Ihre Projekte andere Microsoft. Quantum-Pakete (z. b. Microsoft. Quantum. Numerics) verwenden, führen Sie den Befehl ebenfalls für diese aus.If your projects use any other Microsoft.Quantum packages (e.g. Microsoft.Quantum.Numerics), run the command for these too.

  8. Schließen Sie die Eingabeaufforderung, und wählen Sie Buildprojektmappe Erstellen -> Build Solution (Projekt Mappe neu erstellen) not aus.Close the command prompt and select Build -> Build Solution (do not select Rebuild Solution)

Nun können Sie mit Aktualisieren Ihrer Visual Studio-QDK-Erweiterungfortfahren.You can now skip ahead to update your Visual Studio QDK extension.

Aktualisieren von f #-Projekten in Visual Studio CodeUpdate Q# projects in Visual Studio Code

  1. Öffnen Sie in Visual Studio Code den Ordner mit dem zu Aktualisier nenden Projekt.In Visual Studio Code, open the folder containing the project to update
  2. Wählen Sie Terminal -> neues Terminal aus.Select Terminal -> New Terminal
  3. Befolgen Sie die Anweisungen zum Aktualisieren mithilfe der Befehlszeile (direkt unten).Follow the instructions for updating using the command line (directly below)

Aktualisieren von f #-Projekten mithilfe der BefehlszeileUpdate Q# projects using the command line

  1. Navigieren Sie zu dem Ordner, der die Projektdatei enthält.Navigate to the folder containing your project file

  2. Führen Sie den folgenden Befehl aus:Run the following command:

    dotnet clean [project_name].csproj
    
  3. Aktualisieren Sie in jeder ihrer csproj-Dateien das Ziel Framework auf netcoreapp3.1 (oder, netstandard2.1 Wenn es sich um ein Bibliotheksprojekt handelt).In each of your .csproj files, update the target framework to netcoreapp3.1 (or netstandard2.1 if it is a library project). Das heißt, Sie bearbeiten die Zeilen in der Form:That is, edit lines of the form:

    <TargetFramework>netcoreapp3.1</TargetFramework>
    

    Weitere Informationen zum Angeben von Ziel Frameworks finden Sie hier.You can find more details on specifying target frameworks here.

  4. Führen Sie den folgenden Befehl aus:Run the following command:

    dotnet add package Microsoft.Quantum.Development.Kit
    

    Wenn das Projekt andere Microsoft. Quantum-Pakete (z. b. Microsoft. Quantum. Numerics) verwendet, führen Sie den Befehl ebenfalls für diese aus.If your project uses any other Microsoft.Quantum packages (e.g. Microsoft.Quantum.Numerics), run the command for these too.

  5. Speichern und schließen Sie alle Dateien.Save and close all files.

  6. Wiederholen Sie 1-4 für jede Projekt Abhängigkeit, und navigieren Sie dann zurück zu dem Ordner, der das Hauptprojekt enthält, und führen Sie ausRepeat 1-4 for each project dependency, then navigate back to the folder containing your main project and run:

    dotnet build [project_name].csproj
    

Nachdem Sie Ihre Q #-Projekte aktualisiert haben, befolgen Sie die nachfolgenden Anweisungen, um das QDK selbst zu aktualisieren.With your Q# projects now updated, follow the instructions below to update the QDK itself.

Aktualisieren des QDKUpdating the QDK

Der Aktualisierungsprozess für das QDK hängt von der Entwicklungssprache und-Umgebung ab.The process to update the QDK varies depending on your development language and environment. Wählen Sie unten Ihre Entwicklungsumgebung aus.Select your development environment below.

Aktualisieren von IQ # für pythonUpdate IQ# for Python

  1. Aktualisieren des iqsharp KernelsUpdate the iqsharp kernel

    dotnet tool update -g Microsoft.Quantum.IQSharp
    dotnet iqsharp install
    
  2. Überprüfen der iqsharp VersionVerify the iqsharp version

    dotnet iqsharp --version
    

    Die folgende Ausgabe wird angezeigt.You should see the following output:

    iqsharp: 0.10.1912.501
    Jupyter Core: 1.2.20112.0
    

    Machen Sie sich keine Sorgen, wenn Ihre iqsharp Version höher ist, sollte Sie der neuestenVersion entsprechen.Don't worry if your iqsharp version is higher, it should match the latest release.

  3. Aktualisieren des qsharp PaketsUpdate the qsharp package

    pip install qsharp --upgrade
    
  4. Überprüfen der qsharp VersionVerify the qsharp version

    pip show qsharp
    

    Die folgende Ausgabe wird angezeigt.You should see the following output:

    Name: qsharp
    Version: 0.10.1912.501
    Summary: Python client for Q#, a domain-specific quantum programming language
    ...
    
  5. Führen Sie den folgenden Befehl am Speicherort der .qs Dateien aus.Run the following command from the location of your .qs files

    python -c "import qsharp; qsharp.reload()"
    
  6. Sie können jetzt die aktualisierte QDK-Version verwenden, um Ihre vorhandenen Quantum-Programme auszuführen.You can now use the updated QDK version to run your existing quantum programs.

Aktualisieren von IQ # für jupyter-NotebooksUpdate IQ# for Jupyter Notebooks

  1. Aktualisieren des iqsharp KernelsUpdate the iqsharp kernel

    dotnet tool update -g Microsoft.Quantum.IQSharp
    dotnet iqsharp install
    
  2. Überprüfen der iqsharp VersionVerify the iqsharp version

    dotnet iqsharp --version
    

    Die Ausgabe sollte in etwa wie folgt aussehen:Your output should be similar to the following:

    iqsharp: 0.10.1912.501
    Jupyter Core: 1.2.20112.0
    

    Machen Sie sich keine Sorgen, wenn Ihre iqsharp Version höher ist, sollte Sie der neuestenVersion entsprechen.Don't worry if your iqsharp version is higher, it should match the latest release.

  3. Führen Sie den folgenden Befehl aus einer Zelle im Jupyter Notebook aus:Run the following command from a cell in your Jupyter Notebook:

    %workspace reload
    
  4. Sie können jetzt ein vorhandenes jupyter Notebook öffnen und es mit dem aktualisierten QDK ausführen.You can now open an existing Jupyter notebook and run it with the updated QDK.

Visual Studio-QDK-Erweiterung aktualisierenUpdate Visual Studio QDK extension

  1. Aktualisieren der f # Visual Studio-ErweiterungUpdate the Q# Visual Studio extension

    Hinweis

    Die Projektvorlagen werden mit der Erweiterung aktualisiert.The project templates are updated with the extension. Die aktualisierten Vorlagen gelten nur für neu erstellte Projekte.The updated templates apply to newly created projects only. Der Code für die vorhandenen Projekte wird nicht aktualisiert, wenn die Erweiterung aktualisiert wird.The code for your existing projects is not updated when the extension is updated.

Update vs Code QDK-ErweiterungUpdate VS Code QDK extension

  1. Aktualisieren der Quantum-vs Code ErweiterungUpdate the Quantum VS Code extension

    • Neustart vs CodeRestart VS Code
    • Navigieren Sie zur Registerkarte Erweiterungen .Navigate to the Extensions tab
    • Wählen Sie die Microsoft Quantum Development Kit für Visual Studio Code Erweiterung aus .Select the Microsoft Quantum Development Kit for Visual Studio Code extension
    • Erweiterung erneut ladenReload the extension
  2. Aktualisieren Sie die Quantum-Projektvorlagen:Update the Quantum project templates:

    • Gehe zu Anzeige- -> Befehls PaletteGo to View -> Command Palette
    • Auswählen von " Q #: Install Project Templates "Select Q#: Install project templates
    • Nach wenigen Sekunden sollte ein Popup mit der Bestätigung angezeigt werden, dass die Projektvorlagen erfolgreich installiert wurden.After a few seconds you should get a popup confirming "project templates installed successfully"

C# mit dem dotnet Befehlszeilen ToolC#, using the dotnet command-line tool

  1. Aktualisieren der Quantum-Projektvorlagen für .netUpdate the Quantum project templates for .NET

    dotnet new -i Microsoft.Quantum.ProjectTemplates