Erstellen eines Excel Services-Dashboards mit SQL Server Analysis Services-Daten

GILT FÜR:  ja 2013  nein 2016  nein 2019  keine SharePoint in Microsoft 365

In diesem Artikel wird schritt für Schritt beschrieben, wie Sie Excel 2016 verwenden, um ein einfaches Vertriebsdashboard zu erstellen, das mehrere Berichte und einen Filter mithilfe einer externen Datenverbindung enthält. Das in diesem Artikel beschriebene Beispieldashboard kann mit folgender Abbildung verglichen werden:

Abbildung: Beispiel für ein einfaches Dashboard des Verkaufsteams

Beispiel-Dashboard mit Adventure Works-Daten

In diesem Artikel wird außerdem beschrieben, wie Sie das Dashboard auf SharePoint Server 2013 veröffentlichen, wo es von anderen angezeigt und verwendet werden kann. Führen Sie die Schritte in diesem Artikel aus, um zu erfahren, wie Sie verschiedene Berichte in einem Arbeitsblatt erstellen und anordnen und einen Filter mit diesen Berichten verbinden können.

Bevor Sie beginnen

Bevor Sie mit diesem Vorgang beginnen, sollten Sie die folgenden Informationen über die Voraussetzungen lesen:

  • Excel müssen auf dem Computer installiert sein, den Sie zum Erstellen und Veröffentlichen des Dashboards verwenden.

  • In diesem Szenario werden Adventure Works-Beispieldaten und eine Business Intelligence Center-Website in SharePoint Server 2013 verwendet. Wenn Ihnen keine Beispieldaten und keine Business Intelligence Center-Website zur Verfügung stehen, bitten Sie einen IT-Administrator, sie gemäß der Anweisungen in Konfigurieren von AdventureWorks für Business Intelligence-Lösungen für Sie zu konfigurieren.

  • Excel Services muss in der von Ihnen verwendeten SharePoint-Umgebung konfiguriert sein.

  • Sie müssen über einige Informationen zur Verwendung von Authentifizierungseinstellungen für Excel Services verfügen. Benutzerzugriff kann mithilfe der Windows-Authentifizierung mit Kerberos_Delegation, der Einmaliges Anmelden oder mit OLAP-Datenquellen, dem EffectiveUserName-Feature bereitgestellt werden.

    Informationen zum Konfigurieren von Secure Store finden Sie unter Plan the Secure Store Service in SharePoint Server und Configure the Secure Store Service in SharePoint Server. Informationen zum Konfigurieren des EffectiveUserName-Features für OLAP-Datenquellen finden Sie unter Use Analysis Services EffectiveUserName in SharePoint Server.

Planen des Dashboards

Wir empfehlen das Erstellen eines Dashboard-Plans, bevor Sie mit der Erstellung eines Dashboards beginnen. Der Plan muss nicht umfangreich oder komplex sein. Er sollte Ihnen jedoch eine Vorstellung davon vermitteln, was das Dashboard umfassen soll. Berücksichtigen Sie folgende Fragen, um sich auf die Erstellung eines Dashboardplans vorzubereiten:

  • Wer wird das Dashboard verwenden?

  • Welche Informationen sind gewünscht?

  • Sind Daten vorhanden, die zum Erstellen des Dashboards verwendet werden können?

Unser Beispieldashboard dient als Prototyp, mit dessen Hilfe Sie das Erstellen und Veröffentlichen von Excel Services-Dashboards erlernen können. In der folgenden Tabelle wird erläutert, wie wir einen Dashboardplan für ein ähnliches Dashboard erstellen können.

Tabelle: Basisplan für unser Beispieldashboard

Frage Antwort
Wer wird das Dashboard verwenden?
Das Dashboard ist für die Verwendung durch Vertriebsmitarbeiter, Verkaufsleiter, Führungskräfte und weitere Personen vorgesehen, die sich für die Vertriebsinformationen des fiktiven Unternehmens AdventureWorks Cycles interessieren.
Wie wird das Dashboard verwendet, bzw. welche Arten von Informationen werden von den Dashboardbenutzern gewünscht?
Vertriebsmitarbeiter, Manager, Führungskräfte und andere Dashboardbenutzer verwenden das Dashboard zum Anzeigen, Untersuchen und Analysieren von Daten. Die Dashboardbenutzer möchten mindestens folgende Informationen zur Verfügung gestellt bekommen:
Verkaufszahlen für verschiedene Produktkategorien
Verkaufszahlen für verschiedene Vertriebsgebiete
Verkäufe für Internet- und Händlerkanäle
Dashboardbenutzer möchten das Dashboard zum Anzeigen, Untersuchen und Analysieren von Daten zum Ermitteln von Antworten auf bestimmte Fragen verwenden.
Die Dashboardbenutzer wünschen auch, dass mithilfe von Filtern Schwerpunkte auf bestimmte Informationen gelegt werden können, z. B. die Verkäufe in einem bestimmten Zeitraum.
Sind Daten vorhanden, die zum Erstellen des Dashboards verwendet werden können?
Ja. Die Beispieldatenbank "Adventure Works" enthält die Daten, die wir für das Dashboard verwenden. Da es sich bei den Beispieldaten um einen mehrdimensionalen Datencube handelt, können sie zum Erstellen von interaktiven Berichten verwendet werden, anhand derer die Dashboardbenutzer Daten untersuchen können, indem sie unterschiedliche Detailebenen anzeigen.
Welche Elemente sollte das Dashboard enthalten?
Unser Beispieldashboard umfasst folgende Elemente:
Eine Datenverbindung zu SQL Server Analysis Services
Einen Bericht mit Produktverkaufsdaten für verschiedene Produktkategorien
Einen Bericht mit Verkaufsdaten für verschiedene Vertriebsgebiete
Einen Bericht mit Bestell- und Verkaufsdaten für verschiedene Vertriebskanäle
Einen Bericht mit Bestell- und Verkaufsdaten für verschiedene Produktkategorien
Einen Filter, den Dashboardbenutzer zum Anzeigen von Informationen für einen bestimmten Zeitraum verwenden können

Jetzt da wir unseren Dashboardplan erstellt haben, können wir mit der Erstellung des Dashboards beginnen.

Erstellen des Dashboards

Beim Erstellen das Dashboards beginnen wir mit dem Erstellen einer Datenverbindung. Dann verwenden wir diese Datenverbindung zum Erstellen der Berichte und Filter, die wir verwenden möchten. Anschließend veröffentlichen wir die Arbeitsmappe auf SharePoint Server 2013.

Teil 1: Erstellen einer Datenverbindung

Unser Beispieldashboard verwendet eine einzelne Datenverbindung zu den in SQL Server 2012 Analysis Services gespeicherten Daten. Wir verwenden diese Datenverbindung, um die Berichte und den Filter für das Dashboard zu erstellen.

So erstellen Sie eine Verbindung mit Analysis Services-Daten

  1. Öffnen Sie Microsoft Excel.

  2. Um eine Arbeitsmappe zu erstellen, wählen Sie Leere Arbeitsmappe aus.

  3. Wählen Sie auf der Registerkarte Daten die Gruppe Externe Daten erhalten aus, wählen Sie dann Aus anderen Quellen aus, und wählen Sie dann Aus Analysis Services aus.

    Der Datenverbindungs-Assistent wird geöffnet.

  4. Geben Sie auf der Seite Zum Datenbankserver verbinden im Feld Servername den Namen des Servers ein, auf dem die Analysis Services-Daten gespeichert sind, die Sie verwenden möchten.

  5. Führen Sie im Abschnitt Anmeldeinformationen einen der folgenden Schritte aus.

  • Wenn Ihre Organisation die Authentifizierung Windows, wählen Sie Verwenden Windows Authentifizierung aus, und wählen Sie dann Weiter aus.

  • Wenn Ihre Organisation bestimmte Benutzeranmeldeinformationen verwendet, wählen Sie Benutzername und Kennwort verwenden, geben Sie einen entsprechenden Benutzernamen und ein Kennwort an, und wählen Sie dann Weiter aus.

    Tipp

    Wenn Sie nicht wissen, welche Option Sie auswählen möchten, wenden Sie sich an einen SharePoint Administrator.

  1. Wählen Sie auf der Seite Datenbank und Tabelle auswählen die AdventureWorksDW2012Multidimensional-EE-Datenbank aus, und wählen Sie dann den Adventure Works-Cube aus, und wählen Sie dann Weiter aus.

  2. Wählen Sie auf der Seite Datenverbindungsdatei speichern und fertig stellen die Option Fertig stellen aus.

  3. Wählen Sie auf der Seite Daten importieren die Option Nur Verbindung erstellen aus, und wählen Sie dann OK aus.

  4. Lassen Sie Excel geöffnet.

Bisher haben wir eine Verbindung zum Adventure Works-Cube in Analysis Services erstellt. Diese Datenverbindung wird standardmäßig im Ordner Meine Datenquellen in der Bibliothek Dokumente auf Ihrem Computer gespeichert und in die Arbeitsmappe eingebettet. Wir verwenden die in die Arbeitsmappe für das Dashboard eingebettete ODC-Verbindung.

Der nächste Schritt ist das Erstellen von Berichten für das Dashboard.

Teil 2: Erstellen von Berichten

Für unser Beispieldashboard erstellen wir, wie in der folgenden Tabelle beschrieben, vier Berichte.

Tabelle: Dashboardberichte

Berichtstyp Berichtname Beschreibung
PivotChart-Bericht
ProductSales
Bericht mit einem Balkendiagramm, der die Umsätze für verschiedene Produktkategorien zeigt.
PivotChart-Bericht
GeoSales
Bericht mit einem Balkendiagramm, der die Umsätze für verschiedene Vertriebsgebiete zeigt.
PivotTable-Bericht
ChannelSales
Tabelle, die Bestell- und Verkaufsmeldungen für Internet- und Händlerkanäle anzeigt.
PivotTable-Bericht
OrderSales
Tabelle, die Bestell- und Verkaufsmengen für verschiedene Produktkategorien anzeigt.

Wir beginnen mit dem Erstellen des ProductSales-Berichts.

So erstellen Sie den ProductSales-Bericht

  1. Wählen Excel auf der Registerkarte Einfügen im Abschnitt Diagramme die Option PivotChart.

    Das Dialogfeld PivotChart erstellen wird angezeigt.

  2. Wählen Sie im Abschnitt Daten auswählen, die Analysiert werden sollen die Option Externe Datenquelle verwenden aus, und wählen Sie dann Verbindung auswählen aus.

    Das Dialogfeld Vorhandene Verbindungen wird angezeigt.

  3. Wählen Sie im Abschnitt Verbindungen in dieser Arbeitsmappe die Datenverbindung AdventureWorksDW2012Multidimensional-EE aus, und wählen Sie dann Öffnen aus.

  4. Wählen Sie im PivotChart erstellen die Option Vorhandenes Arbeitsblatt aus, und wählen Sie dann OK aus.

    Diagramm1 wird zur Bearbeitung geöffnet.

  5. Geben Sie in der Liste PivotChart-Felder die folgenden Optionen an:

  • Wählen Sie im Abschnitt Verkaufszusammenfassung die Option Verkaufsbetrag aus.

    Verkaufsbetrag wird im Abschnitt Werte angezeigt, und der Bericht wird aktualisiert, um eine einzelne Leiste zu zeigen.

  • Wählen Sie im Abschnitt Produkt die Option Produktkategorien aus.

    Produktkategorien werden im Abschnitt Achse angezeigt, und der Bericht wird aktualisiert, um Verkaufszahlen in verschiedenen Produktkategorien zu zeigen.

  1. Führen Sie die folgenden Schritte aus, um die Balken in absteigender Reihenfolge zu sortieren:

  2. Wählen Sie PivotChart In der Liste Felder die Dimension Produktkategorien aus, und wählen Sie dann den angezeigten Pfeil nach unten aus.

    Das Dialogfeld Feld auswählen wird angezeigt.

  3. Um das Dialogfeld Sortieren (Kategorie) zu öffnen, wählen Sie Weitere Sortieroptionen... aus.

  4. Wählen Sie im Abschnitt Sortieroptionen die Option Absteigend (Z bis A) nach aus, und verwenden Sie dann die Liste, um Verkaufsbetrag auszuwählen.

  5. Klicken Sie auf OK.

  6. Um sicherzustellen, dass ausreichend Platz für weitere Berichte vorhanden ist, verschieben wir den PivotChart-Bericht im Arbeitsblatt weiter nach links oben. Ziehen Sie den Bericht dazu so weit, dass die linke obere Ecke mit der linken oberen Ecke von Zelle B10 im Arbeitsblatt abschließt.

  7. Um spätere Unklarheiten bezüglich der Berichtnamen zu vermeiden, legen wir einen neuen Namen für den Bericht fest. Löschen Sie auf der Registerkarte Analysieren in der Gruppe PivotChart im Feld Diagrammname den Text chart1, geben Sie ProductSales ein, und drücken Sie auf der Tastatur die Taste .

    Tipp

    Achten Sie darauf, dass der angegebene Name nur alphanumerische Zeichen enthält (keine Leerzeichen).

  8. Um spätere Probleme mit der Größe des Berichts zu vermeiden, legen wir Größeneinstellungen für den Bericht fest. Führen Sie hierzu folgende Schritte aus:

  9. Klicken Sie in einem leeren Abschnitt des Berichts, z. B. in der oberen rechten Ecke des Berichts, mit der rechten Maustaste, und wählen Sie dann Diagrammbereich formatieren aus.

    Die Liste Diagrammbereich formatieren wird geöffnet.

  10. Wählen Sie unter Diagrammoptionen den Symbolleistenbefehl Größe und Eigenschaften aus.

  11. Erweitern Sie den Abschnitt Größe, und wählen Sie dann die Option Seitenverhältnis sperren aus.

  12. Erweitern Sie den Abschnitt Eigenschaften, wählen Sie die Option Nicht verschieben oder Größe mit Zellen aus, und stellen Sie sicher, dass die Option Gesperrt ausgewählt ist.

  13. Um optional alternativen Text für den Bericht anzugeben, erweitern Sie den Abschnitt Alttext, und geben Sie dann den Text ein, den Sie für den Bericht verwenden möchten.

  14. Schließen Sie die Liste Diagrammbereich formatieren.

  15. Speichern Sie die Arbeitsmappe unter einem Dateinamen wie z. B. Adventure Works - Verkauf.

  16. Lassen Sie die Arbeitsmappe geöffnet.

Bisher haben wir einen PivotChart-Bericht erstellt. Im nächsten Schritt erstellen wir einen weiteren PivotChart-Bericht mit dem Namen "GeoSales", der die Verkaufsdaten für verschiedene geografischen Standorten anzeigt.

So erstellen Sie den GeoSales-Bericht

  1. Wählen Excel in dem Arbeitsblatt, das zum Erstellen des ProductSales-Berichts verwendet wurde, zelle K10 aus.

  2. Wählen Sie auf der Registerkarte Einfügen die Option PivotChart aus.

  3. Wählen Sie im Abschnitt Daten auswählen, die Analysiert werden sollen die Option Externe Datenquelle verwenden aus, und wählen Sie dann Verbindung auswählen aus.

    Das Dialogfeld Vorhandene Verbindungen wird angezeigt.

  4. Wählen Sie im Abschnitt Verbindungen in dieser Arbeitsmappe die Datenverbindung AdventureWorksDW2012Multidimensional-EE aus, und wählen Sie dann Öffnen aus.

  5. Wählen Sie im PivotChart erstellen die Option Vorhandenes Arbeitsblatt aus, und wählen Sie dann OK aus.

    Chart2 wird zur Bearbeitung geöffnet.

  6. Verschieben Sie das Diagramm, sodass die linke obere Ecke mit der linken oberen Ecke von Zelle J10 im Arbeitsblatt abschließt.

  7. Geben Sie in der Liste PivotChart-Felder die folgenden Optionen an:

  • Wählen Sie im Abschnitt Verkaufszusammenfassung die Option Verkaufsbetrag aus.

  • Ziehen Sie im Abschnitt Vertriebsgebiet das Element Vertriebsgebiet in den Abschnitt Legende.

    Der Bericht zeigt nach einer Aktualisierung ein Balkendiagramm an, das die Verkaufszahlen für Europa, Nordamerika und den Pazifischen Raum zeigt.

  1. Führen Sie folgende Schritte aus, um Größeneinstellungen für den Bericht festzulegen:

  2. Klicken Sie in einem leeren Abschnitt des Berichts mit der rechten Maustaste, und wählen Sie dann die Option Diagrammbereich formatieren aus.

    Die Liste Diagrammbereich formatieren wird geöffnet.

  3. Wählen Sie unter Diagrammoptionen den Symbolleistenbefehl Größe und Eigenschaften aus.

  4. Erweitern Sie den Abschnitt Größe, und wählen Sie dann die Option Seitenverhältnis sperren aus.

  5. Erweitern Sie den Abschnitt Eigenschaften, wählen Sie die Option Nicht verschieben oder Größe mit Zellen aus, und stellen Sie sicher, dass Locked ausgewählt ist.

  6. Um optional Alttext für den Bericht anzugeben, erweitern Sie den Abschnitt Alttext, und geben Sie dann den Text ein, den Sie für den Bericht verwenden möchten.

  7. Schließen Sie die Liste Diagrammbereich formatieren.

  8. Geben Sie einen neuen Namen für den Bericht an. Löschen Sie auf der Registerkarte Analysieren in der Gruppe PivotChart im Feld Diagrammname den Text für Chart2, geben Sie GeoSales ein, und drücken Sie auf der Tastatur die Taste .

  9. Wählen Sie auf der Registerkarte Datei die Option Speichern aus.

  10. Lassen Sie die Arbeitsmappe geöffnet.

Bisher haben wir zwei Berichte erstellt. Im nächsten Schritt erstellen wir den Bericht "ChannelSales".

So erstellen Sie den ChannelSales-Bericht

  1. Wählen Excel in demselben Arbeitsblatt, das zum Erstellen der vorherigen Berichte verwendet wurde, Zelle B26 aus.

  2. Wählen Sie auf der Registerkarte Einfügen die Option PivotTable aus.

  3. Wählen Sie im Abschnitt Daten auswählen, die Analysiert werden sollen die Option Externe Datenquelle verwenden aus, und wählen Sie dann Verbindung auswählen aus.

    Das Dialogfeld Vorhandene Verbindungen wird angezeigt.

  4. Wählen Sie im Abschnitt Verbindungen in dieser Arbeitsmappe die Datenverbindung AdventureWorksDW2012Multidimensional-EE aus, und wählen Sie dann Öffnen aus.

  5. Wählen Sie die Option Vorhandenes Arbeitsblatt aus, und wählen Sie dann OK aus.

    PivotTable3 wird zur Bearbeitung geöffnet.

  6. Geben Sie in der Liste PivotTable die folgenden Optionen an:

  • Wählen Sie im Abschnitt Bestellungen die Option Auftragsanzahl aus.

  • Wählen Sie im Abschnitt Verkaufszusammenfassung die Option Verkaufsbetrag aus.

  • Wählen Sie im Abschnitt Vertriebskanal die Option Vertriebskanal aus.

    Der Bericht zeigt nach einer Aktualisierung eine Tabelle mit Bestell- und Verkaufszahlen für Internet- und Händlerkanäle an.

  1. Wählen Sie Zelle B26 aus, und löschen Sie dann in der Leiste Formel den Text für Zeilenbeschriftungen, und geben Sie "Kanalverkäufe" ein. Drücken Sie dann auf der Tastatur .

  2. Geben Sie einen neuen Namen für den Bericht an. Löschen Sie auf der Registerkarte Analysieren in der PivotTable-Gruppe im Feld PivotTable-Name den Text für PivotTable3, geben Sie ChannelSales ein, und drücken Sie auf der Tastatur die .

  3. Wählen Sie auf der Registerkarte Datei die Option Speichern aus.

  4. Lassen Sie die Excel-Arbeitsmappe geöffnet.

Bisher haben wir drei Berichte unter Verwendung derselben Datenquelle erstellt. Im nächsten Schritt erstellen wir den Bericht "OrderSales".

So erstellen Sie den OrderSales-Bericht

  1. Wählen Excel in demselben Arbeitsblatt, das zum Erstellen der vorherigen Berichte verwendet wurde, zelle H26 aus.

  2. Wählen Sie auf der Registerkarte Einfügen die Option PivotTable aus.

  3. Wählen Sie im Abschnitt Daten auswählen, die Analysiert werden sollen die Option Externe Datenquelle verwenden aus, und wählen Sie dann Verbindung auswählen aus.

    Das Dialogfeld Vorhandene Verbindungen wird angezeigt.

  4. Wählen Sie im Abschnitt Verbindungen in dieser Arbeitsmappe die Datenverbindung AdventureWorksDW2012Multidimensional-EE aus, und wählen Sie dann Öffnen aus.

  5. Wählen Sie die Option Vorhandenes Arbeitsblatt aus, und wählen Sie dann OK aus.

    PivotTable4 wird zur Bearbeitung geöffnet.

  6. Geben Sie in der Liste PivotTable die folgenden Optionen an:

  • Wählen Sie im Abschnitt Bestellungen die Option Auftragsanzahl aus.

  • Wählen Sie im Abschnitt Verkaufszusammenfassung die Option Verkaufsbetrag aus.

  • Wählen Sie im Abschnitt Produkt die Option Produktkategorien aus.

    Der Bericht zeigt nach einer Aktualisierung eine Tabelle mit Bestell- und Verkaufszahlen für verschiedene Produktkategorien an.

  1. Wählen Sie Zelle H26 aus, und löschen Sie dann in der Leiste Formel den Standardtext für Zeilenbeschriftungen, und geben Sie dann Produkte ein. Drücken Sie dann auf der Tastatur .

  2. Geben Sie einen neuen Namen für den Bericht an. Löschen Sie auf der Registerkarte Analysieren in der PivotTable-Gruppe im Feld PivotTable-Name den Text für PivotTable4, geben Sie OrderSales ein, und drücken Sie auf der Tastatur die Taste .

  3. Wählen Sie auf der Registerkarte Datei die Option Speichern aus.

  4. Lassen Sie die Arbeitsmappe geöffnet.

Bisher haben wir vier Berichte für unser einfaches Dashboard erstellt. Im nächsten Schritt erstellen wir einen Filter.

Teil 3: Erstellen eines Filters

Mit Excel können verschiedene Filterarten erstellt werden. Wir können z. B. einen einfachen Filter erstellen, indem im Abschnitt Filter der Liste Felder ein Feld hinzugefügt wird. Wir können einen Datenschnitt oder - bei Verwendung einer mehrdimensionalen Datenquelle wie z. B. Analysis Services - ein Zeitachsensteuerelement erstellen. Für dieses Beispieldashboard erstellen wir ein Zeitachsensteuerelement. Dieser Filter ermöglicht Benutzern das Anzeigen von Informationen für einen bestimmten Zeitraum.

So erstellen Sie ein Zeitachsensteuerelement

  1. Wählen Excel in dem arbeitsblatt, das zum Erstellen der Berichte verwendet wurde, Zelle B1 aus.

  2. Wählen Sie auf der Registerkarte Einfügen in der Gruppe Filter die Option Zeitachse aus.

    Das Dialogfeld Vorhandene Verbindungen wird angezeigt.

  3. Wählen Sie im Abschnitt Verbindungen in dieser Arbeitsmappe die Datenverbindung AdventureWorksDW2012Multidimensional-EE aus, und wählen Sie dann Öffnen aus.

  4. Das Dialogfeld Zeitachsen einfügen wird angezeigt.

  5. Wählen Sie die Option Datum aus, und wählen Sie dann OK aus.

    Ein Zeitachsensteuerelement wird geöffnet.

  6. Verschieben Sie das Zeitachsensteuerelement, sodass die linke obere Ecke mit der linken oberen Ecke von Zelle B10 abschließt.

  7. Um das Zeitachsensteuerelement zu verbreitern, verwenden Sie die Ziehpunkte zum Ändern der Größe. Ziehen Sie den Ziehpunkt rechts im Steuerelement zu Spalte M.

  8. Wählen Sie das Zeitachsensteuerelement aus, und wählen Sie auf der Registerkarte Optionen in der Gruppe Zeitachse den Symbolleistenbefehl Verbindungen melden aus.

    Das Dialogfeld Verbindungen melden wird angezeigt.

  9. Wählen Sie ChannelSales, GeoSales, OrderSales und ProductSales aus, und wählen Sie dann OK aus.

  10. Wählen Sie auf der Registerkarte Datei die Option Speichern aus.

  11. Lassen Sie die Excel-Arbeitsmappe geöffnet.

Bisher haben wir ein Dashboard erstellt. Der nächste Schritt besteht im Veröffentlichen auf SharePoint Server 2013, wo es von anderen verwendet werden kann.

Veröffentlichen des Dashboards

Um die Arbeitsmappe auf SharePoint Server 2013 zu veröffentlichen, führen wir einen Vier-Schritt-Prozess aus. Zunächst nehmen wir einige Anpassungen vor, die sich darauf auswirken, wie die Arbeitsmappe angezeigt wird. Dann legen wir Excel Services-Datenauthentifizierungseinstellungen für die verwendete externe Datenverbindung fest. Danach legen wir die Optionen zum Veröffentlichen der Arbeitsmappe fest. Schließlich veröffentlichen wir die Arbeitsmappe auf SharePoint Server 2013.

Wir beginnen mit Anpassungen der Arbeitsmappe. Unser Beispieldashboard zeigt standardmäßig Gitternetzlinien auf dem Arbeitsblatt an, das das Dashboard enthält. Der Standardname des Arbeitsblatts lautet Sheet1. Wir können einige geringfügige Anpassungen vornehmen, um die Anzeige des Dashboards zu verbessern.

So nehmen Sie geringfügige Verbesserungen an der Arbeitsmappe vor

  1. Wählen Excel die Registerkarte Ansicht aus.

  2. Zum Entfernen der Gitternetzlinien aus der Ansicht deaktivieren Sie auf der Registerkarte Ansicht in der Gruppe Anzeigen das Kontrollkästchen Gitternetzlinien.

  3. Zum Entfernen von Zeilen- und Spaltenbeschriftungen deaktivieren Sie auf der Registerkarte Ansicht in der Gruppe Anzeigen das Kontrollkästchen Überschriften.

  4. Um das Arbeitsblatt umzubenennen, klicken Sie mit der rechten Maustaste auf die Registerkarte für Sheet1, und wählen Sie dann Umbenennen aus. Geben Sie einen neuen Namen für das Arbeitsblatt ein, z. B. SalesDashboard, und drücken Sie auf der Tastatur .

  5. Wählen Sie auf der Registerkarte Datei die Option Speichern aus.

  6. Lassen Sie die Arbeitsmappe geöffnet.

Die Arbeitsmappe, die wir erstellt haben, verwendet eine externe Datenverbindung, die für das Veröffentlichen der Arbeitsmappe aktiv bleiben soll. Um sicherzustellen, dass die Datenverbindung bestehen bleibt, damit in Excel Services die Datenaktualisierung unterstützt wird, müssen wir Authentifizierungseinstellungen festlegen.

So geben Sie Authentifizierungseinstellungen für die externe Datenverbindung an

  1. Wählen Excel auf der Registerkarte Daten den Symbolleistenbefehl Verbindungen aus.

    Das Dialogfeld Arbeitsmappenverbindungen wird angezeigt und zeigt die AdventureWorksDW2012Multidimensional-EE Datenverbindung an.

  2. Wählen Sie Eigenschaften aus.

  3. Wählen Sie im Dialogfeld Verbindungseigenschaften auf der Registerkarte Definition neben Excel Services die Option Authentifizierung Einstellungen... aus.

  4. Gehen Sie im Excel Services Authentifizierung Einstellungen einen der folgenden Schritte vor:

  • Wenn Excel Services für die Verwendung der Windows Authentifizierung oder des EffectiveUserName-Features konfiguriert ist, wählen Sie Konto des authentifizierten Benutzers verwenden aus, und wählen Sie dann OK aus.

  • Wenn Excel Services für die Verwendung von Einmaliges Anmelden konfiguriert ist, wählen Sie Gespeichertes Konto verwenden aus. Geben Sie im Feld Anwendungs-ID die Store Zielanwendungs-ID an, und wählen Sie dann OK aus.

  • Wenn Excel Services für die Verwendung des unbeaufsichtigten Dienstkontos konfiguriert ist, wählen Sie Keine aus, und wählen Sie dann OK aus.

    Wichtig

    Wenn Sie nicht wissen, welche Option Sie auswählen möchten, wenden Sie sich an einen SharePoint Administrator.

  1. Wählen Sie OK aus, um das Dialogfeld Verbindungseigenschaften zu schließen.

  2. Wenn eine Meldung angezeigt wird, dass die Verbindung in der Arbeitsmappe nicht mehr mit der in der externen Datei definierten Verbindung identisch ist, wählen Sie Ja aus.

  3. Wählen Sie Schließen aus, um das Dialogfeld Arbeitsmappenverbindungen zu schließen.

Als wir die Berichte für das Dashboard erstellt haben, haben wir jedem einen eindeutigen Namen gegeben und ihn als benanntes Element in der Excel. Neben der Veröffentlichung der Arbeitsmappe auf SharePoint Server 2013 sollten wir die benannten Elemente veröffentlichen, die wir definiert haben. Dadurch kann ein benanntes Element später in einem eigenen SharePoint angezeigt werden. Dazu geben wir Veröffentlichungsoptionen für die Arbeitsmappe an.

Tipp

In diesem Artikel wird das Anzeigen eines benannten Elements um dazugehörigen SharePoint-Webpart nicht beschrieben, daher ist das folgende Verfahren optional. Wir empfehlen jedoch als bewährte Methode, das folgende Verfahren auszuführen, da es Ihnen später ein erneutes Veröffentlichen der Arbeitsmappe ersparen kann.

So geben Sie Veröffentlichungsoptionen für die Arbeitsmappe an

  1. Wählen Sie auf der Registerkarte Datei die Option Info aus, und wählen Sie dann Browseransichtsoptionen aus.

  2. Wählen Sie Browseransichtsoptionen aus.

  3. Wählen Sie auf der Registerkarte Anzeigen mithilfe der Liste Elemente in der Arbeitsmappe aus.

  4. Wählen Sie Alle Diagramme und dann Alle PivotTables aus, und wählen Sie dann OK aus.

  5. Wählen Sie auf der Registerkarte Datei die Option Speichern aus.

  6. Lassen Sie die Arbeitsmappe geöffnet.

Der nächste Schritt besteht im Veröffentlichen der Arbeitsmappe auf SharePoint Server 2013.

So veröffentlichen Sie die Arbeitsmappe auf SharePoint Server

  1. Wählen Excel Auf der Registerkarte Datei die Option Speichern unter aus, wählen Sie dann Computer aus, und wählen Sie dann Durchsuchen aus.

    Das Dialogfeld Speichern unter wird angezeigt.

  2. Geben Sie in der Adresszeile die adresse SharePoint an einen Excel Services vertrauenswürdigen Dateispeicherort ein.

  3. Klicken Sie auf Speichern.

    Die Arbeitsmappe wird in der von Ihnen angegebenen SharePoint-Bibliothek veröffentlicht.

  4. Schließen Sie die Excel-Arbeitsmappe

Wir haben das Dashboard erstellt und veröffentlicht und können es nun zum Untersuchen von Daten verwenden.

Verwenden des Dashboards

Nachdem das Dashboard auf SharePoint Server 2013 veröffentlicht wurde, steht es für Benutzer zur Verfügung, um es anzuzeigen und zu verwenden.

So öffnen Sie das Dashboard

  1. Öffnen Sie einen Webbrowser.

  2. Geben Sie in der Adressleiste die Adresse der Business Intelligence Center-Website ein, auf der das Dashboard veröffentlicht wurde.

  3. Wählen Sie Websiteinhalte aus, und wählen Sie dann Dokumente aus.

  4. Wählen Sie das Adventure Works Sales-Dashboard aus.

    Das Dashboard wird zur Anzeige geöffnet.

Jetzt ist das Dashboard zur Anzeige geöffnet, und wir können es zum Ermitteln von Antworten auf bestimmte Fragen verwenden, z. B. der Fragen in der folgenden Tabelle.

Tabelle: Verwenden des Dashboards zum Ermitteln von Antworten auf bestimmte Fragen

Frage Aktion
Für welche Produktkategorie gibt es die meisten Bestellungen?
Zeigen Sie im Bericht "OrderSales" die Spalte Anzahl Bestellungen für verschiedene Produktkategorien an. Sie sehen, dass für "Zubehör" die höchste Anzahl von Bestellungen vorliegt. Außerdem hat Zubehör den geringsten Gesamtumsatz aller vier Produktkategorien.
Verkauft dieses Unternehmen mehr Waren über den Internet- oder den Händlerkanal?
Anhand des Berichts "ChannelSales" können Sie sehen, dass für den Internetkanal zwar mehr Bestellungen vorhanden sind, der Händlerkanal jedoch den höchsten Umsatz aufweist.
In welchem Jahr war der Gesamtumsatz am höchsten?
Wählen Sie mit dem Zeitachsensteuerelement am oberen Rand des Bildschirms den Pfeil nach unten neben MONATE aus, und wählen Sie JAHRE aus. Verwenden Sie das Steuerelement, um ein Jahr gleichzeitig auszuwählen. Das Jahr 2007 hat den höchsten Umsatz.
In welchem Vertriebsgebiet ist der Umsatz des Unternehmens insgesamt am höchsten?
Um den Filter aus dem Zeitachsensteuerelement zu löschen, wählen Sie in der oberen rechten Ecke des Zeitachsensteuerelements den Symbolleistenbefehl Löschen aus. Nordamerika hat den höchsten Umsatz für dieses bestimmte Unternehmen.
Welche Unterkategorie von Fahrrädern erzielt den höchsten Gesamtumsatz?
Doppelklicken Sie im ProductSales-Bericht auf die Leiste für Bikes. Der Bericht wird aktualisiert, um drei Unterkategorien zu zeigen: Mountainbikes, Rennräder und Tourenräder. Die Unterkategorie "Mountain Bikes" hat den höchsten Umsatz.

Siehe auch

Konzepte

Business Intelligence-Funktionen in Excel Services (SharePoint Server 2013)

Erstellen eines Excel Services-Dashboards mithilfe eines Datenmodells (SharePoint Server 2013)