Designer für tabellarische Modelle

Gilt für: SQL Server Analysis Services Azure Analysis Services Power BI Premium

Der Tabellenmodell-Designer ist Teil der Erweiterung von Analysis Services-Projekten für Microsoft Visual Studio, mit zusätzlichen Projekttypvorlagen speziell für die Entwicklung professioneller Tabellarmodelllösungen. Weitere Informationen finden Sie unter "Tools".

Vorteile

Wenn Sie analysis Services-Projekterweiterung für Visual Studio installieren, werden neue Projektvorlagen zum Erstellen von Tabellarmodellen den verfügbaren Projekttypen hinzugefügt. Nachdem ein neues Projekt für tabellarische Modelle auf der Grundlage einer der Vorlagen erstellt wurde, können Sie mit der Erstellung von Modellen beginnen. Dazu verwenden Sie die Designer-Tools und Assistenten für tabellarische Modelle.

Zusätzlich zu neuen Vorlagen und Tools zum Erstellen professioneller mehrdimensionaler und tabellarischer Modelllösungen bietet die Visual Studio Umgebung Debugging- und Projektlebenszyklusfunktionen, die sicherstellen, dass Sie die meisten BI-Lösungen für Ihre Organisation erstellen. Weitere Informationen zu Visual Studio finden Sie unter Erste Schritte mit Visual Studio.

Projektvorlagen

Wenn Sie die Erweiterung für Visual Studio Analysis Services-Projekte installieren, werden die folgenden Projektvorlagen für tabellarische Modelle zu den Projekttypen hinzugefügt:

Analysis Services-Projekt für tabellarische Modelle
Mit dieser Vorlage kann ein neues, leeres tabellarisches Modellprojekt erstellt werden. Kompatibilitätsgrade werden beim Erstellen des Projekts angegeben.

Von Server importieren (tabellarisch)
Mit dieser Vorlage kann ein neues tabellarisches Modellprojekt erstellt werden, indem die Metadaten aus einem vorhandenen tabellarischen Modell in Analysis Services extrahiert werden.

Ältere Modelle haben ältere Kompatibilitätsgrade. Sie können ein Upgrade durchführen, indem Sie die Eigenschaft "Kompatibilitätsebene" nach dem Importieren der Modelldefinition ändern.

Importieren aus PowerPivot
Diese Vorlage wird zum Erstellen eines neuen Tabellarmodellprojekts verwendet, indem die Metadaten und Daten aus einer Power Pivot für Excel Datei extrahiert werden.

Windows und Menüs

Die Visual Studio Tabellenmodellerstellungsumgebung umfasst Folgendes:

Designerfenster

Das Designerfenster dient zur Erstellung tabellarischer Modelle, indem das Modell in einer visuellen Darstellung abgebildet wird. Wenn Sie die Datei Model.bim öffnen, wird das Modell im Designerfenster geöffnet. Zum Erstellen eines Modells im Designerfenster stehen zwei unterschiedliche Ansichtsmodi zur Verfügung:

Datenansicht
In der Datensicht werden Tabellen in einem tabellarischen Rasterformat angezeigt. Außerdem können Sie Measures mit dem Measureraster definieren, das für jede Tabelle ausschließlich in der Datensicht angezeigt werden kann.

Diagrammansicht
In der Diagrammsicht werden Tabellen mit den bestehenden Beziehungen in einem grafischen Format angezeigt. Spalten, Measures, Hierarchien und KPIs können gefiltert werden, und Sie können auswählen, ob das Modell mithilfe einer definierten Perspektive angezeigt wird.

Die meisten Modellerstellungsaufgaben können in einer beliebigen Ansicht ausgeführt werden.

Codefenster anzeigen

Sie können den Code hinter einer „Model.bim“-Datei anzeigen, indem Sie mit der rechten Maustaste auf die Datei klicken und im Projektmappen-Explorer Code anzeigen auswählen. Für Tabellarische Modelle auf Kompatibilitätsebene 1200 und höher wird die Modelldefinition in JSON ausgedrückt.

Projektmappen-Explorer

Im Projektmappen-Explorer-Fenster wird die aktive Projektmappe als logischer Container für Projekte für tabellarische Modelle dargestellt und umfasst die dazugehörigen Elemente. Das Modellprojekt (.smproj) enthält gewöhnlich nur ein (leeres) References-Objekt und die Datei Model.bim. In dieser Ansicht können Sie Projektelemente zum Ändern öffnen und andere Verwaltungsaufgaben ausführen.

Projektmappen für tabellarische Modelle enthalten normalerweise nur ein Projekt. Dagegen kann eine Projektmappe weitere Projekte enthalten, z. B. ein Projekt für Integration Services oder Reporting Services. Sie können eine beliebige Anzahl von Dateien hinzufügen, sofern sie nicht den gleichen Typ aufweisen wie Projektdateien für tabellarische Modelle und ihre Buildvorgang-Eigenschaft nicht auf Kein bzw. ihre In Ausgabeverzeichnis kopieren-Eigenschaft nicht auf Nicht kopieren festgelegt ist.

Klicken Sie zum Anzeigen des Projektmappen-Explorers auf das Menü Ansicht und anschließend auf Projektmappen-Explorer.

Tabellenmodell-Explorer

Der Tabellarische Modell-Explorer hilft Ihnen bei der Navigation von Metadatenobjekten in tabellarischen Modellen.

Klicken Sie zum Anzeigen des Tabellarischen Modell-Explorers auf "ViewOther>Windows", und klicken Sie dann auf "Tabellarische Modell-Explorer".

Tabular Model Explorer

Tabellarische Modell-Explorer organisiert Metadatenobjekte in einer Struktur, die dem Schema eines tabellarischen Modells ähnelt. Datenquellen, Perspektiven, Beziehungen, Rollen, Tabellen und Übersetzungen entsprechen Schemaobjekten der obersten Ebene. Es gibt einige Ausnahmen, insbesondere KPIs und Measures, die technisch keine Objekte auf oberster Ebene sind, sondern untergeordnete Objekte der verschiedenen Tabellen im Modell. Wenn Container der obersten Ebene für alle KPIs und Measures konsolidiert wurden, gestaltet sich die Arbeit mit diesen Objekten jedoch einfacher, insbesondere, wenn Ihr Modell eine sehr große Anzahl von Tabellen umfasst. Measures werden auch unter ihren entsprechenden übergeordneten Tabellen aufgelistet, somit erhalten Sie eine deutliche Übersicht über die tatsächlichen Beziehungen zwischen über- und untergeordneten Elementen. Wenn Sie ein Measure im Container auf oberster Ebene auswählen, wird dasselbe Measure auch in der untergeordneten Auflistung unter seiner Tabelle ausgewählt (und umgekehrt).

Objektknoten im Tabellenmodell-Explorer sind mit den entsprechenden Menüoptionen verknüpft, die in Visual Studio bisher in den Menüs für Modell, Tabelle und Spalte verborgen waren. Sie können mit der rechten Maustaste auf ein Objekt klicken, um Optionen für den Objekttyp anzuzeigen. Es besitzen noch nicht alle Objektknotentypen ein Kontextmenü, aber in künftigen Versionen werden zusätzliche Optionen und Verbesserungen hinzugefügt.

Der Tabellenmodell-Explorer bietet auch eine praktische Suchfunktion. Geben Sie einfach einen Teil des Namens in das Suchfeld ein, woraufhin der Tabellenmodell-Explorer die Strukturansicht auf die Übereinstimmungen eingrenzt.

Eigenschaftenfenster

Im Eigenschaftenfenster werden Eigenschaften des ausgewählten Objekts aufgelistet.

Project Eigenschaften werden nur der Projektname und der Projektordner im Eigenschaftenfenster angezeigt. Projekte verfügen außerdem über zusätzliche Einstellungen für Bereitstellungsoptionen und den Bereitstellungsserver, die Sie über ein Dialogfeld für modale Eigenschaften festlegen können. Klicken Sie in Projektmappen-Explorermit der rechten Maustaste auf das Projekt, und klicken Sie anschließend auf Eigenschaften, um diese Eigenschaften anzuzeigen.

In die Felder des Eigenschaftenfensters sind Steuerelemente eingebettet, die geöffnet werden, wenn Sie darauf klicken. Der Typ des Bearbeitungssteuerelements hängt von der bestimmten Eigenschaft ab. Die Steuerelemente umfassen Bearbeitungsfelder, Dropdownlisten und Links zu benutzerdefinierten Dialogfeldern. Die in grau angezeigten Eigenschaften sind schreibgeschützt.

Klicken Sie zum Anzeigen des Fensters Eigenschaften auf das Menü Ansicht und anschließend auf Eigenschaftenfenster.

Fehlerliste

Das Fenster mit der Fehlerliste enthält Meldungen zum Modellstatus:

  • Benachrichtigungen zu bewährten Sicherheitsmethoden.

  • Anforderungen für die Datenverarbeitung.

  • Informationen zu Semantikfehlern für berechnete Spalten, Measures und Zeilenfilter für Rollen. Bei berechneten Spalten können Sie auf die Fehlermeldung doppelklicken, um zur Fehlerquelle zu navigieren.

  • DirectQuery-Überprüfungsfehler.

Die Fehlerliste wird standardmäßig erst angezeigt, nachdem ein Fehler zurückgegeben wurde. Sie können das Fenster Fehlerliste jedoch jederzeit anzeigen. Klicken Sie zum Anzeigen des Fensters Fehlerliste auf das Menü Ansicht und anschließend auf Fehlerliste.

Output

Erstellungs- und Bereitstellungsinformationen werden (zusätzlich zum modalen Statusdialogfeld) im Fenster Ausgabe angezeigt. Klicken Sie zum Anzeigen des Ausgabefensters auf das Menü Ansicht und anschließend auf Ausgabe .

Beim Installieren der Erweiterung von Analysis Services-Projekten werden zusätzliche Menüelemente speziell für die Erstellung tabellarischer Modelle der menüleiste Visual Studio hinzugefügt. Das Menü "In Erweiterungen" kann verwendet werden, um daten abrufen oder den Datenimport-Assistenten (je nach aktivierter Kompatibilitätsebene und Legacydatenquellen) zu starten, vorhandene Verbindungen anzuzeigen, Arbeitsbereichsdaten zu verarbeiten und den Modellarbeitsbereich in Excel zu durchsuchen. Das Menü Tabelle kann verwendet werden, um Beziehungen zwischen Tabellen zu erstellen und zu verwalten, Measures zu erstellen und zu verwalten sowie Datentabelleneinstellungen, Berechnungsoptionen und andere Tabelleneigenschaften anzugeben. Im Menü Spalte können Sie Spalten in einer Tabelle hinzufügen und löschen, Spalten aus- und einblenden und verschiedene Spalteneigenschaften angeben, z.B. Datentypen und Filter. Sie können Projektmappen für tabellarische Modelle über das Menü Erstellen anlegen und bereitstellen. Die Funktionen zum Kopieren bzw. Einfügen sind im Menü Bearbeiten enthalten.

Zusätzlich zu diesen Menüelementen werden die Analysis Services-Optionen um weitere Einstellungen ergänzt, die im Menü Extras verfügbar sind.

Symbolleiste

Die Analysis Services-Symbolleiste ermöglicht den schnellen und einfachen Zugriff auf die am häufigsten verwendeten Befehle für die Modellerstellung.

Weitere Informationen

Tabellenmodellprojekte
Analysis Services-Tools