Entwickeln von U-SQL-Skripts mit Data Lake-Tools für Visual StudioDevelop U-SQL scripts by using Data Lake Tools for Visual Studio

Azure Data Lake- und Stream Analytics-Tools enthalten Funktionen für zwei Azure-Dienste: Azure Data Lake Analytics und Azure Stream Analytics.Azure Data Lake and Stream Analytics Tools include functionality related to two Azure services, Azure Data Lake Analytics and Azure Stream Analytics. Weitere Informationen zu den Azure Stream Analytics-Szenarien finden Sie unter Installieren der Azure Stream Analytics-Tools für Visual Studio.For more information about the Azure Stream Analytics scenarios, see Azure Stream Analytics tools for Visual Studio.

Dieser Artikel beschreibt, wie Sie Azure Data Lake Analytics-Konten mithilfe von Visual Studio erstellen.This article describes how to use Visual Studio to create Azure Data Lake Analytics accounts. Sie können Aufträge in U-SQL definieren und Aufträge an den Data Lake Analytics-Dienst übermitteln.You can define jobs in U-SQL, and submit jobs to the Data Lake Analytics service. Weitere Informationen zu Data Lake Analytics finden Sie unter Übersicht über Azure Data Lake Analytics.For more information about Data Lake Analytics, see Azure Data Lake Analytics overview.

Wichtig

Wir empfehlen Ihnen das Upgrade auf Azure Data Lake Tools für Visual Studio Version 2.3.3000.4 oder höher.We recommend you upgrade to Azure Data Lake Tools for Visual Studio version 2.3.3000.4 or later. Ältere Versionen stehen nicht mehr als Download zur Verfügung und sind veraltet.The previous versions are no longer available for download and are now deprecated.

  1. Überprüfen Sie, ob Sie von Azure Data Lake Tools für Visual Studio eine niedrigere Version als 2.3.3000.4 verwenden.Check if you are using an earlier version than 2.3.3000.4 of Azure Data Lake Tools for Visual Studio.

    Überprüfen der Toolversion

  2. Falls es sich bei Ihrer Version um eine Version vor 2.3.3000.4 handelt, aktualisieren Sie Ihre Azure Data Lake Tools für Visual Studio über das Download Center:If your version is an earlier version of 2.3.3000.4, update your Azure Data Lake Tools for Visual Studio by visiting the download center:

VoraussetzungenPrerequisites

Installieren von Azure Data Lake Tools für Visual StudioInstall Azure Data Lake Tools for Visual Studio

Für dieses Tutorial muss Data Lake Tools für Visual Studio installiert sein.This tutorial requires that Data Lake Tools for Visual Studio is installed. Weitere Informationen finden Sie unter Installieren von Data Lake Tools für Visual Studio.For more information, see Install Data Lake Tools for Visual Studio.

Herstellen einer Verbindung mit einem Azure Data Lake Analytics-KontoConnect to an Azure Data Lake Analytics account

  1. Öffnen Sie Visual Studio.Open Visual Studio.

  2. Öffnen Sie Data Lake Analytics-Explorer, indem Sie Ansicht > Data Lake Analytics-Explorer auswählen.Open Data Lake Analytics Explorer by selecting View > Data Lake Analytics Explorer.

  3. Klicken Sie mit der rechten Maustaste auf Azure, und wählen Sie dann Verbindung mit Microsoft Azure-Abonnement herstellen aus.Right-click Azure, then select Connect to Microsoft Azure Subscription. Befolgen Sie die Anweisungen unter Bei Ihrem Konto anmelden.In Sign in to your account, follow the instructions.

  4. Wählen Sie im Server-Explorer Azure > Data Lake Analytics aus.In Server Explorer, select Azure > Data Lake Analytics. Es wird eine Liste Ihrer Data Lake Analytics-Konten angezeigt.You see a list of your Data Lake Analytics accounts.

Schreiben Ihres ersten U-SQL-SkriptsWrite your first U-SQL script

Der folgende Text ist ein einfaches U-SQL-Skript.The following text is a simple U-SQL script. Es definiert ein kleines Dataset und schreibt dieses Dataset als Datei mit dem Namen /data.csv in die Standardinstanz von Data Lake Store.It defines a small dataset and writes that dataset to the default Data Lake Store as a file called /data.csv.

USE DATABASE master;
USE SCHEMA dbo;
@a  = 
    SELECT * FROM 
        (VALUES
            ("Contoso", 1500.0),
            ("Woodgrove", 2700.0)
        ) AS 
              D( customer, amount );
OUTPUT @a
    TO "/data.csv"
    USING Outputters.Csv();

Übermitteln eines Data Lake Analytics-AuftragsSubmit a Data Lake Analytics job

  1. Klicken Sie in Visual Studio auf Datei > Neu > Projekt.In Visual Studio, select File > New > Project.

  2. Wählen Sie den Typ U-SQL-Projekt und dann Weiter aus.Select the U-SQL Project type, and then select Next. Wählen Sie in Neues Projekt konfigurieren die Option Erstellen aus.In Configure your new project, select Create.

    Visual Studio erstellt eine Projektmappe mit der Datei Script.usql.Visual Studio creates a solution that contains a Script.usql file.

  3. Fügen Sie das Skript aus Schreiben Ihres ersten U-SQL-Skripts in das Fenster Script.usql ein.Paste the script from Write your first U-SQL script into the Script.usql window.

  4. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf Script.usql, und wählen Sie dann Skript senden aus.In Solution Explorer, right-click Script.usql, and select Submit Script.

  5. Wählen Sie unter Auftrag übermitteln ihr Data Lake Analytics-Konto aus, und wählen Sie Übermitteln aus.In Submit Job, choose your Data Lake Analytics account and select Submit.

    Visual Studio-U-SQL-Projekt senden

Nach der Auftragsübermittlung wird die Registerkarte Auftragsansicht mit dem Auftragsstatus geöffnet.After the job submission, the Job view tab opens to show the job progress.

  • Auftragszusammenfassung enthält die Zusammenfassung des Auftrags.Job Summary shows the summary of the job.
  • Auftragsdiagramm visualisiert den Fortschritt des Auftrags.Job Graph visualizes the progress of the job.
  • Metadatenvorgänge zeigt alle Aktionen, die auf den U-SQL-Katalog ausgeführt wurden.MetaData Operations shows all the actions that were taken on the U-SQL catalog.
  • Daten zeigt alle Eingaben und Ausgaben.Data shows all the inputs and outputs.
  • Unter State History (Statusverlauf) werden die Zeitachse und Statusdetails angezeigt.State History shows the timeline and state details.
  • Unter AU-Analyse sehen Sie, wie viele AUs im Auftrag verwendet wurden, und Sie können Simulationen verschiedener AU-Zuordnungsstrategien erkunden.AU Analysis shows how many AUs were used in the job and explore simulations of different AU allocation strategies.
  • Diagnose enthält eine erweiterte Analyse für die Optimierung der Ausführung und Leistung des Auftrags.Diagnostics provides an advanced analysis for job execution and performance optimization.

U-SQL Visual Studio Data Lake Analytics-Diagramm zur Auftragsleistung

Um den aktuellen Auftragsstatus anzuzeigen und den Bildschirm zu aktualisieren, wählen Sie Aktualisieren aus.To see the latest job status and refresh the screen, select Refresh.

Überprüfen des AuftragsstatusCheck job status

  1. Wählen Sie im Server-Explorer Azure > Data Lake Analytics aus.In Server Explorer, select Azure > Data Lake Analytics.

  2. Erweitern Sie den Namen des Azure Data Lake Analytics-Kontos.Expand the Data Lake Analytics account name.

  3. Doppelklicken Sie auf Aufträge.Double-click Jobs.

  4. Wählen Sie den Auftrag aus, den Sie zuvor gesendet haben.Select the job that you previously submitted.

Anzeigen der AuftragsausgabeSee the job output

  1. Navigieren Sie im Server-Explorer zu dem Auftrag, den Sie gesendet haben.In Server Explorer, browse to the job you submitted.

  2. Klicken Sie auf die Registerkarte Daten .Click the Data tab.

  3. Wählen Sie auf der Registerkarte Auftragsausgaben die Datei "/data.csv" aus.In the Job Outputs tab, select the "/data.csv" file.

Nächste SchritteNext steps