Verwenden von NotebooksUse notebooks

Ein Notebook ist eine Auflistung ausführbare Zellen (Befehle).A notebook is a collection of runnable cells (commands). Wenn Sie ein Notebook verwenden, werden in erster Linie Zellen entwickelt und ausgeführt.When you use a notebook, you are primarily developing and running cells.

Alle Notebook-Tasks werden von UI-Aktionen unterstützt, aber Sie können auch viele Aufgaben mithilfe von Tastenkombinationen ausführen.All notebook tasks are supported by UI actions, but you can also perform many tasks using keyboard shortcuts. Klicken Sie auf das Symbol  Tastatur Symbol, oder wählen Sie die Option ? > Verknüpfungen aus, um die Verknüpfung anzuzeigen.Toggle the shortcut display by clicking the Keyboard Icon icon or selecting ? > Shortcuts.

TastenkombinationenKeyboard shortcuts

Entwickeln von Notebooks Develop notebooks

In diesem Abschnitt wird beschrieben, wie Sie Notebook-Zellen entwickeln und in einem Notebook navigieren.This section describes how to develop notebook cells and navigate around a notebook.

Inhalt dieses Abschnitts:In this section:

Informationen zu NotebooksAbout notebooks

Ein Notebook verfügt über eine Symbolleiste, mit der Sie das Notebook verwalten und Aktionen innerhalb des Notebooks ausführen können:A notebook has a toolbar that lets you manage the notebook and perform actions within the notebook:

Notebook-SymbolleisteNotebook toolbar

und mindestens eine Zelle (oder Befehle), die Sie ausführen können:and one or more cells (or commands) that you can run:

Notebook-ZellenNotebook cells

Ganz rechts in einer Zelle enthält die Zelle Aktionen Zelle Aktionen  drei Menüs: Ausführen, Dashboardund Bearbeiten:At the far right of a cell, the cell actions Cell actions, contains three menus: Run, Dashboard, and Edit:

Symbol "ausführen" Dashboard Edit (Bearbeiten)

und zwei Aktionen: Ausblendenand two actions: Hide Zellen Minimierung und löschenand Delete Löschsymbol..

Hinzufügen einer ZelleAdd a cell

Um eine Zelle hinzuzufügen, bewegen Sie den Mauszeiger über eine Zelle oben oder unten, und klicken Sie auf das  Symbol Zelle hinzufügen , oder greifen Sie ganz rechts auf das Notebook-zellmenü zu, klicken Sie auf  nach unten , und wählen Sie unten Zelle hinzufügen oder Zelle hinzufügen aus.To add a cell, mouse over a cell at the top or bottom and click the Add Cell icon, or access the notebook cell menu at the far right, click Down Caret, and select Add Cell Above or Add Cell Below.

Löschen einer ZelleDelete a cell

Zum Menü "Zellen Aktionen" wechselnGo to the cell actions menu Zell Aktionen ganz rechts, und klicken Sie aufat the far right and click Löschsymbol (Löschen).(Delete).

Wenn Sie eine Zelle löschen, wird standardmäßig ein Bestätigungs Dialogfeld angezeigt.When you delete a cell, by default a delete confirmation dialog displays. Aktivieren Sie das Kontrollkästchen nicht mehr anzeigen , und klicken Sie auf bestätigen, um zukünftige Bestätigungs Dialogfelder zu deaktivieren.To disable future confirmation dialogs, select the Do not show this again checkbox and click Confirm. Sie können auch die Einstellung für das Bestätigungs Dialogfeld mit der Option Befehls Lösch Bestätigung aktivieren im  Konto Symbol > Benutzereinstellungen > Notebook-Einstellungenumschalten.You can also toggle the confirmation dialog setting with the Turn on command delete confirmation option in Account Icon > User Settings > Notebook Settings.

Zum Wiederherstellen gelöschter Zellen wählen Sie entweder > bearbeiten aus, um das Löschen von Zellen rückgängig zu machen , oder verwenden Sie die Z TastenkombinationTo restore deleted cells, either select Edit > Undo Delete Cells or use the (Z) keyboard shortcut.

Ausschneiden einer ZelleCut a cell

Wechseln Sie zu den Zellen Aktionen Menü  Zellen Aktionen ganz rechts, klicken Sie auf  nach unten Einfügemarke, und wählen Sie Zelle Ausschneidenaus.Go to the cell actions menu Cell actions at the far right, click Down Caret, and select Cut Cell.

Sie können auch die X Tastenkombination () verwenden.You can also use the (X) keyboard shortcut.

Um gelöschte Zellen wiederherzustellen, wählen Sie entweder > bearbeiten aus, um die Zellen auszuschneiden oder die Z Tastenkombination () zu verwenden.To restore deleted cells, either select Edit > Undo Cut Cells or use the (Z) keyboard shortcut.

Wählen Sie mehrere Zellen oder alle Zellen aus.Select multiple cells or all cells

Sie können benachbarte Notebook Zellen mithilfe von UMSCHALT + nachoben oder unten für die vorherige und die nächste Zelle auswählen.You can select adjacent notebook cells using Shift + Up or Down for the previous and next cell respectively. Mehrfach ausgewählte Zellen können kopiert, ausgeschnitten, gelöscht und eingefügt werden.Multi-selected cells can be copied, cut, deleted, and pasted.

Um alle Zellen auszuwählen, wählen Sie > bearbeiten aus, um alle Zellen auszuwählen, oder verwenden Sie die Befehlsmodus-Verknüpfung cmd + A.To select all cells, select Edit > Select All Cells or use the command mode shortcut Cmd+A.

StandardspracheDefault language

Die Standardsprache für jede Zelle wird in einem ( ) -Link neben dem Notebook-Namen angezeigt.The default language for each cell is shown in a () link next to the notebook name. Im folgenden Notebook ist SQL die Standardsprache.In the following notebook, the default language is SQL.

Notebook-StandardspracheNotebook default language

So ändern Sie die Standardsprache:To change the default language:

  1. Klicken Sie auf die Verknüpfung ( ) .Click () link. Das Dialogfeld Standardsprache ändern wird angezeigt.The Change Default Language dialog displays.

    Notebook-StandardspracheNotebook default language

  2. Wählen Sie in der Dropdown-Dropdown- Standardsprache die neue SpracheSelect the new language from the Default Language drop-down.

  3. Klicken Sie auf Ändern.Click Change.

  4. Um sicherzustellen, dass vorhandene Befehle weiterhin funktionieren, werden Befehle der vorherigen Standardsprache automatisch einem sprach Magic-Befehl vorangestellt.To ensure that existing commands continue to work, commands of the previous default language are automatically prefixed with a language magic command.

Sprachen mischen Mix languages

Sie können die Standardsprache überschreiben, indem Sie den sprach-Magic-Befehl %<language> am Anfang einer Zelle angeben.You can override the default language by specifying the language magic command %<language> at the beginning of a cell. Folgende magische Befehle werden unterstützt: %python , %r , %scala und %sql .The supported magic commands are: %python, %r, %scala, and %sql.

Hinweis

Wenn Sie einen sprach Magic-Befehl aufrufen, wird der Befehl an die repl im Ausführungs Kontext für das Notebook weitergeleitet.When you invoke a language magic command, the command is dispatched to the REPL in the execution context for the notebook. In einer Sprache definierte Variablen (und somit in der repl für diese Sprache) sind nicht in der repl einer anderen Sprache verfügbar.Variables defined in one language (and hence in the REPL for that language) are not available in the REPL of another language. REPLs kann den Status nur über externe Ressourcen, z. b. Dateien in DBFS oder Objekte im Objektspeicher, freigeben.REPLs can share state only through external resources such as files in DBFS or objects in object storage.

Notebooks unterstützen außerdem einige zusätzliche magische Befehle:Notebooks also support a few auxiliary magic commands:

  • %sh: Ermöglicht Ihnen das Ausführen von shellcode in Ihrem Notebook.%sh: Allows you to run shell code in your notebook. Fügen Sie die Option hinzu, wenn der Shellbefehl einen Beendigungs Status ungleich 0 (null) aufweist -e .To fail the cell if the shell command has a non-zero exit status, add the -e option. Dieser Befehl wird nur auf dem Apache Spark-Treiber ausgeführt, nicht auf den Workers.This command runs only on the Apache Spark driver, and not the workers. Um einen Shellbefehl auf allen Knoten auszuführen, verwenden Sie ein Initialisierungs Skript.To run a shell command on all nodes, use an init script.
  • %fs: Ermöglicht die Verwendung von dbutils File System-Befehlen.%fs: Allows you to use dbutils filesystem commands. Weitere Informationen finden Sie unter dbutils.See dbutils.
  • %md: Ermöglicht Ihnen das einbeziehen verschiedener Dokumentations Typen, einschließlich Text, Bildern und mathematischen Formeln und Gleichungen.%md: Allows you to include various types of documentation, including text, images, and mathematical formulas and equations. Weitere Informationen finden Sie im nächsten Abschnitt.See the next section.

Dokumentation einschließenInclude documentation

Um die Dokumentation in ein Notebook aufzunehmen, können Sie den %md Magic-Befehl verwenden, um markdown-Markup zu identifizieren.To include documentation in a notebook you can use the %md magic command to identify Markdown markup. Das enthaltene markdown-Markup wird in HTML gerendert.The included Markdown markup is rendered into HTML. Dieser markdown-Code Ausschnitt enthält z. b. Markup für eine Überschrift der Ebene:For example, this Markdown snippet contains markup for a level-one heading:

%md # Hello This is a Title

Sie wird als HTML-Titel gerendert:It is rendered as a HTML title:

Notebook-HTML-TitelNotebook HTML title

Reduzierbare ÜberschriftenCollapsible headings

Zellen, die nach Zellen mit markdown-Überschriften angezeigt werden, können in der Überschriften Zelle reduziert werden.Cells that appear after cells containing Markdown headings can be collapsed into the heading cell. Die folgende Abbildung zeigt eine Kopfzeile mit dem Namen über Schrift 1 , bei der die beiden folgenden Zellen reduziert sind.The following image shows a level-one heading called Heading 1 with the following two cells collapsed into it.

Reduzierte ZellenCollapsed cells

Um Überschriften zu erweitern und zu reduzieren, klicken Sie auf + und - .To expand and collapse headings, click the + and -.

Siehe auch ausblenden und Anzeigen von Zellen Inhalt.Also see Hide and show cell content.

Mithilfe relativer Pfade können Sie Links zu anderen Notebooks oder Ordnern in markdownzellen verknüpfen.You can link to other notebooks or folders in Markdown cells using relative paths. Geben href Sie das-Attribut eines Anker Tags als relativen Pfad an, beginnend mit einem, $ und folgen Sie dann dem gleichen Muster wie in UNIX-Dateisystemen:Specify the href attribute of an anchor tag as the relative path, starting with a $ and then follow the same pattern as in Unix file systems:

%md
<a href="$./myNotebook">Link to notebook in same folder as current notebook</a>
<a href="$../myFolder">Link to folder in parent folder of current notebook</a>
<a href="$./myFolder2/myNotebook2">Link to nested notebook</a>

Anzeigen von BildernDisplay images

Verwenden Sie die folgende Syntax, um im Dateispeichergespeicherte Images anzuzeigen:To display images stored in the FileStore, use the syntax:

%md
![test](files/image.png)

Angenommen, Sie verfügen über die Datei "databricks Logo Image" im Dateispeicher:For example, suppose you have the Databricks logo image file in FileStore:

dbfs ls dbfs:/FileStore/
databricks-logo-mobile.png

Wenn Sie den folgenden Code in eine markdown-Zelle einschließen:When you include the following code in a Markdown cell:

Bild in markdown-ZelleImage in Markdown cell

das Bild wird in der Zelle gerendert:the image is rendered in the cell:

Gerendertes BildRendered image

Anzeigen mathematischer GleichungenDisplay mathematical equations

Notebooks unterstützen katex zum Anzeigen mathematischer Formeln und Gleichungen.Notebooks support KaTeX for displaying mathematical formulas and equations. Beispiel:For example,

%md
\\(c = \\pm\\sqrt{a^2 + b^2} \\)

\\(A{_i}{_j}=B{_i}{_j}\\)

$$c = \\pm\\sqrt{a^2 + b^2}$$

\\[A{_i}{_j}=B{_i}{_j}\\]

Rendert als:renders as:

Gerenderte Gleichung 1Rendered equation 1

andand

%md
\\( f(\beta)= -Y_t^T X_t \beta + \sum log( 1+{e}^{X_t\bullet\beta}) + \frac{1}{2}\delta^t S_t^{-1}\delta\\)

where \\(\delta=(\beta - \mu_{t-1})\\)

Rendert als:renders as:

Gerenderte Gleichung 2Rendered equation 2

HTML einschließenInclude HTML

Sie können HTML in ein Notebook einschließen, indem Sie die-Funktion verwenden displayHTML .You can include HTML in a notebook by using the function displayHTML. Ein Beispiel für die Vorgehensweise finden Sie unter HTML, D3 und SVG in Notebooks .See HTML, D3, and SVG in notebooks for an example of how to do this.

Hinweis

Der displayHTML iframe wird von der Domäne bereitgestellt, databricksusercontent.com und die iframe Sandbox enthält das- allow-same-origin Attribut.The displayHTML iframe is served from the domain databricksusercontent.com and the iframe sandbox includes the allow-same-origin attribute. Auf databricksusercontent.com muss über Ihren Browser zugegriffen werden können.databricksusercontent.com must be accessible from your browser. Wenn sie zurzeit in Ihrem Unternehmensnetzwerk blockiert ist, muss sie von der IT in die Whitelist eingefügt werden.If it is currently blocked by your corporate network, it will need to be whitelisted by IT.

Befehls KommentareCommand comments

Mithilfe von Befehls Kommentaren können Sie Diskussionen mit Projektmitarbeitern durchführen.You can have discussions with collaborators using command comments.

Um die Kommentar Rand Leiste zu wechseln, klicken Sie oben rechts in einem Notebook auf die Schaltfläche Kommentare .To toggle the Comments sidebar, click the Comments button at the top right of a notebook.

Notebook-Kommentare umschaltenToggle notebook comments

Zum Hinzufügen eines Kommentars zu einem Befehl:To add a comment to a command:

  1. Markieren Sie den Befehls Text, und klicken Sie auf die Kommentar Blase:Highlight the command text and click the comment bubble:

    Kommentare öffnenOpen comments

  2. Fügen Sie Ihren Kommentar hinzu, und klicken Sie auf Kommentar.Add your comment and click Comment.

    Kommas hinzufügenAdd commenty

Klicken Sie zum Bearbeiten, löschen oder beantworten eines Kommentars auf den Kommentar, und wählen Sie eine Aktion aus.To edit, delete, or reply to a comment, click the comment and choose an action.

Kommentar bearbeitenEdit comment

Zellen Anzeige ändern Change cell display

Es gibt drei Anzeigeoptionen für Notebooks:There are three display options for notebooks:

  • Standard Ansicht: Ergebnisse werden unmittelbar nach Code Zellen angezeigt.Standard view: results are displayed immediately after code cells
  • Nur Ergebnisse: nur Ergebnisse werden angezeigt.Results only: only results are displayed
  • Nebeneinander: Code-und Ergebnis Zellen werden nebeneinander angezeigt. die Ergebnisse werden auf der rechten Seite angezeigt.Side-by-side: code and results cells are displayed side by side, with results to the right

Zum Menü "Ansicht" wechselnGo to the View menu Menü 'Ansicht' , um die Anzeigeoption auszuwählen.to select your display option.

parallele Ansichtside-by-side view

Zeilen-und Befehls Nummern anzeigenShow line and command numbers

Um Zeilennummern oder Befehls Nummern anzuzeigen, wechseln Sie zum Menü Ansicht Ansicht,  und wählen Sie Zeilennummern anzeigen oder Befehls Nummern anzeigenaus.To show line numbers or command numbers, go to the View menu View Menu and select Show line numbers or Show command numbers. Sobald Sie angezeigt werden, können Sie Sie im gleichen Menü wieder ausblenden.Once they’re displayed, you can hide them again from the same menu. Sie können Zeilennummern auch mit der Tastenkombination + Laktivieren.You can also enable line numbers with the keyboard shortcut Control+L.

Anzeigen von Zeilen-oder Befehls Nummern über das Menü "Ansicht"Show line or command numbers via the view menu

Im Notebook aktivierte Zeilen-und Befehls NummernLine and command numbers enabled in notebook

Wenn Sie Zeilen-oder Befehls Nummern aktivieren, speichert databricks Ihre Vorlieben und zeigt Sie in allen anderen Notebooks für diesen Browser an.If you enable line or command numbers, Databricks saves your preference and shows them in all of your other notebooks for that browser.

Befehls Nummern oberhalb der Zellen, die mit diesem bestimmten Befehl verknüpft sind.Command numbers above cells link to that specific command. Wenn Sie auf die Befehls Nummer einer Zelle klicken, wird Ihre URL so aktualisiert, dass Sie mit diesem Befehl verankert wird.If you click on the command number for a cell, it updates your URL to be anchored to that command. Wenn Sie einen Link zu einem bestimmten Befehl in Ihrem Notebook herstellen möchten, klicken Sie mit der rechten Maustaste auf die Befehls Nummer, und wählen Sie Linkadresse kopierenaus.If you want to link to a specific command in your notebook, right-click the command number and choose copy link address.

Suchen und Ersetzen von TextFind and replace text

Zum Suchen und Ersetzen von Text in einem Notebook wählen Sie Datei > suchen und ersetzenaus.To find and replace text within a notebook, select File > Find and Replace.

Suchen und Ersetzen von TextFind and replace text

Die aktuelle Übereinstimmung ist orange hervorgehoben, und alle anderen Übereinstimmungen werden gelb hervorgehoben.The current match is highlighted in orange and all other matches are highlighted in yellow.

Übereinstimmender TextMatching text

Sie können Übereinstimmungen einzeln ersetzen, indem Sie auf " ersetzen" klicken.You can replace matches on an individual basis by clicking Replace.

Sie können zwischen den Übereinstimmungen wechseln, indem Sie auf die Schaltflächen " Prev " und " Next " klicken oder UMSCHALT + Eingabe drücken und eingeben , um zum vorherigen bzw. nächsten Treffer zu wechseln.You can switch between matches by clicking the Prev and Next buttons or pressing shift+enter and enter to go to the previous and next matches, respectively.

Schließen Sie das Tool zum Suchen und ersetzen, indem Sie auf das Symbol "Löschen" klicken  oder ESCdrücken.Close the find and replace tool by clicking Delete Icon or by pressing esc.

AutoVervollständigenAutocomplete

Sie können Azure Databricks Auto Vervollständigen-Features verwenden, um Code Segmente automatisch zu vervollständigen, während Sie Sie in Zellen eingeben.You can use Azure Databricks autocomplete features to automatically complete code segments as you enter them in cells. Dies reduziert das, was Sie merken müssen, und minimiert die Menge an Typisierung, die Sie erledigen müssen.This reduces what you have to remember and minimizes the amount of typing you have to do. Azure Databricks unterstützt zwei Arten von Auto Vervollständigen in Ihrem Notebook: local und Server.Azure Databricks supports two types of autocomplete in your notebook: local and server.

Local Auto Vervollständigen schließt Wörter ab, die im Notebook vorhanden sind.Local autocomplete completes words that exist in the notebook. Die automatische Vervollständigung von Server ist leistungsfähiger, da Sie für definierte Typen, Klassen und Objekte sowie für SQL-Datenbank-und Tabellennamen auf den Cluster zugreift.Server autocomplete is more powerful because it accesses the cluster for defined types, classes, and objects, as well as SQL database and table names. Um den AutoComplete-Server zu aktivieren, müssen Sie das Anfügen eines Notebooks an einen Cluster anfügen und alle Zellen ausführen , die completable-Objekte definieren.To activate server autocomplete, you must attach your attach a notebook to a cluster and run all cells that define completable objects.

Wichtig

Die automatische Vervollständigung des Servers in R-Notebooks wird während der Befehlsausführung blockiert.Server autocomplete in R notebooks is blocked during command execution.

Die automatische Vervollständigung wird durch Drücken der Tab -Taste nach Eingabe eines completable-Objekts auslöst.You trigger autocomplete by pressing Tab after entering a completable object. Nachdem Sie z. b. die Zellen definiert und ausgeführt haben, die die Definitionen von MyClass und enthalten instance , sind die Methoden von instance completable, und eine Liste gültiger Vervollständigungen wird angezeigt, wenn Sie die Tab-Taste drücken.For example, after you define and run the cells containing the definitions of MyClass and instance, the methods of instance are completable, and a list of valid completions displays when you press Tab.

Auto Vervollständigen-AuslösungTrigger autocomplete

Die typvervollständigung und der Abschluss der SQL-Datenbank und des Tabellennamens funktionieren auf dieselbe Weise.Type completion and SQL database and table name completion work in the same way.

Typvervollständigung — —— — SQL-Vervollständigung

SQL Formatieren Format SQL

Azure Databricks stellt Tools bereit, mit denen Sie SQL-Code in Notebook Zellen schnell und problemlos formatieren können.Azure Databricks provides tools that allow you to format SQL code in notebook cells quickly and easily. Diese Tools verringern den Aufwand, den Code zu formatieren und die gleichen Codierungsstandards in Ihren Notebooks zu erzwingen.These tools reduce the effort to keep your code formatted and help to enforce the same coding standards across your notebooks.

Der Formatierer kann auf folgende Weise ausgelöst werden:You can trigger the formatter in the following ways:

  • Einzelne ZellenSingle cells

    • Tastenkombination: Drücken Sie cmd + UMSCHALT + F.Keyboard shortcut: Press Cmd+Shift+F.

    • Befehls Kontextmenü: Wählen Sie im Befehls Kontext-Dropdown Menü einer SQL-Zelle SQL-Format aus.Command context menu: Select Format SQL in the command context drop-down menu of a SQL cell. Dieses Element ist nur in SQL-Notebook-Zellen und denjenigen mit einer %sql Sprachmagiesichtbar.This item is visible only in SQL notebook cells and those with a %sql language magic.

      Formatieren von SQL aus dem Befehls KontextFormatting SQL From Command Context

  • Mehrere ZellenMultiple cells

    Wählen Sie mehrere SQL-Zellen aus, und klicken Sie dann auf Bearbeiten > Formatieren von SQLSelect multiple SQL cells and then select Edit > Format SQL Cells. Wenn Sie Zellen von mehr als einer Sprache auswählen, werden nur SQL-Zellen formatiert.If you select cells of more than one language, only SQL cells are formatted. Dazu zählen auch die, die verwenden %sql .This includes those that use %sql.

    SQL aus Menü "Bearbeiten" FormatierenFormatting SQL From Edit Menu

Dies ist die erste Zelle im vorangehenden Beispiel nach der Formatierung:Here’s the first cell in the preceding example after formatting:

Nach der Formatierung von SQLAfter Formatting SQL

Notebooks ausführen Run notebooks

In diesem Abschnitt wird beschrieben, wie Sie mindestens eine Notebook-Zelle ausführen.This section describes how to run one or more notebook cells.

Inhalt dieses Abschnitts:In this section:

Requirements (Anforderungen)Requirements

Das Notebook muss an einen Cluster angefügt werden.The notebook must be attached to a cluster. Wenn der Cluster nicht ausgeführt wird, wird der Cluster gestartet, wenn Sie eine oder mehrere Zellen ausführen.If the cluster is not running, the cluster is started when you run one or more cells.

Ausführen einer ZelleRun a cell

Klicken Sie in den Zellen Aktionen im Menü Zelle  auf der rechten Seite auf das  Symbol ausführen, und wählen Sie Zelle ausführenaus, oder drücken Sie UMSCHALT + EingabeTaste.In the cell actions menu Cell actions at the far right, click Run Icon and select Run Cell, or press shift+enter.

Wichtig

Die maximale Größe für eine Notebook-Zelle, sowohl der Inhalt als auch die Ausgabe, beträgt 16 MB.The maximum size for a notebook cell, both contents and output, is 16MB.

Versuchen Sie beispielsweise, diesen Python-Code Ausschnitt auszuführen, der auf die vordefinierte spark Variableverweist.For example, try running this Python code snippet that references the predefined spark variable.

spark

Führen Sie dann einen echten Code aus:and then, run some real code:

1+1 # => 2

Hinweis

Notebooks verfügen über eine Reihe von Standardeinstellungen:Notebooks have a number of default settings:

  • Wenn Sie eine Zelle ausführen, wird das Notebook automatisch ohne Eingabeaufforderung an einen laufenden Cluster angefügt .When you run a cell, the notebook automatically attaches to a running cluster without prompting.
  • Wenn Sie UMSCHALT + EingabeTaste drücken, führt das Notebook automatisch einen Bildlauf zur nächsten Zelle aus, wenn die Zelle nicht sichtbar ist.When you press shift+enter, the notebook auto-scrolls to the next cell if the cell is not visible.

Um diese Einstellungen zu ändern, wählen Sie  Konto Symbol > Benutzereinstellungen > Notebook-Einstellungen aus, und konfigurieren Sie die entsprechenden Kontrollkästchen.To change these settings, select Account Icon > User Settings > Notebook Settings and configure the respective checkboxes.

Alle über oder niedriger ausführenRun all above or below

Wenn Sie alle Zellen vor oder nach einer Zelle ausführen möchten, wechseln Sie zu den Zellen Aktionen Menü  Zelle Aktionen ganz rechts, klicken Sie auf "  Ausführen" , und wählen Sie " alle ausführen " oder Run All Below"alle ausführen" aus.To run all cells before or after a cell, go to the cell actions menu Cell actions at the far right, click Run Menu, and select Run All Above or Run All Below.

Alles unten ausführen schließt die Zelle ein, in der Sie sich befinden.Run All Below includes the cell you are in. Alles oben ausführen ist nicht.Run All Above does not.

Alle Zellen ausführen Run all cells

Um alle Zellen in einem Notebook auszuführen, wählen Sie in der Notebook-Symbolleiste die Option alle ausführen aus.To run all the cells in a notebook, select Run All in the notebook toolbar.

Wichtig

Führen Sie nicht alle aus, wenn die Schritte für die Bereitstellung und die Bereitstellung im selben Notebook ausgeführt werden.Do not do a Run All if steps for mount and unmount are in the same notebook. Dies könnte zu einer Racebedingung führen und die Einstellungspunkte möglicherweise beschädigen.It could lead to a race condition and possibly corrupt the mount points.

Mehrere Ausgaben pro Zelle anzeigenView multiple outputs per cell

Python-Notebooks und- %python Zellen in nicht-python-Notebooks unterstützen mehrere Ausgaben pro Zelle.Python notebooks and %python cells in non-Python notebooks support multiple outputs per cell.

Mehrere Ausgaben in einer ZelleMultiple outputs in one cell

Diese Funktion erfordert Databricks Runtime 7,1 oder höher und ist in Databricks Runtime 7,1 standardmäßig deaktiviert.This feature requires Databricks Runtime 7.1 or above and is disabled by default in Databricks Runtime 7.1. Aktivieren Sie es durch Festlegen von spark.databricks.workspace.multipleResults.enabled true .Enable it by setting spark.databricks.workspace.multipleResults.enabled true.

Python-und Scala-Fehler HervorhebungPython and Scala error highlighting

Python-und Scala-Notebooks unterstützen Fehler Hervorhebung.Python and Scala notebooks support error highlighting. Das heißt, dass die Codezeile, die den Fehler auslöst, in der Zelle hervorgehoben wird.That is, the line of code that is throwing the error will be highlighted in the cell. Wenn die Fehlerausgabe außerdem eine StackTrace ist, wird die Zelle, in der der Fehler ausgelöst wird, in StackTrace als Link zur Zelle angezeigt.Additionally, if the error output is a stacktrace, the cell in which the error is thrown is displayed in the stacktrace as a link to the cell. Sie können auf diesen Link klicken, um zum problematischen Code zu springen.You can click this link to jump to the offending code.

Python-Fehler HervorhebungPython error highlighting

Scala-Fehler HervorhebungScala error highlighting

BenachrichtigungenNotifications

Benachrichtigungen warnen Sie für bestimmte Ereignisse, z. b. welcher Befehl derzeit ausgeführt wird, während alle Zellen ausgeführt werden und welche Befehle sich im Fehlerzustand befinden.Notifications alert you to certain events, such as which command is currently running during Run all cells and which commands are in error state. Wenn Ihr Notebook mehrere Fehler Benachrichtigungen anzeigt, verfügt das erste über einen Link, mit dem Sie alle Benachrichtigungen löschen können.When your notebook is showing multiple error notifications, the first one will have a link that allows you to clear all notifications.

Notebook-BenachrichtigungenNotebook notifications

Notebook-Benachrichtigungen sind standardmäßig aktiviert.Notebook notifications are enabled by default. Sie können Sie unter dem  Konto Symbol > Benutzereinstellungen > Notebook-Einstellungendeaktivieren.You can disable them under Account Icon > User Settings > Notebook Settings.

Databricks-RatgeberDatabricks Advisor

Der databricks Advisor analysiert die Befehle bei jeder Durchführung automatisch und zeigt entsprechende Ratschläge in den Notebooks an.Databricks Advisor automatically analyzes commands every time they are run and displays appropriate advice in the notebooks. Die Hinweise zur Empfehlung enthalten Informationen, die Ihnen helfen, die Leistung von Arbeits Auslastungen zu verbessern, Kosten zu reduzieren und häufige Fehler zu vermeiden.The advice notices provide information that can assist you in improving the performance of workloads, reducing costs, and avoiding common mistakes.

Ratschläge anzeigenView advice

Ein blaues Feld mit einem Glühbirnen Symbol signalisiert, dass die Ratschläge für einen Befehl verfügbar sind.A blue box with a lightbulb icon signals that advice is available for a command. Im Feld wird die Anzahl der verschiedenen Ratschläge angezeigt.The box displays the number of distinct pieces of advice.

Databricks-RatschlägeDatabricks advice

Klicken Sie auf die Glühbirne, um das Feld zu erweitern und die Ratschläge anzuzeigen.Click the lightbulb to expand the box and view the advice. Ein oder mehrere Hinweise werden sichtbar.One or more pieces of advice will become visible.

Ratschläge anzeigenView advice

Klicken Sie auf den Link Weitere Informationen, um die Dokumentation mit weiteren Informationen zu den Empfehlungen anzuzeigen.Click the Learn more link to view documentation providing more information related to the advice.

Klicken Sie auf den Link nicht mehr anzeigen , um die Ratschläge auszublenden.Click the Don’t show me this again link to hide the piece of advice. Die Ratschläge dieses Typs werden nicht mehr angezeigt.The advice of this type will no longer be displayed. Diese Aktion kann in den Notebook-Einstellungen umgekehrtwerden.This action can be reversed in Notebook Settings.

Klicken Sie erneut auf die Glühbirne, um das ratfeld zu reduzieren.Click the lightbulb again to collapse the advice box.

Beratungs EinstellungenAdvice settings

Greifen Sie auf die Seite Notebook-Einstellungen zu, indem Sie  Konto Symbol > Benutzereinstellungen > Notebook-Einstellungen auswählen, oder indem Sie auf das Zahnrad Symbol im erweiterten ratfeld klicken.Access the Notebook Settings page by selecting Account Icon > User Settings > Notebook Settings or by clicking the gear icon in the expanded advice box.

Notebook-EinstellungenNotebook settings

Aktivieren Sie die Option databricks Advisor aktivieren, um Ratschläge zu aktivieren oder zu deaktivieren.Toggle the Turn on Databricks Advisor option to enable or disable advice.

Der Link ausgeblendete Ratschläge zurücksetzen wird angezeigt, wenn ein oder mehrere Arten von Empfehlungen aktuell ausgeblendet sind.The Reset hidden advice link is displayed if one or more types of advice is currently hidden. Klicken Sie auf den Link, um den ratungstyp wieder sichtbar zu machen.Click the link to make that advice type visible again.

Ausführen eines Notebooks aus einem anderen Notebook Run a notebook from another notebook

Sie können ein Notebook von einem anderen Notebook ausführen, indem Sie den %run <notebook> Magic-Befehl verwenden.You can run a notebook from another notebook by using the %run <notebook> magic command. Dies entspricht ungefähr einem :load Befehl in einer Scala-repl auf dem lokalen Computer oder einer- import Anweisung in Python.This is roughly equivalent to a :load command in a Scala REPL on your local machine or an import statement in Python. Alle Variablen, die in definiert <notebook> sind, werden in Ihrem aktuellen Notebook verfügbar.All variables defined in <notebook> become available in your current notebook.

%run muss sich in einer Zelle _selbst_befinden, da das gesamte Notebook Inline ausgeführt wird.%run must be in a cell by itself, because it runs the entire notebook inline.

Hinweis

Sie können nicht verwenden %run , um eine python-Datei und import die in dieser Datei definierten Entitäten in einem Notebook auszuführen.You cannot use %run to run a Python file and import the entities defined in that file into a notebook. Zum Importieren aus einer python-Datei müssen Sie die Datei in einer Python-Bibliothek Verpacken, eine Azure Databricks Bibliothek aus dieser Python-Bibliothek erstellen und die Bibliothek in dem Cluster installieren , mit dem Sie Ihr Notebook ausführen.To import from a Python file you must package the file into a Python library, create an Azure Databricks library from that Python library, and install the library into the cluster you use to run your notebook.

BeispielExample

Angenommen, Sie haben notebookA und notebookB .Suppose you have notebookA and notebookB. notebookA enthält eine Zelle mit dem folgenden Python-Code:notebookA contains a cell that has the following Python code:

x = 5

Obwohl Sie in nicht definiert haben x notebookB , können Sie x in auf zugreifen, notebookB nachdem Sie ausgeführt haben %run notebookA .Even though you did not define x in notebookB, you can access x in notebookB after you run %run notebookA.

%run /Users/path/to/notebookA

print(x) # => 5

Um einen relativen Pfad anzugeben, stellen Sie ihn mit ./ oder vor ../ .To specify a relative path, preface it with ./ or ../. Wenn sich z. notebookA b notebookB . und im selben Verzeichnis befinden, können Sie Sie alternativ von einem relativen Pfad ausführen.For example, if notebookA and notebookB are in the same directory, you can alternatively run them from a relative path.

%run ./notebookA

print(x) # => 5
%run ../someDirectory/notebookA # up a directory and into another

print(x) # => 5

Komplexere Interaktionen zwischen Notebooks finden Sie unter Notebook-Workflows.For more complex interactions between notebooks, see Notebook workflows.

Notebook-Status und- Ergebnisse verwalten Manage notebook state and results

Nachdem Sie ein Notebook an einen Cluster angefügt und eine oder mehrere Zellen ausgeführthaben, hat Ihr Notebook den Status und zeigt die Ergebnisse an.After you attach a notebook to a cluster and run one or more cells, your notebook has state and displays results. In diesem Abschnitt wird beschrieben, wie Sie den Notebook Zustand und die Ergebnisse verwalten.This section describes how to manage notebook state and results.

Inhalt dieses Abschnitts:In this section:

Notizbücher Status und Ergebnisse löschen Clear notebooks state and results

Um den Notebook Zustand und die Ergebnisse zu löschen, klicken Sie in der Notebook-Symbolleiste auf Löschen , und wählen Sie die AktionTo clear the notebook state and results, click Clear in the notebook toolbar and select the action:

Status und Ergebnisse löschenClear state and results

Herunterladen von ErgebnissenDownload results

Standardmäßig ist das Herunterladen von Ergebnissen aktiviert.By default downloading results is enabled. Informationen zum Umschalten dieser Einstellung finden Sie unter Verwalten der Möglichkeit zum Herunterladen von Ergebnissen aus Notebooks.To toggle this setting, see Manage the ability to download results from notebooks. Wenn das Herunterladen der Ergebnisse deaktiviert ist,  wird die Schaltfläche Download Ergebnis nicht angezeigt.If downloading results is disabled, the Download Result button is not visible.

Zellen Ergebnis herunterladenDownload a cell result

Sie können ein Zellen Ergebnis, das eine tabellarische Ausgabe enthält, auf Ihren lokalen Computer herunterladen.You can download a cell result that contains tabular output to your local machine. Klicken Sie aufClick the Ergebnis herunterladen Schaltfläche am unteren Rand einer Zelle.button at the bottom of a cell.

Zellen Ergebnisse herunterladenDownload cell results

Eine CSV-Datei export.csv mit dem Namen wird in Ihr Standard-Downloadverzeichnis heruntergeladen.A CSV file named export.csv is downloaded to your default download directory.

Vollständige Ergebnisse herunterladenDownload full results

Standardmäßig gibt Azure Databricks 1000 Zeilen eines dataframes zurück.By default Azure Databricks returns 1000 rows of a DataFrame. Wenn mehr als 1000 Zeilen vorhanden sind, ein Pfeil nach untenWhen there are more than 1000 rows, a down arrow Schaltfläche mit Pfeil nach unten wird hinzugefügt.is added to the Ergebnis herunterladen Schaltfläche.button. So laden Sie alle Ergebnisse einer Abfrage herunter:To download all the results of a query:

  1. Klicken Sie neben Download Ergebnis auf den Pfeil nach unten,  und wählen Sie vollständige Ergebnisse herunterladen.Click the down arrow next to Download Result and select Download full results.

    Vollständige Ergebnisse herunterladenDownload full results

  2. Wählen Sie erneut ausführen und herunterladenaus.Select Re-execute and download.

    Erneut ausführen und Ergebnisse herunterladenRe-run and download results

    Nach dem Herunterladen der vollständigen Ergebnisse wird eine CSV-Datei mit dem Namen export.csv auf den lokalen Computer heruntergeladen, und der /databricks-results Ordner enthält einen generierten Ordner, der die vollständigen Abfrageergebnisse enthält.After you download full results, a CSV file named export.csv is downloaded to your local machine and the /databricks-results folder has a generated folder containing full the query results.

    Heruntergeladene ErgebnisseDownloaded results

Zellen Inhalt ausblenden und anzeigen Hide and show cell content

Zellen Inhalt besteht aus zellcode und dem Ergebnis der Ausführung der Zelle.Cell content consists of cell code and the result of running the cell. Sie können den zellcode und das Ergebnis mithilfe des Menüs "Zellen Aktionen" ausblenden und anzeigen.You can hide and show the cell code and result using the cell actions menu Zell Aktionen rechts oben in der Zelle.at the top right of the cell.

So blenden Sie Zellen Code aus:To hide cell code:

  • Klicken Sie auf  nach unten, und wählen Sie Code ausblenden .Click Down Caret and select Hide Code

Führen Sie einen der folgenden Schritte aus, um das Zellen Ergebnis auszublenden und anzuzeigen:To hide and show the cell result, do any of the following:

  • Klicken Sie auf  nach unten, und wählen Sie Ergebnis ausblendenClick Down Caret and select Hide Result
  • AuswählenSelect Zellen Minimierung
  • Geben Sie ESC > UMSCHALT + o ein.Type Esc > Shift + o

Um ausgeblendeten zellcode oder Ergebnisse anzuzeigen, klicken Sie auf die Links Links anzeigen :To show hidden cell code or results, click the Show links:

Ausgeblendeten Code und Ergebnisse anzeigenShow hidden code and results

Siehe auch redusible-Überschriften.See also Collapsible headings.

Notebook-IsolationNotebook isolation

Die Notebook-Isolation bezieht sich auf die Sichtbarkeit von Variablen und Klassen zwischen Notebooks.Notebook isolation refers to the visibility of variables and classes between notebooks. Azure Databricks unterstützt zwei Isolations Typen:Azure Databricks supports two types of isolation:

  • Variablen-und Klassen IsolationVariable and class isolation
  • Isolation der Spark-SitzungSpark session isolation

Hinweis

Da alle an denselben Cluster angefügten Notebooks auf denselben Cluster-VMS ausgeführt werden, ist auch bei aktivierter Aktivierung der Spark-Sitzung keine garantierte Benutzer Isolation innerhalb eines Clusters vorhanden.Since all notebooks attached to the same cluster execute on the same cluster VMs, even with Spark session isolation enabled there is no guaranteed user isolation within a cluster.

Variablen-und Klassen IsolationVariable and class isolation

Variablen und Klassen sind nur im aktuellen Notebook verfügbar.Variables and classes are available only in the current notebook. Beispielsweise können zwei Notebooks, die an denselben Cluster angefügt sind, Variablen und Klassen mit dem gleichen Namen definieren. diese Objekte sind jedoch unterschiedlich.For example, two notebooks attached to the same cluster can define variables and classes with the same name, but these objects are distinct.

Um eine Klasse zu definieren, die für _alle Notebooks sichtbar ist, die an denselben Cluster angefügt_sind, definieren Sie die Klasse in einer Paket Zelle.To define a class that is visible to all notebooks attached to the same cluster, define the class in a package cell. Anschließend können Sie mit dem voll qualifizierten Namen auf die-Klasse zugreifen. Dies entspricht dem Zugriff auf eine Klasse in einer angefügten Scala-oder Java-Bibliothek.Then you can access the class by using its fully qualified name, which is the same as accessing a class in an attached Scala or Java library.

Isolation der Spark -Sitzung Spark session isolation

Jedes Notebook, das an einen Cluster mit Apache Spark 2.0.0 und höher angefügt ist, verfügt über eine vordefinierte Variable mit dem Namen spark , die eine darstellt SparkSession .Every notebook attached to a cluster running Apache Spark 2.0.0 and above has a pre-defined variable called spark that represents a SparkSession. SparkSession ist der Einstiegspunkt für die Verwendung von Spark-APIs und das Festlegen von Laufzeitkonfigurationen.SparkSession is the entry point for using Spark APIs as well as setting runtime configurations.

Die Isolation der Spark-Sitzung ist standardmäßig aktiviert.Spark session isolation is enabled by default. Sie können auch globale temporäre Sichten verwenden, um temporäre Sichten über Notebooks hinweg freizugeben.You can also use global temporary views to share temporary views across notebooks. Weitere Informationen finden Sie unter CREATE VIEW oder CREATE VIEW.See Create View or CREATE VIEW. Legen Sie zum Deaktivieren der Isolation der Spark-Sitzung spark.databricks.session.share true in der Spark-Konfigurationauf fest.To disable Spark session isolation, set spark.databricks.session.share to true in the Spark configuration.

Wichtig

spark.databricks.session.shareDurch das Festlegen von true wird die Überwachung unterbrochen, die sowohl für streamingnotebook-als auch für-Setting spark.databricks.session.share true breaks the monitoring used by both streaming notebook cells and streaming jobs. Dies betrifft insbesondere:Specifically:

  • Die Diagramme in streamingzellen werden nicht angezeigt.The graphs in streaming cells are not displayed.
  • Aufträge werden nicht blockiert, solange ein Stream ausgeführt wird (Sie führen einfach "erfolgreich" aus, um den Stream zu beenden).Jobs do not block as long as a stream is running (they just finish “successfully”, stopping the stream).
  • Streams in Aufträgen werden nicht auf die Beendigung überwacht.Streams in jobs are not monitored for termination. Stattdessen müssen Sie manuell aufzurufen awaitTermination() .Instead you must manually call awaitTermination().
  • Das Aufrufen der Anzeigefunktion für streamingdataframes funktioniert nicht.Calling the display function on streaming DataFrames doesn’t work.

Zellen, die Befehle in anderen Sprachen auslösende (d. h. Zellen, die %scala , %python , %r und verwenden), %sql und Zellen, die andere Notebooks enthalten (d. h. Zellen, die verwenden %run ), sind Teil des aktuellen Notebooks.Cells that trigger commands in other languages (that is, cells using %scala, %python, %r, and %sql) and cells that include other notebooks (that is, cells using %run) are part of the current notebook. Daher befinden sich diese Zellen in derselben Sitzung wie andere Notebook-Zellen.Thus, these cells are in the same session as other notebook cells. Im Gegensatz dazu führt ein Notebook-Workflow ein Notebook mit einem isolierten aus SparkSession , was bedeutet, dass temporäre Sichten, die in einem solchen Notebook definiert sind, in anderen Notebooks nicht sichtbar sind.By contrast, a notebook workflow runs a notebook with an isolated SparkSession, which means temporary views defined in such a notebook are not visible in other notebooks.

VersionskontrolleVersion control

Azure Databricks über die grundlegende Versionskontrolle für Notebooks verfügt.Azure Databricks has basic version control for notebooks. Sie können die folgenden Aktionen für Revisionen ausführen: Kommentare hinzufügen, Revisionen wiederherstellen und löschen und Revisions Verlauf löschen.You can perform the following actions on revisions: add comments, restore and delete revisions, and clear revision history.

Um auf Notebook-Revisionen zuzugreifen, klicken Sie oben rechts auf der Notebook-Symbolleiste auf Revisions Verlauf .To access notebook revisions, click Revision History at the top right of the notebook toolbar.

Inhalt dieses Abschnitts:In this section:

Hinzufügen eines KommentarsAdd a comment

So fügen Sie der aktuellen Revision einen Kommentar hinzu:To add a comment to the latest revision:

  1. Klicken Sie auf die Revision.Click the revision.

  2. Klicken Sie auf den Link jetzt speichern .Click the Save now link.

    Kommentar speichernSave comment

  3. Geben Sie im Dialogfeld "Notebook Revision speichern" einen Kommentar ein.In the Save Notebook Revision dialog, enter a comment.

  4. Klicken Sie auf Speichern.Click Save. Die Notebook-Revision wird mit dem eingegebenen Kommentar gespeichert.The notebook revision is saved with the entered comment.

Revision wiederherstellenRestore a revision

So stellen Sie eine Revision wieder her:To restore a revision:

  1. Klicken Sie auf die Revision.Click the revision.

  2. Klicken Sie auf diese Revision wiederherstellen.Click Restore this revision.

    Revision wiederherstellenRestore revision

  3. Klicken Sie auf Confirm (Bestätigen).Click Confirm. Die ausgewählte Revision wird zur letzten Revision des Notebooks.The selected revision becomes the latest revision of the notebook.

Löschen einer RevisionDelete a revision

So löschen Sie den Revisions Eintrag eines Notebooks:To delete a notebook’s revision entry:

  1. Klicken Sie auf die Revision.Click the revision.

  2. Klicken Sie auf das Papierkorb SymbolClick the trash icon Papierkorb..

    Revision löschenDelete revision

  3. Klicken Sie auf Ja, löschen.Click Yes, erase. Die ausgewählte Revision wird aus dem Revisions Verlauf des Notebooks gelöscht.The selected revision is deleted from the notebook’s revision history.

Löschen eines Revisions VerlaufsClear a revision history

So löschen Sie den Revisions Verlauf eines Notebooks:To clear a notebook’s revision history:

  1. Wählen Sie Datei aus, > den Revisions Verlauf zu löschen.Select File > Clear Revision History.

  2. Klicken Sie auf Ja, löschen.Click Yes, clear. Der Notebook-Revisions Verlauf wurde gelöscht.The notebook revision history is cleared.

    Warnung

    Nach dem Löschen kann der Revisions Verlauf nicht wieder hergestellt werden.Once cleared, the revision history is not recoverable.

Git-VersionskontrolleGit version control

Azure Databricks ist auch in diese git-basierten Tools für die Versionskontrolle integriert:Azure Databricks also integrates with these Git-based version control tools: