Schnellstart: Erstellen und Freigeben eines NotebooksQuickstart: Create and share a notebook

  1. Navigieren Sie zu Azure Notebooks, und melden Sie sich anGo to Azure Notebooks and sign in. (ausführliche Informationen hierzu finden Sie unter Schnellstart: Anmelden bei Azure Notebooks).(For details, see Quickstart - Sign in to Azure Notebooks).

  2. Wählen Sie oben auf Ihrer öffentlichen Profilseite Meine Projekte aus:From your public profile page, select My Projects at the top of the page:

    Link „Meine Projekte“ am oberen Rand des Browserfensters

  3. Klicken Sie auf der Seite My Projects (Meine Projekte) auf + New Project (+ Neues Projekt, Tastenkombination: n). Wenn Ihr Browserfenster schmal ist, wird möglicherweise nur + für die Schaltfläche angezeigt:On the My Projects page, select + New Project (keyboard shortcut: n); the button may appear only as + if the browser window is narrow:

    Befehl „New Project“ (Neues Projekt) auf der Seite „My Projects“ (Meine Projekte)

  4. Geben Sie folgende Informationen im angezeigten Popupfenster Create New Project (Neues Projekt erstellen) an, und klicken Sie anschließend auf Create (Erstellen):In the Create New Project popup that appears, enter or set the following details, then select Create:

    • Projektname: Hallo-Welt in PythonProject name: Hello World in Python

    • Projekt-ID: hello-world-pythonProject ID: hello-world-python

    • Public project (Öffentliches Projekt): (nicht aktiviert)Public project: (cleared)

    • Create a README.md (README-Datei erstellen): (nicht aktiviert)Create a README.md: (cleared)

      Popupfenster „Neues Projekt“ mit Detailangaben

  5. Nach einigen Augenblicken navigiert Azure Notebooks zum neuen Projekt.After a few moments, Azure Notebooks navigates you to the new project. Fügen Sie dem Projekt ein Notebook hinzu, indem Sie das Dropdownelement + New (+ Neu) (das möglicherweise nur als + angezeigt wird) und dann Notebook auswählen:Add a notebook to the project by selecting the + New drop-down (which may appear as only +), then selecting Notebook:

  6. Geben Sie im Popup Create New Notebook (Neues Notebook erstellen), das angezeigt wird, einen Dateinamen für Ihr Notebook ein, z. B. HelloWorldInPython.ipynb ( .ipynb bedeutet IronPython (Jupyter) Notebook), und wählen Sie Python 3.6 als Sprache aus (auch als Kernel bezeichnet):In the Create New Notebook popup that appears, enter a filename for your notebook, such as HelloWorldInPython.ipynb (.ipynb means IronPython (Jupyter) Notebook), and select Python 3.6 for the language (also referred to as the kernel):

    Popup „Create New Notebook“ (Neues Notebook erstellen)

  7. Wählen Sie New (Neu) aus, um die Erstellung des Notebooks abzuschließen, das dann in der Dateiliste Ihres Projekts angezeigt wird:Select New to finish creating the notebook, which then appears in your project's file list:

    Neues Notizbuch in der Dateiliste des Projekts

Ausführen des NotebooksRun the notebook

  1. Wählen Sie das neue Notebook aus, um es im Editor auszuführen; der von Ihnen gewählte Kernel (in diesem Beispiel Python 3.6) wird automatisch für das Notebook aktiviert:Select the new notebook to run it in the editor; the kernel you selected (Python 3.6 in this example) is automatically activated for this notebook:

    Ansicht eines neuen Notebooks in Azure Notebooks

  2. Standardmäßig weist das Notebook eine leere Codezelle auf.By default, the notebook has one empty code cell. Um den Zelltyp in Markdown zu ändern, wählen Sie Markdown in der Zelltyp-Dropdownliste aus:To change the cell type to Markdown, use the cell type drop-down to select Markdown:

    Ändern des Zelltyps in einem neuen Notebook

  3. Geben oder fügen Sie den folgenden Überschriftstext in die Zelle ein:Enter or paste the following heading text into the cell:

    # Hello World in Python
    
  4. Da Sie Markdown bearbeiten, wird der Text als Überschrift mit dem Zeichen "#" angezeigt.Because you're editing Markdown, the text appears as a header with the "#". Um das Markdown in HTML wiederzugeben, wählen Sie die Schaltfläche Run (Ausführen) aus.To render the Markdown into HTML, select the Run button. Anschließend erstellt Azure Notebooks dahinter automatisch eine neue Codezelle:Azure Notebooks then automatically creates a new code cell afterwards:

    Die Schaltfläche „Run“ (Ausführen) für eine Zelle und wiedergegebenes Markdown

  5. Geben Sie in der Codezelle den folgenden Python-Code ein:In the code cell, enter the following Python code:

    from datetime import datetime
    
    now = datetime.now()
    msg = "Hello, Azure Notebooks! Today is %s"  % now.strftime("%A, %d %B, %Y")
    print(msg)
    
  6. Wählen Sie Run (Ausführen, Tastenkombination: UMSCHALT+EINGABE) aus, um den Code auszuführen.Select Run (keyboard shortcut: Shift+Enter) to run the code. Unterhalb der Zelle sollten Sie bei Erfolg eine Ausgabe ähnlich dem folgenden Text sehen:Below the cell you should see successful output similar to the following text:

    Hello, Azure Notebooks! Today is Thursday, 15 November, 2018
    
  7. Wählen Sie die Schaltfläche „Speichern“ aus, um Ihre Arbeit zu speichern:Select the save icon to save your work:

    Symbol „Speichern“ auf der Jupyter-Notebooksymbolleiste

  8. Wählen Sie den Menübefehl File (Datei) > Close and Halt (Beenden und schließen) aus, um den Server zu beenden und das Browserfenster zu schließen.Select the File > Close and Halt menu command to stop the server and close the browser window.

Teilen des NotebooksShare the notebook

Um Ihr Notebook zu teilen, wechseln Sie ggf. zur Projektseite zurück, klicken Sie mit der rechten Maustaste auf die Notebookdatei, wählen Sie Copy Link (Link kopieren, Tastenkombination: y) aus, und fügen Sie diesen Link in eine geeignete Nachricht ein (E-Mail, Chat usw.).To share your notebook, switch back to the project page if needed, right-click the notebook file, select Copy Link (keyboard shortcut: y), and paste that link into an appropriate message (email, IM, etc.).

Auf der Projektseite können Sie außerdem das Menü Freigabe verwenden, um einen Link abzurufen, eine E-Mail-Nachricht mit dem Link zu erstellen oder einen HTML- und Markdown-Einbindungscode anzufordern:On the project page, you can also use the Share menu to obtain a link, create an email message with the link, or obtain HTML and Markdown embed code:

Projektbefehl „Freigabe“

Nächste SchritteNext steps