Schnellstart: Bereitstellen des Unity-Beispiels für den Desktop

In dieser Schnellstartanleitung erfahren Sie, wie Sie die Schnellstartbeispiel-App für Unity auf einem Desktop-PC bereitstellen und ausführen.

In dieser Schnellstartanleitung wird Folgendes vermittelt:

  • Erstellen der Schnellstartbeispiel-App für den Desktop
  • Bereitstellen des Beispiels auf einem PC
  • Ausführen des Beispiels auf einem PC

Voraussetzungen

In dieser Schnellstartanleitung stellen Sie das Beispielprojekt aus Schnellstart: Rendern eines Modells mit Unity bereit.

Stellen Sie sicher, dass Ihre Anmeldeinformationen ordnungsgemäß mit der Szene gespeichert werden und Sie über den Unity-Editor eine Verbindung mit einer Sitzung herstellen können.

Deaktivieren der Virtual Reality-Unterstützung

Derzeit werden nur flache Desktop-Apps auf dem Desktop unterstützt. Die VR-Unterstützung muss daher deaktiviert werden.

  1. Öffnen Sie Edit > Project Settings... (Bearbeiten > Projekteinstellungen).
  2. Wählen Sie auf der linken Seite Player aus.
  3. Wählen Sie die Registerkarte Universal Windows Platform settings (UWP-Einstellungen) aus.
  4. Erweitern Sie den Eintrag XR Settings (XR-Einstellungen).
  5. Deaktivieren Sie Virtual Reality Supported (Unterstützung für virtuelle Realität).
    Playereinstellungen
  6. Erweitern Sie oberhalb von XR Settings (XR-Einstellungen) die Option Publishing Settings (Veröffentlichungseinstellungen).
  7. Vergewissern Sie sich unter Supported Device Families (Unterstützte Gerätefamilien), ob Desktop aktiviert ist.

Erstellen des Beispielprojekts

  1. Öffnen Sie File > Build Settings (Datei > Buildeinstellungen).
  2. Ändern Sie Plattform in Universelle Windows-Plattform. (Eigenständiger PC wird ebenfalls unterstützt, aber hier nicht verwendet. Siehe Plattformeinschränkungen)
  3. Legen Sie Target Device (Zielgerät) auf PC fest.
  4. Legen Sie Architecture (Architektur) auf x86 fest.
  5. Legen Sie Build Type (Buildtyp) auf D3D Project (D3D-Projekt) fest.
    Buildeinstellungen
  6. Wählen Sie Switch to Platform (Zu Plattform wechseln) aus.
  7. Wenn Sie auf Build (Erstellen) oder „Build And Rund“ (Erstellen und ausführen) klicken, werden Sie zur Auswahl eines Ordners aufgefordert, in dem die Projektmappe gespeichert werden soll.
  8. Öffnen Sie die generierte Datei Quickstart.sln mit Visual Studio.
  9. Ändern Sie die Konfiguration in Release und x86.
  10. Ändern Sie den Debuggermodus in Local Machine (Lokaler Computer).
    Projektmappenkonfiguration
  11. Erstellen Sie die Projektmappe.

Starten des Beispielprojekts

Starten Sie den Debugger in Visual Studio (F5). Die App wird automatisch auf dem PC bereitgestellt.

Daraufhin sollte die Beispiel-App gestartet und anschließend eine neue Sitzung initiiert werden. Nach einer Weile ist die Sitzung bereit, und das remote gerenderte Modell wird vor Ihnen angezeigt. Wenn Sie das Beispiel später ein zweites Mal starten möchten, ist das nun auch über das Startmenü möglich.

Nächste Schritte

In der nächsten Schnellstartanleitung wird das Konvertieren eines benutzerdefinierten Modells erläutert.