Verwenden von BizTalk-MapperUsing BizTalk Mapper

ÜbersichtOverview

Der BizTalk-Mapper befindet sich in der Visual StudioVisual Studio Shell.The BizTalk Mapper resides in the Visual StudioVisual Studio shell. Einige Funktionen in der BizTalk-Mapper basieren auf den Elementen der Benutzeroberfläche der Visual StudioVisual Studio Shell.Some of the functionality in the BizTalk Mapper relies on the user interface elements of the Visual StudioVisual Studio shell. Sie verwenden, z. B. die Datei, bearbeiten, und Ansicht Menüs wie bei anderen entwicklungsvorgängen in würde Visual StudioVisual Studio.For example, you use the File, Edit, and View menus just as you would for other development in Visual StudioVisual Studio. Informationen zu diesen häufig verwendeten Funktionen sind verfügbar, aus der Hilfe Menü.Information about this common functionality is available from the Help menu.

Der BizTalk-Mapper wird aktiviert, wenn Sie eine neue Zuordnung zu einem BizTalk-Projekt hinzufügen, wenn Sie eine vorhandene Zuordnung (BTM-Datei) öffnen oder wenn Sie eine Zuordnung reaktivieren, indem Sie auf der Registerkarte im Hauptfenster Visual StudioVisual Studio Bearbeitungsfenster.The BizTalk Mapper becomes active when you add a new map to a BizTalk project, when you open an existing map (a .btm file), or when you reactivate a map by clicking its tab in the main Visual StudioVisual Studio editing window.

Hinweis

Der BizTalk-Mapper speichert Zuordnungsdateien mittels UTF-16-zeichencodierung.The BizTalk Mapper saves map files using UTF-16 character encoding.

Wenn Sie BizTalk-Projekt ein vorhandenes Element hinzufügen, ist die Buildaktion immer auf festgelegt BtsCompile.When you add an existing artifact to a BizTalk project, the build action is always set to BtsCompile. Auch wenn Sie ein vorhandenes Element umbenennen, wird seine Buildaktion auf den Standardwert festgelegt BtsCompile.Even when you rename an existing artifact, its build action is set to the default value BtsCompile. Beim Hinzufügen oder ein vorhandenes Element umbenennen, müssen Sie daher die Buildaktion abhängig davon, ob Sie dieses bestimmte Element oder nicht erstellen möchten.Hence, while adding or renaming an existing artifact, you need to set the build action appropriately depending on whether you want to build that particular artifact or not.

Teile der BizTalk-MapperParts of the BizTalk Mapper

Die folgende Abbildung zeigt die verschiedenen Teile des BizTalk-Mapper innerhalb Visual StudioVisual Studio.The following figure shows various parts of BizTalk Mapper within Visual StudioVisual Studio.

BizTalk-MapperBizTalk Mapper

Die Funktion der einzelnen Ansichten lautet wie folgt aus:The functionality of each of the views is as follows:

  • Visual Studio-Mapper-Menüband.Visual Studio Mapper Utility Ribbon. Die BizTalk ServerBizTalk Server -Mapper bietet ein Menüband mit Mapper-bezogenen Befehlen.The BizTalk ServerBizTalk Server Mapper provides a utility ribbon to surface Mapper-related commands. Das Menüband bietet Informationen zum Quellschema, Umschaltfläche, für die Ansicht nach Relevanz für Quell- und Zielschemas, Umschaltfläche zum ein- oder Ausblenden von Verknüpfungen außerhalb des Gültigkeitsbereichs, ein/aus-Schalter zum automatischen Bildlauf aktivieren oder deaktivieren, zum Schwenken der Mapper-Oberfläche Schaltfläche, Steuerelemente Vergrößern oder verkleinern Out und das Suchfeld ein.The ribbon provides source schema information, toggle button for relevance view for source and destination schemas, toggle button to show or hide totally out of scope links, toggle switch to turn auto-scrolling on or off, button to pan the Mapper surface, controls to zoom in or zoom out, and the search text box. Die folgende Abbildung zeigt dem funktionsmenüband, dass Sie am oberen Rand auf der Rasterseite angezeigt.The following figure shows the utility ribbon you can see at the top of the grid page.

    Menüband des MapperMapper ribbon

  • Quellschemastruktur-Ansicht.Source schema tree view. Diese Ansicht befindet sich im Hauptfenster Visual StudioVisual Studio -Fenster mit der Zielschemastruktur- und der Rasteransicht bearbeiten.This view shares the main Visual StudioVisual Studio editing window with the destination schema tree view and the grid view.

    Wie der Name schon sagt, zeigt diese Ansicht das Schema, das die Instanznachrichten beschreibt, die die Quelle der Zuordnung sind.As the name suggests, this view displays the schema that describes the instance messages that are the source of mapping. Die Links, die die Zuordnung definieren führen von der Quellschemastruktur-Ansicht zur Rasteransicht und schließlich an der Zielschemastruktur-Ansicht.The links that define the mapping lead from the source schema tree view to the grid view, and, ultimately, to the destination schema tree view.

    Weitere Informationen dazu, wie BizTalk-Schemas in einer schemastrukturansicht dargestellt werden, finden Sie unter darstellen von Schemas in BizTalk.For more information about how BizTalk schemas are represented in a schema tree view, see BizTalk Representation of Schemas.

  • Zielschemastruktur-Ansicht.Destination schema tree view. Diese Ansicht befindet sich im Hauptfenster Visual StudioVisual Studio -Fenster mit der Quellschemastruktur-Ansicht und der Rasteransicht bearbeiten.This view shares the main Visual StudioVisual Studio editing window with the source schema tree view and the grid view.

    Wie der Name schon sagt, zeigt diese Ansicht das Schema, das die Instanznachrichten beschreibt, die das Ziel der Zuordnung sind.As the name suggests, this view displays the schema that describes the instance messages that are the destination of the mapping. Die Links, die die Zuordnung definieren führen in der Zielschemastruktur-Ansicht aus der Rasteransicht und letztlich von der Quellschemastruktur-Ansicht.The links that define the mapping lead into the destination schema tree view from the grid view, and ultimately from the source schema tree view.

    Weitere Informationen dazu, wie BizTalk-Schemas in einer schemastrukturansicht dargestellt werden, finden Sie unter darstellen von Schemas in BizTalk.For more information about how BizTalk schemas are represented in a schema tree view, see BizTalk Representation of Schemas.

  • Rasteransicht.Grid view. Diese Ansicht befindet sich im Hauptfenster Visual StudioVisual Studio bearbeiten Sie das Fenster mit der Quellschemastruktur-Ansicht und der Zielschemastruktur-Ansicht, mit der Quellschemastruktur-Ansicht auf der linken Seite und der Zielschemastruktur-Ansicht rechts.This view shares the main Visual StudioVisual Studio editing window with the source schema tree view and the destination schema tree view, with the source schema tree view to the left and the destination schema tree view to the right.

    Wie der Name bereits vermuten lässt, spielt diese Ansicht einer entscheidende Rolle bei der Definition von Zuordnungen, mit der Verknüpfungen und Funktoide dieses Steuerelements, wie Daten in einer quellinstanznachricht in eine Instanznachricht transformiert werden, die mit dem Zielschema übereinstimmt.As the name suggests, this view plays a critical role in the definition of maps, containing the links and functoids that control how data in a source instance message is transformed into an instance message that conforms to the destination schema.

    Die Rasteransicht kann über mehrere Ebenen, genannten Rasterseiten, sodass Sie komplexe Zuordnungen in logische Untereinheiten aufteilen verfügen.The grid view can have multiple layers, called grid pages, allowing you to organize complex maps into logical subdivisions of mappings. Rasterseiten verwenden im Allgemeinen mehr Platz als jeweils angezeigt werden können, und es gibt verschiedene effektive Möglichkeiten, führen Sie einen Bildlauf innerhalb einer Rasterseite.Grid pages generally use more space than can be displayed at one time, and there are several effective ways to scroll within a grid page.

    Arbeiten Sie aktiv in dieser Ansicht Ihrer Zuordnung erstellen.You actively work in this view to construct your map.

  • Visual Studio-Toolbox-Fenster.Visual Studio Toolbox window. Verwenden Sie diese Ansicht, um Funktoide, die für die Verwendung in BizTalk-Zuordnungen und als Quelle für die Drag & Drop-Vorgänge zum Platzieren von Funktoiden auf einer Rasterseite anzuzeigen.You use this view to display the functoids available for use in BizTalk maps, and as the source of the drag-and-drop operations to place functoids in a grid page.

    Die in der Toolbox angezeigten Funktoide werden ihrer Kategorie entsprechend angeordnet.The functoids shown in the Toolbox are organized according to their categories. Weitere Informationen zu den verfügbaren Funktoiden finden Sie unter Funktoide in Zuordnungen.For more information about the available functoids, see Functoids in Maps. Siehe auch die Referenz zum Funktoid in der Anleitungen und Entwickler-API-Namespace Referenz zur Benutzeroberflächein the UI guidance and developers API namespace reference.Also see the Functoid Reference in der Anleitungen und Entwickler-API-Namespace Referenz zur Benutzeroberflächein the UI guidance and developers API namespace reference.

  • Visual Studio-Eigenschaftenfenster.Visual Studio Properties window. Sie verwenden in dieser Ansicht und den zugehörigen Dialogfeldern, um zu untersuchen und Festlegen der Eigenschaften von Verknüpfungen und Funktoide, die Sie zum Definieren Ihrer Zuordnung erstellen.You use this view, and its associated dialog boxes, to examine and set the properties of the links and functoids that you create to define your map.

    Wenn Sie eine Verknüpfung oder ein Funktoid auf einer Rasterseite in der Rasteransicht auswählen, wählen Sie einen Schemaknoten in der Quell- oder Zielschema-Strukturansichten oder eine Zuordnung in der Projektmappen-Explorer Fenster; die entsprechenden Eigenschaften der Verbindung, Funktoid Schemaknoten oder Zuordnung, die in angezeigt werden die Eigenschaften Fenster mithilfe der standardmäßigen Visual Studio-Konventionen.When you select a link or functoid in a grid page in the Grid view, select a schema node in the source or destination schema tree views, or select a map in the Solution Explorer window; the corresponding properties of that link, functoid, schema node, or map appear in the Properties window using the standard Visual Studio conventions. Z. B. die Eigenschaften sind in Kategorien unterteilt, und können gemäß diesen Kategorien oder alphabetisch angezeigt werden.For example, the properties are grouped into categories, and can be displayed according to these categories or alphabetically.

    Ausführliche Informationen zu den verschiedenen Eigenschaften, die für Verknüpfungen, Funktoide, Schemaknoten oder der Zuordnung selbst verfügbar sind, finden Sie die Map-Eigenschaftenverweis und Referenz zur Eigenschaft 'Schema'in der Anleitungen und Entwickler-API-Namespace Referenz zur Benutzeroberflächein the UI guidance and developers API namespace reference.For detailed information about the different sets of properties that are available for links, functoids, schema nodes, or the map itself, see the Map Property Reference and the Schema Property Reference in der Anleitungen und Entwickler-API-Namespace Referenz zur Benutzeroberflächein the UI guidance and developers API namespace reference.

  • Visual Studio-Aufgabenliste und Ausgabe-Fenster.Visual Studio Task List and Output windows. Sie verwenden diese Ansichten zum Überprüfen der Ergebnisse überprüfen, kompilieren und Testen Ihrer BizTalk-Zuordnungen im Wesentlichen die gleiche Weise, dass diese Sichten, beim Kompilieren von Quellcode verwendet werden und Erstellen anderer Projekttypen.You use these views to examine the results of validating, compiling, and testing your BizTalk maps in much the same way that these views are used when compiling source code and building other types of projects.

    Zusätzlich zu diesen Ansichten können Sie mehrere Dialogfelder interagieren.In addition to these views, you can interact with several dialog boxes. Diese Dialogfelder werden in der Regel geöffnet, wenn Sie z. B. die Eingabeparameter für ein Funktoid eine komplexe Eigenschaft bearbeiten.You usually open these dialog boxes when you are editing a complex property such as the input parameters to a functoid.

    Sie verwenden häufig das Projektmappen-Explorer-Fenster in Verbindung mit BizTalk-Mapper.You often use the Solution Explorer window in conjunction with BizTalk Mapper. Z. B. um eine neue Zuordnung erstellen, mit der rechten Maustaste in des BizTalk-Projekts die Projektmappen-Explorer Fenster, klicken Sie auf hinzufügen, klicken Sie auf neues Element hinzufügen, und verwenden Sie dann die Neues Element hinzufügen Dialogfeld einen Namen ein, und Erstellen einer neuen Karte.For example, to create a new map, right-click the BizTalk project in the Solution Explorer window, click Add, click Add New Item, and then use the Add New Item dialog box to name and create a new map.

Nächste SchritteNext steps

Siehe auchSee Also

Gewusst wie: optimieren die Anzeige von LinksHow to Optimize the Display of Links