Exemplarische Vorgehensweise: Kompilieren eines C++/CLI-Programms, das auf die CLR in Visual Studio

Mit C++/CLI können Sie C++-Programme erstellen, die .NET-Klassen sowie native C++-Typen verwenden. C++/CLI ist für die Verwendung in Konsolenanwendungen und DLLs vorgesehen, die nativen C++-Code umschließen und über .NET-Programme zugänglich machen. Um eine benutzeroberfläche Windows .NET zu erstellen, verwenden Sie C# oder Visual Basic.

Für dieses Verfahren können Sie Ihr eigenes C++-Programm eingeben oder eines der Beispielprogramme verwenden. Das Beispielprogramm, das für diese Vorgehensweise verwendet wird, erstellt eine Textdatei namens „textfile.txt“, die im Projektverzeichnis gespeichert wird.

Voraussetzungen

  • Grundlegende Kenntnisse der Programmiersprache C++.
  • In Visual Studio 2017 und höher ist die C++/CLI-Unterstützung eine optionale Komponente. Um es zu installieren, öffnen Sie die Visual Studio-Installer im Windows Startmenü. Stellen Sie sicher, dass die Kachel Desktopentwicklung mit C++ überprüft ist, und aktivieren Sie im Abschnitt Optionale Komponenten auch C++/CLI-Unterstützung.

Erstellen eines neuen Projekts

Die folgenden Schritte variieren leicht, je nachdem, welche Version von Visual Studio Sie verwenden. Um die Dokumentation für Ihre bevorzugte Version von Visual Studio anzuzeigen, verwenden Sie das Auswahlsteuerelement Version. Es befindet sich am Anfang des Inhaltsverzeichnisses auf dieser Seite.

So erstellen Sie ein C++/CLI-Projekt in Visual Studio

  1. Klicken Projektmappen-Explorermit der rechten Maustaste auf den oberen Bereich, um das Dialogfeld Neue Project zu öffnen.

  2. Geben Sie oben im Dialogfeld CLR in das Suchfeld ein, und wählen Sie dann CLR Empty Project aus der Ergebnisliste aus.

  3. Klicken Sie auf die Schaltfläche Erstellen, um das Projekt zu erstellen.

So erstellen Sie ein C++/CLI-Projekt in Visual Studio 2017

  1. Erstellen Sie ein neues Projekt. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Projekt.

  2. Klicken Sie in den Visual C++-Projekttypen auf CLR, und klicken Sie dann auf leeres CLR-Projekt.

  3. Geben Sie einen Projektnamen ein. Standardmäßig erhält die Projektmappe, in der das Projekt enthalten ist, den gleichen Namen wie das neue Projekt. Sie können jedoch auch einen anderen Namen eingeben. Wenn Sie möchten, können Sie auch einen anderen Speicherort für das Projekt angeben.

  4. Klicken Sie auf OK, um das neue Projekt zu erstellen.

So erstellen Sie ein C++/CLI-Projekt in Visual Studio 2015

  1. Erstellen Sie ein neues Projekt. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Projekt.

  2. Klicken Sie in den Visual C++-Projekttypen auf CLR, und klicken Sie dann auf leeres CLR-Projekt.

  3. Geben Sie einen Projektnamen ein. Standardmäßig erhält die Projektmappe, in der das Projekt enthalten ist, den gleichen Namen wie das neue Projekt. Sie können jedoch auch einen anderen Namen eingeben. Wenn Sie möchten, können Sie auch einen anderen Speicherort für das Projekt angeben.

  4. Klicken Sie auf OK, um das neue Projekt zu erstellen.

Hinzufügen einer Quelldatei

  1. Wenn der Projektmappen-Explorer nicht angezeigt wird, klicken Sie im Menü Ansicht auf Projektmappen-Explorer.

  2. Fügen Sie dem Projekt eine neue Quelldatei hinzu:

    • Klicken Sie mit der rechten Maustaste auf den Ordner Quelldateienin Projektmappen-Explorer , zeigen Sie auf Hinzufügen,und klicken Sie auf Neues Element.

    • Klicken Sie auf C++-Datei (.cpp), geben Sie einen Dateinamen ein, und klicken Sie dann auf Hinzufügen.

    Die CPP-Datei wird im Ordner Quelldateien in Projektmappen-Explorer und ein Fenster im Registerkartenfenster angezeigt, in dem Sie den code eingeben, den Sie in diese Datei eingeben möchten.

  3. Klicken Sie in Visual Studio in die neu erstellte Registerkarte, und geben Sie ein gültiges Visual C++-Programm ein, oder kopieren Sie eines der Beispielprogramme und fügen es ein.

    Sie können beispielsweise das Beispielprogramm How to: Write a Text File (C++/CLI) (Vorgehensweise: Schreiben einer Textdatei (C++/CLI)) verwenden (im Knoten Dateibehandlung und E/A des Programmierhandbuchs).

    Beachten Sie, wenn Sie das Beispielprogramm verwenden, dass Sie das Schlüsselwort gcnew anstelle von new beim Erstellen eines .NET-Objekts verwenden, und dass gcnew ein Handle (^) anstelle eines Pointers (*) zurückgibt:

    StreamWriter^ sw = gcnew StreamWriter(fileName);

    Weitere Informationen zur C++/CLI-Syntax finden Sie unter Komponentenerweiterungen für Laufzeitplattformen.

  4. Klicken Sie im Menü Build auf Projektmappe erstellen.

    Im Ausgabefenster werden Informationen zum Kompilierungsprozess angezeigt, z.B. der Speicherort des Buildprotokolls und eine Meldung über den Buildstatus.

    Wenn Sie Änderungen vornehmen und das Programm ausführen, ohne einen Buildvorgang auszuführen, gibt ein Dialogfeld möglicherweise an, dass das Projekt nicht mehr aktuell ist. Aktivieren Sie in diesem Dialogfeld das Kontrollkästchen, bevor Sie auf OK klicken, wenn Sie möchten, dass Visual Studio immer die aktuellen Versionen von Dateien verwendet, anstatt Sie jedes zur Eingabe aufzufordern, wenn die Anwendung erstellt wird.

  5. Klicken Sie im Menü Debuggen auf Ohne Debuggen starten.

  6. Wenn Sie das Beispielprogramm verwendet haben und das Programm ausführen, wird ein Befehlsfenster angezeigt, das angibt, dass die Textdatei erstellt wurde.

    Die Textdatei textfile.txt befindet sich nun in Ihrem Projektverzeichnis. Sie können diese Datei mit dem Editor öffnen.

    Hinweis

    Durch Auswählen der leeren CLR-Projektvorlage wird automatisch die Compileroption /clr festgelegt. Klicken Sie zum Überprüfen mit der rechten Maustaste auf das Projekt im Projektmappen-Explorer, klicken Sie auf Eigenschaften, und überprüfen Sie dann die Option Common Language Runtime-Unterstützung im Knoten Allgemein der Konfigurationseigenschaften.

Siehe auch

C++-Programmiersprachenreferenz
Projekte und Buildsysteme