Lesen und Verstehen von C++-Code in Visual Studio

Der C++-Code-Editor und die IDE in Visual Studio bieten viele Programmierhilfen. Einige sind nur für C++, und einige sind im Wesentlichen für alle Visual Studio-Sprachen identisch. Weitere Informationen über die freigegebenen Features finden Sie unter Schreiben von Code im Code- und Text-Editor.

Farbliche Kennzeichnung

Visual Studio färbt Syntaxelemente ein, um zwischen Typen von Symbolen zu unterscheiden, z. B. Sprachschlüsselwörter, Typnamen, Namen von Variablen, Funktionsparameter, Zeichenfolgenliterale usw.

Screenshot showing code colorization in the editor.

Nicht verwendeter Code (z. B. Code unter „#if 0“) wird blasser dargestellt.

Screenshot showing inactive code in the editor.

Sie können die Farben anpassen, indem Sie „Fonts“ (Schriftarten) im Schnellstart eingeben und Schriftarten und Farben auswählen. Scrollen Sie im Dialogfeld Schriftarten und Farben nach unten zu dem C-/C++-Optionen, und wählen Sie dann eine benutzerdefinierte Schriftart und/oder Farbe aus.

Gliedern

Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle in einer Quellcodedatei, und wählen Sie Gliedern aus, um Codeblöcke und/oder benutzerdefinierte Regionen zu reduzieren oder zu erweitern, um das Durchsuchen nur des für Sie interessanten Codes zu vereinfachen. Weitere Informationen finden Sie unter Gliedern.

Screenshot of C plus plus Outlining.

Wenn Sie Ihren Cursor vor eine geschweifte Klammer („{“ oder „}“) platzieren, hebt der Editor das zugehörige Gegenstück hervor.

Weitere Gliederungsoptionen finden Sie im Hauptmenü unter Bearbeiten>Gliederung.

Zeilennummern

Sie können Zeilennummern zu Ihrem Projekt hinzufügen, indem Sie Extras>Optionen>Text-Editor>Alle Sprachen>Allgemein öffnen oder mit Schnellstart (STRG+Q) nach „line num“ (Zeilennummern) suchen. Zeilennummern können für alle Sprachen oder nur für spezifische Sprachen festgelegt werden, einschließlich C++.

Scrollen und Vergrößern

Sie können den Editor vergrößern oder verkleinern, indem Sie STRG halten und mit dem Mausrad scrollen. Sie können auch die Zoomeinstellung in der unteren linken Ecke nutzen.

Screenshot of the C plus plus Zoom Control.

Mit dem Scrollleisten-Code Map-Modus können Sie schnell scrollen und eine Codedatei durchsuchen, ohne die aktuelle Position zu verlassen. Sie können auf eine beliebige Stelle in der Code Map klicken, um zu dieser zu springen.

Screenshot of the Code Map in C plus plus.

Geben Sie „map“ in das Schnellstart-Suchfeld in der Hauptsymbolleiste ein, und wählen Sie Use scroll map mode (Scroll-Code Map-Modus verwenden) aus, um den Code Map-Modus zu aktivieren. Weitere Informationen finden Sie unter Vorgehensweise: Verfolgen von Code durch Anpassen der Scrollleiste.

Wenn der Code Map-Modus deaktiviert ist, hebt die Scrollleiste weiterhin die Änderungen hervor, die Sie in der Datei vorgenommen haben. Grün gibt gespeicherte Änderungen an, und Gelb gibt nicht gespeicherte Änderungen an.

QuickInfo und ParameterInfo

Zeigen Sie auf eine beliebige Variable, Funktion oder ein anderes Symbol, um Informationen über dieses zu erhalten, einschließlich der Deklaration und weiteren Kommentare, die davor platziert wurden.

Screenshot showing the Quick Info tooltip in Visual Studio 2019.

Die QuickInfo enthält einen Link zum Online suchen. Öffnen Sie Extras>Optionen>Text-Editor>C++>Ansicht, um den Suchanbieter festzulegen.

Wenn Ihr Code einen Fehler aufweist, können Sie auf diesen zeigen. In der QuickInfo wird die Fehlermeldung angezeigt. Sie können die Fehlermeldung auch im Fenster „Fehlerliste“ finden.

Screenshot showing Quick Info on error.

Screenshot showing the Quick Info tooltip in Visual Studio 2017.

Wenn Ihr Code einen Fehler aufweist, können Sie auf diesen zeigen. In der QuickInfo wird die Fehlermeldung angezeigt. Sie können die Fehlermeldung auch im Fenster Fehlerliste finden.

Screenshot showing Quick Info on error.

Wenn Sie eine Funktion aufrufen, zeigt die ParameterInfo die Parametertypen und die erwartete Reihenfolge an.

Screenshot of Parameter Info in C plus plus.

Peek-Definition

Zeigen Sie auf eine Variablen- oder Funktionsdeklaration, klicken Sie mit der rechten Maustaste, und wählen Sie dann Definition einsehen aus, um eine Inlineansicht der Definition anzuzeigen, ohne die aktuelle Position zu verlassen. Weitere Informationen finden Sie unter Peek-Definition (Alt+F12).

Screenshot of C plus plus Peek Definition.

F1-Hilfe

Platzieren Sie den Cursor in oder direkt hinter einen Typ, ein Schlüsselwort oder einer Funktion, und drücken Sie F1, um direkt das entsprechende Referenzthema auf docs.microsoft.com zu öffnen. F1 funktioniert auch für Elemente in der Fehlerliste und in vielen Dialogfeldern.

Klassenansicht

Die Klassenansicht zeigt durchsuchbare Strukturen aller Codesymbole und deren Bereiche sowie über- und untergeordnete Hierarchien pro Projekt an. Sie können in den Klassenansichtseinstellungen konfigurieren (klicken Sie hierzu oben im Fenster auf das Zahnradsymbol), was in der Klassenansicht angezeigt wird.

Screenshot of Class View in C plus plus.

Diagramm für Includedateien generieren

Klicken Sie mit der rechten Maustaste auf eine Codedatei im Projekt, und wählen Sie Diagramm für Includedateien generieren aus, um ein Diagramm darüber anzuzeigen, welche Dateien in anderen Dateien enthalten sind.

Screenshot of C plus plus graph of include files.

Aufrufhierarchie anzeigen

Klicken Sie mit der rechten Maustaste auf einen beliebigen Funktionsaufruf, und lassen Sie eine rekursive Liste aller Funktionen anzeigen, die er aufruft, sowie aller Funktionen, die ihn aufrufen. Jede Funktion in der Liste kann auf die gleiche Weise erweitert werden. Weitere Informationen finden Sie unter Aufrufhierarchie.

Screenshot of C plus plus Call Hierarchy.

Weitere Informationen

Schreiben und Umgestalten von Code (C++)
Navigieren in C++-Code in Visual Studio
Zusammenarbeit mit Live Share für C++