Exemplarische Vorgehensweise: Arbeiten mit Projekten und Projektmappen (C++)

In diesem Abschnitt lesen Sie, wie Sie ein C++-Projekt in Visual Studio erstellen, Code hinzufügen und dann das Projekt erstellen und ausführen. Bei dem Projekt in dieser exemplarischen Vorgehensweise handelt es sich um ein Programm, das nachverfolgt, wie viele Spieler verschiedene Kartenspiele spielen.

In Visual Studio wird die Arbeit in Projekten und Projektmappen organisiert. Eine Projektmappe kann mehrere Projekte aufweisen, z.B. eine DLL und eine ausführbare Datei, die auf diese DLL verweist. Weitere Informationen finden Sie unter Projektmappen und Projekte.

Vor der Installation

Sie benötigen mindestens Visual Studio 2017, um diese exemplarische Vorgehensweise abschließen zu können. Wie Sie eine Kopie erhalten, erfahren Sie in der folgenden Anleitung: Install C++ support in Visual Studio (Installieren der C++-Unterstützung in Visual Studio). Wenn Sie dies noch nicht durchgeführt haben, befolgen Sie nach der Installation die nächsten Schritte im Tutorial „Hallo Welt“, um sicherzustellen, dass die C++-Komponenten ordnungsgemäß installiert wurden und alles funktioniert.

Es ist hilfreich, die Grundlagen von C++ zu verstehen und zu wissen, wofür der Compiler, der Linker und der Debugger verwendet werden. Im Tutorial wird ebenfalls davon ausgegangen, dass Sie mit Windows vertraut sind und wissen, wie Sie z.B. Menüs und Dialogfelder verwenden.

Erstellen eines Projekts

Um ein Projekt zu erstellen, wählen Sie zunächst eine Projekttypvorlage. Für jeden Projekttyp legt Visual Studio Compilereinstellungen fest und generiert abhängig vom Typ Startcode, den Sie später ändern können. Die folgenden Schritte variieren leicht, je nachdem, welche Version von Visual Studio Sie verwenden. Um die Dokumentation für Ihre bevorzugte Version von Visual Studio anzuzeigen, verwenden Sie das Auswahlsteuerelement Version. Es befindet sich am Anfang des Inhaltsverzeichnisses auf dieser Seite.

Erstellen eines Projekts in Visual Studio 2019

  1. Wählen Sie im Hauptmenü Datei > Neu > Projekt aus, um das Dialogfeld Neues Projekt erstellen zu öffnen.

  2. Legen Sie oben im Dialogfeld die Sprache auf C++ , die Plattform auf Windows und den Projekttyp auf Konsole fest.

  3. Wählen Sie aus der gefilterten Projekttypliste Konsolen-App aus, und klicken Sie auf Weiter. Geben Sie auf der nächsten Seite Game als Name für das Projekt ein.

    Sie können den Standardspeicherort in der Dropdownliste Speicherort akzeptieren, einen anderen Speicherort eingeben oder über die Schaltfläche Durchsuchen das Verzeichnis auswählen, in dem Sie das Projekt speichern möchten.

    Beim Erstellen eines Projekts wird das Projekt von Visual Studio in eine Projektmappe eingefügt. Standardmäßig weist die Lösung den gleichen Namen wie das Projekt auf. Sie können den Namen im Feld Projektmappenname ändern. Behalten Sie für dieses Beispiel jedoch den Standardnamen bei.

  4. Klicken Sie auf die Schaltfläche Erstellen, um das Projekt zu erstellen.

    Visual Studio erstellt Ihre neue Projektmappe und die Projektdateien und öffnet den Editor für die Quellcodedatei „Game.cpp“, die generiert wurde.

Erstellen eines Projekts in Visual Studio 2017

  1. Wählen Sie in der Menüleiste Datei > Neu > Projekt aus.

  2. Erweitern Sie Installiert im linken Bereich des Dialogfeld Neues Projekt, und wählen Sie Visual C++ aus, wenn dies nicht bereits geöffnet ist.

  3. Wählen Sie aus der Liste der installierten Vorlagen im mittleren Bereich Windows-Konsolenanwendung aus.

  4. Geben Sie im Feld Name einen Namen für das Projekt ein. Geben Sie für dieses Beispiel Game ein.

    Sie können den Standardspeicherort in der Dropdownliste Speicherort akzeptieren, einen anderen Speicherort eingeben oder über die Schaltfläche Durchsuchen das Verzeichnis auswählen, in dem Sie das Projekt speichern möchten.

    Beim Erstellen eines Projekts wird das Projekt von Visual Studio in eine Projektmappe eingefügt. Standardmäßig weist die Lösung den gleichen Namen wie das Projekt auf. Sie können den Namen im Feld Projektmappenname ändern. Behalten Sie für dieses Beispiel jedoch den Standardnamen bei.

  5. Wählen Sie die Schaltfläche OK aus, um das Projekt zu erstellen.

    Visual Studio erstellt Ihre neue Projektmappe und die Projektdateien und öffnet den Editor für die Quellcodedatei „Game.cpp“, die generiert wurde.

Erstellen eines Projekts in Visual Studio 2015

  1. Wählen Sie in der Menüleiste Datei > Neu > Projekt aus.

  2. Erweitern Sie Installiert im linken Bereich des Dialogfeld Neues Projekt, und wählen Sie Visual C++ aus, wenn dies nicht bereits geöffnet ist.

  3. Wählen Sie aus der Liste der installierten Vorlagen im mittleren Bereich Win32-Konsolenanwendung aus.

  4. Geben Sie im Feld Name einen Namen für das Projekt ein. Geben Sie für dieses Beispiel Game ein.

    Sie können den Standardspeicherort in der Dropdownliste Speicherort akzeptieren, einen anderen Speicherort eingeben oder über die Schaltfläche Durchsuchen das Verzeichnis auswählen, in dem Sie das Projekt speichern möchten.

    Beim Erstellen eines Projekts wird das Projekt von Visual Studio in eine Projektmappe eingefügt. Standardmäßig weist die Lösung den gleichen Namen wie das Projekt auf. Sie können den Namen im Feld Projektmappenname ändern. Behalten Sie für dieses Beispiel jedoch den Standardnamen bei.

  5. Wählen Sie die Schaltfläche OK aus, um das Projekt zu erstellen.

    Visual Studio erstellt Ihre neue Projektmappe und die Projektdateien und öffnet den Editor für die Quellcodedatei „Game.cpp“, die generiert wurde.

Organisieren von Projekten und Dateien

Sie können den Projektmappen-Explorer verwenden, um Projekte, Dateien und andere Ressourcen in der Projektmappe zu organisieren und zu verwalten.

In diesem Teil der exemplarischen Vorgehensweise wird gezeigt, wie dem Projekt eine Klasse hinzugefügt wird. Wenn Sie die Klasse hinzufügen, fügt Visual Studio die entsprechenden H- und CPP-Dateien hinzu. Die Ergebnisse werden im Projektmappen-Explorer angezeigt.

So fügen Sie einem Projekt eine Klasse hinzu

  1. Wenn das Fenster Projektmappen-Explorer nicht in Visual Studio angezeigt wird, klicken Sie in der Menüleiste auf Ansicht > Projektmappen-Explorer.

  2. Wählen Sie im Projektmappen-Explorer das Projekt Game aus. Klicken Sie in der Menüleiste auf Projekt > Klasse hinzufügen.

  3. Geben Sie im Dialogfeld Klasse hinzufügen Cardgame in das Feld Klassenname ein. Ändern Sie die Standarddateinamen und - einstellungen nicht. Klicken Sie auf die Schaltfläche OK .

    Visual Studio erstellt neue Dateien und fügt diese zum Projekt hinzu. Diese werden im Fenster Projektmappen-Explorer angezeigt. Die Dateien „Cardgame.h“ und „Cardgame.cpp“ werden im Editor geöffnet.

  4. Bearbeiten Sie die Datei „Cardgame.h“, und nehmen Sie folgende Änderungen vor:

    • Fügen Sie hinter der öffnenden geschweiften Klammer der Klassendefinition zwei private Datenmember hinzu.

      int players;
      static int totalParticipants;
      
    • Ändern Sie den Standardkonstruktor, der von Visual Studio generiert wurde. Suchen Sie nach dem public:-Zugriffsspezifizierer nach der Zeile, die folgendermaßen aussieht:

      Cardgame();

      Ändern Sie den Konstruktor so, dass er einen Parameter vom Typ int namens players annimmt.

      Cardgame(int players);

    • Fügen Sie nach dem Standarddestruktor eine Inline-Deklaration für eine static int-Memberfunktion namens GetParticipants hinzu, die keine Parameter übernimmt und den Wert totalParticipants zurückgibt.

      static int GetParticipants() { return totalParticipants; }

    Die Datei „Cardgame.h“ sieht nach der Änderung ungefähr wie der folgende Code aus:

    #pragma once
    class Cardgame
    {
        int players;
        static int totalParticipants;
    public:
        Cardgame(int players);
        ~Cardgame();
        static int GetParticipants() { return totalParticipants; }
    };
    

    Die Zeile #pragma once teilt dem Compiler mit, die Headerdatei nur einmal aufzunehmen. Weitere Informationen finden Sie unter once. Informationen zu weiteren C++-Schlüsselwörtern in der oben gezeigten Headerdatei finden Sie unter class, int, static und public.

  5. Klicken Sie oben im Bearbeitungsbereich auf die Registerkarte Cardgame.cpp, um die Datei zum Bearbeiten zu öffnen.

  6. Löschen Sie den gesamten Inhalt der Datei, und ersetzen Sie ihn durch den folgenden Code:

    #include "pch.h" // remove this line in Visual Studio 2019
    #include "Cardgame.h"
    #include <iostream>
    
    using namespace std;
    
    int Cardgame::totalParticipants = 0;
    
    Cardgame::Cardgame(int players)
        : players(players)
    {
        totalParticipants += players;
        cout << players << " players have started a new game.  There are now "
             << totalParticipants << " players in total." << endl;
    }
    
    Cardgame::~Cardgame()
    {
    }
    

    Hinweis

    Sie können bei der Codeeingabe die automatische Vervollständigung verwenden. Wenn Sie diesen Code beispielsweise über die Tastatur eingeben, können Sie pl oder tot eingeben und STRG+LEERTASTE drücken. Die automatische Vervollständigung gibt players oder totalParticipants für Sie ein.

Hinzufügen von Testcode zur main-Funktion

Fügen Sie Code zu Ihrer App hinzu, der die neuen Funktionen testet.

Hinzufügen von Testcode zum Projekt

  1. Ersetzen Sie im Editor-Fenster Game.cpp den vorhandenen Code durch Folgendes:

    // Game.cpp : Defines the entry point for the console application.
    //
    
    #include "pch.h" // remove this line in Visual Studio 2019
    #include "Cardgame.h"
    #include <iostream>
    
    using namespace std;
    
    void PlayGames()
    {
        Cardgame bridge(4);
        Cardgame blackjack(8);
        Cardgame solitaire(1);
        Cardgame poker(5);
    }
    
    int main()
    {
        PlayGames();
        return 0;
    }
    

    Der Code fügt eine Testfunktion (PlayGames) zum Quellcode hinzu und ruft diese in main auf.

Erstellen und Ausführen Ihres App-Projekts

Erstellen Sie nun das Projekt, und führen Sie die App aus.

So erstellen Sie das Projekt und führen es aus

  1. Wählen Sie auf der Menüleiste Erstellen > Projektmappe erstellen aus.

    Die Ausgabe eines Builds wird im Ausgabefenster angezeigt. Wenn der Build erfolgreich erstellt wurde, sollte die Ausgabe in etwa wie folgt aussehen:

    1>------ Build started: Project: Game, Configuration: Debug Win32 ------
    1>pch.cpp
    1>Cardgame.cpp
    1>Game.cpp
    1>Generating Code...
    1>Game.vcxproj -> C:\Users\<username>\source\repos\Game\Debug\Game.exe
    ========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    

    Abhängig von der Buildkonfiguration können im Ausgabefenster verschiedene Schritte angezeigt werden. Wenn das Projekt jedoch erfolgreich erstellt wird, sollte die letzte Zeile der angezeigten Ausgabe ähneln.

    Wenn die Erstellung nicht erfolgreich war, vergleichen Sie Ihren Code mit dem Code, der in den Schritten weiter oben gezeigt wurde.

  2. Klicken Sie zum Ausführen des Projekts auf der Menüleiste auf Debuggen > Starten ohne Debuggen. Es sollte ein Konsolenfenster angezeigt werden, und die Ausgabe sollte dem folgenden Beispiel ähneln:

    4 players have started a new game.  There are now 4 players in total.
    8 players have started a new game.  There are now 12 players in total.
    1 players have started a new game.  There are now 13 players in total.
    5 players have started a new game.  There are now 18 players in total.
    

    Drücken Sie eine Taste, um das Konsolenfenster zu schließen.

Glückwunsch, Sie haben erfolgreich ein App-Projekt und eine Projektmappe erstellt. Fahren Sie mit der exemplarischen Vorgehensweise fort, um mehr über das Erstellen von C++-Codeprojekten in Visual Studio zu erfahren.

Nächste Schritte

Zurück: Verwenden der Visual Studio-IDE für C++-Desktopentwicklung
Weiter: Exemplarische Vorgehensweise: Erstellen eines Projekts (C++)

Siehe auch

C++-Programmiersprachenreferenz
Projekte und Buildsysteme