Bereitstellen von .NET Core-Apps mit Visual StudioDeploying .NET Core apps with Visual Studio

Sie können eine .NET Core-Anwendung entweder als Framework-abhängige Bereitstellung bereitstellen, was die Binärdateien Ihrer Anwendung einschließt, jedoch von Präsenz von .NET Core auf dem Zielsystem abhängt, oder als eigenständige Bereitstellung,die jeweils Ihre Anwendung sowie .NET Core-Binärdateien einschließt.You can deploy a .NET Core application either as a framework-dependent deployment, which includes your application binaries but depends on the presence of .NET Core on the target system, or as a self-contained deployment, which includes both your application and .NET Core binaries. Einen Überblick über die Bereitstellung von .NET Core-Anwendungen finden Sie unter .NET Core Anwendungsbereitstellung.For an overview of .NET Core application deployment, see .NET Core Application Deployment.

Die folgenden Abschnitte zeigen, wie Sie Microsoft Visual Studio zum Erstellen der folgenden Bereitstellungen verwenden:The following sections show how to use Microsoft Visual Studio to create the following kinds of deployments:

  • Framework-abhängige BereitstellungFramework-dependent deployment
  • Framework-abhängige Bereitstellung mit DrittanbieterabhängigkeitenFramework-dependent deployment with third-party dependencies
  • Eigenständige BereitstellungSelf-contained deployment
  • Eigenständige Bereitstellung mit DrittanbieterabhängigkeitenSelf-contained deployment with third-party dependencies

Informationen zur Verwendung von Visual Studio zur Entwicklung von .NET Core-Anwendungen finden Sie unter Voraussetzungen für .NET Core unter Windows.For information on using Visual Studio to develop .NET Core applications, see Prerequisites for .NET Core on Windows.

Framework-abhängige BereitstellungFramework-dependent deployment

Die Bereitstellung einer Framework-abhängigen Bereitstellung ohne Drittanbieter-Abhängigkeiten umfasst nur das Erstellen, Testen und Veröffentlichen der Anwendung.Deploying a framework-dependent deployment with no third-party dependencies simply involves building, testing, and publishing the app. Ein einfaches, in C# geschriebenes Beispiel veranschaulicht den Prozess.A simple example written in C# illustrates the process.

  1. Erstellen eines ProjektsCreate the project.

    Wählen Sie Datei > Neu > Projekt aus.Select File > New > Project. Wählen Sie im Dialogfeld Neues Projekt .NET Core im Bereich „Projekttypen“ Installiert aus, und wählen Sie die Vorlage Konsolen-App (.NET Core) im mittleren Bereich aus.In the New Project dialog, select .NET Core in the Installed project types pane, and select the Console App (.NET Core) template in the center pane. Geben Sie im Textfeld Name einen Projektnamen ein, z.B. „FDD“.Enter a project name, such as "FDD", in the Name text box. Klicken Sie auf die Schaltfläche OK.Select the OK button.

  2. Fügen Sie den Quellcode der Anwendung hinzu.Add the application's source code.

    Öffnen Sie die Program.cs-Datei im Editor, und ersetzen Sie den automatisch generierten Code durch den folgenden Code.Open the Program.cs file in the editor and replace the auto-generated code with the following code. Der Benutzer wird zur Texteingabe aufgefordert, und die einzelnen Wörter, die vom Benutzer eingegeben wurden, werden angezeigt.It prompts the user to enter text and displays the individual words entered by the user. Der reguläre Ausdruck \w+ wird verwendet, um Wörter im Eingabetext zu trennen.It uses the regular expression \w+ to separate the words in the input text.

    using System;
    using System.Text.RegularExpressions;
    
    namespace Applications.ConsoleApps
    {
        public class ConsoleParser
        {
            public static void Main()
            {
                Console.WriteLine("Enter any text, followed by <Enter>:\n");
                String s = Console.ReadLine();
                ShowWords(s);
                Console.Write("\nPress any key to continue... ");
                Console.ReadKey();
            }
    
            private static void ShowWords(String s)
            {
                String pattern = @"\w+";
                var matches = Regex.Matches(s, pattern);
                if (matches.Count == 0)
                {
                    Console.WriteLine("\nNo words were identified in your input.");
                }
                else
                {
                    Console.WriteLine($"\nThere are {matches.Count} words in your string:");
                    for (int ctr = 0; ctr < matches.Count; ctr++)
                    {
                        Console.WriteLine($"   #{ctr,2}: '{matches[ctr].Value}' at position {matches[ctr].Index}");
                    }
                }
            }
        }
    }
    
    
  3. Erstellen Sie ein Debugbuild Ihrer App.Create a Debug build of your app.

    Wählen Sie Erstellen > Projektmappe erstellen aus.Select Build > Build Solution. Sie können auch das Debugbuild Ihrer Anwendung erstellen und ausführen, indem Sie Debuggen > Debugging starten auswählen.You can also compile and run the Debug build of your application by selecting Debug > Start Debugging.

  4. Stellen Sie Ihre App bereit.Deploy your app.

    Nachdem Sie die Anwendung debuggt und getestet haben, erstellen Sie die Dateien, die mit Ihrer Anwendung bereitgestellt werden.After you've debugged and tested the program, create the files to be deployed with your app. Um eine Veröffentlichung über Visual Studio durchzuführen, tun Sie Folgendes:To publish from Visual Studio, do the following:

    1. Ändern Sie die Projektmappenkonfiguration von Debuggen zu Freigabe auf der Symbolleiste, um eine Releaseversion (anstatt eine Debugversion) Ihrer App zu erstellen.Change the solution configuration from Debug to Release on the toolbar to build a Release (rather than a Debug) version of your app.

    2. Führen Sie auf dem Projekt (nicht in der Projektmappe) im Projektmappen-Explorer einen Rechtsklick aus, und wählen Sie Veröffentlichen aus.Right-click on the project (not the solution) in Solution Explorer, and select Publish.

    3. Wählen Sie auf der Registerkarte Veröffentlichen Veröffentlichen aus.In the Publish tab, select Publish. Visual Studio schreibt die Dateien, die Ihre Anwendung enthalten, in das lokale Dateisystem.Visual Studio writes the files that comprise your application to the local file system.

    4. Die Registerkarte Veröffentlichen zeigt nun ein einzelnes Profil an: FolderProfile.The Publish tab now shows a single profile, FolderProfile. Die Konfigurationseinstellungen des Profils werden im Abschnitt Zusammenfassung der Registerkarte gezeigt.The profile's configuration settings are shown in the Summary section of the tab.

    Die resultierenden Dateien werden in ein Verzeichnis namens PublishOutput platziert, das sich in einem Unterverzeichnis des \bin\release-Unterverzeichnis Ihres Projekts befindet.The resulting files are placed in a directory named PublishOutput that is in a subdirectory of your project's .\bin\release subdirectory.

Der Veröffentlichungsprozess gibt zusammen mit den Dateien Ihrer Anwendung eine Programmdatenbankdatei (.pdb) aus, die Debuginformationen über Ihre Anwendung enthält.Along with your application's files, the publishing process emits a program database (.pdb) file that contains debugging information about your app. Die Datei ist vornehmlich für das Debuggen von Ausnahmen nützlich.The file is useful primarily for debugging exceptions. Sie können sich auch dazu entschließen, sie nicht mit den Dateien Ihrer Anwendung zu packen.You can choose not to package it with your application's files. Jedoch sollten Sie sie für den Fall speichern, dass Sie das Releasebuild Ihrer App debuggen möchten.You should, however, save it in the event that you want to debug the Release build of your app.

Stellen Sie den vollständige Satz von Anwendungsdateien so bereit, wie Sie möchten.Deploy the complete set of application files in any way you like. Sie können sie z.B. in einer ZIP-Datei verpacken, und einen einfachen copy-Befehl verwenden, oder sie mit jedem Installationspaket Ihrer Wahl bereitstellen.For example, you can package them in a Zip file, use a simple copy command, or deploy them with any installation package of your choice. Sobald die Anwendung installiert ist, können Benutzer sie mithilfe des dotnet-Befehls ausführen und den Dateinamen der Anwendung bereitstellen, z.B. dotnet fdd.dll.Once installed, users can then execute your application by using the dotnet command and providing the application filename, such as dotnet fdd.dll.

Das Installationsprogramm sollte zusätzlich zu den Binärdateien der Anwendung das freigegebene Framework-Installationsprogramm bündeln, oder als erforderliche Komponente im Rahmen der Anwendungsinstallation überprüfen.In addition to the application binaries, your installer should also either bundle the shared framework installer or check for it as a prerequisite as part of the application installation. Die Installation des gemeinsam genutzten Frameworks erfordert Administrator-/Root-Zugriff, da es sich um eine computerweite Installation handelt.Installation of the shared framework requires Administrator/root access since it is machine-wide.

Framework-abhängige Bereitstellung mit DrittanbieterabhängigkeitenFramework-dependent deployment with third-party dependencies

Die Bereitstellung einer Framework-abhängigen Bereitstellung mit mindestens einer Drittanbieterabhängigkeit erfordert, dass Abhängigkeiten für Ihr Projekt verfügbar sind.Deploying a framework-dependent deployment with one or more third-party dependencies requires that any dependencies be available to your project. Die folgenden Schritte müssen noch durchgeführt werden, bevor Sie Ihre App erstellen können:The following additional steps are required before you can build your app:

  1. Verwenden Sie den NuGet-Paket-Manager, um einem NuGet-Paket einen Verweis für Ihr Projekt hinzuzufügen. Falls das Paket noch nicht auf Ihrem System verfügbar ist, installieren Sie es.Use the NuGet Package Manager to add a reference to a NuGet package to your project; and if the package is not already available on your system, install it. Wählen Sie zum Öffnen des Paket-Managers Tools > NuGet-Paket-Manager > NuGet-Pakete für Projektmappe verwalten aus.To open the package manager, select Tools > NuGet Package Manager > Manage NuGet Packages for Solution.

  2. Bestätigen Sie, dass Newtonsoft.Json auf Ihrem System installiert ist. Falls nicht, installieren Sie es.Confirm that Newtonsoft.Json is installed on your system and, if it is not, install it. Die Registerkarte Installiert listet NuGet-Pakete auf, die auf Ihrem System installiert sind.The Installed tab lists NuGet packages installed on your system. Wenn Newtonsoft.Json hier nicht aufgelistet ist, wählen Sie die Registerkarte Durchsuchen aus, und geben Sie „Newtonsoft.Json“ in das Suchfeld ein.If Newtonsoft.Json is not listed there, select the Browse tab and enter "Newtonsoft.Json" in the search box. Wählen Sie Newtonsoft.Json aus, und wählen Sie im rechten Bereich Ihre Projekt, bevor Sie auf Installieren klicken.Select Newtonsoft.Json and, in the right pane, select your project before selecting Install.

  3. Wenn Newtonsoft.Json bereits auf Ihrem System installiert ist, fügen Sie es Ihrem Projekt hinzu, indem Sie Ihr Projekt im rechten Bereich der Registerkarte Pakete für Projektmappe verwalten auswählen.If Newtonsoft.Json is already installed on your system, add it to your project by selecting your project in the right pane of hte Manage Packages for Solution tab.

Beachten Sie, dass eine Framework-abhängige Bereitstellung mit Drittanbieter-Abhängigkeiten nur so tragbar wie ihre Drittanbieter-Abhängigkeiten ist.Note that a framework-dependent deployment with third-party dependencies is only as portable as its third-party dependencies. Falls eine Drittanbieter-Bibliothek nur macOS unterstützen sollte, so wird die Anwendung nicht auf Windows-Systeme übertragbar sein.For example, if a third-party library only supports macOS, the app isn't portable to Windows systems. Dies kann geschehen, wenn die Drittanbieter-Abhängigkeit selbst vom nativen Code abhängt.This happens if the third-party dependency itself depends on native code. Ein gutes Beispiel dafür ist der Kestrel-Server, der eine native Abhängigkeit unter libuv erfordert.A good example of this is Kestrel server, which requires a native dependency on libuv. Wenn bei dieser Art von Drittanbieter-Abhängigkeit eine FDD für eine Anwendung erstellt wird, enthält die veröffentlichte Ausgabe einen Ordner für jede Runtime-ID (RID), die die native Abhängigkeit unterstützt (und im NuGet-Paket vorhanden ist).When an FDD is created for an application with this kind of third-party dependency, the published output contains a folder for each Runtime Identifier (RID) that the native dependency supports (and that exists in its NuGet package).

Eigenständige Bereitstellung mit DrittanbieterabhängigkeitenSelf-contained deployment without third-party dependencies

Das Bereitstellen einer eigenständigen Bereitstellung ohne Abhängigkeiten von Drittanbietern umfasst das Erstellen des Projekts, das Ändern der CSPROJ-Datei sowie das Erstellen, Testen und Veröffentlichen der Anwendung.Deploying a self-contained deployment with no third-party dependencies involves creating the project, modifying the csproj file, building, testing, and publishing the app. Ein einfaches, in C# geschriebenes Beispiel veranschaulicht den Prozess.A simple example written in C# illustrates the process.

  1. Erstellen eines ProjektsCreate the project.

    Wählen Sie Datei > Neu > Projekt aus.Select File > New > Project. Wählen Sie im Dialogfeld Neues Projekt hinzufügen .NET Core im Bereich „Projekttypen“ Installiert aus, und wählen Sie die Vorlage Konsolen-App (.NET Core) im mittleren Bereich aus.In the Add New Project dialog, select .NET Core in the Installed project types pane, and select the Console App (.NET Core) template in the center pane. Geben Sie im Textfeld Name einen Projektnamen ein, z.B. „SCD“, und klicken Sie auf die Schaltfläche OK.Enter a project name, such as "SCD", in the Name text box, and select the OK button.

  2. Fügen Sie den Quellcode der Anwendung hinzu.Add the application's source code.

    Öffnen Sie die Program.cs-Datei in einem Editor, und ersetzen Sie den automatisch generierten Code durch den folgenden Code.Open the Program.cs file in your editor, and replace the auto-generated code with the following code. Der Benutzer wird zur Texteingabe aufgefordert, und die einzelnen Wörter, die vom Benutzer eingegeben wurden, werden angezeigt.It prompts the user to enter text and displays the individual words entered by the user. Der reguläre Ausdruck \w+ wird verwendet, um Wörter im Eingabetext zu trennen.It uses the regular expression \w+ to separate the words in the input text.

    using System;
    using System.Text.RegularExpressions;
    
    namespace Applications.ConsoleApps
    {
        public class ConsoleParser
        {
            public static void Main()
            {
                Console.WriteLine("Enter any text, followed by <Enter>:\n");
                String s = Console.ReadLine();
                ShowWords(s);
                Console.Write("\nPress any key to continue... ");
                Console.ReadKey();
            }
    
            private static void ShowWords(String s)
            {
                String pattern = @"\w+";
                var matches = Regex.Matches(s, pattern);
                if (matches.Count == 0)
                {
                    Console.WriteLine("\nNo words were identified in your input.");
                }
                else
                {
                    Console.WriteLine($"\nThere are {matches.Count} words in your string:");
                    for (int ctr = 0; ctr < matches.Count; ctr++)
                    {
                        Console.WriteLine($"   #{ctr,2}: '{matches[ctr].Value}' at position {matches[ctr].Index}");
                    }
                }
            }
        }
    }
    
    
  3. Definieren Sie die Zielplattformen für Ihre App.Define the platforms that your app will target.

    1. Führen Sie auf Ihrem Projekt (nicht in der Projektmappe) im Projektmappen-Explorer einen Rechtsklick aus, und wählen Sie Edit SCD.csproj (SCD.csproj bearbeiten) aus.Right-click on your project (not the solution) In Solution Explorer, and select Edit SCD.csproj.

    2. Erstellen Sie das Tag <RuntimeIdentifiers> im Abschnitt <PropertyGroup> Ihrer Datei csproj, der die Plattformen Ihrer Anwendungsziele definiert und die Runtime-ID jeder Zielplattform angibt.Create a <RuntimeIdentifiers> tag in the <PropertyGroup> section of your csproj file that defines the platforms your app targets, and specify the runtime identifier (RID) of each platform that you target. Beachten Sie, dass Sie auch ein Semikolon hinzufügen müssen, um die RIDs trennen.Note that you also need to add a semicolon to separate the RIDs. Sie finden eine RID-Liste im RID-Katalog.See Runtime IDentifier catalog for a list of runtime identifiers.

    Das folgende Beispiel gibt an, dass die Anwendung unter den Betriebssystemen Windows 10 (64-Bit) und OS X 10.11 (64-Bit) ausgeführt wird.For example, the following example indicates that the app runs on 64-bit Windows 10 operating systems and the 64-bit OS X Version 10.11 operating system.

<PropertyGroup>
    <RuntimeIdentifiers>win10-x64;osx.10.11-x64</RuntimeIdentifiers>
</PropertyGroup>

Beachten Sie, dass das Element <RuntimeIdentifiers> jedem <PropertyGroup>-Element in Ihrer Datei CSPROJ hinzugefügt werden kann.Note that the <RuntimeIdentifiers> element can go into any <PropertyGroup> that you have in your csproj file. Eine vollständige CSPROJ-Beispieldatei wird später in diesem Abschnitt angezeigt.A complete sample csproj file appears later in this section.

  1. Erstellen Sie ein Debugbuild Ihrer App.Create a Debug build of your app.

    Wählen Sie Erstellen > Projektmappe erstellen aus.Select Build > Build Solution. Sie können auch das Debugbuild Ihrer Anwendung erstellen und ausführen, indem Sie Debuggen > Debugging starten auswählen.You can also compile and run the Debug build of your application by selecting Debug > Start Debugging.

  2. Veröffentlichen Sie die App.Publish your app.

    Nachdem Sie das Programm debuggt und getestet haben, erstellen Sie die Dateien, die mit Ihrer App für jede Zielplattform bereitgestellt werden sollen.After you've debugged and tested the program, create the files to be deployed with your app for each platform that it targets.

    Um eine Veröffentlichung Ihrer App über Visual Studio durchzuführen, tun Sie Folgendes:To publish your app from Visual Studio, do the following:

    1. Ändern Sie die Projektmappenkonfiguration von Debuggen zu Freigabe auf der Symbolleiste, um eine Releaseversion (anstatt eine Debugversion) Ihrer App zu erstellen.Change the solution configuration from Debug to Release on the toolbar to build a Release (rather than a Debug) version of your app.

    2. Führen Sie auf dem Projekt (nicht in der Projektmappe) im Projektmappen-Explorer einen Rechtsklick aus, und wählen Sie Veröffentlichen aus.Right-click on the project (not the solution) in Solution Explorer and select Publish.

    3. Wählen Sie auf der Registerkarte Veröffentlichen Veröffentlichen aus.In the Publish tab, select Publish. Visual Studio schreibt die Dateien, die Ihre Anwendung enthalten, in das lokale Dateisystem.Visual Studio writes the files that comprise your application to the local file system.

    4. Die Registerkarte Veröffentlichen zeigt nun ein einzelnes Profil an: FolderProfile.The Publish tab now shows a single profile, FolderProfile. Die Konfigurationseinstellungen des Profils werden im Abschnitt Zusammenfassung der Registerkarte gezeigt. Ziellaufzeit identifiziert, welche Laufzeit veröffentlicht wurde; Zielort identifiziert, wo die Dateien für die eigenständige Bereitstellung geschrieben wurden.The profile's configuration settings are shown in the Summary section of the tab. Target Runtime identifies which runtime has been published, and Target Location identifies where the files for the self-contained deployment were written.

    5. Visual Studio schreibt standardmäßig alle veröffentlichten Dateien in ein einzelnes Verzeichnis.Visual Studio by default writes all published files to a single directory. Der Einfachheit halber ist es am besten, separate Profile für jede Ziellaufzeit zu erstellen und veröffentlichte Dateien in einem plattformspezifischen Verzeichnis zu platzieren.For convenience, it's best to create separate profiles for each target runtime and to place published files in a platform-specific directory. Dafür muss ein separates Veröffentlichungsprofil für jede Zielplattform erstellt werden.This involves creating a separate publishing profile for each target platform. Erstellen Sie nun die Anwendung für jede Plattform neu, indem Sie Folgendes tun:So now rebuild the application for each platform by doing the following:

      1. Wählen Sie Neues Profil erstellen im Dialogfeld Veröffentlichen aus.Select Create new profile in the Publish dialog.

      2. Ändern Sie im Dialogfeld Veröffentlichungsziel auswählen den Speicherort Ordner auswählen in bin\Release\PublishOutput\win10-x64.In the Pick a publish target dialog, change the Choose a folder location to bin\Release\PublishOutput\win10-x64. Klicken Sie auf OK.Select OK.

      3. Wählen Sie das neue Profil (FolderProfile1) in der Liste der Profile aus, und stellen Sie sicher, dass die Ziellaufzeit win10-x64 ist.Select the new profile (FolderProfile1) in the list of profiles, and make sure that the Target Runtime is win10-x64. Falls nicht, wählen Sie Einstellungen aus.If it isn't, select Settings. Ändern Sie im Dialogfeld Profileinstellungen die Ziellaufzeit in win10-x64, und klicken Sie auf Speichern.In the Profile Settings dialog, change the Target Runtime to win10-x64 and select Save. Wählen Sie andernfalls Abbrechen aus.Otherwise, select Cancel.

      4. Wählen Sie Veröffentlichen aus, um Ihre App für 64-Bit-Windows 10-Plattformen zu veröffentlichen.Select Publish to publish your app for 64-bit Windows 10 platforms.

      5. Arbeiten Sie erneut die vorherigen Schritte durch, um ein Profil für die osx.10.11-x64-Plattform zu erstellen.Follow the previous steps again to create a profile for the osx.10.11-x64 platform. Der Zielort ist bin\Release\PublishOutput\osx.10.11-x64, und die Ziellaufzeit ist osx.10.11-x64.The Target Location is bin\Release\PublishOutput\osx.10.11-x64, and the Target Runtime is osx.10.11-x64. Der Name, den Visual Studio diesem Profil zuweist, ist FolderProfile2.The name that Visual Studio assigns to this profile is FolderProfile2.

    Beachten Sie, dass jeder Zielort den vollständigen Dateisatz enthält (Dateien Ihrer Anwendung und alle .NET Core-Dateien), der zum Starten Ihrer Anwendung erforderlich ist.Note that each target location contains the complete set of files (both your app files and all .NET Core files) needed to launch your app.

Der Veröffentlichungsprozess gibt zusammen mit den Dateien Ihrer Anwendung eine Programmdatenbankdatei (.pdb) aus, die Debuginformationen über Ihre Anwendung enthält.Along with your application's files, the publishing process emits a program database (.pdb) file that contains debugging information about your app. Die Datei ist vornehmlich für das Debuggen von Ausnahmen nützlich.The file is useful primarily for debugging exceptions. Sie können sich auch dazu entschließen, sie nicht mit den Dateien Ihrer Anwendung zu packen.You can choose not to package it with your application's files. Jedoch sollten Sie sie für den Fall speichern, dass Sie das Releasebuild Ihrer App debuggen möchten.You should, however, save it in the event that you want to debug the Release build of your app.

Stellen Sie die veröffentlichen Dateien in einer beliebigen Weise bereit.Deploy the published files in any way you like. Sie können sie z.B. in einer ZIP-Datei verpacken, und einen einfachen copy-Befehl verwenden, oder sie mit jedem Installationspaket Ihrer Wahl bereitstellen.For example, you can package them in a Zip file, use a simple copy command, or deploy them with any installation package of your choice.

Es folgt die vollständige CSPROJ-Datei dieses Projekts:The following is the complete csproj file for this project.

<Project Sdk="Microsoft.NET.Sdk">
  <PropertyGroup>
    <OutputType>Exe</OutputType>
    <TargetFramework>netcoreapp1.1</TargetFramework>
    <RuntimeIdentifiers>win10-x64;osx.10.11-x64</RuntimeIdentifiers>
  </PropertyGroup>
</Project>

Eigenständige Bereitstellung mit DrittanbieterabhängigkeitenSelf-contained deployment with third-party dependencies

Das Bereitstellen einer eigenständigen Bereitstellung mit einer oder mehreren Drittanbieter-Abhängigkeiten umfasst das Hinzufügen der Drittanbieter-Abhängigkeit:Deploying a self-contained deployment with one or more third-party dependencies involves adding the dependencies. Die folgenden Schritte müssen noch durchgeführt werden, bevor Sie Ihre App erstellen können:The following additional steps are required before you can build your app:

  1. Verwenden Sie den NuGet-Paket-Manager, um einem NuGet-Paket einen Verweis für Ihr Projekt hinzuzufügen. Falls das Paket noch nicht auf Ihrem System verfügbar ist, installieren Sie es.Use the NuGet Package Manager to add a reference to a NuGet package to your project; and if the package is not already available on your system, install it. Wählen Sie zum Öffnen des Paket-Managers Tools > NuGet-Paket-Manager > NuGet-Pakete für Projektmappe verwalten aus.To open the package manager, select Tools > NuGet Package Manager > Manage NuGet Packages for Solution.

  2. Bestätigen Sie, dass Newtonsoft.Json auf Ihrem System installiert ist. Falls nicht, installieren Sie es.Confirm that Newtonsoft.Json is installed on your system and, if it is not, install it. Die Registerkarte Installiert listet NuGet-Pakete auf, die auf Ihrem System installiert sind.The Installed tab lists NuGet packages installed on your system. Wenn Newtonsoft.Json hier nicht aufgelistet ist, wählen Sie die Registerkarte Durchsuchen aus, und geben Sie „Newtonsoft.Json“ in das Suchfeld ein.If Newtonsoft.Json is not listed there, select the Browse tab and enter "Newtonsoft.Json" in the search box. Wählen Sie Newtonsoft.Json aus, und wählen Sie im rechten Bereich Ihre Projekt, bevor Sie auf Installieren klicken.Select Newtonsoft.Json and, in the right pane, select your project before selecting Install.

  3. Wenn Newtonsoft.Json bereits auf Ihrem System installiert ist, fügen Sie es Ihrem Projekt hinzu, indem Sie Ihr Projekt im rechten Bereich der Registerkarte Pakete für Projektmappe verwalten auswählen.If Newtonsoft.Json is already installed on your system, add it to your project by selecting your project in the right pane of the Manage Packages for Solution tab.

Es folgt die vollständige CSPROJ-Datei dieses Projekts:The following is the complete csproj file for this project:

<Project Sdk="Microsoft.NET.Sdk">
  <PropertyGroup>
    <OutputType>Exe</OutputType>
    <TargetFramework>netcoreapp1.1</TargetFramework>
    <RuntimeIdentifiers>win10-x64;osx.10.11-x64</RuntimeIdentifiers>
  </PropertyGroup>
  <ItemGroup>
    <PackageReference Include="Newtonsoft.Json" Version="10.0.2" />
  </ItemGroup>
</Project>

Wenn Sie Ihre Anwendung bereitstellen, sind die Drittanbieter-Abhängigkeiten, die in Ihrer Anwendung verwendet werden, auch in Ihren Anwendungsdateien enthalten.When you deploy your application, any third-party dependencies used in your app are also contained with your application files. Drittanbieter-Bibliotheken müssen nicht auf dem System vorhanden sein, auf dem die Anwendung ausgeführt wird.Third-party libraries aren't required on the system on which the app is running.

Beachten Sie, dass Sie eine eigenständige Bereitstellung mit einer Drittanbieter-Bibliothek nur auf von dieser Bibliothek unterstützten Plattformen bereitstellen können.Note that you can only deploy a self-contained deployment with a third-party library to platforms supported by that library. Dies ist ähnlich, als wenn Sie über Drittanbieter-Abhängigkeiten mit nativen Abhängigkeiten in Ihrer Framework-abhängigen Bereitstellung verfügen, wobei die nativen Abhängigkeiten nicht auf der Zielplattform vorhanden sind, es sei denn, sie wurden dort zuvor installiert.This is similar to having third-party dependencies with native dependencies in your framework-dependent deployment, where the native dependencies won't exist on the target platform unless they were previously installed there.

Siehe auchSee also

.NET Core Anwendungsbereitstellung .NET Core Application Deployment
.NET Core Runtime-ID (RID)-Katalog.NET Core Runtime IDentifier (RID) catalog