Installieren von .NET Core unter LinuxInstall .NET Core on Linux

.NET Core ist für verschiedene Linux-Distributionen verfügbar..NET Core is available on different Linux distributions. Für die meisten Linux-Plattformen und -Distributionen gibt es jedes Jahr eine Hauptversion. Die meisten bieten einen Paket-Manager, der zur Installation von .NET Core genutzt wird.Most Linux platforms and distributions have a major release each year, and most provide a package manager that is used to install .NET Core. In diesem Artikel wird beschrieben, was derzeit unterstützt wird und welcher Paket-Manager verwendet wird.This article describes what is currently supported and which package manager is used.

Der Rest dieses Artikels ist eine Übersicht über die einzelnen Linux-Hauptdistributionen, die .NET Core unterstützt.The rest of this article is a breakdown of each major Linux distribution that .NET Core supports. Alle .NET Core-Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports erreicht oder die Linux-Distribution das Ende ihrer Lebensdauer erreicht.All .NET Core releases remain supported until either the version of .NET Core reaches end-of-support or the Linux distribution reaches end-of-life.

Eine LTS-Version (Long-Term Release) bietet bestmögliche Kompatibilität.For the best compatibility, choose a long-term release (LTS) version.

Nicht unterstützte VersionenUnsupported releases

Die folgenden Versionen von .NET Core werden ❌ nicht mehr unterstützt.The following versions of .NET Core are ❌ no longer supported. Die Downloads dafür bleiben weiterhin veröffentlicht:The downloads for these still remain published:

  • 3.03.0
  • 2.22.2
  • 2.02.0

Diese Versionen ohne Support werden in den folgenden Abschnitten nicht näher beschrieben, und Ihre Laufzeit kann variieren, wenn Sie versuchen, sie zu installieren.These unsupported versions aren't detailed in the sections below and your mileage may vary if you try to install them.

AlpineAlpine

Es sind keine Installationsprogramme für Alpine vorhanden.There are no installers for Alpine. Sie müssen entweder das Installationsskript verwenden oder die Anweisungen zur manuellen Installation befolgen.You must either use the install script or follow the manual install instructions.

Die folgende Tabelle enthält die derzeit unterstützten .NET Core-Releases sowie die Versionen von Alpine, unter denen sie unterstützt werden.The following table is a list of currently supported .NET Core releases and the versions of Alpine they're supported on. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports oder die Version von Alpine das Ende ihrer Lebensdauer erreicht.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of Alpine reaches end-of-life.

  • ✔️ gibt an, dass die Version von Alpine oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of Alpine or .NET Core is still supported.
  • ❌ gibt an, dass die Version von Alpine oder .NET Core in diesem Alpine-Release nicht unterstützt wird.A ❌ indicates that the version of Alpine or .NET Core isn't supported on that Alpine release.
  • Wenn sowohl eine Version von Alpine als auch eine Version von .NET Core mit ✔️ versehen sind, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of Alpine and a version of .NET Core have ✔️, that OS and .NET combination are supported.
AlpineAlpine .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview.NET 5 Preview
✔️ 3.12✔️ 3.12 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 3.11✔️ 3.11 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 3.10✔️ 3.10 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 3.9✔️ 3.9 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
3.83.8 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter Alpine.For more information, see Install .NET Core on Alpine.

CentOSCentOS

CentOS 7 nutzt Yum als Paket-Manager, CentOS 8 verwendet DNF.CentOS 7 uses Yum as a package manager and CentOS 8 uses DNF.

Die folgende Tabelle enthält die derzeit unter CentOS 7 und CentOS 8 unterstützten .NET Core-Versionen.The following table is a list of currently supported .NET Core releases on both CentOS 7 and CentOS 8. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports erreicht oder die Version von CentOS nicht mehr unterstützt wird.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of CentOS is no longer supported.

CentOSCentOS .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 8✔️ 8 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 7✔️ 7 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter CentOS.For more information, see Install .NET Core on CentOS.

DebianDebian

Debian verwendet APT (Advanced Package Tool) als Paket-Manager.Debian uses APT (Advanced Package Tool) as a package manager.

Die folgende Tabelle enthält die derzeit unterstützten .NET Core-Versionen und Versionen von Debian, unter denen sie unterstützt werden.The following table is a list of currently supported .NET Core releases and the versions of Debian they're supported on. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports oder die Version von Debian das Ende ihrer Lebensdauer erreicht.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of Debian reaches end-of-life.

  • ✔️ gibt an, dass die Version von Debian oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of Debian or .NET Core is still supported.
  • ❌ gibt an, dass die Version von Debian oder .NET Core in dieser Debian-Version nicht unterstützt wird.A ❌ indicates that the version of Debian or .NET Core isn't supported on that Debian release.
  • Wenn sowohl eine Version von Debian als auch eine Version von .NET Core über ✔️ verfügen, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of Debian and a version of .NET Core have ✔️, that OS and .NET combination are supported.
DebianDebian .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 10✔️ 10 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 9✔️ 9 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
88 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter Debian.For more information, see Install .NET Core on Debian.

FedoraFedora

Fedora verwendet DNF als Paket-Manager.Fedora uses DNF as its package manager.

Die folgende Tabelle enthält die derzeit unterstützten .NET Core-Versionen und Versionen von Fedora, unter denen sie unterstützt werden.The following table is a list of currently supported .NET Core releases and the versions of Fedora they're supported on. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports oder die Version von Fedora das Ende ihrer Lebensdauer erreicht.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of Fedora reaches end-of-life.

  • ✔️ gibt an, dass die Version von Fedora oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of Fedora or .NET Core is still supported.
  • ❌ gibt an, dass die Version von Fedora oder .NET Core in dieser Fedora-Version nicht unterstützt wird.A ❌ indicates that the version of Fedora or .NET Core isn't supported on that Fedora release.
  • Wenn sowohl eine Version von Fedora als auch eine Version von .NET Core über ✔️ verfügen, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of Fedora and a version of .NET Core have ✔️, that OS and .NET combination are supported.
FedoraFedora .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 32✔️ 32 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 31✔️ 31 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
3030 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
2929 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
2828 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
2727 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter Fedora.For more information, see Install .NET Core on Fedora.

openSUSEopenSUSE

openSUSE verwendet zypper als Paket-Manager.openSUSE uses zypper as the package manager.

Die folgende Tabelle enthält die derzeit unter openSUSE 15 unterstützten .NET Core-Versionen.The following table is a list of currently supported .NET Core releases on openSUSE 15. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports erreicht oder die Version von openSUSE nicht mehr unterstützt wird.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of openSUSE is no longer supported.

  • ✔️ gibt an, dass die Version von openSUSE oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of openSUSE or .NET Core is still supported.
  • ❌ gibt an, dass die Version von openSUSE oder .NET Core in dieser openSUSE-Version nicht unterstützt wird.A ❌ indicates that the version of openSUSE or .NET Core isn't supported on that openSUSE release.
  • Wenn sowohl eine Version von openSUSE als auch eine Version von .NET Core über ✔️ verfügen, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of openSUSE and a version of .NET Core have ✔️, that OS and .NET combination are supported.
openSUSEopenSUSE .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 15✔️ 15 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter openSUSE.For more information, see Install .NET Core on openSUSE.

Red HatRed Hat

Red Hat Enterprise Linux (RHEL) verwendet yum (RHEL 7) und DNF (RHEL 8) als Paket-Manager.Red Hat Enterprise Linux (RHEL) uses yum (RHEL 7) and DNF (RHEL 8) as the package manager.

Die folgende Tabelle enthält die derzeit unter RHEL 7 und RHEL 8 unterstützten .NET Core-Versionen.The following table is a list of currently supported .NET Core releases on both RHEL 7 and RHEL 8. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports erreicht oder die Version von RHEL nicht mehr unterstützt wird.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of RHEL is no longer supported.

  • ✔️ gibt an, dass die Version von RHEL oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of RHEL or .NET Core is still supported.
  • ❌ gibt an, dass die Version von RHEL oder .NET Core in dieser RHEL-Version nicht unterstützt wird.A ❌ indicates that the version of RHEL or .NET Core isn't supported on that RHEL release.
  • Wenn sowohl eine Version von RHEL als auch eine Version von .NET Core über ✔️ verfügen, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of RHEL and a version of .NET Core have ✔️, that OS and .NET combination are supported.
RHELRHEL .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 8✔️ 8 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 7✔️ 7 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter RHEL.For more information, see Install .NET Core on RHEL.

SLESSLES

SLES verwendet zypper als Paket-Manager.SLES uses zypper as the package manager.

Die folgende Tabelle enthält die derzeit unter SLES 12 SP2 and SLES 15 unterstützten .NET Core-Versionen.The following table is a list of currently supported .NET Core releases on both SLES 12 SP2 and SLES 15. Diese Versionen werden weiterhin unterstützt, bis entweder die Version von .NET Core das Ende des Supports erreicht oder die Version von SLES nicht mehr unterstützt wird.These versions remain supported until either the version of .NET Core reaches end-of-support or the version of SLES is no longer supported.

  • ✔️ gibt an, dass die Version von SLES oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of SLES or .NET Core is still supported.
  • ❌ gibt an, dass die Version von SLES oder .NET Core in dieser SLES-Version nicht unterstützt wird.A ❌ indicates that the version of SLES or .NET Core isn't supported on that SLES release.
  • Wenn sowohl eine Version von SLES als auch eine Version von .NET Core über ✔️ verfügen, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of SLES and a version of .NET Core have ✔️, that OS and .NET combination are supported.
SLESSLES .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 15✔️ 15 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
✔️ 12 SP2✔️ 12 SP2 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter SLES.For more information, see Install .NET Core on SLES.

UbuntuUbuntu

Ubuntu verwendet APT (Advanced Package Tool) als Paket-Manager.Ubuntu uses APT (Advanced Package Tool) as a package manager.

Die folgende Tabelle zeigt den Supportstatus von Ubuntu und .NET Core.The following table represents the support status of Ubuntu and .NET Core.

  • ✔️ gibt an, dass die Version von Ubuntu oder .NET Core weiterhin unterstützt wird.A ✔️ indicates that the version of Ubuntu or .NET Core is still supported.
  • ❌ gibt an, dass die Version von Ubuntu oder .NET Core in dieser Ubuntu-Version nicht unterstützt wird.A ❌ indicates that the version of Ubuntu or .NET Core isn't supported on that Ubuntu release.
  • Wenn sowohl eine Version von Ubuntu als auch eine Version von .NET Core über ✔️ verfügen, wird diese Kombination aus Betriebssystem und .NET unterstützt.When both a version of Ubuntu and a version of .NET Core have ✔️, that OS and .NET combination are supported.
UbuntuUbuntu .NET Core 2.1.NET Core 2.1 .NET Core 3.1.NET Core 3.1 .NET 5 Preview (nur manuelle Installation).NET 5 Preview (manual install only)
✔️ 20.04 (LTS)✔️ 20.04 (LTS) ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
19.1019.10 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
19.0419.04 ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
18.1018.10 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
✔️ 18.04 (LTS)✔️ 18.04 (LTS) ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview
17.1017.10 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
17.0417.04 ✔️ 2.1✔️ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
16.1016.10 ❌ 2.1❌ 2.1 ❌ 3.1❌ 3.1 ❌ 5.0 Preview❌ 5.0 Preview
✔️ 16.04 (LTS)✔️ 16.04 (LTS) ✔️ 2.1✔️ 2.1 ✔️ 3.1✔️ 3.1 ✔️ 5.0 Preview✔️ 5.0 Preview

Weitere Informationen finden Sie unter Installieren von .NET Core unter Ubuntu.For more information, see Install .NET Core on Ubuntu.

Nächste SchritteNext steps