Vertrauensanker für den Zertifizierungspfad beim Einrichten der App-Verbindung nicht gefunden

Symptome

Wenn Sie versuchen, eine Verbindung mit Supply Chain Management herzustellen, zeigt die Warehouse Management-App möglicherweise die folgende Fehlermeldung an:

java.security.cert.certPathValidatorException: Vertrauensanker für Zertifizierungspfad nicht gefunden.

Dieses Problem kann sich auf Geräte mit den folgenden Eigenschaften auswirken:

  • Betriebssystemversion: Android 4.4.x (z. B. Zebra TC55). Dies ist bei aktuellen Android-Versionen kein Problem.
  • Supply Chain Management-Standort: Cloud
  • Verbindungsmodus: Geheimer Clientschlüssel oder Zertifikat

Mögliche Ursache

Microsoft hat möglicherweise die ssl-Serverzertifikate aktualisiert, die von Supply Chain Management verwendet werden. Daher haben sich das Stammzertifikat und/oder eines der Zwischenzertifikate möglicherweise geändert, sodass das neue Zertifikat nicht in der Liste der vertrauenswürdigen Systemzertifikate für das mobile Gerät enthalten ist. Neuere Versionen von Android aktualisieren automatisch die Listen der vertrauenswürdigen Zertifikate, android 4.4.x jedoch nicht.

Lösung

Führen Sie einen der folgenden Schritte aus, um dieses Problem zu beheben:

  • Verwenden Sie die im nächsten Abschnitt beschriebene Problemumgehung, um jedes relevante Gerät zu aktualisieren.
  • Möglicherweise ist es möglich, sich an Zebra oder Google zu wenden, um ein Update der Zertifikate der vertrauenswürdigen Systemzertifizierungsstelle (Ca) zu erhalten. Wir haben dies jedoch nicht bestätigt.
  • Wenn möglich, sollten Sie ältere Geräte durch Geräte ersetzen, auf denen eine neuere Version von Android ausgeführt wird (wobei vertrauenswürdige Zertifizierungsstellenzertifikate automatisch aktualisiert werden).

Problemumgehung

Schritt 1: Exportieren des neuen Stammzertifikats aus Supply Chain Management

Laden Sie das neue Stammzertifikat manuell in Ihrem Internetbrowser herunter, indem Sie die folgenden Schritte ausführen:

  1. Melden Sie sich bei Dynamics Supply Chain Management an, und öffnen Sie die Startseite.
  2. Wählen Sie in der Adressleiste Ihres Browsers das Sperrsymbol aus, um das Dialogfeld Standort ist sicher zu öffnen.
  3. Wählen Sie im Dialogfeld Zertifikat (gültig) aus, um das Fenster Zertifikat für dieses Zertifikat zu öffnen.
  4. Öffnen Sie die Registerkarte Zertifizierungspfad im Fenster Zertifikat .
  5. Wählen Sie das oberste Zertifikat aus, das in der Hierarchie angezeigt wird. (dies ist das Stammzertifikat).
  6. Öffnen Sie die Registerkarte Details im Fenster Zertifikat .
  7. Wählen Sie unten auf der Registerkarte Details die Schaltfläche In Datei kopieren aus.
  8. Der Zertifikatexport-Assistent wird geöffnet. Wählen Sie Weiter aus, um fortzufahren.
  9. Die Seite Dateiformat exportieren wird geöffnet. Wählen Sie DER-codierte binär X.509 (. CER). Wählen Sie dann Weiter aus, um den Vorgang fortzusetzen.
  10. Die Seite Zu exportierende Dateien wird geöffnet, und geben Sie einen Dateinamen und einen Speicherort an. Wählen Sie dann Weiter aus, um den Vorgang fortzusetzen.
  11. Die Seite Assistenten zum Abschließen des Zertifikatexports wird geöffnet, auf der das Ergebnis Ihres Exports angezeigt wird. Wählen Sie Fertig stellen aus.

Schritt 2: Installieren des heruntergeladenen Zertifikats auf den betroffenen Geräten

Installieren Sie das heruntergeladene Zertifikat wie folgt:

  1. Übertragen Sie das Zertifikat, das Sie im vorherigen Schritt heruntergeladen haben, auf das Gerät, das Sie aktualisieren möchten. Sie können z. B. eine SD-Karte oder eine Netzwerkverbindung verwenden, um die Datei für Ihr Gerät verfügbar zu machen.
  2. Öffnen Sie die Sicherheitseinstellungen für Ihr Gerät, und wählen Sie die Menüoption aus, um ein Zertifikat aus einer Datei zu installieren. (Die genauen Schritte hierfür variieren je nach Gerät und Betriebssystemversion.)
  3. Das neue Zertifikat sollte jetzt auf der Registerkarte Benutzer für vertrauenswürdige Zertifikate angezeigt werden.
  4. Wiederholen Sie dieses Verfahren für jedes betroffene Gerät.