Auswählen Entity Framework Lauf Zeit Version für EF-Designer-ModelleSelecting Entity Framework Runtime Version for EF Designer Models

Hinweis

Nur EF6 und höher: Die Features, APIs usw., die auf dieser Seite erläutert werden, wurden in Entity Framework 6 eingeführt.EF6 Onwards Only - The features, APIs, etc. discussed in this page were introduced in Entity Framework 6. Wenn Sie eine frühere Version verwenden, gelten manche Informationen nicht.If you are using an earlier version, some or all of the information does not apply.

Beginnend mit EF6 wurde dem EF-Designer der folgende Bildschirm hinzugefügt, damit Sie die Version der Laufzeit auswählen können, die Sie beim Erstellen eines Modells als Ziel auswählen möchten.Starting with EF6 the following screen was added to the EF Designer to allow you to select the version of the runtime you wish to target when creating a model. Der Bildschirm wird angezeigt, wenn die neueste Version von Entity Framework nicht bereits im Projekt installiert ist.The screen will appear when the latest version of Entity Framework is not already installed in the project. Wenn die neueste Version bereits installiert ist, wird Sie standardmäßig verwendet.If the latest version is already installed it will just be used by default.

Lauf Zeit Version auswählen

Ziel EF6. xTargeting EF6.x

Sie können EF6 auf dem Bildschirm "wählen Sie Ihre Version" auswählen, um dem Projekt die EF6-Laufzeit hinzuzufügen.You can choose EF6 from the 'Choose Your Version' screen to add the EF6 runtime to your project. Nachdem Sie EF6 hinzugefügt haben, wird dieser Bildschirm im aktuellen Projekt nicht mehr angezeigt.Once you've added EF6, you’ll stop seeing this screen in the current project.

EF6 wird deaktiviert, wenn Sie bereits eine ältere Version von EF installiert haben (da Sie nicht mehrere Versionen der Laufzeit aus demselben Projekt ausrichten können).EF6 will be disabled if you already have an older version of EF installed (since you can't target multiple versions of the runtime from the same project). Wenn die EF6-Option hier nicht aktiviert ist, führen Sie die folgenden Schritte aus, um Ihr Projekt auf EF6 zu aktualisieren:If EF6 option is not enabled here, follow these steps to upgrade your project to EF6:

  1. Klicken Sie in Projektmappen-Explorer mit der rechten Maustaste auf das Projekt, und wählen Sie nuget-Pakete verwalten aus.Right-click on your project in Solution Explorer and select Manage NuGet Packages...
  2. Updates auswählenSelect Updates
  3. Wählen Sie EntityFramework aus (stellen Sie sicher, dass es auf die gewünschte Version aktualisiert wird).Select EntityFramework (make sure it is going to update it to the version you want)
  4. Klicken Sie auf Aktualisieren.Click Update

 

Ziel EF5. xTargeting EF5.x

Sie können EF5 auf dem Bildschirm "wählen Sie Ihre Version" auswählen, um dem Projekt die EF5-Laufzeit hinzuzufügen.You can choose EF5 from the 'Choose Your Version' screen to add the EF5 runtime to your project. Nachdem Sie EF5 hinzugefügt haben, wird der Bildschirm mit deaktivierter EF6-Option angezeigt.Once you've added EF5, you’ll still see the screen with the EF6 option disabled.

Wenn Sie eine EF4. x-Version der Laufzeit bereits installiert haben, sehen Sie, dass die EF-Version auf dem Bildschirm anstelle von EF5 aufgeführt wird.If you have an EF4.x version of the runtime already installed then you will see that version of EF listed in the screen rather than EF5. In dieser Situation können Sie ein Upgrade auf EF5 ausführen, indem Sie die folgenden Schritte ausführen:In this situation you can upgrade to EF5 using the following steps:

  1. Tools auswählen- > Bibliothekspaket-Manager- > Paket-Manager-KonsoleSelect Tools -> Library Package Manager -> Package Manager Console
  2. Ausführen von " install-Package" EntityFramework-Version 5.0.0Run Install-Package EntityFramework -version 5.0.0

 

Ziel EF4. xTargeting EF4.x

Mithilfe der folgenden Schritte können Sie die EF4. x-Laufzeit für Ihr Projekt installieren:You can install the EF4.x runtime to your project using the following steps:

  1. Tools auswählen- > Bibliothekspaket-Manager- > Paket-Manager-KonsoleSelect Tools -> Library Package Manager -> Package Manager Console
  2. Ausführen von " install-Package" EntityFramework-Version 4.3.0Run Install-Package EntityFramework -version 4.3.0