Voraussetzungen für Exchange 2013Exchange 2013 prerequisites

Gilt für: Exchange Server 2013Applies to: Exchange Server 2013

Dieses Thema enthält die Schritte zum Installieren der erforderlichen Windows Server 2012 R2-, Windows Server 2012-und Windows Server 2008 R2 mit Service Pack 1 (SP1)-Betriebssystemvoraussetzungen für das Microsoft Exchange 2013-Postfach, den Client Zugriffs-und den Edge-Transport. Serverrollen.This topic provides the steps for installing the necessary Windows Server 2012 R2, Windows Server 2012 and Windows Server 2008 R2 with Service Pack 1 (SP1) operating system prerequisites for the Microsoft Exchange 2013 Mailbox, Client Access, and Edge Transport server roles. Außerdem werden die erforderlichen Voraussetzungen für die Installation der Exchange 2013 Verwaltungstools auf Windows 8-, Windows 8.1-und Windows 7-Clientcomputern bereitgestellt.It also provides the prerequisites required to install the Exchange 2013 management tools on Windows 8, Windows 8.1, and Windows 7 client computers.

Was sollten Sie wissen, bevor Sie beginnen?What do you need to know before you begin?

  • Die Informationen in diesem Thema gelten für Service Pack 1 und höhere Versionen von Exchange 2013.The information in this topic is applicable to Service Pack 1 and later versions of Exchange 2013.

  • Die Edge-Transport-Serverrolle steht ab Exchange 2013 SP1 zur Verfügung.The Edge Transport server role is available starting with Exchange 2013 SP1.

  • Stellen Sie sicher, dass die Funktionsebene Ihrer Gesamtstruktur mindestens Windows Server 2003 ist und dass der Schemamaster Windows Server 2003 mit Service Pack 2 oder höher ausführt.Make sure that the functional level of your forest is at least Windows Server 2003, and that the schema master is running Windows Server 2003 with Service Pack 2 or later. Weitere Informationen zur Funktionsebene Windows finden Sie unter Managing Domains and Forests.For more information about the Windows functional level, see Managing Domains and Forests.

  • Die vollständige Installationsoption von Windows Server 2012 R2, Windows Server 2012 und Windows Server 2008 R2 SP1 muss für alle Server verwendet werden, auf denen Exchange 2013-Serverrollen oder-Verwaltungstools installiert sind.The full installation option of Windows Server 2012 R2, Windows Server 2012 and Windows Server 2008 R2 SP1 must be used for all servers running Exchange 2013 server roles or management tools.

  • Sie müssen den Computer zuerst zu den entsprechenden internen Active Directory-Gesamtstrukturen und -Domänen hinzufügen.You must first join the computer to the appropriate internal Active Directory forest and domain.

  • Bei einigen Voraussetzungen müssen Sie den Server neu starten, um die Installation abzuschließen.Some prerequisites require you to reboot the server to complete installation.

    • Installieren Sie die neuesten Windows-Updates auf Ihrem Computer. Weitere Informationen finden Sie unter Prüfliste für Bereitstellungssicherheit.Install the latest Windows updates on your computer. For more information, see Deployment security checklist.

      Hinweis

      Wenn Sie die Postfachserverrolle installieren und beabsichtigen, dass der Server Mitglied einer Database Availability Group (DAG) ist, müssen Sie Windows Server 2012 R2 Standard oder Datacenter Edition, Windows Server 2012 Standard oder Datacenter Edition oder Windows Server 2008 R2 SP1 Enterprise Edition.If you're installing the Mailbox server role and you intend for the server to be a member of a database availability group (DAG), you must be running Windows Server 2012 R2 Standard or Datacenter Edition, Windows Server 2012 Standard or Datacenter Edition, or Windows Server 2008 R2 SP1 Enterprise Edition. Windows Server 2008 R2 SP 1 Standard Edition unterstützt nicht die Funktionen, die für DAGs erforderlich sind.Windows Server 2008 R2 SP 1 Standard Edition doesn't support the features needed for DAGs.
      Windows kann nicht aktualisiert werden, wenn Exchange auf dem Server installiert ist.You can't upgrade Windows when Exchange is installed on the server.
      Um ein Upgrade auf verwaltete API von Microsoft Unified Communications (UCMA) 4,0 durchführen zu können, müssen Sie zunächst alle früheren Versionen von UCMA deinstallieren, die mithilfe von Softwareinstalliert werden.To upgrade to Microsoft Unified Communications Managed API (UCMA) 4.0, you must first uninstall any previous versions of UCMA that are installed by using Add/Remove programs.

Tipp

Liegt ein Problem vor?Having problems? Bitten Sie in den Exchange-Foren um Hilfe.Ask for help in the Exchange forums. Besuchen Sie die Foren unter Exchange Server.Visit the forums at Exchange Server.

Active Directory-VorbereitungActive Directory preparation

Der Computer, den Sie für die Vorbereitung Active Directory auf Exchange 2013 verwenden möchten, muss bestimmte Voraussetzungen erfüllen.The computer you want to use to prepare Active Directory for Exchange 2013 has specific prerequisites that must be met.

Installieren Sie die folgende Software in der angegebenen Reihenfolge auf dem Computer, der zum Vorbereiten der Active Directory verwendet wird:Install the following software, in the order shown, on the computer that will be used to prepare Active Directory:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

  2. Windows Management Framework 4,0 (im Lieferumfang von Windows Server 2012 R2 enthalten)Windows Management Framework 4.0 (included with Windows Server 2012 R2)

Nach der Installation der oben aufgeführten Software führen Sie die folgenden Schritte aus, um das Verwaltungspaket für Remotetools zu installieren. Nachdem Sie das Verwaltungspaket für Remotetools installiert haben, können Sie den Computer für die Vorbereitung von Active Directory verwenden. Weitere Informationen zum Vorbereiten von Active Directory finden Sie unter Vorbereitung von Active Directory und Domänen.After you've installed the software listed above, complete the following steps to install the Remote Tools Administration Pack. After you've installed the Remote Tools Administration Pack you'll be able to use the computer to prepare Active Directory. For more information about preparing Active Directory, see Prepare Active Directory and domains.

  1. Öffnen Sie Windows PowerShell.Open Windows PowerShell.

  2. Installieren Sie das Verwaltungspaket für Remote Tools.Install the Remote Tools Administration Pack.

    • Führen Sie auf einem Windows Server 2012 R2-oder Windows Server 2012-Computer den folgenden Befehl aus.On a Windows Server 2012 R2 or Windows Server 2012 computer, run the following command.

      Install-WindowsFeature RSAT-ADDS
      
    • Führen Sie auf einem Computer mit Windows Server 2008 R2 SP1 den folgenden Befehl aus.On a Windows Server 2008 R2 SP1 computer, run the following command.

      Add-WindowsFeature RSAT-ADDS
      

Voraussetzungen für Windows Server 2012 R2 und Windows Server 2012Windows Server 2012 R2 and Windows Server 2012 prerequisites

Die erforderlichen Voraussetzungen für die Installation von Exchange 2013 auf einem Computer mit Windows Server 2012 R2 oder Windows Server 2012 hängen von den Exchange-Rollen ab, die Sie installieren möchten.The prerequisites that are needed to install Exchange 2013 on a Windows Server 2012 R2 or Windows Server 2012 computer depends on which Exchange roles you want to install. Lesen Sie den Abschnitt weiter unten, der den Rollen entspricht, die Sie installieren möchten.Read the section below that matches the roles you want to install.

Postfach-oder Client Zugriffs-ServerrollenMailbox or Client Access server roles

Befolgen Sie die Anweisungen in diesem Abschnitt, um die erforderlichen Komponenten auf Windows Server 2012 R2-oder Windows Server 2012-Computern zu installieren, auf denen Sie eine der folgenden Aktionen ausführen möchten:Follow the instructions in this section to install the prerequisites on Windows Server 2012 R2 or Windows Server 2012 computers where you want to do one of the following:

  • Installieren Sie nur die Postfachserverrolle auf einem Computer.Install only the Mailbox server role on a computer.

  • Installieren Sie nur die Client Zugriffs-Serverrolle auf einem Computer.Install only the Client Access server role on a computer.

  • Installieren Sie die Postfach-und Client Zugriffs-Serverrolle auf demselben Computer.Install both the Mailbox and Client Access server roles on the same computer.

Gehen Sie folgendermaßen vor, um die erforderlichen Windows-Rollen und -Features zu installieren:Do the following to install the required Windows roles and features:

  1. Öffnen Sie Windows PowerShell.Open Windows PowerShell.

  2. Führen Sie den folgenden Befehl aus, um die erforderlichen Windows-Komponenten zu installieren.Run the following command to install the required Windows components.

    Install-WindowsFeature AS-HTTP-Activation, Desktop-Experience, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-PowerShell, Web-Mgmt-Console, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation, RSAT-ADDS
    

Nach der Installation der Betriebssystemrollen und -features installieren Sie folgende Softwareprodukte in der angegebenen Reihenfolge:After you've installed the operating system roles and features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    Wichtig

    Exchange 2013 CU23 erfordert .NET Framework 4.7.2.Exchange 2013 CU23 requires .NET Framework 4.7.2. Aktualisieren Sie Ihre Server auf .NET Framework 4.7.2, bevor Sie Exchange 2013 CU23 installieren, oder Sie erhalten eine Fehlermeldung.Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. Wenn Sie .NET Framework 4.7.1 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU22 durch, bevor Sie .NET Framework 4.7.2 installieren.If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. Wenn Sie .NET Framework 4.6.2 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU20 durch, bevor Sie .NET Framework 4.7.1 installieren.If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4,0 (im Lieferumfang von Windows Server 2012 R2 enthalten)Windows Management Framework 4.0 (included with Windows Server 2012 R2)

  3. Microsoft Unified Communications Managed API 4.0, Core Runtime 64-BitMicrosoft Unified Communications Managed API 4.0, Core Runtime 64-bit

  4. Visual C++ Redistributable Package für Visual Studio 2012Visual C++ Redistributable Package for Visual Studio 2012

  5. Visual C++ Redistributable-Paket für Visual Studio 2013Visual C++ Redistributable Package for Visual Studio 2013

Hinweis

Hier finden Sie eine Übersicht der neuesten unterstützen Visual C++ Redistributable-VersionenHere you'll find an overview of the latest supported Visual C++ Redistributable versions

Edge-Transport (Serverrolle)Edge Transport server role

Befolgen Sie die Anweisungen in diesem Abschnitt, um die erforderlichen Komponenten auf Windows Server 2012 R2-oder Windows Server 2012-Computern zu installieren, auf denen Sie die Edge-Transport-Server Rolle auf einem Computer installieren möchten.Follow the instructions in this section to install the prerequisites on Windows Server 2012 R2 or Windows Server 2012 computers where you want to install the Edge Transport server role on a computer.

Gehen Sie folgendermaßen vor, um die erforderlichen Windows-Rollen und -Features zu installieren:Do the following to install the required Windows roles and features:

  1. Öffnen Sie Windows PowerShell.Open Windows PowerShell.

  2. Führen Sie den folgenden Befehl aus, um die erforderlichen Windows-Komponenten zu installieren.Run the following command to install the required Windows components.

    Install-WindowsFeature ADLDS
    

Installieren Sie die Version von Microsoft .NET Framework, die der Version von Exchange 2013 entspricht, die Sie installieren:Install the version of Microsoft .NET Framework that corresponds to the version of Exchange 2013 you're installing:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    Wichtig

    Exchange 2013 CU23 erfordert .NET Framework 4.7.2.Exchange 2013 CU23 requires .NET Framework 4.7.2. Aktualisieren Sie Ihre Server auf .NET Framework 4.7.2, bevor Sie Exchange 2013 CU23 installieren, oder Sie erhalten eine Fehlermeldung.Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. Wenn Sie .NET Framework 4.7.1 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU22 durch, bevor Sie .NET Framework 4.7.2 installieren.If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. Wenn Sie .NET Framework 4.6.2 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU20 durch, bevor Sie .NET Framework 4.7.1 installieren.If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4,0 (im Lieferumfang von Windows Server 2012 R2 enthalten)Windows Management Framework 4.0 (included with Windows Server 2012 R2)

  3. Visual C++ Redistributable Package für Visual Studio 2012Visual C++ Redistributable Package for Visual Studio 2012

Hinweis

Hier finden Sie eine Übersicht der neuesten unterstützen Visual C++ Redistributable-VersionenHere you'll find an overview of the latest supported Visual C++ Redistributable versions

Voraussetzungen für Windows Server 2008 R2 SP1Windows Server 2008 R2 SP1 prerequisites

Die erforderlichen Voraussetzungen für die Installation von Exchange 2013 auf einem Computer mit Windows Server 2008 R2 SP1 hängen davon ab, welche Exchange-Rollen Sie installieren möchten.The prerequisites that are needed to install Exchange 2013 on a Windows Server 2008 R2 SP1 computer depends on which Exchange roles you want to install. Lesen Sie den Abschnitt weiter unten, der den Rollen entspricht, die Sie installieren möchten.Read the section below that matches the roles you want to install.

Postfach-oder Client Zugriffs-ServerrollenMailbox or Client Access server roles

Befolgen Sie die Anweisungen in diesem Abschnitt, um die erforderlichen Komponenten auf Windows Server 2008 R2 SP1-Computern zu installieren, auf denen Sie eine der folgenden Aktionen ausführen möchten:Follow the instructions in this section to install the prerequisites on Windows Server 2008 R2 SP1 computers where you want to do one of the following:

  • Installieren Sie nur die Postfachserverrolle auf einem Computer.Install only the Mailbox server role on a computer.

  • Installieren Sie nur die Client Zugriffs-Serverrolle auf einem Computer.Install only the Client Access server role on a computer.

  • Installieren Sie die Postfach-und Client Zugriffs-Serverrolle auf demselben Computer.Install both the Mailbox and Client Access server roles on the same computer.

Gehen Sie folgendermaßen vor, um die erforderlichen Windows-Rollen und -Features zu installieren:Do the following to install the required Windows roles and features:

  1. Öffnen Sie Windows PowerShell.Open Windows PowerShell.

  2. Führen Sie den folgenden Befehl aus, um das Server-Manager-Modul zu laden.Run the following command to load the Server Manager module.

    Import-Module ServerManager
    
  3. Führen Sie den folgenden Befehl aus, um die erforderlichen Windows-Komponenten zu installieren.Run the following command to install the required Windows components.

    Add-WindowsFeature Desktop-Experience, NET-Framework, NET-HTTP-Activation, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Web-Server, WAS-Process-Model, Web-Asp-Net, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, RSAT-ADDS
    

Nach der Installation der Betriebssystemrollen und -features installieren Sie folgende Softwareprodukte in der angegebenen Reihenfolge:After you've installed the operating system roles and features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    Wichtig

    Exchange 2013 CU23 erfordert .NET Framework 4.7.2.Exchange 2013 CU23 requires .NET Framework 4.7.2. Aktualisieren Sie Ihre Server auf .NET Framework 4.7.2, bevor Sie Exchange 2013 CU23 installieren, oder Sie erhalten eine Fehlermeldung.Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. Wenn Sie .NET Framework 4.7.1 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU22 durch, bevor Sie .NET Framework 4.7.2 installieren.If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. Wenn Sie .NET Framework 4.6.2 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU20 durch, bevor Sie .NET Framework 4.7.1 installieren.If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4,0Windows Management Framework 4.0

  3. Microsoft Unified Communications Managed API 4.0, Core Runtime 64-BitMicrosoft Unified Communications Managed API 4.0, Core Runtime 64-bit

  4. Visual C++ Redistributable Package für Visual Studio 2012Visual C++ Redistributable Package for Visual Studio 2012

  5. Visual C++ Redistributable-Paket für Visual Studio 2013Visual C++ Redistributable Package for Visual Studio 2013

    Hinweis

    Hier finden Sie eine Übersicht der neuesten unterstützen Visual C++ Redistributable-VersionenHere you'll find an overview of the latest supported Visual C++ Redistributable versions

  6. Microsoft Knowledge Base-Artikel KB974405 (Windows Identity Foundation)Microsoft Knowledge Base article KB974405 (Windows Identity Foundation)

  7. Knowledge Base-Artikel KB2619234 (Enable the Association Cookie/GUID, die von RPC über HTTP verwendet wird, auch auf der RPC-Ebene in Windows 7 und in Windows Server 2008 R2 verwendet werden)Knowledge Base article KB2619234 (Enable the Association Cookie/GUID that is used by RPC over HTTP to also be used at the RPC layer in Windows 7 and in Windows Server 2008 R2)

  8. Knowledge Base-Artikel KB2533623 (unsichere Bibliotheks Lade kann Remotecodeausführung ermöglichen)Knowledge Base article KB2533623 (Insecure library loading could allow remote code execution)

    Hinweis

    Dieser Hotfix ist möglicherweise bereits installiert, wenn Sie Windows Update zum Installieren von Sicherheitsupdates auf Ihrem Computer konfiguriert haben.This hotfix may already be installed if you've configured Windows Update to install security updates on your computer.

Edge-Transport (Serverrolle)Edge Transport server role

Befolgen Sie die Anweisungen in diesem Abschnitt, um die erforderlichen Komponenten auf Windows Server 2008 R2 SP1-Computern zu installieren, auf denen Sie die Edge-Transport-Server Rolle auf einem Computer installieren möchten.Follow the instructions in this section to install the prerequisites on Windows Server 2008 R2 SP1 computers where you want to install the Edge Transport server role on a computer.

Gehen Sie folgendermaßen vor, um die erforderlichen Windows-Rollen und -Features zu installieren:Do the following to install the required Windows roles and features:

  1. Öffnen Sie Windows PowerShell.Open Windows PowerShell.

  2. Führen Sie den folgenden Befehl aus, um das Server-Manager-Modul zu laden.Run the following command to load the Server Manager module.

    Import-Module ServerManager
    
  3. Führen Sie den folgenden Befehl aus, um die erforderlichen Windows-Komponenten zu installieren.Run the following command to install the required Windows components.

    Add-WindowsFeature NET-Framework, ADLDS
    

Nach der Installation der Betriebssystemrollen und -features installieren Sie folgende Softwareprodukte in der angegebenen Reihenfolge:After you've installed the operating system roles and features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    Wichtig

    Exchange 2013 CU23 erfordert .NET Framework 4.7.2.Exchange 2013 CU23 requires .NET Framework 4.7.2. Aktualisieren Sie Ihre Server auf .NET Framework 4.7.2, bevor Sie Exchange 2013 CU23 installieren, oder Sie erhalten eine Fehlermeldung.Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. Wenn Sie .NET Framework 4.7.1 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU22 durch, bevor Sie .NET Framework 4.7.2 installieren.If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. Wenn Sie .NET Framework 4.6.2 ausführen, führen Sie ein Upgrade auf Exchange 2013 CU20 durch, bevor Sie .NET Framework 4.7.1 installieren.If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4,0Windows Management Framework 4.0

  3. Microsoft Unified Communications Managed API 4.0, Core Runtime 64-BitMicrosoft Unified Communications Managed API 4.0, Core Runtime 64-bit

  4. Visual C++ Redistributable Package für Visual Studio 2012Visual C++ Redistributable Package for Visual Studio 2012

    Hinweis

    Hier finden Sie eine Übersicht der neuesten unterstützen Visual C++ Redistributable-VersionenHere you'll find an overview of the latest supported Visual C++ Redistributable versions

Windows 7 Voraussetzungen (nur Verwaltungstools)Windows 7 prerequisites (admin tools only)

Befolgen Sie die Anweisungen in diesem Abschnitt, um die erforderlichen Komponenten auf domänenbezogenen Windows 7 64-Bit-Computern zu installieren, auf denen die Exchange-Verwaltungstools installiert werden sollen.Follow the instructions in this section to install the prerequisites on domain-joined Windows 7 64-bit computers where you want to install the Exchange management tools.

  1. Öffnen Sie die SystemSteuerung, und wählen Sie dann Programmeaus.Open Control Panel, and then select Programs.

  2. Klicken Sie auf Windows-Funktionen ein-oder ausschalten.Click Turn Windows features on or off.

  3. Navigieren Sie zu Internetinformationsdienste > -Webverwaltungs Tools > IIS 6-Verwaltungskompatibilität.Navigate to Internet Information Services > Web Management Tools > IIS 6 Management Compatibility.

  4. Aktivieren Sie das Kontrollkästchen für IIS 6-Verwaltungskonsole, und klicken Sie dann auf OK.Select the check box for IIS 6 Management Console, and then click OK.

Nachdem Sie die Betriebssystemfunktionen installiert haben, installieren Sie die folgende Software in der angegebenen Reihenfolge:After you've installed the operating system features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

  2. Windows Management Framework 4,0Windows Management Framework 4.0

  3. Knowledge Base-Artikel KB974405 (Windows Identity Foundation)Knowledge Base article KB974405 (Windows Identity Foundation)

Voraussetzungen für Windows 8 und Windows 8.1 (nur Verwaltungstools)Windows 8 and Windows 8.1 prerequisites (admin tools only)

.NET Framework 4.7.2.NET Framework 4.7.2