Ereignis-ID 1309, und Sie können nicht auf OWA und ECP zugreifen, nachdem Sie Exchange Server 2016 oder Exchange Server 2013 installiert haben

Ursprüngliche KB-Nummer: 3099532

Symptome

Sie haben Microsoft Exchange Server 2016 oder Exchange Server 2013 erfolgreich installiert. Der Installationsvorgang ist möglicherweise fehlgeschlagen oder wurde zu einem bestimmten Zeitpunkt unterbrochen und dann fortgesetzt und schließlich erfolgreich abgeschlossen. Wenn Sie jedoch versuchen, auf Exchange Systemsteuerung (ECP) oder Outlook Web App (OWA) zuzugreifen, erhalten Sie die folgende Fehlermeldung:

Leider hat etwas nicht geklappt

Diese Informationen können wir momentan nicht abrufen. Wiederholen Sie den Vorgang zu einem späteren Zeitpunkt. Wenden Sie sich an den Helpdesk, wenn das Problem weiterhin auftritt.

Screenshot der Fehlermeldung: Diese Informationen können derzeit nicht abgerufen werden.

Darüber hinaus kann das folgende Ereignis im Anwendungsprotokoll protokolliert werden:

Log Name:  Application
Source:  ASP.NET 4.0.30319.0
Event ID:  1309
Task Category:  Web Event
Level:  Warning
Keywords:  Classic
User:  N/A
Computer:  Exch2.contoso.com
Description:

Event code: 3005
Event message: An unhandled exception has occurred.

Event ID: f23d9d455f3145068c57286262ac517f
Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
  Application domain: /LM/W3SVC/2/ROOT/owa-5-130879214460462920
  Trust level: Full
  Application Virtual Path: /owa
  Application Path: C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\owa\
  Machine name: EXCH2

Process information:
  Process ID: 4348
  Process name: w3wp.exe
  Account name: NT AUTHORITY\SYSTEM

Exception information:
  Exception type: TargetInvocationException
  Exception message: Exception has been thrown by the target of an invocation.
  at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck,
  Boolean&canBeCached, RuntimeMethodHandleInternal&ctor, Boolean&bNeedSecurityCheck)

    * SharedWebConfig.config is missing from either of these locations:
      C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
      C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess

Ursache

Dieses Problem tritt auf, wenn SharedWebConfig.config an einem der folgenden Speicherorte fehlt:

  • C:\Programme\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy
  • C:\Programme\Microsoft\Exchange Server\V15\ClientAccess

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Identifizieren Sie auf dem Server, auf dem das Problem auftritt, den Speicherort, an dem die Datei fehlt.

  2. Generieren Sie die fehlende Datei:

    1. Führen Sie aus cd %ExchangeInstallPath%\bin , um das aktuelle Verzeichnis in den Ordner bin zu ändern, der sich unter dem Exchange-Installationspfad befindet.

    2. Verwenden Sie das tool DependentAssemblyGenerator.exe, um die Datei zu generieren:

      • Wenn die Datei in C:\Programme\Microsoft\Exchange Server\V15\ClientAccess fehlt, führen Sie den folgenden Befehl aus:
      DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\ClientAccess" -configFile "%ExchangeInstallPath%\ClientAccess\SharedWebConfig.config"
      
      • Wenn die Datei in C:\Programme\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy fehlt, führen Sie den folgenden Befehl aus:
      DependentAssemblyGenerator.exe -exchangePath "%ExchangeInstallPath%\bin" -exchangePath "%ExchangeInstallPath%\FrontEnd\HttpProxy" -configFile "%ExchangeInstallPath%\FrontEnd\HttpProxy\SharedWebConfig.config"
      
  3. Führen Sie IISRESET aus, oder starten Sie den Server neu.

Weitere Informationen

Die SharedWebConfig.config-Datei wird während der Installationsphase des Setups generiert. Wenn Setup nach einer Unterbrechung fortgesetzt wird, werden die Schritte nach der Installation für die Rollen, die vor der Unterbrechung erfolgreich installiert wurden, nicht ausgeführt.