Freigegebenes Postfach in Exchange Online unerwartet getrennt

Symptome

In einer Hybridumgebung migrieren Sie ein reguläres Postfach von Microsoft Exchange Server zu Exchange Online und konvertieren dann das reguläre Postfach in Exchange Online in ein freigegebenes Postfach. Das freigegebene Postfach in Exchange Online ist nicht lizenziert und verfügt nicht über einen Halteraum. Nach der Konvertierung wird das freigegebene Postfach in Exchange Online jedoch getrennt.

Ursache

Dieses Problem tritt auf, weil der Postfachtyp in Exchange Online nicht mehr mit dem Postfachtyp des lokalen Remotepostfachs übereinstimmt. Da die Synchronisierungsrichtung von lokal zu Exchange Online erfolgt, kann der Konflikt beim Postfachtyp dazu führen, dass Exchange Online das freigegebene Postfach später zu einem regulären Postfach rückgängig machen. Exchange Online kann ein reguläres Postfach trennen, wenn ihm keine Lizenz zugewiesen und kein Haltespeicher angewendet wurde.

Lösung

Wichtig

Es kann zu einem dauerhaften Verlust des Postfachinhalts kommen, wenn diese Schritte nicht innerhalb von 30 Tagen nach der Trennung des Postfachs abgeschlossen werden. Wenn Sie nach ablauf des 30-tägigen Zeitraums eine Lizenz zuweisen, wird die Verbindung mit dem Postfach nicht wiederhergestellt, und stattdessen wird ein neues Postfach bereitgestellt.

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:

  1. Weisen Sie vorübergehend eine Lizenz zu, um die Verbindung mit dem Postfach wiederherzustellen.

  2. Aktualisieren Sie das lokale Remotepostfach auf den Shared Typ, indem Sie das folgende Cmdlet in der lokalen Exchange-Verwaltungsshell (EMS) ausführen:

    Set-RemoteMailbox -Identity <mailbox ID> -Type Shared
    
  3. Konvertieren Sie das reguläre Postfach in ein freigegebenes Postfach in Exchange Online, indem Sie den folgenden Befehl in Exchange Online PowerShell ausführen:

    Set-Mailbox -Identity <mailbox ID> -Type Shared
    
  4. Entfernen Sie die temporäre Lizenz.