Aktualisieren auf die neueste Office JavaScript-API-Bibliothek und das Add-in-Manifest-Schema der Version 1,1Update to the latest Office JavaScript API library and version 1.1 add-in manifest schema

In diesem Artikel wird beschrieben, wie Sie die JavaScript-Dateien (Office.js und App-spezifische .js-Dateien) und die Add-In-Manifestvalidierungsdatei im Office-Add-In-Projekt auf Version 1.1 aktualisieren.This article describes how to update your JavaScript files (Office.js and app-specific .js files) and add-in manifest validation file in your Office Add-in project to version 1.1.

Hinweis

Projekte, die in Visual Studio 2019 erstellt wurden, verwenden bereits Version 1,1.Projects created in Visual Studio 2019 will already use version 1.1. Es gibt jedoch gelegentlich kleinere Updates für Version 1.1, die Sie mithilfe der Verfahren in diesem Artikel anwenden können.However there are occasional minor updates to version 1.1 that you can apply by using the techniques in this article.

Aktuelleste Projektdateien verwendenUse the most up-to-date project files

Wenn Sie Visual Studio zum Entwickeln Ihres Add-Ins verwenden, müssen Sie Visual Studio 2019 herunterladen, um die neuesten API-Mitglieder der Office-JavaScript-API und die v 1.1-Features des Add-in-Manifests zu verwenden (das mit offappmanifest-1.1. XSD überprüft wird).If you use Visual Studio to develop your add-in, to use the newest API members of the Office JavaScript API and the v1.1 features of the add-in manifest (which is validated against offappmanifest-1.1.xsd), you need to download Visual Studio 2019. Informationen zum Herunterladen von Visual Studio 2019 finden Sie auf der Seite Visual Studio IDE.To download Visual Studio 2019, see the Visual Studio IDE page. Während der Installation müssen Sie die Arbeitslast für die Office/SharePoint-Entwicklung auswählen.During installation you'll need to select the Office/SharePoint development workload.

Wenn Sie einen Text-Editor oder eine andere IDE als Visual Studio zum Entwickeln der Add-In verwenden, müssen Sie die Verweise auf das CDN für Office.js und die Version des Schemas, auf das im Manifest der Add-In verwiesen wird, aktualisieren.If you use a text editor or IDE other than Visual Studio to develop your add-in, you need to update the references to the CDN for Office.js and the version of schema referenced in your add-in's manifest.

Um ein Add-in zu erstellen, das mit neuen und aktualisierten Office.js API-und Add-in-manifestfunktionen entwickelt wurde, müssen Ihre Kunden Office 2013 SP1 oder höher lokale Produkte der Version ausführen und gegebenenfalls SharePoint Server 2013 SP1 und zugehörige Server Produkte, Exchange Server 2013 Service Pack 1 (SP1) oder die entsprechenden Online gehosteten Produkte: Microsoft 365, SharePoint Online und Exchange Online.To run an add-in developed using new and updated Office.js API and add-in manifest features, your customers must be running Office 2013 SP1 or later version on-premises products, and where applicable, SharePoint Server 2013 SP1 and related server products, Exchange Server 2013 Service Pack 1 (SP1), or the equivalent online hosted products: Microsoft 365, SharePoint Online, and Exchange Online.

Informationen zum Herunterladen von Office, SharePoint und Exchange SP1-Produkten finden Sie in folgenden Ressourcen:To download Office, SharePoint, and Exchange SP1 products, see the following:

Aktualisieren eines Office-Add-In-Projekts mithilfe von Visual StudioUpdating an Office Add-in project created with Visual Studio

Für Projekte, die vor der Veröffentlichung von v 1.1 der Office-JavaScript-API und des Add-in-Manifest-Schemas erstellt wurden, können Sie die Dateien eines Projekts mit dem NuGet-Paket-Manageraktualisieren und dann die HTML-Seiten Ihres Add-ins aktualisieren, um darauf zu verweisen.For projects created before the release of v1.1 of the Office JavaScript API and add-in manifest schema, you can update a project's files using the NuGet Package Manager, and then update your add-in's HTML pages to reference them.

Beachten Sie, dass das Update pro Projekt angewendet wird. Das heißt, Sie müssen den Updatevorgang für jedes Add-in-Projekt wiederholen, in dem Sie die Version 1.1 von Office.js und des Add-in-Manifestschemas verwenden möchten.Note that the update process is applied on a per-project basis - you'll need to repeat the updating process for each add-in project in which you want to use v1.1 of Office.js and add-in manifest schema.

Aktualisieren der Office-JavaScript-API-Bibliotheksdateien in Ihrem Projekt auf die neueste VersionUpdate the Office JavaScript API library files in your project to the newest release

Mit den folgenden Schritten werden Ihre Office.js Bibliotheksdateien auf die neueste Version aktualisiert.The following steps will update your Office.js library files to the latest version. Die Schritte verwenden Visual Studio 2019, sind jedoch für frühere Versionen von Visual Studio ähnlich.The steps use Visual Studio 2019, but they are similar for previous versions of Visual Studio.

  1. Öffnen oder erstellen Sie in Visual Studio 2019 ein neues Office-Add-in Projekt.In Visual Studio 2019, open or create a new Office Add-in project.
  2. Wählen Sie Tools > NuGet Paket-Manager > Verwalten von NuGet-Paketen für die Lösung.Choose Tools > NuGet Package Manager > Manage Nuget Packages for Solution.
  3. Wählen Sie die Registerkarte Updates.Choose the Updates tab.
  4. Wählen Sie „Microsoft.Office.js“ aus.Select Microsoft.Office.js. Stellen Sie sicher, dass die Paketquelle aus nuget.orgstammt.Ensure the package source is from nuget.org.
  5. Klicken Sie im linken Bereich auf Installieren , und führen Sie den Paket Updateprozess aus.In the left pane, choose Install and complete the package update process.

Sie müssen ein paar weitere Schritte ausführen, um das Update abzuschließen.You'll need to take a few additional steps to complete the update. Kommentieren oder löschen Sie im Head -Tag der HTML-Seiten Ihres Add-ins vorhandene office.js Skriptverweise, und verweisen Sie wie folgt auf die aktualisierte Office JavaScript-API-Bibliothek:In the head tag of your add-in's HTML pages, comment out or delete any existing office.js script references, and reference the updated Office JavaScript API library as follows:

<script src="https://appsforoffice.microsoft.com/lib/1/hosted/office.js" type="text/javascript"></script>

Hinweis

Die Notation /1/ in office.js in der CDN-URL gibt an, dass die neueste inkrementelle Version innerhalb von Version 1 von „Office.js“ verwendet werden soll.The /1/ in the office.js in the CDN URL specifies to use the latest incremental release within version 1 of Office.js.

Aktualisieren der Manifestdatei in Ihrem Projekt für die Verwendung von Schemaversion 1.1Update the manifest file in your project to use schema version 1.1

Aktualisieren Sie in der Manifestdatei des Add-Ins das Attribut xmlns des Elements OfficeApp, indem Sie den Versionswert in 1.1 ändern (alle anderen Attribute außer xmlns bleiben unverändert).In your add-in's manifest file, update the xmlns attribute of the OfficeApp element changing the version value to 1.1 (leaving attributes other than the xmlns attribute unchanged).

<?xml version="1.0" encoding="utf-8"?>
<OfficeApp xsi:type="ContentApp"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns="http://schemas.microsoft.com/office/appforoffice/1.1">
  
  <!-- manifest contents -->

</OfficeApp>

Hinweis

Nachdem Sie die Version des Add-in-Manifest-Schemas auf 1,1 aktualisiert haben, müssen Sie die Funktionen und Capability -Elemente entfernen und durch die Hosts -und Host -Elemente oder die Requirements-und Requirement-Elemente ersetzen.After updating the version of the add-in manifest schema to 1.1, you will need to remove the Capabilities and Capability elements, and replace them with either the Hosts and Host elements or the Requirements and Requirement elements.

Aktualisieren eines mit einem Text-Editor oder einer anderen integrierten Entwicklungsumgebung erstellten Office-Add-In-ProjektsUpdating an Office Add-in project created with a text editor or other IDE

Für Projekte, die vor der Veröffentlichung von v 1.1 der Office-JavaScript-API und des Add-in-Manifest-Schemas erstellt wurden, müssen Sie die HTML-Seiten Ihres Add-ins aktualisieren, um auf CDN der v 1.1-Bibliothek zu verweisen, und die Manifestdatei des Add-ins so aktualisieren, dass das Schema v 1.1 verwendet wird.For projects created before the release of v1.1 of the Office JavaScript API and add-in manifest schema, you need to update your add-in's HTML pages to reference CDN of the v1.1 library, and update your add-in's manifest file to use schema v1.1.

Das Update wird pro Projekt angewendet. Das heißt, Sie müssen den Updatevorgang für jedes Add-In-Projekt wiederholen, in dem Sie die Version 1.1 von Office.js und des Add-In-Manifestschemas verwenden möchten.The update process is applied on a per-project basis - you'll need to repeat the updating process for each add-in project in which you want to use v1.1 of Office.js and add-in manifest schema.

Sie benötigen keine lokalen Kopien der Office-JavaScript-API-Dateien (Office.js und App-spezifischen. js-Dateien), um einem Office-Add-in zu entwickeln (auf das CDN verweisen, um die erforderlichen Dateien zur Laufzeit herunterzuladen Office.js), aber wenn Sie eine lokale Kopie der Bibliotheksdateien verwenden möchten, können Sie das Befehlszeilenprogramm NuGet und den Install-Package Microsoft.Office.js Befehl zum Herunterladen verwenden.You don't need local copies of the Office JavaScript API files (Office.js and app-specific .js files) to develop anOffice Add-in (referencing the CDN for Office.js downloads the necessary files at runtime), but if you want a local copy of the library files you can use the NuGet Command-Line Utility and the Install-Package Microsoft.Office.js command to download them.

Hinweis

Wie Sie eine Kopie der XSD (XML-Schemadefinition) für Add-In-Manifeste in Version 1.1 abrufen können, illustriert das Codebeispiel in der Schemareferenz für Office-Add-In-Manifeste (v1.1).To get a copy of the XSD (XML Schema Definition) for the v1.1 add-in manifest, see the listing in Schema reference for Office Add-ins manifests (v1.1).

Aktualisieren der Office-JavaScript-API-Bibliotheksdateien in Ihrem Projekt für die Verwendung der neuesten VersionUpdate the Office JavaScript API library files in your project to use the newest release

  1. Öffnen Sie die HTML-Seiten Ihres Add-Ins in Ihrem Texteditor oder Ihrer IDE.Open the HTML pages for your add-in in your text editor or IDE.

  2. Kommentieren oder löschen Sie im Head -Tag der HTML-Seiten Ihres Add-ins vorhandene office.js Skriptverweise, und verweisen Sie wie folgt auf die aktualisierte Office JavaScript-API-Bibliothek:In the head tag of your add-in's HTML pages, comment out or delete any existing office.js script references, and reference the updated Office JavaScript API library as follows:

    <script src="https://appsforoffice.microsoft.com/lib/1/hosted/office.js" type="text/javascript"></script>
    

    Hinweis

    Die Notation /1/ vor office.js in der CDN-URL legt fest, dass die neueste inkrementelle Version innerhalb von Version 1 von „Office.js“ verwendet werden soll.The /1/ in front of office.js in the CDN URL specifies to use the latest incremental release within version 1 of Office.js.

Aktualisieren der Manifestdatei in Ihrem Projekt für die Verwendung von Schemaversion 1.1Update the manifest file in your project to use schema version 1.1

Aktualisieren Sie in der Manifestdatei des Add-Ins das Attribut xmlns des Elements OfficeApp, indem Sie den Versionswert in 1.1 ändern (alle anderen Attribute außer xmlns bleiben unverändert).In your add-in's manifest file, update the xmlns attribute of the OfficeApp element changing the version value to 1.1 (leaving attributes other than the xmlns attribute unchanged).

<?xml version="1.0" encoding="utf-8"?>
<OfficeApp xsi:type="ContentApp"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xmlns="http://schemas.microsoft.com/office/appforoffice/1.1">
  
  <!-- manifest contents -->

</OfficeApp>

Hinweis

Nachdem Sie die Version des Add-in-Manifest-Schemas auf 1,1 aktualisiert haben, müssen Sie die Funktionen und Capability -Elemente entfernen und durch die Hosts -und Host -Elemente oder die Requirements-und Requirement-Elemente ersetzen.After updating the version of the add-in manifest schema to 1.1, you will need to remove the Capabilities and Capability elements, and replace them with either the Hosts and Host elements or the Requirements and Requirement elements.

Siehe auchSee also