Querladen Office-Add-Ins für Tests von einer NetzwerkfreigabeSideload Office Add-ins for testing from a network share

Sie können eine Office-Add-in in einem Office-Client unter Windows testen, indem Sie das Manifest in einer Netzwerkdateifreigabe (Anweisungen unten) veröffentlichen.You can test an Office Add-in in an Office client that is on Windows by publishing the manifest to a network file share (instructions below). Diese Bereitstellungsoption sollte verwendet werden, wenn Sie die Entwicklung und Tests auf einem localhost abgeschlossen haben und das Add-in über einen nicht lokalen Server oder ein Cloud-Konto testen möchten.This deployment option is intended to be used when you have completed development and testing on a localhost and want to test the add-in from a non-local server or cloud account.

Wichtig

Die Bereitstellung nach Netzwerkfreigabe wird für Produktions-Add-Ins nicht unterstützt. Diese Methode weist die folgenden Einschränkungen auf:Deployment by network share is not supported for production add-ins. This method has the following limitations:

  • Das Add-in kann nur auf Windows-Computern installiert werden.The add-in can only be installed on Windows computers.
  • Wenn das Menüband in einer neuen Version eines Add-Ins geändert wird, muss jeder Benutzer das Add-in erneut installieren.If a new version of an add-in changes the ribbon, each user will have to reinstall the add-in.

Hinweis

Wenn das Add-In-Projekt mit einer hinreichend neueren Version des Yeoman-Generators für Office Add-Ins erstellt wurde, wird das Add-In automatisch im Office Desktop-Client quergeladen, wenn Sie npm start ausführen.If your add-in project was created with a sufficiently recent version of the Yeoman generator for Office Add-ins, the add-in will automatically sideload in the Office desktop client when you run npm start.

Dieser Artikel bezieht sich nur auf das Testen von Word-, Excel-, PowerPoint-und Project-Add-Ins und nur unter Windows.This article applies only to testing Word, Excel, PowerPoint, and Project add-ins and only on Windows. Wenn Sie auf einer anderen Plattform testen oder ein Outlook-Add-In testen möchten, sehen Sie sich eines der folgenden Themen an, um Ihr Add-In querzuladen:If you want to test on another platform or want to test an Outlook add-in, see one of the following topics to sideload your add-in:

Das folgende Video führt Sie durch den Prozess des Querladens von Add-Ins auf Office-Desktop oder in Office Online mithilfe eines Katalogs mit freigegebenen Ordnern.The following video walks you through the process of sideloading your add-in in Office on the web or desktop using a shared folder catalog.

Freigeben eines OrdnersShare a folder

  1. Wechseln Sie auf dem Windows-Computer, auf dem Sie das Add-in hosten möchten, zum übergeordneten Ordner oder zum Laufwerkbuchstaben des Ordners, den Sie als die, den Sie als freigegebenen Ordnerkatalog verwenden möchten.In File Explorer on the Windows computer where you want to host your add-in, go to the parent folder, or drive letter, of the folder you want to use as your shared folder catalog.

  2. Öffnen Sie das Kontextmenü für den Ordner, den Sie als Katalog mit freigegebenen Ordnern verwenden möchten (mit der rechten Maustaste auf den Ordner klicken), und wählen Sie Eigenschaften aus.Open the context menu for the folder you want to use as your shared folder catalog (right-click the folder) and choose Properties.

  3. Öffnen Sie im Dialogfeld Eigenschaften die Registerkarte Freigabe, und wählen Sie dann die Schaltfläche Freigeben.Within the Properties dialog window, open the Sharing tab and then choose the Share button.

    Dialogfeld "Ordnereigenschaften" mit hervorgehobener Registerkarte "Freigabe" und Schaltfläche "Freigeben"

  4. Fügen Sie im Dialogfeld Netzwerkzugriff sich selbst und alle anderen Benutzer und/oder Gruppen hinzu, mit denen Sie das Add-In teilen möchten.Within the Network access dialog window, add yourself and any other users and/or groups with whom you want to share your add-in. Sie benötigen mindestens Lese-/Schreibzugriff auf den Ordner.You will need at least Read/Write permission to the folder. Nachdem Sie Personen für die Freigabe ausgewählt haben, wählen Sie die Schaltfläche Freigeben aus.After you have finished choosing people to share with, choose the Share button.

  5. Wenn Sie eine Bestätigung erhalten, dass Ihr Ordner freigegeben wurde, notieren Sie den vollständigen Netzwerkpfad, der unmittelbar nach dem Ordnernamen angezeigt wird.When you see confirmation that Your folder is shared, make note of the full network path that's displayed immediately following the folder name. (Sie müssen diesen Wert als Katalog-URL eingeben, wenn Sie den freigegebenen Ordner als vertrauenswürdigen Katalog angeben, wie im nächsten Abschnitt dieses Artikels beschrieben.) Wählen Sie die Fertig-Schaltfläche, um das Netzwerkzugriff-Dialogfeld zu schließen.(You will need to enter this value as the Catalog Url when you specify the shared folder as a trusted catalog, as described in the next section of this article.) Choose the Done button to close the Network access dialog window.

    Netzwerkzugriff-Dialog mit hervorgehobenem Freigabepfad

  6. Wählen Sie die Schaltfläche OK aus, um das Dialogfeld Eigenschaften zu schließen.Choose the Close button to close the Properties dialog window.

Geben Sie den freigegebenen Ordner als vertrauenswürdigen Katalog an.Specify the shared folder as a trusted catalog

Manuelles Konfigurieren der VertrauensstellungConfigure the trust manually

  1. Öffnen Sie ein neues Dokument in Excel, Word, PowerPoint oder Project.Open a new document in Excel, Word, PowerPoint, or Project.

  2. Klicken Sie auf die Registerkarte Datei und dann auf Optionen.Choose the File tab, and then choose Options.

  3. Wählen Sie Sicherheitscenter aus, und wählen Sie dann die Schaltfläche Einstellungen für das Sicherheitscenter aus.Choose Trust Center, and then choose the Trust Center Settings button.

  4. Wählen Sie Vertrauenswürdige Add-In-Kataloge.Choose Trusted Add-in Catalogs.

  5. Geben Sie im Feld Katalog-URL den vollständigen Netzwerkpfad zu dem Ordner ein, den Sie zuvor freigegeben haben.In the Catalog Url box, enter the full network path to the folder that you shared previously. Wenn Sie bei der Freigabe des Ordners den vollständigen Netzwerkpfad des Ordners nicht notiert haben, können Sie ihn über das Eigenschaften-Dialogfeld des Ordners wie im folgenden Screenshot gezeigt abrufen.If you failed to note the folder's full network path when you shared the folder, you can get it from the folder's Properties dialog window, as shown in the following screenshot.

    Dialog "Ordnereigenschaften" mit hervorgehobener Registerkarte "Freigabe" und Netzwerkpfad

  6. Nach der Eingabe des vollständigen Netzwerkpfads des Ordners in das Feld Katalog-URL wählen Sie die Katalog hinzufügen-Schaltfläche.After you've entered the full network path of the folder into the Catalog Url box, choose the Add catalog button.

  7. Wählen Sie das Kontrollkästchen Im Menü anzeigen für das neu hinzugefügte Element, und wählen Sie dann die OK-Schaltfläche zum Schließen des Sicherheitscenter-Dialogfelds.Select the Show in Menu check box for the newly-added item, and then choose the OK button to close the Trust Center dialog window.

    Dialog "Sicherheitscenter" mit ausgewähltem Katalog

  8. Klicken Sie auf die Schaltfläche OK , um das Dialogfenster Optionen zu schließen.Choose the OK button to close the Options dialog window.

  9. Schließen Sie die Office-Anwendung und öffnen Sie sie erneut, damit die Änderungen wirksam werden.Close and reopen the Office application so your changes will take effect.

Konfigurieren der Vertrauensstellung mit einem RegistrierungsskriptConfigure the trust with a Registry script

  1. Erstellen Sie in einem Text-Editor eine Datei namens "TrustNetworkShareCatalog.reg".In a text editor, create a file named TrustNetworkShareCatalog.reg.

  2. Fügen Sie der Datei den folgenden Inhalt hinzu:Add the following content to the file:

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\WEF\TrustedCatalogs\{-random-GUID-here-}]
    "Id"="{-random-GUID-here-}"
    "Url"="\\\\-share-\\-folder-"
    "Flags"=dword:00000001
    
  3. Verwenden Sie eines der zahlreichen Onlinetools für die GUID-Erstellung, z. B. GUID-Generator, um eine Zufalls-GUID zu generieren, und ersetzen Sie in der Datei "TrustNetworkShareCatalog.reg" die Zeichenfolge "-random-GUID-here-"-an beiden Stellen durch die GUID.Use one of the many online GUID generation tools, such as GUID Generator, to generate a random GUID, and within the TrustNetworkShareCatalog.reg file, replace the string "-random-GUID-here-" in both places with the GUID. (Die einschließenden {}-Symbole sollten beibehalten werden.)(The enclosing {} symbols should remain.)

  4. Ersetzen Sie den Url-Wert durch den vollständigen Netzwerkpfad zu dem Ordner, den Sie zuvor freigegeben haben.Replace the Url value with the full network path to the folder that you shared previously. (Beachten Sie, dass alle \-Zeichen in der URL verdoppelt werden müssen.) Wenn Sie bei der Freigabe des Ordners den vollständigen Netzwerkpfad des Ordners nicht notiert haben, können Sie ihn über das Eigenschaften-Dialogfeld des Ordners wie im folgenden Screenshot gezeigt abrufen.(Note that any \ characters in the URL must be doubled.) If you failed to note the folder's full network path when you shared the folder, you can get it from the folder's Properties dialog window, as shown in the following screenshot.

    Dialog "Ordnereigenschaften" mit hervorgehobener Registerkarte "Freigabe" und Netzwerkpfad

  5. Die gesamte Datei sollte jetzt wie folgt aussehen.The file should now look like the following. Speichern Sie sie.Save it.

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\WEF\TrustedCatalogs\{01234567-89ab-cedf-0123-456789abcedf}]
    "Id"="{01234567-89ab-cedf-0123-456789abcedf}"
    "Url"="\\\\TestServer\\OfficeAddinManifests"
    "Flags"=dword:00000001
    
  6. Schließen Sie alle Office-Anwendungen.Close all Office applications.

  7. Führen Sie die Datei "TrustNetworkShareCatalog.reg" genauso wie jede ausführbare Datei aus, z. B. durch Doppelklicken.Run the TrustNetworkShareCatalog.reg just as you would any executable, such as double-clicking it.

Querladen des Add-InsSideload your add-in

  1. Legen Sie die Manifest-XML-Datei eines Add-Ins, das Sie testen, in den freigegebenen Ordnerkatalog.Put the manifest XML file of any add-in that you are testing in the shared folder catalog. Beachten Sie, dass Sie die Webanwendung selbst auf einem Webserver bereitstellen.Note that you deploy the web application itself to a web server. Achten Sie darauf, die URL im SourceLocation-Element der Manifestdatei anzugeben.Be sure to specify the URL in the SourceLocation element of the manifest file.

    Wichtig

    Zwar ist die Verwendung eines HTTPS-Endpunkts für Ihr Add-in in allen Add-in-Szenarien nicht unbedingt erforderlich, es wird jedoch dringend empfohlen. Add-Ins, die nicht SSL-gesichert (HTTPS) sind, generieren unsichere Inhalts Warnungen und Fehler während der Verwendung. Wenn Sie planen, Ihr Add-in in Office im Internet auszuführen oder Ihr Add-in in AppSource zu veröffentlichen, muss es SSL-gesichert sein. Wenn Ihr Add-in auf externe Daten und Dienste zugreift, sollte es SSL-gesichert sein, um Daten bei der Übertragung zu schützen. Selbstsignierte Zertifikate können für die Entwicklung und das Testen verwendet werden, solange das Zertifikat auf dem lokalen Computer als vertrauenswürdig eingestuft wird.While not strictly required in all add-in scenarios, using an HTTPS endpoint for your add-in is strongly recommended. Add-ins that are not SSL-secured (HTTPS) generate unsecure content warnings and errors during use. If you plan to run your add-in in Office on the web or publish your add-in to AppSource, it must be SSL-secured. If your add-in accesses external data and services, it should be SSL-secured to protect data in transit. Self-signed certificates can be used for development and testing, so long as the certificate is trusted on the local machine.

  2. Wählen Sie in Excel, Word oder PowerPoint Meine Add-Ins aus der Registerkarte Einfügen des Menübands aus.In Excel, Word, or PowerPoint, select My Add-ins on the Insert tab of the ribbon. Wählen Sie in Project Meine Add-Ins auf der Registerkarte Projekt im Menüband aus.In Project, select My Add-ins on the Project tab of the ribbon.

  3. Wählen Sie im Dialogfeld Office-Add-Ins oben die Option Freigegebener Ordner aus.Choose SHARED FOLDER at the top of the Office Add-ins dialog box.

  4. Wählen Sie den Namen des Add-Ins aus, und klicken Sie auf Hinzufügen, um das Add-In einzufügen.Select the name of the add-in and choose Add to insert the add-in.

Entfernen eines quer geladene-Add-insRemove a sideloaded add-in

Sie können ein zuvor quer geladene-Add-in entfernen, indem Sie den Office-Cache auf Ihrem Computer löschen.You can remove a previously sideloaded add-in by clearing the Office cache on your computer. Details zum Löschen des Caches unter Windows finden Sie im Artikel Clear the Office Cache.Details on how to clear the cache on Windows can be found in the article Clear the Office cache.

Weitere ArtikelSee also