Informationen zur AutoVervollständigen-Liste von Outlook

Ursprüngliche KB-Nummer:   2199226

Zusammenfassung

Dieser Artikel enthält eine Übersicht über die Microsoft Outlook Auto Vervollständigen-Liste (auch als Outlook-Vervollständigungsliste bezeichnet). Zusätzlich zur Beschreibung des Features enthält dieser Artikel weitere Informationen und Schritt-für-Schritt-Anleitungen für erfahrene Benutzer zum Verwalten der Liste.

Weitere Informationen

Die AutoVervollständigen-Liste wird von Outlook verwaltet. Die Liste wird sowohl von der automatischen Namensüberprüfung als auch von der automatischen Vervollständigungsfunktion verwendet. Die AutoVervollständigen-Liste, die auch als Nickname-Cache bezeichnet wird, wird automatisch generiert, wenn Sie e-Mail-Nachrichten von Outlook senden. Die Liste enthält SMTP-Adressen, legacyExchangeDN-Einträge und Anzeigenamen für Personen, an die Sie zuvor e-Mails gesendet haben.

Hinweis

Die AutoVervollständigen-Liste für Outlook ist spezifisch für Outlook und wird nicht von Outlook Web App (OWA) freigegeben. OWA verwaltet seine eigene AutoVervollständigen-Liste.

Die folgenden Abschnitte enthalten Informationen zur Funktion "AutoVervollständigen".

Grenzwert für die Anzahl der Einträge

Outlook schränkt die Anzahl der Einträge ein, die Sie in der Liste AutoVervollständigen speichern können. Nachdem Sie diesen Grenzwert erreicht haben, verwendet Outlook einen internen Algorithmus, um die besten Namen zu ermitteln, die aus der Liste entfernt werden sollen. Dies erfolgt basierend auf einer Nutzungs Gewichtung. Sie finden daher möglicherweise einige Namen unerwartet aus ihrem Spitznamen Cache entfernt. Es gibt zwei allgemeine Ansätze, die Sie verwenden können, um diese Situation zu vermeiden:

  1. Sie können proaktive AutoVervollständigen-Listeneinträge entfernen, die Sie nicht mehr benötigen. Dies ist der bevorzugte Ansatz. Weitere Informationen zur Vorgehensweise finden Sie unter How to Remove AutoComplete List Entries One to a Time section.
  2. Sie können den Grenzwert für den Spitznamen Cache verbessern. Da diese Konfiguration nicht getestet wird, wird Sie nicht empfohlen. Wenn Sie einen größeren Spitznamen Cache haben, können Sie auch eine größere Anzahl von zwischengespeicherten Einträgen verlieren, wenn ihr Spitznamen Cache aufgrund von Beschädigung unbrauchbar wird. Weitere Informationen zum Erweitern des Grenzwerts finden Sie im Abschnitt Vorgehensweise zum Ändern des Grenzwerts für die AutoVervollständigen-Liste .

Die Grenzwerte lauten wie folgt:

  • Outlook 2016:1.000 Einträge
  • Outlook 2013:1.000 Einträge
  • Outlook 2010:1.000 Einträge
  • Outlook 2007:2.000 Einträge
  • Outlook 2003:1.000 Einträge

Aktivieren des Features "AutoVervollständigen"

In diesem Abschnitt erfahren Sie, wie Sie das Feature "AutoVervollständigen" aktivieren oder deaktivieren.

Outlook 2010, Outlook 2013 und Outlook 2016

Führen Sie die folgenden Schritte aus, um auf die AutoVervollständigen-Einstellung zuzugreifen:

  1. Wählen Sie im Menü Datei die Option   Optionenaus.

  2. Wählen Sie die Registerkarte e-Mail aus.

  3. Scrollen Sie ungefähr halb herunter, bis Sie Nachrichten sendensehen. Stellen Sie sicher, dass die Liste automatisch vervollständigen verwenden zum vorschlagen von Namen bei der Eingabe im Feld an-, CC-und Bcc-Zeilen aktiviert ist.

    Fenster "Nachrichten senden", verwenden Sie die Auto Vervollständigen-Liste zum vorschlagen von Namen bei der Eingabe im Feld an, CC und Bcc-Zeilen aktiviert.

Outlook 2003 und Outlook 2007

Führen Sie die folgenden Schritte aus, um auf die AutoVervollständigen-Einstellungen zuzugreifen:

  1. Wählen Sie Toolsaus, und wählen Sie dann Optionenaus.

  2. Klicken Sie auf die Schaltfläche e-Mail-Optionen .

  3. Klicken Sie auf die Schaltfläche Erweiterte e-Mail-Optionen .

  4. Stellen Sie sicher, dass das Feld Namen bei Abschluss von an, CC und Bcc vorschlagen   aktiviert ist. (Der Screenshot für diesen Schritt folgt.)

    Fenster "Nachrichten senden", verwenden Sie die Auto Vervollständigen-Liste zum vorschlagen von Namen bei der Eingabe im Feld an, CC und Bcc-Zeilen aktiviert.

Importieren von NK2-Dateien in Outlook 2010, Outlook 2013 und Outlook 2016

In Microsoft Office Outlook 2007 und früheren Versionen wird die AutoVervollständigen-Liste in einer Spitznamendatei (NK2) auf dem Datenträger gespeichert. Outlook 2010, Outlook 2013 und Outlook 2016 speichern Sie die AutoVervollständigen-Liste als ausgeblendete Nachricht in Ihrem primären Nachrichtenspeicher. Mit Outlook 2010, Outlook 2013 und Outlook 2016 können Sie die älteren NK2-Dateien importieren.

Weitere Informationen zum Importieren von NK2-Dateien in Outlook 2010 finden Sie unter Importieren der Auto Vervollständigen-Liste von einem anderen Computer.

Vorgehensweise Kopieren der AutoVervollständigen-Liste

Die Schritte zum Exportieren und Importieren der AutoVervollständigen-Liste sind unterschiedlich, je nachdem, welche Version von Outlook Sie verwendet haben.

Outlook 2016, Outlook 2013 und Outlook 2010

Führen Sie die folgenden Schritte aus, um die Liste AutoVervollständigen in Outlook 2016, Outlook 2013 und Outlook 2010 zu kopieren:

Schritt 1

Führen Sie die folgenden Schritte aus, um die AutoVervollständigen-Post Fach Nachricht zu exportieren:

  1. Beenden Sie Outlook, und schließen Sie dann Outlook Web Access oder Outlook Web App (OWA) auf allen Arbeitsstationen, die mit Ihrem Postfach verbunden sind.
  2. Laden Sie MfcMapiherunter, und installieren Sie es.
  3. Führen Sie mfcmapi.exe aus.
  4. Wählen Sie im Menü Sitzung die Option Anmeldungaus.
  5. Wenn Sie zur Eingabe eines Profils aufgefordert werden, wählen Sie den gewünschten Profilnamen aus, und wählen Sie dann OKaus.
  6. Suchen Sie im oberen Bereich die dem Postfach entsprechende Position, und doppelklicken Sie darauf.
  7. Erweitern Sie im linken Navigationsbereich den Knoten Stamm Container, und erweitern Sie dann oben im Informationsspeicher oder IPM_Subtree.
  8. Klicken Sie mit der rechten Maustaste auf den Ordner Posteingang , und wählen Sie zugeordnete Inhaltstabelle öffnenaus. Mit dieser Aktion wird ein neues MfcMapi-Fenster geöffnet, das verschiedene Eigenschaften enthält.
  9. Klicken Sie unter der Spalte Betreff mit der rechten Maustaste auf das Element mit dem Betreff IPM.Configuration. AutoVervollständigen, und wählen Sie dann Nachricht exportierenaus. Mit dieser Aktion wird das Fenster Nachricht in Datei speichern geöffnet.
  10. Wählen Sie in der Dropdownliste msg- Datei (Unicode) aus, und wählen Sie dann OKaus.
  11. Wählen Sie einen Ordnerspeicherort aus, in dem die Nachricht gespeichert werden soll, und wählen Sie dann Speichernaus. Notieren Sie diesen Speicherort.

Schritt 2

Führen Sie die folgenden Schritte aus, um die AutoVervollständigen-Post Fach Nachricht zu importieren.

  1. Beenden Sie Outlook, und schließen Sie dann Outlook Web Access oder Outlook Web App (OWA) auf allen Arbeitsstationen, die mit Ihrem Postfach verbunden sind.

  2. Laden Sie MfcMapiherunter, und installieren Sie es.

  3. Führen Sie mfcmapi.exe aus.

  4. Wählen Sie im Menü Sitzung die Option Anmeldungaus.

  5. Wenn Sie zur Eingabe eines Profils aufgefordert werden, wählen Sie den gewünschten Profilnamen aus, und wählen Sie dann OKaus.

  6. Suchen Sie im oberen Bereich die dem Postfach entsprechende Position, und doppelklicken Sie darauf.

  7. Erweitern Sie im linken Navigationsbereich Stamm Postfach, und erweitern Sie dann oben im Informationsspeicher oder IPM_Subtree.

  8. Klicken Sie mit der rechten Maustaste auf den Ordner Posteingang , und wählen Sie zugeordnete Inhaltstabelle öffnenaus. Mit dieser Aktion wird ein neues MfcMapi-Fenster geöffnet, das verschiedene Eigenschaften enthält.

  9. Um doppelte Einträge zu vermeiden, müssen Sie die vorhandene AutoVervollständigen-Nachricht löschen.

    Hinweis

    Vor dem Löschen des IPM.Configuration. "AutoVervollständigen "-Nachricht, müssen Sie die Nachricht mit den Schritten im Abschnitt Kopieren der AutoVervollständigen-Liste exportieren.

    Führen Sie die folgenden Schritte aus, um die vorhandene AutoVervollständigen-Nachricht zu löschen:

    1. Suchen Sie in der Spalte Betreff das Element mit dem Betreff IPM.Configuration. AutoVervollständigen.
    2. Klicken Sie mit der rechten Maustaste auf das Element, und wählen Sie dann Nachricht löschenaus. Dadurch wird das Fenster Element löschen geöffnet.
    3. Wählen Sie in der Dropdownliste die Option permanenter Löschvorgang (Löschungen für gelöschte Element Aufbewahrung, falls unterstützt) aus, und wählen Sie dann OKaus.
  10. Wählen Sie im Menü Ordner die Option importierenaus, und wählen Sie dann aus msg aus.

  11. Suchen Sie die msg-Datei, die Sie in Schritt 11 des Abschnitts Kopieren der AutoVervollständigen-Liste erstellt haben, und wählen Sie dann OKaus.

  12. Wählen Sie im Fenster Belastungs Meldung, das angezeigt wird, in der Liste Lade Formatvorlage die Option Nachricht in aktuellen Ordner laden aus, und wählen Sie dann OKaus.

Die AutoVervollständigen-Informationen werden aus dem IPM.Configuration importiert. Autocomplete_ <hexadecimal code> . msg, wobei der Platzhalter <hexadecimal code> eine lange Zeichenfolge von Zahlen und Buchstaben darstellt.

Outlook 2007 und Outlook 2003

Die Schritte zum Kopieren der AutoVervollständigen-Liste in Outlook 2003 und Outlook 2007 sind unterschiedlich. Dies liegt daran, dass Outlook 2003 und Outlook 2007 die AutoVervollständigen-Liste in der NK2-Datei speichern.

Informationen zum Kopieren der Auto Vervollständigen-Liste in Outlook 2007 finden Sie unter importieren oder Kopieren der Auto Vervollständigen-Liste auf einen anderen Computer.

Vorgehensweise Entfernen von Einträgen in der AutoVervollständigen-Liste nacheinander

Führen Sie die folgenden Schritte aus, um Einträge aus dem AutoVervollständigen-Cache einen Eintrag gleichzeitig zu entfernen:

  1. Öffnen Sie eine neue e-Mail-Nachricht.
  2. Geben Sie die ersten Zeichen des AutoVervollständigen-Eintrags ein, den Sie entfernen möchten.
  3. Wenn der Eintrag in der Liste mit Vorschlägen angezeigt wird, bewegen Sie den Mauszeiger über den Vorschlag, bis er hervorgehoben wird, ihn jedoch nicht auswählen.
  4. Wenn das x-Symbol neben dem markierten Vorschlag angezeigt wird, wählen Sie x aus, um den Eintrag aus der Liste zu entfernen, oder drücken Sie die ENTF -Taste auf der Tastatur.

Durch die Auswahl von X wird verhindert, dass dieser Eintrag (Name) wieder in der AutoVervollständigen-Liste angezeigt wird, aber er wird nicht aus Ihrem Konto entfernt. Dieser Eintrag wird möglicherweise weiterhin in anderen Bereichen in Outlook angezeigt (beispielsweise in Suchfeldern).

Hinweis

Wenn Sie eine Person eine neue e-Mail senden, nachdem Sie Ihren Namen aus der Liste "AutoVervollständigen" entfernt haben, werden Ihre Informationen wieder zur Liste hinzugefügt.

So löschen Sie die gesamte AutoVervollständigen-Liste

In diesem Abschnitt wird das Löschen der AutoVervollständigen-Liste erläutert.

Outlook 2016, Outlook 2013 und Outlook 2010

Verwenden Sie eine der folgenden beiden Methoden, um die AutoVervollständigen-Liste in Outlook 2010, Outlook 2013 und Outlook 2016 zu löschen.

Methode 1

  1. Öffnen Sie Outlook.

  2. Klicken Sie auf der Registerkarte Datei auf Optionen.

  3. Wählen Sie die Registerkarte e-Mail aus.

  4. Wählen Sie unter Nachrichten sendendie Option leere Auto Vervollständigen-Listeaus.

    Fenster &quot;Nachrichten senden&quot;, verwenden Sie die Auto Vervollständigen-Liste zum vorschlagen von Namen bei der Eingabe im Feld an, CC und Bcc-Zeilen aktiviert.

  5. Wählen Sie die Option Ja aus.

Methode 2

Starten Sie Outlook mithilfe der/CleanAutoCompleteCache-Option. Gehen Sie dazu wie folgt vor:

  1. Wählen Sie Start und dann Ausführen aus.
  2. Geben Sie Outlook.exe/CleanAutoCompleteCacheein.

Hinweis

Wenn Outlook nicht am Standardspeicherort installiert ist, müssen Sie auf den Pfad des Outlook.exes deuten.

Outlook 2007 und Outlook 2003

Zum Löschen der AutoVervollständigen-Liste in Outlook 2003 und Outlook 2007 müssen Sie die NK2-Datei manuell löschen. Führen Sie die folgenden Schritte aus, um die Datei. nk2 zu löschen:

  1. Beenden Sie Outlook.

  2. Wählen Sie Startaus, und wählen Sie dann Computeraus.

  3. Wählen Sie organisierenaus, und wählen Sie dann Ordner-und Suchoptionenaus.

  4. Wählen Sie auf der Registerkarte Ansicht die Option versteckte Dateien, Ordner und Laufwerke anzeigenaus.

  5. Wählen Sie OK aus.

  6. Wählen Sie Start, Alle Programme, Zubehör, und wählen Sie dann Ausführenaus.

  7. Geben Sie im Dialogfeld Ausführen den folgenden Befehl ein (einschließlich der Anführungszeichen), und klicken Sie dann auf OK:

    C:\ Benutzer \ Benutzername\AppData\Roaming\Microsoft\Outlook

    Hinweis

    Username in diesem Pfad ist der Name des aktuell angemeldeten Windows-Benutzers.

  8. Klicken Sie mit der rechten Maustaste auf. NK2-Datei mit dem Namen des Profils, das Sie zurücksetzen möchten, und wählen Sie dann Umbenennenaus.

  9. Benennen Sie die Datei alsProfilname. bak um, und drücken Sie dann die EINGABETASTE.

  10. Starten Sie Outlook.

Probleme mit dem AutoVervollständigen-Cache

In diesem Abschnitt werden bekannte Probleme beschrieben, die mit dem AutoVervollständigen-Cache auftreten können. Der AutoVervollständigen-Cache kann im Laufe der Zeit beschädigt werden und möglicherweise keine neuen Einträge speichern. In diesem Fall können Sie versuchen, einzelne Einträge aus der Liste zu entfernen. Informationen hierzu finden Sie unter How to Remove AutoComplete List Entries One to a Time section. Wenn das Problem dadurch nicht behoben wird, kann die gesamte AutoVervollständigen-Liste zurückgesetzt werden. Verwenden Sie dazu den Abschnitt mit dem Titel "Löschen der gesamten AutoVervollständigen-Liste".

Vorgehensweise ändern des Grenzwerts für die AutoVervollständigen-Liste

Da diese Konfiguration nicht getestet wird, wird Sie nicht empfohlen. Wenn Sie eine größere AutoVervollständigen-Liste haben, können Sie auch eine größere Anzahl von zwischengespeicherten Einträgen verlieren, wenn Ihr AutoVervollständigen-Cache aufgrund von Beschädigung unbrauchbar wird. Aufgrund dieses Haftungsausschlusses können Sie die folgenden Registrierungsdaten verwenden, um den Listen Grenzwert für die Autovervollständigung in Outlook zu verbessern.

Wichtig

Dieser Abschnitt, diese Methode bzw. diese Aufgabe enthält eine Beschreibung der Schritte zum Bearbeiten der Registrierung. Durch die falsche Bearbeitung der Registrierung können schwerwiegende Probleme verursacht werden. Daher ist es wichtig, bei der Ausführung der folgenden Schritte sorgfältig vorzugehen. Für zusätzlichen Schutz sichern Sie die Registrierung, bevor Sie sie ändern. Sie können die Registrierung wiederherstellen, wenn ein Problem auftritt. Weitere Informationen zum Sichern und Wiederherstellen der Registrierung finden Sie unter Sichern und Wiederherstellen der Registrierung in Windows.

  1. Beenden Sie Outlook.

  2. Starten Sie den Registrierungs-Editor.

    • Drücken Sie in Windows 8. x die Windows-Taste, geben Sie Regedit ein, und drücken Sie dann die EingabeTaste.
    • Wählen Sie in Windows 7 und Windows Vista Startaus, geben Sie Regedit in das Suchfeld starten ein, und drücken Sie dann die EingabeTaste.
  3. Suchen Sie den folgenden Registrierungsunterschlüssel, und wählen Sie ihn aus:
      HKEY_CURRENT_USER\Software\Microsoft\Office\<x.0>\Outlook\AutoNameCheck

    Hinweis

    Der Platzhalter <x. 0> in diesem Registrierungsunterschlüssel stellt Ihre Version von Microsoft Office dar. Verwenden Sie den entsprechenden Wert aus der folgenden Liste.

    Outlook 2016 = 16,0
    Outlook 2013 = 15,0
    Outlook 2010 = 14,0
    Outlook 2007 = 12,0
    Outlook 2003 = 11,0

  4. Klicken Sie im Menü Bearbeiten auf neu, und wählen Sie dann DWORD-Wertaus.

  5. Geben Sie MaxNickNamesein, und drücken Sie dann die EINGABETASTE.

  6. Klicken Sie im Menü Bearbeiten auf ändern.

  7. Geben Sie den neuen Wert für den Grenzwert ein, und wählen Sie dann OKaus.

    Hinweis

    • Stellen Sie sicher, dass Sie die Zahl in Dezimalformeingeben. Dies ist das richtige Formular, mit dem die Nummer eingegeben werden kann.
    • Versuchen Sie, den Grenzwert um nur einen marginalen Betrag zu erhöhen, um den neuen Grenzwert zu testen. Um beispielsweise eine 20-prozentige Anhebung des Grenzwerts in Outlook 2013 zu erstellen, geben Sie 1200 für den MaxNickNames Wert an.
  8. Beenden Sie den Registrierungs-Editor.

  9. Starten Sie Outlook.

Hinweis

Der MaxNickNames Registrierungswert gibt lediglich den nicht standardmäßigen Grenzwert an. Daher können Sie diesen Wert auch verwenden, um den Grenzwert für den Spitznamen Cache zu verringern.