Abfrageübersicht in Power BI DesktopQuery overview in Power BI Desktop

Ist diese Seite hilfreich?

Mit Power BI Desktop vernetzen Sie sich mit der Welt der Daten, erstellen überzeugende und fundierte Berichte und teilen Ihre Arbeit mit anderen, die dann darauf aufbauen und so ihr Business Intelligence-Potenzial erweitern können.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop verfügt über drei Ansichten:Power BI Desktop has three views:

  • Berichtsansicht. Hier entwerfen Sie mithilfe selbst erstellter Abfragen ansprechende Visualisierungen, ordnen diese wie gewünscht und bei Bedarf auf mehreren Seiten an und geben Sie für andere Benutzer freiReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Datenansicht. Hier können Sie die Daten Ihres Berichts im Datenmodellformat anzeigen und Measures hinzufügen, neue Spalten erstellen und Beziehungen verwaltenData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Beziehungsansicht. Hier können Sie eine grafische Darstellung der Beziehungen abrufen, die in Ihrem Datenmodell eingerichtet wurden, und diese je nach Bedarf verwalten oder ändern.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Um auf diese Ansichten zuzugreifen, verwenden Sie die drei Symbole auf der linken Seite in Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. In der folgenden Abbildung ist die Berichtsansicht ausgewählt. Dies wird durch den gelben Streifen neben dem Symbol signalisiert.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop enthält auch einen Abfrage-Editor, mit dem Sie eine Verbindung mit einer oder mehreren Datenquellen herstellen, die Daten gemäß Ihren Anforderungen strukturieren und transformieren und das Modell dann in Power BI Desktop laden können.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Das vorliegende Dokument enthält eine Übersicht über die Arbeit mit Daten im Abfrage-Editor.This document provides an overview of the work with data in the Query Editor. Aber es gibt natürlich noch mehr, das Sie wissen sollten. Deswegen finden Sie am Ende dieses Dokuments eine Reihe von Links, über die Sie ausführliche Anleitungen zu unterstützten Datentypen, zum Herstellen einer Datenverbindung, zum Strukturieren von Daten, zum Erstellen von Beziehungen und für den Einstieg in Power BI Desktop aufrufen können.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Zuerst wollen wir uns aber mit dem Abfrage-Editor vertraut machen.But first, let’s see get acquainted with Query Editor.

Abfrage-EditorThe Query Editor

Zum Aufrufen des Abfrage-Editors wählen Sie in Power BI Desktop auf der Registerkarte Start die Option Abfragen bearbeiten aus.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Solange noch keine Datenverbindungen hergestellt wurden, ist der Abfrage-Editor ein leerer Bereich, der auf Daten wartet.With no data connections, Query Editor appears as a blank pane, ready for data.

Sobald eine Abfrage geladen wurde, werden im Abfrage-Editor weitere Informationen angezeigt.Once a query is loaded, Query Editor view becomes more interesting. Wenn Sie eine Verbindung mit der folgenden Webdatenquelle herstellen, lädt der Abfrage-Editor Informationen zu den Daten, mit deren Strukturierung Sie anschließend beginnen können.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Nach dem Herstellen der Datenverbindung präsentiert sich der Abfrage-Editor wie folgt:Here’s how Query Editor appears once a data connection is established:

  1. Im Menüband sind jetzt viele Schaltflächen aktiv, über die Sie die Daten in der Abfrage interaktiv bearbeiten könnenIn the ribbon, many buttons are now active to interact with the data in the query

  2. Im linken Bereich sind die Abfragen aufgelistet und können ausgewählt, angezeigt und strukturiert werdenIn the left pane, queries are listed and available for selection, viewing, and shaping

  3. Der mittlere Bereich zeigt die Daten der ausgewählten Abfrage an und erlaubt deren StrukturierungIn the center pane, data from the selected query is displayed and available for shaping

  4. Das Fenster Abfrageeinstellungen wird angezeigt. Hier sind die Eigenschaften der Abfrage und die angewendeten Schritte aufgelistetThe Query Settings window appears, listing the query’s properties and applied steps

In den folgenden Abschnitten sehen wir uns alle vier Bereiche an: das Menüband, den Abfragebereich, die Datenansicht und den Bereich „Abfrageeinstellungen“.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Das Menüband im Abfrage-EditorThe query ribbon

Das Menüband im Abfrage-Editor enthält vier Registerkarten: Start, Transformieren, Spalte hinzufügen und Ansicht.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

Die Registerkarte Start enthält allgemeine Abfrageaufgaben wie die Option Daten abrufen (das ist der erste Schritt bei jeder Abfrage).The Home tab contains the common query tasks, including the first step in any query, which is Get Data. In der folgenden Abbildung ist das Menüband mit der Registerkarte Start dargestellt.The following image shows the Home ribbon.

Um eine Datenverbindung herzustellen und mit dem Erstellen der Abfrage zu beginnen, klicken Sie auf die Schaltfläche Daten abrufen.To connect to data and begin the query building process, select the Get Data button. Ein Menü mit den am häufigsten verwendeten Datenquellen wird angezeigt.A menu appears, providing the most common data sources.

Weitere Informationen zu verfügbaren Datenquellen finden Sie unter Datenquellen.For more information about available data sources, see Data Sources. Informationen zum Herstellen von Datenverbindungen sowie entsprechende Beispiele und Schritte finden Sie unter Verbinden mit Daten.For information about connecting to data, including examples and steps, see Connect to Data.

Auf der Registerkarte Transformieren haben Sie Zugriff auf allgemeine Aufgaben zum Transformieren der Daten. Sie können z.B. Spalten hinzufügen oder entfernen, Datentypen ändern, Spalten teilen oder andere datenbezogene Aufgaben durchführen.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. In der folgenden Abbildung ist die Registerkarte Transformieren dargestellt.The following image shows the Transform tab.

Weitere Informationen zum Transformieren von Daten sowie Beispiele hierzu finden Sie unter Kombinieren und Strukturieren von Daten.For more information about transforming data, including examples, see Combine and Shape Data.

Die Registerkarte Spalte hinzufügen enthält weitere Aufgaben im Zusammenhang mit dem Hinzufügen einer Spalte, dem Formatieren von Spaltendaten und dem Hinzufügen benutzerdefinierter Spalten.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. In der folgenden Abbildung ist die Registerkarte Spalte hinzufügen dargestellt.The following image shows the Add Column tab.

Die Registerkarte Ansicht im Menüband wird zum Umschalten der Anzeige bestimmter Bereiche oder Fenster verwendet.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Sie dient auch zum Anzeigen des Erweiterten Editors.It’s also used to display the Advanced Editor. In der folgenden Abbildung ist die Registerkarte Ansicht dargestellt.The following image shows the View tab.

Es ist hilfreich zu wissen, dass viele der im Menüband verfügbaren Aufgaben auch über das Kontextmenü (zugänglich nach einem Rechtsklick auf eine Spalte oder andere Daten im mittleren Bereich) aufgerufen werden können.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Linker BereichThe left pane

Im linken Bereich werden die Anzahl der aktiven Abfragen sowie der Name der Abfrage angezeigt.The left pane displays the number of active queries, as well as the name of the query. Wenn Sie im linken Bereich eine Abfrage auswählen, werden die entsprechenden Daten im mittleren Bereich angezeigt. Hier können Sie die Daten entsprechend Ihren Anforderungen strukturieren und transformieren.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Die folgende Abbildung zeigt den linken Bereich mit mehreren Abfragen.The following image shows the left pane with multiple queries.

Mittlerer Bereich (Datenbereich)The center (data) pane

Im mittleren Bereich bzw. Datenbereich werden die Daten der ausgewählten Abfrage angezeigt.In the center pane, or Data pane, data from the selected query is displayed. Hier werden die meisten Aufgaben im Abfrage-Editor ausgeführt.This is where much of the work of the Query view is accomplished.

In der folgenden Abbildung wird die bereits früher erstellte Webdatenverbindung angezeigt. Die Spalte Health care quality ist ausgewählt, und durch Rechtsklick auf die Überschrift werden die im Kontextmenü verfügbaren Elemente angezeigt.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Beachten Sie, dass viele Kontextmenüelemente auch als Schaltflächen auf den Registerkarten im Menüband verfügbar sind.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Bei Auswahl eines Kontextmenüelements (oder einer Schaltfläche im Menüband) wendet die Abfrage den Schritt auf die Daten an und speichert ihn als Teil der Abfrage.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Die Schritte werden wie im nächsten Abschnitt beschrieben im Bereich Abfrageeinstellungen in der entsprechenden Reihenfolge aufgezeichnet.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Bereich „Abfrageeinstellungen“The query settings pane

Im Bereich Abfrageeinstellungen werden alle Schritte angezeigt, die mit einer Abfrage verbunden sind.The Query Settings pane is where all steps associated with a query are displayed. Im folgenden Bild geht aus dem Bereich Abfrageeinstellungen unter Angewendete Schritte beispielsweise hervor, dass wir gerade den Typ der Spalte Health care quality geändert haben.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Beim Anwenden weiterer Strukturierungsschritte auf die Abfrage werden auch diese im Bereich Angewendete Schritte erfasst.As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Es ist wichtig zu wissen, dass die zugrunde liegenden Daten nicht geändert werden. Die Abfrage passt nur die Ansicht und Struktur der Daten an. Jegliche Interaktion mit den Basisdaten erfolgt in der von der Abfrage strukturierten und modifizierten Ansicht dieser Daten.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

Im Bereich Abfrageeinstellungen können Sie Schritte nach Bedarf umbenennen, löschen oder neu anordnen.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Klicken Sie dazu mit der rechten Maustaste in den Bereich Angewendete Schritte, und nehmen Sie im Kontextmenü die gewünschte Auswahl vor.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Alle Abfrageschritte werden in der Reihenfolge ausgeführt, in der sie im Bereich Angewendete Schritte aufgeführt sind.All query steps are carried out in the order they appear in the Applied Steps pane.

Erweiterter EditorThe Advanced Editor

Wenn Sie den Code, den der Abfrage-Editor bei den einzelnen Schritten erzeugt, anzeigen oder eigenen Strukturierungscode erstellen möchten, können Sie das im Fenster Erweiterter Editortun.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Zum Starten des Erweiterten Editors wählen Sie zunächst Ansicht im Menüband und dann Erweiterter Editoraus.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Ein Fenster wird geöffnet, in dem der Code der vorhandenen Abfrage angezeigt wird.A window appears, showing the existing query code.

Im Fenster Erweiterter Editor können Sie den Code direkt bearbeiten.You can directly edit the code in the Advanced Editor window. Zum Schließen des Fensters wählen Sie die Schaltfläche Fertig oder Abbrechen aus.To close the window, select the Done or Cancel button.

Speichern der ArbeitSaving your work

Wenn Ihre Abfrage das gewünschte Aussehen hat, können Sie die Änderungen am Datenmodell in Power BI Desktop anwenden lassen und den Abfrage-Editor dann schließen.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Wählen Sie hierzu im Abfrage-Editor im Menü Datei die Option Schließen und übernehmen aus.To do that, select Close & Apply from Query Editor's File menu.

Nachfolgend zeigt Power BI Desktop in einem Dialogfeld eine Fortschrittsanzeige an.As progress is made, Power BI Desktop provides a dialog to display its status.

Wenn die Bearbeitung Ihrer Abfrage abgeschlossen ist oder Sie einfach nur sicherstellen möchten, dass Ihre Arbeit gespeichert wird, können Sie sie in Power BI Desktop als PBIX-Datei speichern.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Wählen Sie zum Speichern wie in der folgenden Abbildung gezeigt Datei > Speichern (oder Datei > Speichern unter) aus.To save your work, select File > Save (or File > Save As), as shown in the following image.

Nächste SchritteNext steps

Mit Power BI Desktop können Sie viele Aufgaben ausführen.There are all sorts of things you can do with Power BI Desktop. Weitere Informationen zu den Funktionen und Möglichkeiten finden Sie in den folgenden Ressourcen:For more information on its capabilities, check out the following resources: