Verwenden von R im Abfrage-EditorUsing R in Query Editor

Sie können R, eine häufig von Statistikern, Business Analysten und Datenanalysten verwendete Programmiersprache, im Abfrage-Editor von Power BI Desktop verwenden.You can use R, a programming language widely used by statisticians, data scientists, and data analysts, in the Power BI Desktop Query Editor. Dank der Integration von R in den Abfrage-Editor können Sie mithilfe von R Daten bereinigen, erweiterte Datenstrukturierung und Analysen in Datasets ausführen, einschließlich der Ergänzung fehlender Daten, Prognosen und Clustering, um nur einige der Möglichkeiten zu nennen.This integration of R into Query Editor lets you perform data cleansing using R, and perform advanced data shaping and analytics in datasets, including completion of missing data, predictions, and clustering, just to name a few. R ist eine leistungsfähige Sprache, die im Abfrage-Editor zum Erstellen des Datenmodells und Erzeugen von Berichten verwendet werden kann.R is a powerful language, and can be used in Query Editor to prepare your data model and create reports.

Installieren von RInstalling R

Damit Sie R im Abfrage-Editor von Power BI Desktop verwenden können, müssen Sie R auf dem lokalen Computer installieren.To use R in Power BI Desktop's Query Editor, you need to install R on your local machine. R können Sie an vielen Stellen im Internet kostenlos herunterladen und installieren, u.a. von der Revolution R Open-Downloadseite und aus dem CRAN-Repository.You can download and install R for free from many locations, including the Revolution Open download page, and the CRAN Repository.

Verwenden von R im Abfrage-EditorUsing R in Query Editor

Um die Verwendung von R im Abfrage-Editor zu veranschaulichen, verwenden wir ein Aktiendataset. Dieses basiert auf einer CSV-Datei, die Sie hier herunterladen können, um die Vorgehensweise nachzuvollziehen.To show how to use R in Query Editor, we'll use an example from a stock market dataset, based on a .CSV file that you can download from here and follow along. Dieses Beispiel umfasst die folgenden Schritte:The steps for this example are the following:

  1. Laden Sie zunächst die Daten in Power BI Desktop.First, load your data into Power BI Desktop. In diesem Beispiel laden wir die Datei EuStockMarkets_NA.csv.In this example we'll load the EuStockMarkets_NA.csv file. Wählen Sie in Power BI Desktop im Menüband Start die Option Daten abrufen > CSV aus.Select Get Data > CSV from the Home ribbon in Power BI Desktop.

  2. Wählen Sie die Datei aus und dann Öffnen aus. Anschließend wird die CSV-Datei im Dialogfeld CSV-Datei angezeigt.Select the file and select Open, and the CSV is displayed in the CSV file dialog.

  3. Nachdem die Daten geladen wurden, werden sie in Power BI Desktop im Bereich Felder angezeigt.Once the data is loaded, you'll see it in the Fields pane in Power BI Desktop.

  4. Öffnen Sie den Abfrage-Editor, indem Sie in Power BI Desktop auf der Registerkarte Start die Option Abfragen bearbeiten auswählen.Open Query Editor by selecting Edit Queries from the Home tab in Power BI Desktop.

  5. Wählen Sie auf der Registerkarte Transformieren die Option R-Skript ausführen aus. Der Editor R-Skript ausführen wird angezeigt (im nächsten Schritt dargestellt).In the Transform tab, select Run R Script and the Run R Script editor appears (shown in the next step). Beachten Sie, dass in Zeile 15 und 20 Daten fehlen. Dies trifft auch für andere Zeilen zu, die in der folgenden Abbildung nicht dargestellt sind.Notice that rows 15 and 20 suffer from missing data, as do other rows you can't see in the following image. In den folgenden Schritten wird gezeigt, wie R diese Zeilen für Sie ausfüllt.The steps below show how R can (and will) complete those rows for you.

  6. In diesem Beispiel geben wir den folgenden Skriptcode ein:For this example, we'll enter the following script code:

    library(mice)
    tempData <- mice(dataset,m=1,maxit=50,meth='pmm',seed=100)
    completedData <- complete(tempData,1)
    output <- dataset
    output$completedValues <- completedData$"SMI missing values"
    

    Hinweis

    In der R-Umgebung muss das Paket mice installiert sein, damit der oben gezeigte Skriptcode ordnungsgemäß ausgeführt wird.You'll need to have the mice library installed in your R environment for the previous script code to work properly. Führen Sie zum Installieren des Pakets „mice“ in der R-Installation den folgenden Befehl aus: | > install.packages('mice')To install mice, run the following in your R installation: | > install.packages('mice')

    Wenn der Code in das Dialogfeld R-Skript ausführen eingefügt wird, sieht er folgendermaßen aus:When put into the Run R Script dialog, the code looks like the following:

  7. Nach dem Klicken auf OK wird im Abfrage-Editor ein Hinweis zum Datenschutz angezeigt.When we select OK, Query Editor displays a warning about data privacy.

  8. Für die ordnungsgemäße Ausführung von R-Skripts im Power BI-Dienst müssen alle Datenquellen auf Öffentlich festgelegt werden.For the R scripts to work properly in the Power BI service, all data sources need to be set to public. Weitere Informationen zu den Datenschutzeinstellungen und deren Bedeutung finden Sie unter Sicherheitsstufen.For more information about privacy settings and their implications, see Privacy Levels.

    Nachdem wir diese Einstellung vorgenommen haben, wird im Bereich Felder eine neue Spalte mit dem Namen completedValues angezeigt.Once we do so, we see a new column in the Fields well called completedValues. Beachten Sie, dass einige Datenelemente fehlen, z.B. in Zeile 15 und 18.Notice there are a few missing data elements, such as on row 15 and 18. Im nächsten Abschnitt wird beschrieben, wie dies von R behandelt wird.We'll see how R handles that in the next section.

Mit einigen wenigen Zeilen R-Skript konnte der Abfrage-Editor die fehlenden Werte anhand eines Vorhersagemodells einfügen.With just five lines of R script, Query Editor filled in the missing values with a predictive model.

Erstellen von visuellen Elementen aus R-Skript-DatenCreating visuals from R script data

Wir können jetzt ein visuelles Element erstellen, um zu sehen, wie der R-Skript-Code mithilfe des Pakets mice die fehlenden Werte eingefügt hat, wie in der folgenden Abbildung gezeigt.Now we can create a visual to see how the R script code using the mice library completed the missing values, as shown in the following image.

Wenn das visuelle Element und alle weiteren visuellen Elemente, die wir eventuell mit Power BI Desktop erstellen möchten, vollständig erstellt wurden, können wir die Power BI Desktop-Datei (eine PBIX-Datei) speichern und dann das Datenmodell, einschließlich der in ihm enthaltenen R-Skripts, im Power BI-Dienst verwenden.Once that visual is complete, and any other visuals we might want to create using Power BI Desktop, we can save the Power BI Desktop file (which saves as a .pbix file) and then use the data model, including the R scripts that are part of it, in the Power BI service.

Hinweis

Möchten Sie eine fertige PBIX-Datei nach Abschluss dieser Schritte sehen?Want to see a completed .pbix file with these steps completed? Dann können Sie die vollständige Power BI Desktop-Datei, die in diesen Beispielen verwendet wurde, hier herunterladen.You're in luck - you can download the completed Power BI Desktop file used in these examples right here.

Nachdem Sie die PBIX-Datei in den Power BI-Dienst hochgeladen haben, sind einige zusätzliche Schritte erforderlich, um die Datenaktualisierung (im Dienst) und das Aktualisieren der visuellen Elemente im Dienst zu aktivieren (zum Aktualisieren der visuellen Elemente erfordern die Daten Zugriff auf R).Once you've uploaded the .pbix file to the Power BI service, a couple more steps are necessary to enable data refresh (in the service) and to enable visuals to be updated in the service (the data needs access to R for visuals to be updated). Die zusätzlichen Schritte lauten wie folgt:The additional steps are the following:

  • Aktivieren geplanter Aktualisierungen für das Dataset – Informationen zum Aktivieren geplanter Aktualisierungen für die Arbeitsmappe, die das Dataset mit R-Skripts enthält, finden Sie unter Konfigurieren geplanter Aktualisierungen. Dort finden Sie auch Informationen über Personal Gateway.Enable scheduled refresh for the dataset - to enable scheduled refresh for the workbook that contains your dataset with R scripts, see Configuring scheduled refresh, which also includes information about Personal Gateway.
  • Installieren von Personal Gateway – Auf dem Computer, auf dem sich die Datei befindet und auf dem R installiert ist, muss Personal Gateway installiert sein. Der Power BI-Dienst benötigt Zugriff auf die Arbeitsmappe und muss alle aktualisierten visuellen Elemente erneut rendern.Install the Personal Gateway - you need a Personal Gateway installed on the machine where the file is located, and where R is installed; the Power BI service must access that workbook and re-render any updated visuals. Weitere Informationen zum Installieren und Konfigurieren von Personal GatewayYou can get more information on how to install and configure Personal Gateway.

EinschränkungenLimitations

Für Abfragen, die im Abfrage-Editor erstellte R-Skripts enthalten, gelten einige Einschränkungen:There are some limitations to queries that include R scripts created in Query Editor:

  • Alle R-Datenquelleneinstellungen müssen auf Öffentlich festgelegt sein, und alle anderen Schritte einer im Abfrage-Editor erstellten Abfrage müssen ebenfalls öffentlich sein.All R data source settings must be set to Public, and all other steps in a query created in Query Editor must also be public. Um zu den Datenquelleneinstellungen zu gelangen, wählen Sie in Power BI Desktop die Option Datei > Optionen und Einstellungen > Datenquelleneinstellungen aus.To get to data source settings, in Power BI Desktop select File > Options and settings > Data source settings.

    Wählen Sie im Dialogfeld Datenquelleneinstellungen die Datenquelle(n) aus. Wählen Sie dann Berechtigungen bearbeiten aus, und stellen Sie sicher, dass die Datenschutzebene auf Öffentlich festgelegt ist.From the Data Source Settings dialog, select the the data source(s) and then select Edit Permissions... and ensure that the Privacy Level is set to Public.

  • Um geplante Aktualisierungen der visuellen R-Elemente oder des Datasets zu ermöglichen, müssen Sie Geplante Aktualisierung aktivieren, und auf dem Computer, auf dem sich die Arbeitsmappe und die R-Installation befinden, muss Personal Gateway installiert sein.To enable scheduled refresh of your R visuals or dataset, you need to enable Scheduled refresh and have a Personal Gateway installed on the computer that houses the workbook and the R installation. Weitere Informationen zu beiden Features finden Sie im vorherigen Abschnitt dieses Artikels, der Links zu weiteren Informationen über jedes dieser Features enthält.For more information on both, see the previous section in this article, which provides links to learn more about each.

R und benutzerdefinierte Abfragen bieten Ihnen unzählige Möglichkeiten – Sie können Daten analysieren und genau so strukturieren, wie sie dargestellt werden sollen.There are all sorts of things you can do with R and custom queries, so explore and shape your data just the way you want it to appear.