Lernprogramm: Analysieren von Umsatzdaten aus Excel und einem OData-FeedTutorial: Analyzing sales data from Excel and an OData feed

Mit Power BI Desktop können Sie Verbindungen mit allen Arten unterschiedlicher Datenquellen herstellen und diese dann in einer Weise kombinieren und formen, die es ermöglicht, interessante und überzeugende Datenanalysen und Visualisierungen zu erstellen.With Power BI Desktop, you can connect to all sorts of different data sources, then combine and shape them in ways that facilitate making interesting, compelling data analysis and visualizations. In diesem Tutorial erfahren Sie, wie Sie Daten aus zwei Datenquellen kombinieren.In this tutorial, you'll learn how to combine data from two data sources.

Es ist üblich, die Daten auf mehrere Datenquellen zu verteilen, z. B. Produktinformationen in einer Datenbank, während sich die Umsatzinformationen in einer anderen Datenbank befinden.It's common to have data spread across multiple data sources, such as product information in one database, and sales information in another. Die Techniken, die in diesem Dokument vorgestellt werden, beziehen sich auf eine Excel-Arbeitsmappe und einen OData-Feed, können aber auch auf andere Datenquellen wie SQL Server-Abfragen, CSV-Dateien oder eine beliebige Datenquelle in Power BI Desktop angewendet werden.The techniques you'll learn in this document include an Excel workbook and an OData feed, but these techniques can be applied to other data sources too, like SQL Server queries, CSV files, or any data source in Power BI Desktop.

In diesem Tutorial importieren Sie Daten aus Excel (dies sind Produktinformationen) und aus einem OData-Feed (der die Auftragsdaten enthält).In this tutorial, you import data from Excel (it includes product information) and from an OData feed (which contains orders data). Sie werden Transformations- und Aggregationsschritte durchführen und Daten aus beiden Quellen kombinieren, um einen Bericht zum Gesamtumsatz pro Produkt und Jahr zu erstellen, der interaktive Visualisierungen einbezieht.You'll perform transformation and aggregation steps, and combine data from both sources to produce a Total Sales per Product and Year report that includes interactive visualizations.

Der fertige Bericht wird wie folgt aussehen:Here's what the final report will look like:

Damit Sie die Schritte in diesem Tutorial ausführen können, benötigen Sie die Arbeitsmappe „Products“, die Sie herunterladen können: Klicken Sie hier, um die DateiProducts.xlsx herunterzuladen. To follow the steps in this tutorial you need the Products workbook, which you can download: clickhere to downloadProducts.xlsx.

Weisen Sie der Datei im Dialogfeld Speichern unter die Bezeichnung Products.xlsxzu.In the Save As dialog box, name the file Products.xlsx.

Aufgabe 1: Abrufen von Produktdaten aus einer Excel-ArbeitsmappeTask 1: Get product data from an Excel workbook

In dieser Aufgabe importieren Sie Produkte aus der Datei „Products.xlsx“ in Power BI Desktop.In this task, you import products from the Products.xlsx file into Power BI Desktop.

Schritt 1: Herstellen der Verbindung mit einer Excel-ArbeitsmappeStep 1: Connect to an Excel workbook

  1. Starten Sie Power BI Desktop.Launch Power BI Desktop.
  2. Wählen Sie im Menüband „Start“ den Befehl Daten abrufenaus.From the Home ribbon, select Get Data. Excel ist eine der Am häufigsten verwendeten Datenverbindungen, sodass Sie diese direkt im Menü Daten abrufen auswählen können.Excel is one of the Most Common data connections, so you can select it directly from the Get Data menu.

  3. Wenn Sie die Schaltfläche „Daten abrufen“ direkt auswählen, können Sie auch Datei > Excel und dann Verbinden auswählen.If you select the Get Data button directly, you can also select FIle > Excel and select Connect.
  4. Wählen Sie im Dialogfeld Datei öffnen die Datei Products.xlsx aus.In the Open File dialog box, select the Products.xlsx file.
  5. Wählen Sie im Bereich Navigator die Tabelle Produkte aus, und wählen Sie dann Bearbeitenaus.In the Navigator pane, select the Products table and then select Edit.

Schritt 2: Entfernen sonstiger Spalten zur ausschließlichen Anzeige relevanter SpaltenStep 2: Remove other columns to only display columns of interest

In diesem Schritt entfernen Sie alle Spalten außer ProductID, ProductName, UnitsInStockund QuantityPerUnit.In this step you remove all columns except ProductID, ProductName, UnitsInStock, and QuantityPerUnit. In Power BI Desktop gibt es oft mehrere Möglichkeiten zum Ausführen einer Aufgabe.In Power BI Desktop, there are often a few ways to accomplish the same task. Beispielsweise lassen sich viele Schaltflächen im Menüband auch erreichen, indem das Kontextmenü für eine Spalte oder Zelle verwendet wird.For example, many buttons in the ribbon can also be achieved by using the right-click menu on a column or a cell.

Power BI Desktop umfasst den Abfrage-Editor, der die Komponente ist, in der Sie Ihre Datenquellen formen und transformieren.Power BI Desktop includes Query Editor, which is where you shape and transform your data connections. Der Abfrage-Editor wird automatisch geöffnet, wenn Sie Bearbeiten im Navigatorauswählen.Query Editor opens automatically when you select Edit from Navigator. Sie können den Abfrage-Editor auch öffnen, indem Sie in Power BI Desktop im Menüband Start den Befehl Abfragen bearbeiten auswählen.You can also open the Query Editor by selecting Edit Queries from the Home ribbon in Power BI Desktop. Die folgenden Schritte werden im Abfrage-Editor ausgeführt.The following steps are performed in Query Editor.

  1. Wählen Sie im Abfrage-Editor die Spalten ProductID, ProductName, QuantityPerUnitund UnitsInStock aus (verwenden Sie STRG+Klicken , um mehrere Spalten auszuwählen, oder UMSCHALT+Klicken , um Spalten auszuwählen, die nebeneinander liegen).In Query Editor, select the ProductID, ProductName, QuantityPerUnit, and UnitsInStock columns (use Ctrl+Click to select more than one column, or Shift+Click to select columns that are beside each other).
  2. Wählen Sie im Menüband den Befehl Spalten entfernen>Andere Spalten entfernenaus, oder klicken Sie mit der rechten Maustaste auf eine Spaltenüberschrift, und klicken Sie dann auf Andere Spalten entfernen.Select Remove Columns > Remove Other Columns from the ribbon, or right-click on a column header and click Remove Other Columns.

Schritt 3: Ändern des Datentyps der Spalte „UnitsInStock“Step 3: Change the data type of the UnitsInStock column

Wenn der Abfrage-Editor eine Verbindung mit Daten herstellt, prüft er jedes Feld, um den besten Datentyp zu ermitteln.When Query Editor connects to data, it reviews each field and to determine the best data type. Für die Excel-Arbeitsmappe werden die auf Lager befindlichen Produkte immer mit ganzen Zahlen angegeben, weshalb Sie in diesem Schritt bestätigen, dass die Spalte UnitsInStock den Datentyp „Ganze Zahl“ hat.For the Excel workbook, products in stock will always be a whole number, so in this step you confirm the UnitsInStock column’s datatype is Whole Number.

  1. Wählen Sie die Spalte UnitsInStock aus.Select the UnitsInStock column.
  2. Klicken Sie im Menüband Start auf die Dropdown-Schaltfläche Datentyp .Select the Data Type drop-down button in the Home ribbon.
  3. Wenn nicht bereits „Ganze Zahl“ angezeigt wird, wählen Sie in der Dropdownliste „Datentyp“ den Typ Ganze Zahl aus (die Schaltfläche Datentyp: zeigt auch den Datentyp für die aktuelle Auswahl an).If not already a Whole Number, select Whole Number for data type from the drop down (the Data Type: button also displays the data type for the current selection).

Erstellte Schritte in Power BI DesktopPower BI Desktop steps created

Beim Ausführen von Abfrageaktivitäten im Abfrage-Editor werden Abfrageschritte erstellt und im Bereich Abfrageeinstellungen in der Liste Angewendete Schritte aufgelistet.As you perform query activities in Query Editor, query steps are created and listed in the Query Settings pane, in the Applied Steps list. Jeder Abfrageschritt verfügt über eine entsprechende Formel, die auch als Sprache „M“ bezeichnet wird.Each query step has a corresponding formula, also known as the "M" language. Weitere Informationen zur Formelsprache „M“ finden Sie unter Informationen zu Power BI-Formeln.For more information about the “M” formula language, see Learn about Power BI formulas.

AufgabeTask AbfrageschrittQuery step FormelFormula
Herstellen der Verbindung mit einer Excel-ArbeitsmappeConnect to an Excel workbook QuelleSource Quelle{[Item="Products",Kind="Table"]}[Data]Source{[Name="Products"]}[Data]
Heraufstufen der ersten Zeile zu TabellenspaltenüberschriftenPromote the first row to table column headers FirstRowAsHeaderFirstRowAsHeader Table.PromoteHeadersTable.PromoteHeaders
(Produkte)(Products)
Entfernen sonstiger Spalten zur ausschließlichen Anzeige relevanter SpaltenRemove other columns to only display columns of interest RemovedOtherColumnsRemovedOtherColumns Table.SelectColumnsTable.SelectColumns
(FirstRowAsHeader,{"ProductID", "ProductName", "QuantityPerUnit", "UnitsInStock"})(FirstRowAsHeader,{"ProductID", "ProductName", "QuantityPerUnit", "UnitsInStock"})
Geänderter DatentypChange datatype Geänderter TypChanged Type Table.TransformColumnTypes(#"Removed Other Columns",{{"UnitsInStock", Int64.Type}})Table.TransformColumnTypes(#"Removed Other Columns",{{"UnitsInStock", Int64.Type}})

Aufgabe 2: Importieren von Bestelldaten aus einem OData-FeedTask 2: Import order data from an OData feed

In dieser Aufgabe lesen Sie die Bestelldaten ein.In this task, you'll bring in order data. Dieser Schritt stellt das Herstellen der Verbindung mit einem Vertriebssystem dar.This step represents connecting to a sales system. Sie importieren Daten in Power BI Desktop aus dem Northwind-OData-Beispielfeed unter der folgenden URL, die Sie kopieren und in einem der nächsten Schritte einfügen können: http://services.odata.org/V3/Northwind/Northwind.svc/You import data into Power BI Desktop from the sample Northwind OData feed at the following URL, which you can copy (and then paste) in the steps below: http://services.odata.org/V3/Northwind/Northwind.svc/

Schritt 1: Herstellen der Verbindung mit einem OData-FeedStep 1: Connect to an OData feed

  1. Wählen Sie im Abfrage-Editor auf der Registerkarte des Menübands Start den Befehl Daten abrufen aus.From the Home ribbon tab in Query Editor, select Get Data.
  2. Navigieren Sie zu der OData-Feed -Datenquelle.Browse to the OData Feed data source.
  3. Fügen Sie im Dialogfeld OData-Feed die URL für den Northwind-OData-Feed ein.In the OData Feed dialog box, paste the URL for the Northwind OData feed.
  4. Wählen Sie OKaus.Select OK.
  5. Wählen Sie im Bereich Navigator die Tabelle Orders aus, und wählen Sie dann Bearbeitenaus.In the Navigator pane, select the Orders table, and then select Edit.

Hinweis

Zum Anzeigen einer Vorschau können Sie auf einen Tabellennamen klicken, ohne das Kontrollkästchen zu aktivieren.You can click a table name, without selecting the checkbox, to see a preview.

Schritt 2: Erweitern der Tabelle „Order_Details“Step 2: Expand the Order_Details table

Die Tabelle Orders enthält einen Verweis auf eine Tabelle Details mit den einzelnen Produkten, die in den jeweiligen Aufträgen enthalten sind.The Orders table contains a reference to a Details table, which contains the individual products that were included in each Order. Wenn Sie eine Verbindung mit einer Datenquellen herstellen, die mehrere Tabellen hat (z. B. eine relationale Datenbank), können Sie mithilfe dieser Verweise Ihre Abfrage erstellen.When you connect to data sources with multiples tables (such as a relational database) you can use these references to build up your query.

In diesem Schritt erweitern Sie die Tabelle Order_Details, die mit der Tabelle Orders verknüpft ist, um die Spalten ProductID, UnitPrice und Quantity aus der Tabelle Order_Details in der Tabelle Orders zu kombinieren.In this step, you expand the Order_Details table that is related to the Orders table, to combine the ProductID, UnitPrice, and Quantity columns from Order_Details into the Orders table. Dies ist eine Darstellung der Daten in diesen Tabellen:This is a representation of the data in these tables:

Der Vorgang Erweitern kombiniert Spalten aus einer verknüpften Tabelle in einer Subjekttabelle.The Expand operation combines columns from a related table into a subject table. Wenn die Abfrage ausgeführt wird, werden Zeilen aus der verknüpften Tabelle (Order_Details) mit Zeilen aus der Subjekttabelle (Orders) kombiniert.When the query runs, rows from the related table (Order_Details) are combined into rows from the subject table (Orders).

Nachdem Sie die Tabelle Order_Details erweitert haben, werden der Tabelle Orders drei neue Spalten und zusätzliche Zeilen hinzugefügt – eine für jede Zeile in der geschachtelten oder verknüpften Tabelle.After you expand the Order_Details table, three new columns and additional rows are added to the Orders table, one for each row in the nested or related table.

  1. Scrollen Sie in der Abfrageansicht nach unten zur Spalte Order_Details.In the Query View, scroll to the Order_Details column.
  2. Wählen Sie in der Spalte Order_Details das Erweiterungssymbol aus ().In the Order_Details column, select the expand icon ().
  3. In der Dropdownliste Erweitern :In the Expand drop-down:
    1. Wählen Sie (Alle Spalten auswählen) aus, um alle Spalten zu deaktivieren.Select (Select All Columns) to clear all columns.
    2. Wählen Sie ProductID, UnitPriceund Quantityaus.Select ProductID, UnitPrice, and Quantity.
    3. Klicken Sie auf OK.Click OK.

Schritt 3: Entfernen sonstiger Spalten zur ausschließlichen Anzeige relevanter SpaltenStep 3: Remove other columns to only display columns of interest

In diesem Schritt entfernen Sie alle Spalten außer OrderDate, ShipCity, ShipCountry, Order_Details.ProductID, Order_Details.UnitPrice und Order_Details.Quantity.In this step you remove all columns except OrderDate, ShipCity, ShipCountry, Order_Details.ProductID, Order_Details.UnitPrice, and Order_Details.Quantity columns. In der vorherigen Aufgabe haben Sie Andere Spalten entfernenverwendet.In the previous task, you used Remove Other Columns. Für diese Aufgabe entfernen Sie die ausgewählten Spalten.For this task, you remove selected columns.

  1. Wählen Sie in der Abfrageansicht alle Spalten aus, indem Sie die Schritte aIn the Query View, select all columns by completing a. und b ausführen:and b.:
    1. Klicken Sie auf die erste Spalte (OrderID).Click the first column (OrderID).
    2. Klicken Sie bei gedrückter UMSCHALTTASTE auf die letzte Spalte (Shipper).Shift+Click the last column (Shipper).
    3. Klicken Sie nun, nachdem alle Spalten ausgewählt sind, bei gedrückter STRG-TASTE auf die folgenden Spalten, um ihre Auswahl aufzuheben: OrderDate, ShipCity, ShipCountry, Order_Details.ProductID, Order_Details.UnitPrice und Order_Details.Quantity.Now that all columns are selected, use Ctrl+Click to unselect the following columns: OrderDate, ShipCity, ShipCountry, Order_Details.ProductID, Order_Details.UnitPrice, and Order_Details.Quantity.
  2. Nun sind nur die Spalten ausgewählt, die entfernt werden sollen. Klicken Sie mit der rechten Maustaste auf eine der ausgewählten Spaltenüberschrift, und klicken Sie dann auf Spalten entfernen.Now that only the columns we want to remove are selected, right-click on any selected column header and click Remove Columns.

Schritt 4: Berechnen der Zwischensumme für jede Zeile in „Order_Details“Step 4: Calculate the line total for each Order_Details row

Mit Power BI Desktop können Sie Berechnungen erstellen, die auf den von Ihnen importierten Spalten basieren, um die Daten optimal zu nutzen, mit denen Sie eine Verbindung herstellen.Power BI Desktop lets you to create calculations based on the columns you are importing, so you can enrich the data that you connect to. In diesem Schritt erstellen Sie eine Benutzerdefinierte Spalte, um die Zwischensumme für jede Zeile in Order_Details zu berechnen.In this step, you create a Custom Column to calculate the line total for each Order_Details row.

Berechnen der Zwischensumme für jede Zeile in Order_DetailsCalculate the line total for each Order_Details row:

  1. Klicken Sie auf der Menübandregisterkarte Spalte hinzufügen auf Benutzerdefinierte Spalte hinzufügen.In the Add Column ribbon tab, click Add Custom Column.

  2. Geben Sie im Dialogfeld Benutzerdefinierte Spalte hinzufügen im Textfeld Benutzerdefinierte Spaltenformel Folgendes ein: [Order_Details.UnitPrice] * [Order_Details.Quantity].In the Add Custom Column dialog box, in the Custom Column Formula textbox, enter [Order_Details.UnitPrice] * [Order_Details.Quantity].
  3. Geben Sie in das Textfeld Neuer Spaltenname den Namen LineTotalein.In the New column name textbox, enter LineTotal.

  4. Klicken Sie auf OK.Click OK.

Schritt 5: Festlegen des Datentyps des Felds „LineTotal“Step 5: Set the datatype of the LineTotal field

  1. Klicken Sie mit der rechten Maustaste auf die Spalte LineTotal .Right click the LineTotal column.
  2. Wählen Sie Typ ändern und dann Dezimalzahl aus.Select Change Type and choose Decimal Number.

Schritt 6: Umbenennen und erneutes Anordnen von Spalten in der AbfrageStep 6: Rename and reorder columns in the query

In diesem Schritt schließen Sie den Vorgang ab, das Modell für das Erstellen von Berichten einfach zu gestalten, indem Sie die abschließenden Spalten umbenennen und ihre Reihenfolge ändern.In this step you finish making the model easy to work with when creating reports, by renaming the final columns and changing their order.

  1. Ziehen Sie im Abfrage-Editordie Spalte LineTotal nach links hinter die Spalte ShipCountry.In Query Editor, drag the LineTotal column to the left, after ShipCountry.

  2. Entfernen Sie das Präfix Order_Details.Remove the Order_Details. aus den Spalten Order_Details.ProductID, Order_Details.UnitPrice und Order_Details.Quantity, indem Sie auf jede Spaltenüberschrift doppelklicken und diesen Text aus dem Spaltennamen löschen.prefix from the Order_Details.ProductID, Order_Details.UnitPrice and Order_Details.Quantity columns, by double-clicking on each column header, and then deleting that text from the column name.

Erstellte Schritte in Power BI DesktopPower BI Desktop steps created

Beim Ausführen von Abfrageaktivitäten im Abfrage-Editor werden Abfrageschritte erstellt und im Bereich Abfrageeinstellungen in der Liste Angewendete Schritte aufgelistet.As you perform query activities in Query Editor, query steps are created and listed in the Query Settings pane, in the Applied Steps list. Jeder Abfrageschritt verfügt über eine entsprechende Power Query-Formel, die auch als Sprache „M“ bezeichnet wird.Each query step has a corresponding Power Query formula, also known as the "M" language. Weitere Informationen zu dieser Formelsprache finden Sie unter Informationen zu Power BI-Formeln.For more information about this formula language, see Learn about Power BI formulas.

AufgabeTask AbfrageschrittQuery step FormelFormula
Herstellen einer Verbindung mit einem OData-FeedConnect to an OData feed QuelleSource Quelle{[Name="Orders"]}[Data]Source{[Name="Orders"]}[Data]
Erweitern der Tabelle „Order_Details“Expand the Order_Details table Erweitern von „Order_Details“Expand Order_Details Table.ExpandTableColumnTable.ExpandTableColumn
(Orders, "Order_Details", {"ProductID", "UnitPrice", "Quantity"}, {"Order_Details.ProductID", "Order_Details.UnitPrice", "Order_Details.Quantity"})(Orders, "Order_Details", {"ProductID", "UnitPrice", "Quantity"}, {"Order_Details.ProductID", "Order_Details.UnitPrice", "Order_Details.Quantity"})
Entfernen sonstiger Spalten zur ausschließlichen Anzeige relevanter SpaltenRemove other columns to only display columns of interest RemovedColumnsRemovedColumns Table.RemoveColumnsTable.RemoveColumns
(#"Expand Order_Details",{"OrderID", "CustomerID", "EmployeeID", "RequiredDate", "ShippedDate", "ShipVia", "Freight", "ShipName", "ShipAddress", "ShipCity", "ShipRegion", "ShipPostalCode", "ShipCountry", "Customer", "Employee", "Shipper"})(#"Expand Order_Details",{"OrderID", "CustomerID", "EmployeeID", "RequiredDate", "ShippedDate", "ShipVia", "Freight", "ShipName", "ShipAddress", "ShipCity", "ShipRegion", "ShipPostalCode", "ShipCountry", "Customer", "Employee", "Shipper"})
Berechnen der Zwischensumme für jede Zeile in „Order_Details“Calculate the line total for each Order_Details row InsertedColumnInsertedColumn Table.AddColumnTable.AddColumn
(RemovedColumns, "Custom", each [Order_Details.UnitPrice] * [Order_Details.Quantity])(RemovedColumns, "Custom", each [Order_Details.UnitPrice] * [Order_Details.Quantity])

Aufgabe 3: Kombinieren der Abfragen für Produkte und GesamtumsätzeTask 3: Combine the Products and Total Sales queries

Sie müssen in Power BI Desktop keine Abfragen kombinieren, um für diese einen Bericht zu erstellen.Power BI Desktop does not require you to combine queries to report on them. Sie können stattdessen Beziehungen zwischen Datasets erstellen.Instead, you can create Relationships between datasets. Diese Beziehungen können für eine beliebige Spalte erstellt werden, die Ihren Datasets gemeinsam ist.These relationships can be created on any column that is common to your datasets. Weitere Informationen finden Sie unter Erstellen und Verwalten von Beziehungen.For more information see Create and manage relationships.

In diesem Tutorial gibt es Auftrags- (Orders) und Produktdaten (Products), die das gemeinsame Feld „ProductID“ haben. Daher muss sichergestellt werden, dass es eine Beziehung zwischen diesen Daten in dem Modell gibt, das mit Power BI Desktop verwendet wird.In this tutorial, we have Orders and Products data that share a common 'ProductID' field, so we need to ensure there's a relationship between them in the model we're using with Power BI Desktop. Geben Sie in Power BI Desktop einfach an, dass die Spalten aus jeder Tabelle verknüpft sind (d. h. Spalten, die dieselben Werte haben).Simply specify in Power BI Desktop that the columns from each table are related (i.e. columns that have the same values). Power BI Desktop ermittelt die Richtung und Kardinalität der Beziehung für Sie.Power BI Desktop works out the direction and cardinality of the relationship for you. In einigen Fällen werden die Beziehungen sogar automatisch erkannt.In some cases, it will even detect the relationships automatically.

In dieser Aufgabe bestätigen Sie, dass in Power BI Desktop eine Beziehung zwischen den Abfragen Products und Total Sales eingerichtet ist.In this task, you confirm that a relationship is established in Power BI Desktop between the Products and Total Sales queries.

Schritt 1: Bestätigen der Beziehung zwischen „Products“ und „Total Sales“Step 1: Confirm the relationship between Products and Total Sales

  1. Zunächst muss das Modell geladen werden, das im Abfrage-Editor in Power BI Desktop erstellt wurde.First, we need to load the model that we created in Query Editor into Power BI Desktop. Wählen Sie im Abfrage-Editor auf der Registerkarte des Menübands Start den Befehl Schließen & laden aus.From the Home ribbon of Query Editor, select Close & Load.

  2. Power BI Desktop lädt die Daten aus den beiden Abfragen.Power BI Desktop loads the data from the two queries.

  3. Nachdem die Daten geladen sind, wählen Sie auf der Menübandregisterkarte Start den Befehl Beziehungen verwalten aus.Once the data is loaded, select the Manage Relationships button Home ribbon.

  4. Wählen Sie die Schaltfläche Neu...Select the New… aus.button

  5. Wenn Sie versuchen, die Beziehung zu erstellen, sehen Sie, dass bereits eine Beziehung vorhanden ist.When we attempt to create the relationship, we see that one already exists! Wie im Dialogfeld Beziehung erstellen dargestellt (durch die schattierten Spalten), gibt es bereits eine Beziehung zwischen den ProductsID -Feldern in den beiden Abfragen.As shown in the Create Relationship dialog (by the shaded columns), the ProductsID fields in each query already have an established relationship.

  6. Wählen Sie Abbrechenaus, und wählen Sie dann die Ansicht Beziehung in Power BI Desktop aus.Select Cancel, and then select Relationship view in Power BI Desktop.

  7. Sie sehen die folgende Darstellung, die die Beziehung zwischen den Abfragen visualisiert.We see the following, which visualizes the relationship between the queries.

  8. Wenn Sie auf den Pfeil auf der Verbindungslinie der Abfragen doppelklicken, wird das Dialogfeld Beziehung bearbeiten angezeigt.When you double-click the arrow on the line that connects the to queries, an Edit Relationship dialog appears.

  9. Es ist nicht erforderlich, irgendeine Änderung vorzunehmen, also wählen Sie einfach Abbrechen aus, um das Dialogfeld Beziehung bearbeiten zu schließen.No need to make any changes, so we'll just select Cancel to close the Edit Relationship dialog.

Aufgabe 4: Erstellen von Visualisierungen mithilfe Ihrer DatenTask 4: Build visuals using your data

Mithilfe von Power BI Desktop können Sie eine Vielzahl von Visualisierungen erstellen, um Erkenntnisse aus Ihren Daten zu gewinnen.Power BI Desktop lets you create a variety of visualizations to gain insights from your data. Sie können Berichte mit mehreren Seiten erstellen und jede Seite kann mehrere visuelle Elemente enthalten.You can build reports with multiple pages and each page can have multiple visuals. Sie können mit den Visualisierungen interagieren, um dabei zu helfen, die Daten einfacher zu analysieren und zu verstehen.You can interact with your visualizations to help analyze and understand your data. Weitere Informationen zum Bearbeiten von Berichten finden Sie unter Bearbeiten eines Berichts.For more information about editing reports, see Edit a Report.

In dieser Aufgabe erstellen Sie einen Bericht auf Basis der zuvor geladenen Daten.In this task, you create a report based on the data previously loaded. Sie können die Spalten, über die Sie die Visualisierungen erstellen, im Bereich „Felder“ auswählen.You use the Fields pane to select the columns from which you create the visualizations.

Schritt 1: Erstellen von Diagrammen, die Einheiten im Bestand nach Produkt und Gesamtumsätzen pro Jahr anzeigenStep 1: Create charts showing Units in Stock by Product and Total Sales by Year

Ziehen Sie UnitsInStock aus dem Bereich „Felder“ (dieser Bereich befindet sich am rechten Rand des Bildschirms) auf eine leere Stelle des Zeichenbereichs.Drag UnitsInStock from the Field pane (the Fields pane is along the right of the screen) onto a blank space on the canvas. Es wird eine Tabellenvisualisierung erstellt.A Table visualization is created. Ziehen Sie nun „ProductName“ in das Feld „Achse“. Dieses befindet sich in der unteren Hälfte des Bereichs „Visualisierungen“.Next, drag ProductName to the Axis box, found in the bottom half of the Visualizations pane. Wählen Sie dann über das Symbol mit den Auslassungspunkten, das sich in der rechten oberen Ecke der Visualisierung befindet, Sortieren nach > UnitsInStock aus.Then we then select Sort By > UnitsInStock using the skittles in the top right corer of the visualization.

Ziehen Sie OrderDate auf den Zeichenbereich unter das erste Diagramm, ziehen Sie dann „LineTotal“ (ebenfalls aus dem Bereich „Felder“) auf das visuelle Objekt, und wählen Sie dann „Liniendiagramm“ aus.Drag OrderDate to the canvas beneath the first chart, then drag LineTotal (again, from the Fields pane) onto the visual, then select Line Chart. Die folgende Visualisierung wird erstellt.The following visualization is created.

Ziehen Sie nun ShipCountry in einen Abschnitt oben rechts im Zeichenbereich.Next, drag ShipCountry to a space on the canvas in the top right. Da Sie ein geografisches Feld ausgewählt haben, wurde automatisch eine Karte erstellt.Because you selected a geographic field, a map was created automatically. Ziehen Sie nun LineTotal in das Feld Werte. Die Kreise auf der Karte für jedes Land haben jetzt eine relative Größe in Bezug auf LineTotal für Aufträge, die an das jeweilige Land geliefert wurden.Now drag LineTotal to the Values field; the circles on the map for each country are now relative in size to the LineTotal for orders shipped to that country.

Schritt 2: Interagieren mit Berichtsvisualisierungen zur weiteren AnalyseStep 2: Interact with your report visuals to analyze further

Mithilfe von Power BI Desktop können Sie mit visuellen Elementen interagieren, die sich gegenseitig hervorheben und filtern, um weitere Trends zu erkennen.Power BI Desktop lets you interact with visuals that cross-highlight and filter each other to uncover further trends. Weitere Informationen finden Sie unter Filtern und Hervorheben in BerichtenFor more detail see Filtering and Highlighting in Reports

  1. Klicken Sie auf den hellblauen Kreis, der zentriert in Canada. angezeigt wirdClick on the light blue circle centered in Canada. Beachten Sie, wie die anderen visuellen Elemente gefiltert werden, um den Bestand (ShipCountry) und die gesamten Aufträge (LineTotal) ausschließlich für Kanada anzuzeigen.Note how the other visuals are filtered to show Stock (ShipCountry) and Total Orders (LineTotal) just for Canada.

Abschließen des UmsatzanalyseberichtsComplete Sales Analysis Report

Nachdem Sie alle Schritte ausgeführt haben, verfügen Sie über einen Umsatzbericht, der die Daten aus der Datei „Products.xlsx“ und dem Northwind-OData-Feed kombiniert.After you perform all these steps, you will have a Sales Report that combines data from Products.xlsx file and Northwind OData feed. Der Bericht zeigt Visualisierungen, die bei der Analyse der Umsatzdaten aus verschiedenen Ländern helfen.The report shows visuals that help analyze sales information from different countries. Sie können hier eine vollständige Power BI Desktop-Datei für dieses Tutorial herunterladen.You can download a completed Power BI Desktop file for this tutorial here.

Nächste SchritteNext steps