Direktes Eingeben von Daten in paginierte Berichte im Berichts-Generator: Power BIEnter data directly in a paginated report in Report Builder - Power BI

GILT FÜR:APPLIES TO: ✔️ Power BI-Dienst✔️ Power BI service ✔️ Paginierte Power BI-Berichte✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI DesktopGILT FÜR:APPLIES TO: ✔️ Power BI-Dienst✔️ Power BI service ✔️ Paginierte Power BI-Berichte✔️ Power BI paginated reports ✔️ Power BI Premium✔️ Power BI Premium ❌ Power BI Desktop❌ Power BI Desktop

In diesem Artikel erhalten Sie Informationen zu einem Feature in der neuen Version von Microsoft Power BI Report Builder, das es Ihnen ermöglicht, Daten direkt als eingebettetes Dataset in einen RDL-Bericht einzugeben.In this article, you learn about a feature in the new version of Microsoft Power BI Report Builder that lets you enter data directly into an RDL report as an embedded dataset. Dieses Feature ist Power BI Desktop ähnlich.This feature is similar to Power BI Desktop. Sie können die Daten direkt in das Dataset in Ihrem Bericht eingeben oder sie aus einem anderen Programm wie Microsoft Excel einfügen.You can type the data directly in a dataset in your report, or paste it from another program like Microsoft Excel. Wenn Sie durch die Eingabe von Daten ein Dataset erstellen, können Sie dieses genauso wie jedes andere von Ihnen erstellte eingebettete Dataset verwenden.After you've created a dataset by entering data, you can use it just like you would any other embedded dataset you've created. Außerdem können Sie mehre Tabellen hinzufügen und diese als Filter verwenden.Plus you can add more than one table and use one as a filter for the other. Dieses Feature eignet sich besonders für kleine, statische Datasets, die Sie möglicherweise in Ihrem Bericht verwenden müssen (z. B. Berichtsparameter).This feature is especially useful for small, static datasets you might need to use in your report, like report parameters.

VoraussetzungenPrerequisites

Erstellen einer Datenquelle und eines DatasetsCreate a data source and dataset

Wenn Sie den Berichts-Generator heruntergeladen und installiert haben, ändert sich der Workflow zum Hinzufügen einer eingebetteten Datenquelle und eines eingebetteten Datensets in Ihren Bericht nicht.After you’ve downloaded and installed Report Builder, you follow the same workflow you use to add an embedded data source and dataset to your report. In der folgenden Prozedur wird unter Datenquellen eine neue Option angezeigt: Daten eingeben.In the following procedure, under Data Sources you see a new option: Enter Data. Die müssen diese Datenquelle einmal pro Bericht einrichten.You only need to set up this data source once in a report. Anschließend können Sie mehrere Tabellen mit eingegebenen Daten als separate Datasets erstellen, die alle dieselbe Datenquelle verwenden.After that, you can create multiple tables of entered data as separate datasets, all using that single data source.

  1. Klicken Sie im Bereich Berichtsdaten auf Neu > Dataset.In the Report Data pane, select New > Dataset.

    Screenshot: Neues Dataset in Report Builder

  2. Klicken Sie im Dialogfeld Dataseteigenschaften auf Ein in den eigenen Bericht eingebettetes Dataset verwenden.In the Dataset Properties dialog box, select Use a dataset embedded in my report.

  3. Klicken Sie neben Datenquelle auf Neu.Next to Data source , select New.

    Screenshot: Neue eingebettete Datenquelle

  4. Klicken Sie im Dialogfeld Datenquelleneigenschaften auf Use a connection embedded in my report (In meinem Bericht eingebettete Verbindung verwenden).In the Data Source Properties dialog box, select Use a connection embedded in my report.

  5. Klicken Sie unter Verbindungstyp auswählen auf DATEN EINGEBEN > OK.In the Select connection type box, select ENTER DATA > OK.

    Screenshot: Datenquelle „DATEN EINGEBEN“

  6. Klicken Sie dann wieder im Dialogfeld Dataseteigenschaften auf Abfrage-Designer.Back in the Dataset Properties dialog box, select Query Designer.

  7. Klicken Sie mit der rechten Maustaste in den Bereich Abfrage-Designer , und geben Sie Ihre Daten in die Tabelle ein.In the Query Designer pane, right-click and paste your data in the table.

    Screenshot: Eingeben von Daten im Abfrage-Designer

  8. Führen Sie für NewColumn einen Doppelklick aus, und geben Sie den Spaltennamen ein.To set the column names, double-click each NewColumn and type the column name.

    Screenshot: Festlegen der Spaltennamen

  9. Wenn die erste Spalte Spaltenüberschriften der ursprünglichen Daten enthält, klicken Sie mit der rechten Maustaste darauf, und löschen Sie sie.If the first row contains column headings from the original data, right-click and delete it.

  10. Standardmäßig ist der Datentyp für jede Spalte eine Zeichenfolge.By default, the data type for each column is String. Wenn Sie den Datentyp ändern möchten, klicken Sie erst mit der rechten Maustaste auf den Spaltenheader und anschließend mit der linken auf Typ ändern , um einen anderen Datentyp wie „Date“ oder „Float“ festzulegen.To change the data type, right-click the column header > Change Type , and set it to another data type, such as Date or Float.

    Screenshot: Ändern des Datentyps

  11. Wenn Sie fertig sind und die Tabelle erstellt haben, klicken Sie auf OK.When you’ve finished creating the table, select OK.

    Die Abfrage, die dann generiert wird, unterscheidet sich nicht von der Abfrage bei einer XML-Datenquelle.The query that’s generated is the same as you’d see with an XML data source. Im Hintergrund verwenden wir XML als den Datenanbieter.Under the covers, we’re using XML as the data provider. Wir haben diesen so umfunktioniert, dass hierbei auch dieses Szenario aktiviert wird.We’ve repurposed it to enable this scenario as well.

    Screenshot: XML-Datenstruktur

  12. Klicken Sie im Dialogfeld Dataseteigenschaften auf OK.In the Dataset Properties dialog box, select OK.

  13. Dann werden Ihre Datenquelle und Ihr Dataset im Berichtsdatenbereich angezeigt.You see your data source and dataset in the Report Data pane.

    Screenshot: Dataset im Berichtsdatenbereich

Sie können Ihr Dataset als Basis für Datenvisualisierungen in Ihrem Bericht verwenden.You can use your dataset as the basis for data visualizations in your report. Außerdem können Sie ein anderes Dataset hinzufügen und dafür dieselbe Datenquelle verwenden.You can also add another dataset and use the same data source for it.

Entwerfen des BerichtsDesign the report

Da Sie nun über eine Datenquelle und ein Dataset verfügen, können Sie Ihren Bericht erstellen.Now that you have a data source and dataset, you're ready to create your report. Beim folgenden Verfahren wird ein einfacher Bericht auf Grundlage der Daten aus dem vorherigen Abschnitt erstellt.The following procedure creates a simple report based on the data in the previous section.

  1. Klicken Sie auf im Menü Einfügen auf Tabelle > Tabellen-Assistent.On the Insert menu, select Table > Table Wizard.

    Screenshot: Klicken auf „Tabellen-Assistent“

  2. Klicken Sie auf das gerade erstellte Dataset und dann auf Weiter.Select the dataset you just created > Next.

    Screenshot: Dialogfeld zum Auswählen eines Datasets

  3. Ziehen Sie auf der Seite „Felder anordnen“ die Felder, die Sie gruppieren möchten, aus dem Feld Verfügbare Felder in das Feld Zeilengruppen.In the Arrange fields page, drag fields you want to group by from the Available fields box to the Row groups box. In diesem Beispiel:In this example:

    • CountryRegionCountryRegion
    • SalesYearSalesYear
  4. Ziehen Sie die Felder, die Sie aggregieren möchten, aus dem Feld Verfügbare Felder in das Feld Werte.Drag the fields you want to aggregate from the Available fields box to the Values box. In diesem Beispiel:In this example:

    • SalesAmountSalesAmount

    Report Builder summiert standardmäßig die Felder im Feld Werte. Sie können jedoch auch eine andere Aggregation auswählen.By default, Report Builder sums the fields in the Values box, but you can choose another aggregation.

    Screenshot: verschiedene Aggregationen, aus denen ausgewählt werden kann

  5. Wählen Sie Weiter aus.Select Next.

  6. Übernehmen Sie auf der Seite Layout auswählen die Standardeinstellungen, aber deaktivieren Sie Gruppen erweitern/reduzieren.In the Choose the layout page, keep all the default settings, but clear Expand/collapse groups. Im Allgemeinen ist das Erweitern und Reduzieren von Gruppen hilfreich. In diesem Fall möchten wir jedoch alle Daten anzeigen.In general, expanding and collapsing groups is great, but this time we want to see all the data.

  7. Wählen Sie Weiter > Fertig stellen aus.Select Next > Finish. Die Tabelle wird auf der Entwurfsoberfläche angezeigt.The table is displayed on the design surface.

    Screenshot des Berichts in der Entwurfsansicht

Ausführen des BerichtsRun the report

Führen Sie den Bericht aus, um die tatsächlichen Werte und eine Vorschau anzuzeigen.To see the actual values and preview the report, you run it.

  1. Klicken Sie auf dem Menüband Startseite auf Ausführen.Select Run in the Home ribbon.

    Screenshot: Klicken auf „Ausführen“ auf dem Menüband „Startseite“

    Nun werden die Werte angezeigt.Now you see the values. Die Matrix enthält mehr Zeilen, als in der Entwurfsansicht angezeigt wurden.The matrix has more rows than you saw in Design view! Sie können entweder die Seite formatieren oder die Standardeinstellungen verwenden, bevor Sie auf Ihrem lokalen Computer speichern oder im Dienst veröffentlichen.You can either format the page or decide to use the default settings before saving to your local computer or publishing to the service.

  2. Klicken Sie auf Seitenlayout , um zu sehen, wie der gedruckte Bericht aussehen wird.To see how your report will look when you print it, select Print Layout.

    Screenshot: Klicken auf „Seitenlayout“

    Der Bericht wird nun so angezeigt, wie er auf einer gedruckten Seite aussehen wird.Now you see it as it will look on a printed page.

    Screenshot des Berichts in der Ansicht „Seitenlayout“

Hochladen eines paginierten Berichts im Power BI-DienstUpload the paginated report to the Power BI service

Da jetzt paginierte Berichte im Power BI-Dienst unterstützt werden, können Sie Ihren paginierten Bericht für eine Premium-Kapazität hochladen.Now that paginated reports are supported in the Power BI service, you can upload your paginated report to a Premium capacity. Weitere Informationen finden Sie unter Hochladen eines paginierten Berichts.See Upload a paginated report for details.

Hochladen des paginierten Berichts in einen BerichtsserverUpload the paginated report to a report server

Sie können paginierte Berichte auch im Power BI-Berichtsserver oder dem Berichtsserver für SQL Server Reporting Services 2016 und 2017 hochladen.You can also upload your paginated report to a Power BI Report Server or SQL Server Reporting Services 2016 or 2017 report server. Vorher müssen Sie allerdings das folgende Element als zusätzliche Datenerweiterung zu Ihrer RsReportServer.config-Datei hinzufügen.Before you do, you need to add the following item to your RsReportServer.config as an additional data extension. Sichern Sie Ihre RsReportServer.config-Datei, bevor Sie Änderungen vornehmen, falls Probleme auftreten sollten.Back up your RsReportServer.config file before you make the change, in case you run into any issues.

<Extension Name="ENTERDATA" Type="Microsoft.ReportingServices.DataExtensions.XmlDPConnection,Microsoft.ReportingServices.DataExtensions">
    <Configuration>
        <ConfigName>ENTERDATA</ConfigName>
    </Configuration>
</Extension>

Nach der Bearbeitung sollte die Liste mit Datenanbietern in der Konfigurationsdatei wie folgt aussehen:After you've edited it, here's what the list of data providers in the config file should look like:

Screenshot der Konfigurationsdatei „RsReportServer“

Jetzt können Sie Berichte für Ihren Berichtsserver veröffentlichen, die diese neue Funktion verwenden.That’s it – you can now publish reports that use this new functionality to your report server.

Nächste SchritteNext steps