Abfrageübersicht in Power BI DesktopQuery overview in Power BI Desktop

Mit Power BI Desktop stellen Sie eine Verbindung zur Welt der Daten her, erstellen überzeugende und fundierte Berichte und teilen Ihre Ergebnisse mit anderen Personen, die dann auf Ihrer Arbeit aufbauen und so ihr Business Intelligence-Potenzial erweitern können.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop verfügt über drei Ansichten:Power BI Desktop has three views:

  • Berichtsansicht. Hier entwerfen Sie mithilfe selbst erstellter Abfragen ansprechende Visualisierungen, ordnen diese wie gewünscht und bei Bedarf auf mehreren Seiten an und geben Sie für andere Benutzer freiReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Datenansicht. Hier können Sie die Daten Ihres Berichts im Datenmodellformat anzeigen und Measures hinzufügen, neue Spalten erstellen und Beziehungen verwaltenData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Beziehungsansicht. Hier können Sie eine grafische Darstellung der Beziehungen abrufen, die in Ihrem Datenmodell eingerichtet wurden, und diese je nach Bedarf verwalten oder ändern.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Sie können auf diese Ansichten zugreifen, indem Sie auf eins der drei Symbole auf der linken Seite von Power BI Desktop klicken.Access these views by selecting one of the three icons along the left side of Power BI Desktop. In der folgenden Abbildung ist die Berichtsansicht ausgewählt. Dies wird durch den gelben Streifen neben dem Symbol signalisiert.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Screenshot von Power BI Desktop mit der ausgewählten Berichtsansicht

Im Lieferumfang von Power BI Desktop ist auch der Power Query-Editor enthalten.Power BI Desktop also comes with Power Query Editor. Diesen können Sie verwenden, um eine Verbindung mit Datenquellen herzustellen, um die Daten gemäß Ihren Anforderungen zu strukturieren und zu transformieren und um das Modell anschließend in Power BI Desktop zu laden.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Dieses Dokument bietet nur eine Übersicht über die Arbeit mit Daten im Power Query-Editor, aber es gibt noch viele weitere Artikel zu diesem Thema.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. Am Ende dieses Dokuments finden Sie Links zu detaillierten Anleitungen zu unterstützten Datentypen.At the end of this document, you'll find links to detailed guidance about supported data types. Außerdem finden Sie Anleitungen zum Herstellen einer Verbindung mit Daten, zum Strukturieren von Daten, zum Erstellen von Beziehungen und zu den ersten Schritten.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Zuerst wollen wir uns aber mit dem Power Query-Editor vertraut machen.But first, let's see get acquainted with Power Query Editor.

Power Query-EditorPower Query Editor

Sie können den Power Query-Editor aufrufen, indem Sie auf der Registerkarte Start auf die Option Abfragen bearbeiten klicken.To get to Power Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Screenshot von Power BI Desktop mit der Registerkarte „Home“ des Power Query-Editors

Solange noch keine Datenverbindungen hergestellt wurden, wird für den Power Query-Editor ein leerer Bereich angezeigt, zu dem Daten hinzugefügt werden können.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Screenshot von Power BI Desktop mit dem Power Query-Editor ohne Datenverbindungen

Sobald eine Abfrage geladen wurde, werden im Power Query-Editor weitere Informationen angezeigt.Once a query is loaded, Power Query Editor view becomes more interesting. Wenn Sie eine Verbindung mit der folgenden Webdatenquelle herstellen, lädt der Power Query-Editor Informationen zu den Daten, mit deren Strukturierung Sie anschließend beginnen können:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Nach dem Herstellen einer Datenverbindung sieht der Power Query-Editor wie folgt aus:Here's how Power Query Editor appears once a data connection is established:

  1. Im Menüband sind jetzt viele Schaltflächen aktiv, über die Sie die Daten in der Abfrage interaktiv bearbeiten können.In the ribbon, many buttons are now active to interact with the data in the query.

  2. Im linken Bereich sind die Abfragen aufgelistet und können ausgewählt, angezeigt und strukturiert werden.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. Im mittleren Bereich werden die Daten der ausgewählten Abfrage angezeigt und können dort strukturiert werden.In the center pane, data from the selected query is displayed and available for shaping.

  4. Der Bereich Abfrageeinstellungen wird angezeigt. Hier sind die Eigenschaften der Abfrage und die angewendeten Schritte aufgelistet.The Query Settings pane appears, listing the query's properties and applied steps.

    Screenshot von Power BI Desktop mit dem Bereich „Abfrageeinstellungen“ im Power Query-Editor

In den folgenden Abschnitten erhalten Sie Informationen zu allen vier Bereichen: dem Menüband, dem Abfragebereich, der Datenansicht und dem Bereich „Abfrageeinstellungen“.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Das Menüband im Abfrage-EditorThe query ribbon

Das Menüband im Power Query-Editor besteht aus vier Registerkarten: Start, Modellierung, Spalte und Ansicht.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

Die Registerkarte Start enthält die allgemeinen Abfrageaufgaben.The Home tab contains the common query tasks.

Screenshot von Power BI Desktop mit dem Abfragemenüband im Power Query-Editor

Wenn Sie eine Datenverbindung herstellen und mit der Abfrageerstellung beginnen möchten, klicken Sie auf Neue Quelle.To connect to data and begin the query building process, select New Source. Ein Menü mit den am häufigsten verwendeten Datenquellen wird angezeigt.A menu appears, providing the most common data sources.

Screenshot von Power BI Desktop mit der Schaltfläche „Neue Quelle“

Weitere Informationen zu verfügbaren Datenquellen finden Sie unter Datenquellen.For more information about available data sources, see Data Sources. Informationen zum Herstellen von Datenverbindungen sowie entsprechende Beispiele und Schritte finden Sie unter Verbinden mit Daten.For information about connecting to data, including examples and steps, see Connect to Data.

Über die Registerkarte Modellierung erhalten Sie Zugriff auf häufig verwendete Tasks zur Datentransformierung. Beispiele:The Transform tab provides access to common data transformation tasks, such as:

  • Das Hinzufügen oder Entfernen von SpaltenAdding or removing columns
  • Das Ändern von DatentypenChanging data types
  • Das Teilen von SpaltenSplitting columns
  • Andere datengesteuerte TasksOther data-driven tasks

Screenshot von Power BI Desktop mit der Registerkarte „Home“

Weitere Informationen zum Transformieren von Daten sowie Beispiele hierzu finden Sie unter Tutorial: Strukturieren und Kombinieren von Daten in Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

Die Registerkarte Spalte hinzufügen enthält weitere Aufgaben im Zusammenhang mit dem Hinzufügen einer Spalte, dem Formatieren von Spaltendaten und dem Hinzufügen benutzerdefinierter Spalten.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. In der folgenden Abbildung ist die Registerkarte Spalte hinzufügen dargestellt.The following image shows the Add Column tab.

Screenshot von Power BI Desktop mit der Registerkarte „Spalte hinzufügen“

Die Registerkarte Ansicht im Menüband wird zum Umschalten der Anzeige bestimmter Bereiche oder Fenster verwendet.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Sie dient auch zum Anzeigen der Seite „Erweiterter Editor“.It's also used to display the Advanced Editor. In der folgenden Abbildung ist die Registerkarte Ansicht dargestellt.The following image shows the View tab.

Screenshot von Power BI Desktop mit der Registerkarte „Ansicht“

Es ist hilfreich zu wissen, dass viele der im Menüband verfügbaren Aufgaben auch über einen Rechtsklick auf eine Spalte oder andere Daten im mittleren Bereich aufgerufen werden können.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Linker Bereich (Abfragen)The left (Queries) pane

Im linken Bereich bzw. im Abfragebereich werden die Anzahl der aktiven Abfragen sowie der Name der Abfrage angezeigt.The left pane, or Queries pane, displays the number of active queries and the name of the query. Wenn Sie im linken Bereich eine Abfrage auswählen, werden die entsprechenden Daten im mittleren Bereich angezeigt. Hier können Sie die Daten entsprechend Ihren Anforderungen strukturieren und transformieren.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Die folgende Abbildung zeigt den linken Bereich mit einer Abfrage.The following image shows the left pane with a query.

Screenshot von Power BI Desktop mit Abfragen im linken Bereich

Mittlerer Bereich (Datenbereich)The center (Data) pane

Im mittleren Bereich bzw. im Datenbereich werden die Daten der ausgewählten Abfrage angezeigt.In the center pane, or Data pane, data from the selected query is displayed. Hier werden die meisten Aufgaben der Abfrageansicht ausgeführt.This pane is where much of the work of the Query view is accomplished.

Die folgende Abbildung zeigt die zuvor eingerichtete Webdatenverbindung.In the following image shows the Web data connection established earlier. Die Spalte Product (Produkt) ist ausgewählt, und es wurde das Kontextmenü der Kopfzeile der Spalte geöffnet, um die verfügbaren Menüelemente anzuzeigen.The Product column is selected, and its header is right-clicked to show the available menu items. Beachten Sie, dass viele Kontextmenüelemente auch als Schaltflächen auf den Registerkarten im Menüband verfügbar sind.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Screenshot von Power BI Desktop mit Daten im mittleren Bereich

Wenn Sie auf ein Kontextmenüelement oder auf eine Schaltfläche auf dem Menüband klicken, wendet die Abfrage den Schritt auf die Daten an.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Außerdem speichert sie den Schritt als Teil der Abfrage.It also saves step as part of the query itself. Die Schritte werden wie im nächsten Abschnitt beschrieben im Bereich Abfrageeinstellungen in der entsprechenden Reihenfolge aufgezeichnet.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Der rechte Bereich (Abfrageeinstellungen)The right (Query Settings) pane

Im rechten Bereich bzw. im Bereich Abfrageeinstellungen werden alle Schritte angezeigt, die einer Abfrage zugeordnet sind.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Im folgenden Bild geht aus dem Bereich Abfrageeinstellungen unter Angewendete Schritte beispielsweise hervor, dass wir gerade den Typ der Spalte Health care quality geändert haben.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Screenshot von Power BI Desktop mit Abfrageeinstellungen im rechten Bereich

Beim Anwenden weiterer Strukturierungsschritte auf die Abfrage werden auch diese im Bereich Angewendete Schritte erfasst.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Sie sollten wissen, dass die zugrunde liegenden Daten nicht geändert werden.It's important to know that the underlying data isn't changed. Stattdessen ändert und strukturiert der Power Query-Editor seine Ansicht der Daten.Rather, Power Query Editor adjusts and shapes its view of the data. Außerdem strukturiert und ändert er die Ansicht jeglicher Interaktionen mit den zugrunde liegenden Daten basierend auf der strukturierten und geänderten Ansicht dieser Daten im Power Query-Editor.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

Im Bereich Abfrageeinstellungen können Sie Schritte nach Bedarf umbenennen, löschen oder neu anordnen.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Klicken Sie dazu mit der rechten Maustaste in den Bereich Angewendete Schritte, und nehmen Sie im Kontextmenü die gewünschte Auswahl vor.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Alle Abfrageschritte werden in der Reihenfolge ausgeführt, in der sie im Bereich Angewendete Schritte aufgeführt sind.All query steps are carried out in the order they appear in the Applied Steps pane.

Screenshot von Power BI Desktop mit den Filtern „EIGENSCHAFTEN“ und „ANGEWENDETE SCHRITTE“ unter „Abfrageeinstellungen“

Erweiterter EditorAdvanced Editor

Mit dem Erweiterten Editor können Sie den Code abrufen, den der Power Query-Editor bei jedem Schritt erstellt.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Außerdem können Sie ihn nutzen, um einen eigenen Strukturierungscode zu erstellen.It also lets you create your own shaping code. Zum Starten des Erweiterten Editors wählen Sie zunächst Ansicht im Menüband und dann Erweiterter Editor aus.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Ein Fenster wird geöffnet, in dem der Code der vorhandenen Abfrage angezeigt wird.A window appears, showing the existing query code.
Screenshot von Power BI Desktop mit dem Dialogfeld „Erweiterter Editor“Screenshot of Power B I Desktop showing Advanced Editor dialog box.

Im Fenster Erweiterter Editor können Sie den Code direkt bearbeiten.You can directly edit the code in the Advanced Editor window. Zum Schließen des Fensters wählen Sie die Schaltfläche Fertig oder Abbrechen aus.To close the window, select the Done or Cancel button.

Speichern der ArbeitSaving your work

Wenn Sie mit Ihrer Abfrage zufrieden sind, klicken Sie im Dateimenü des Power Query-Editors auf Close & Apply (Schließen und anwenden).When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Mit dieser Aktion werden die Änderungen angewendet und der Editor geschlossen.This action applies the changes and closes the editor.
Screenshot von Power BI Desktop mit der Option zum Schließen und Anwenden auf der Registerkarte „Datei“Screenshot of Power B I Desktop showing Close and Apply option under File tab.

Nachfolgend zeigt Power BI Desktop in einem Dialogfeld eine Fortschrittsanzeige an.As progress is made, Power BI Desktop provides a dialog to display its status.
Screenshot von Power BI Desktop mit dem Dialogfeld zur Bestätigung der übernommenen Abfrageänderungen

Wenn Sie fertig sind, kann Power BI Desktop Ihre Arbeit in Form einer PBIX-Datei speichern.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Klicken Sie zum Speichern Ihrer Arbeit wie in der folgenden Abbildung gezeigt auf Datei > Speichern (oder Datei > Speichern unter).To save your work, select File > Save (or File > Save As), as shown in the following image.
Screenshot von Power BI Desktop mit der Registerkarte „Datei“ des Power Query-EditorsScreenshot of Power B I Desktop showing Power Query Editor File tab.

Nächste SchritteNext steps

Mit Power BI Desktop können Sie viele Aufgaben ausführen.There are all sorts of things you can do with Power BI Desktop. Weitere Informationen zu den Funktionen und Möglichkeiten finden Sie in den folgenden Ressourcen:For more information on its capabilities, check out the following resources: