Slicer in Power BI

GILT FÜR: ✔️ Power BI Desktop ✔️ Power BI service

Angenommen, die Leser des Berichts sollen die gesamten Vertriebsmetriken einsehen, aber auch die Leistung einzelner Bezirksleiter und in unterschiedlichen Zeiträumen hervorheben können. Sie können separate Berichte oder vergleichende Diagramme erstellen. Im Bereich „Filter“ können Sie Filter hinzufügen. Alternativ können Sie auch Datenschnitte verwenden. Slicer sind eine weitere Art von Filter. Sie beschränken den Teil des Datasets, der in den anderen Berichtsvisualisierungen angezeigt wird.

Animation des Slicers in Aktion.

Dieser Artikel führt Sie durch das Erstellen und Formatieren eines einfachen Datenschnitts mit dem kostenlosen Analysebeispiel für den Einzelhandel. Außerdem werden die Steuerung der vom Slicer betroffenen Visuals, das Synchronisieren mit Slicern auf anderen Seiten sowie das Filtern und Formatieren von Slicern behandelt.

In diesen weiteren Artikeln wird die Erstellung bestimmter Slicertypen erläutert:

Verwenden von Slicern

Slicer sind für folgende Zwecke gut geeignet:

  • Anzeigen häufig verwendeter oder wichtiger Filter für den einfacheren Zugriff im Zeichenbereich des Berichts
  • Einfacheres Anzeigen des aktuellen gefilterten Zustands, ohne dass das Öffnen einer Dropdownliste erforderlich ist.
  • Filtern nach Spalten, die nicht benötigt werden und in den Datentabellen versteckt sind
  • Erstellen von zielgerichteten Berichten, indem Slicers neben wichtigen Visuals angeordnet werden

Power BI-Slicer unterstützen Folgendes nicht:

  • Eingabefelder
  • Drilldownoptionen

Erstellen von Slicern

Dieser Datenschnitt filtert Daten vom Bezirksleiter. Wenn Sie dieses Verfahren durchlaufen möchten, laden Sie die PBIX-Datei mit dem Analysebeispiel für den Einzelhandel herunter.

  1. Öffnen Sie Power BI Desktop, und wählen Sie über die Menüleiste Datei > Öffnen aus.

  2. Wechseln Sie zur PBIX-Datei mit dem Analysebeispiel für den Einzelhandel, und wählen Sie dann Öffnen aus.

  3. Wählen Sie im linken Bereich das Symbol Bericht Screenshot des Berichtssymbols. aus, um die Datei in der Berichtsansicht zu öffnen.

  4. Wählen Sie auf der Seite Übersicht, auf der im Berichtszeichenbereich keine Auswahl getroffen wurde, das Symbol Slicer Screenshot des Slicersymbols. im Bereich Visualisierungen aus, um einen neuen Slicer zu erstellen.

  5. Wählen Sie nach Auswahl des neuen Slicers im Bereich Felder den Eintrag District (Bezirk) > DM (Bezirksleiter) aus, um den Slicer aufzufüllen.

    Der neue Slicer wird nun mit einer Liste der Namen der Bezirksleiter und ihrer zugehörigen Auswahlfelder aufgefüllt.

    Screenshot des mit Namen der Bezirksleiter aufgefüllten Slicers.

  6. Sie können die Größe der Elemente im Zeichenbereich ändern und diese ziehen, um Platz für den Slicer zu machen. Beachten Sie, dass die Elemente des Slicers abgeschnitten werden, wenn Sie ihn zu stark verkleinern.

  7. Wählen Sie im Slicer Namen aus, und beachten Sie die Auswirkungen auf die anderen Visualisierungen auf der Seite. Wählen Sie die Namen erneut aus, um ihre Auswahl aufzuheben. Oder halten Sie die STRG-TASTE gedrückt, um mehrere Namen auszuwählen. Die Auswahl sämtlicher Namen hat die gleiche Wirkung wie die Auswahl keiner Namen.

  8. Wählen Sie alternativ im Bereich Visualisierungen den Befehl Format (Farbrollensymbol) aus, um Ihren Slicer zu formatieren.

    Es gibt zu viele Möglichkeiten, um sie alle hier zu beschreiben. Experimentieren Sie daher, und erstellen Sie einen für Sie geeigneten Slicer. In der folgenden Abbildung hat der erste Slicer eine horizontale Ausrichtung und farbige Hintergründe für die Elemente. Der zweite Slicer ist vertikal ausgerichtet und färbt den Text für ein eher standardmäßiges Aussehen.

    Screenshot des formatierten Slicers.

    Tipp

    Slicerelemente für Listen werden standardmäßig in aufsteigender Reihenfolge sortiert. Wenn Sie die Sortierreihenfolge in absteigend umkehren möchten, klicken Sie rechts oben im Slicer auf die Auslassungspunkte ( ... ) und anschließend auf Absteigend sortieren.

Steuern der Auswirkungen von Slicern auf visuelle Seitenelemente

Auf Berichtsseiten haben Slicer standardmäßig auf alle anderen Visualisierungen auf dieser Seite Auswirkungen, auch untereinander. Beachten Sie die Auswirkungen auf die anderen Visualisierungen, wenn Sie gerade erstellte Werte in der Liste und Schieberegler für Datumsangaben auswählen. Die gefilterten Daten stellen eine Schnittmenge der Werte dar, die in beiden Slicern ausgewählt wurden.

Mithilfe visueller Interaktionen können Sie ausschließen, dass einige Seitenvisualisierungen von anderen beeinflusst werden. Auf der Seite Übersicht zeigt das Diagramm Total Sales Variance by FiscalMonth and District Manager (Abweichung vom Gesamtumsatz nach Geschäftsmonat und Bezirksleiter) die gesamten Vergleichsdaten für Bezirksleiter nach Monat, die jederzeit sichtbar bleiben sollen. Sie können mithilfe visueller Interaktionen verhindern, dass dieses Diagramm anhand der Auswahl im Slicer gefiltert wird.

  1. Wechseln Sie zur Seite Übersicht des Berichts, und wählen Sie dann den Slicer DM (Bezirksleiter) aus, den Sie zuvor erstellt haben.

  2. Wählen Sie in im Power BI Desktop-Menü unter Visual Tools das Menü Format und anschließend Interaktionen bearbeiten aus.

    Über allen Visuals auf der Seite werden Filtersteuerelemente Screenshot von Filtersteuerelementen. jeweils mit der Option Filter und Keine angezeigt. Anfänglich ist die Option Filter in allen Steuerelementen vorab ausgewählt.

  3. Wählen Sie das Symbol Ohne über dem Diagramm Total Sales Variance by FiscalMonth and District Manager (Abweichung vom Gesamtumsatz nach Geschäftsmonat und Bezirksleiter) aus, um die Filterung durch den Slicer DM zu beenden.

  4. Wählen Sie den Slicer OpenDate und dann die Option Ohne über dem Diagramm Total Sales Variance by FiscalMonth and District Manager (Abweichung vom Gesamtumsatz nach Geschäftsmonat und Bezirksleiter) aus, um die Filterung durch diesen Slicer zu beenden.

    Wenn Sie in den Slicern Namen und Datumsbereiche ausgewählt haben, bleibt das Diagramm Total Sales Variance by FiscalMonth and District Manager (Abweichung vom Gesamtumsatz nach Geschäftsmonat und Bezirksleiter) unverändert.

Weitere Informationen zur Bearbeitung von Interaktionen finden Sie unter Ändern der Interaktion von Visualisierungen in einem Power BI-Bericht.

Synchronisieren und Verwenden von Slicern auf anderen Seiten

Sie können einen Slicer synchronisieren und auf beliebigen oder allen Seiten in einem Bericht verwenden.

Im aktuellen Bericht enthält die Seite District Monthly Sales (Monatsumsätze nach Bezirk) auch den Slicer District Manager (Bezirksleiter). Aber was wäre, wenn wir uns diesen Slicer auch auf der Seite New Stores (Neue Filialen) wünschen würden? Die Seite New Stores (Neue Filialen) hat ebenfalls einen Slicer, liefert aber nur Informationen zu Store Name (Filialname). Im Bereich Slicer synchronisieren können Sie den Slicer District Manager (Bezirksleiter) mit diesen Seiten synchronisieren, damit sich die Auswahl der Slicer auf einer beliebigen Seite auf Visualisierungen auf allen drei Seiten auswirkt.

  1. Klicken Sie im Power BI Desktop-Menü Ansicht auf Slicer synchronisieren.

    Screenshot der Option „Slicer synchronisieren“.

    Der Bereich Slicer synchronisieren wird zwischen den Bereichen Filter und Visualisierungen angezeigt.

    Screenshot des Bereichs „Slicer synchronisieren“.

  2. Wählen Sie auf der Seite District Monthly Sales (Monatsumsätze nach Bezirk) des Berichts den Slicer District Manager (Bezirksleiter) aus.

    Da Sie auf der Seite Übersicht bereits den Slicer District Manager (DM) erstellt haben, wird der Bereich Slicer synchronisieren wie folgt angezeigt:

    Screenshot zum Synchronisieren des Slicers „Monatsumsätze nach Bezirk“.

  3. Wählen Sie in der Spalte Synchronisieren des Bereichs Slicer die Seiten Overview (Übersicht), District Monthly Sales (Monatsumsätze nach Bezirk) und New Stores (Neue Filialen) aus.

    Diese Auswahl bewirkt, dass der Slicer District Monthly Sales (Monatsumsätze nach Bezirk) auf diesen drei Seiten synchronisiert wird.

  4. Wählen Sie in der Spalte Sichtbar des Bereichs Slicer die Seite New Stores (Neue Filialen) aus.

    Diese Auswahl bewirkt, dass der Slicer District Monthly Sales (Monatsumsätze nach Bezirk) auf diesen drei Seiten sichtbar ist. Der Bereich Slicer synchronisieren wird nun wie folgt angezeigt:

    Screenshot zum Auswählen von Seiten in „Slicer synchronisieren“.

  5. Beobachten Sie die Auswirkungen der Synchronisierung des Slicers und der Sichtbarmachung auf den anderen Seiten. Auf der Seite District Monthly Sales (Monatsumsätze nach Bezirk) zeigt der Slicer für District Manager (Bezirksleiter) jetzt die gleiche Auswahl wie auf der Seite Übersicht. Auf der Seite New Stores (Neue Filialen) ist nun der Slicer District Manager (Bezirksleiter) sichtbar, was sich auf die Auswahlmöglichkeiten auswirkt, die im Slicer Store Name (Filialnamen) sichtbar sind.

    Tipp

    Der Slicer wird zwar auf den synchronisierten Seiten zunächst in der gleichen Größe und an der gleichen Position wie auf der ursprünglichen Seite angezeigt, Sie können die synchronisierten Slicer auf den verschiedenen Seiten jedoch unabhängig voneinander verschieben, formatieren und ihre Größe ändern.

    Hinweis

    Wenn Sie einen Slicer auf einer Seite synchronisieren, ihn auf dieser Seite jedoch nicht sichtbar machen, werden die Daten auf der Seite von den auf den anderen Seiten ausgewählten Slicern weiterhin gefiltert.

Synchronisieren separater Slicer

Sie können auch zwei oder mehr separate Slicer synchronisieren. Dies ist besonders nützlich, wenn Sie mit zusammengesetzten Modellen arbeiten, da Sie möglicherweise die gleiche Auswahl für mehrere Quellen treffen möchten, ohne sich auf quellübergreifende Gruppenbeziehungen verlassen zu müssen. Sie müssen eine Gruppe erstellen, um zwei oder mehr Slicer zu synchronisieren.

  1. Stellen Sie zunächst sicher, dass der Auswahlbereich angezeigt wird, indem Sie ihn im Menü Ansicht auswählen.

  2. Wählen Sie die Slicer aus, die Sie synchronisieren möchten, und erstellen Sie im Auswahlbereich im Kontextmenü eine Gruppe:

    Screenshot: Erstellen einer Gruppe im Auswahlbereich

    Alternativ können Sie die Gruppe erstellen, indem Sie die Slicer auswählen und im Menü Format die Option Gruppe auswählen.

  3. Benennen Sie die soeben erstellte Gruppe um, indem Sie im Auswahlbereich auf den Gruppennamen doppelklicken und die Umbenennung bestätigen.

    Screenshot: Umbenennen einer Gruppe im Auswahlbereich

  4. Stellen Sie sicher, dass der Bereich Slicer synchronisieren angezeigt wird, indem Sie ihn im Menü Ansicht auswählen.

  5. Wählen Sie im Bereich Slicer synchronisieren einen der Slicer in der Gruppe aus, und geben Sie den Gruppennamen unter Erweiterte Optionen ein.

    Screenshot: Eingeben eines Gruppennamens im Abschnitt „Erweitert“ des Auswahlbereichs

  6. Stellen Sie sicher, dass Sie je nach Szenario entweder Feldänderungen an anderen Slicern synchronisieren, Filteränderungen mit anderen Slicern synchronisieren oder beides auswählen.

    • Wenn Sie nur die Slicer synchron halten möchten, damit die von den Slicern festgelegten Filter synchron bleiben, wählen Sie Filteränderungen mit anderen Slicern synchronisieren aus.
    • Wenn Sie auch sicherstellen möchten, dass alle Änderungen, die Sie an dem Feld vornehmen, auf dem die Slicer basieren, gruppenübergreifend synchronisiert werden, wählen Sie Filteränderungen mit anderen Slicern synchronisieren aus.
  7. Testen Sie, ob die Synchronisierung wie gewünscht funktioniert, indem Sie die Auswahl und/oder das Feld in einem der Slicer ändern. Sehen Sie nach, ob dass sie ebenfalls in den anderen Slicern in der Gruppe aktualisiert wird.

Filterslicer

Sie können Filter auf Visualebene auf Slicer anwenden, um die Liste der Werte zu reduzieren, die im Slicer angezeigt werden. Beispielsweise können Sie leere Werte aus einem Listenslicer oder bestimmte Datumsangaben aus einem Bereichsslicer herausfiltern. Hierbei werden nur die Werte beeinflusst, die im Slicer angezeigt werden, nicht der Filter, den der Slicer auf andere Visuals anwendet, wenn Sie eine Auswahl treffen. Angenommen, Sie wenden einen Filter auf einen Bereichsslicer an, um nur bestimmte Datumsangaben anzuzeigen. Die Auswahl im Slicer zeigt nur die ersten und letzten Datumsangaben aus dem Bereich an, die anderen Datumsangaben werden jedoch in Ihren anderen Visuals angezeigt. Sobald Sie Änderungen am ausgewählten Bereich im Slicer vornehmen, werden auch die anderen Visuals geändert. Wenn der Slicer gelöscht wird, werden wieder alle Datumsangaben angezeigt.

Weitere Informationen über Filter auf Visualebene finden Sie unter Filtertypen.

Formatieren von Slicern

Abhängig vom Slicertyp sind verschiedene Formatierungsoptionen verfügbar. Wenn Sie die Ausrichtung Horizontal, das Layout Dynamisch und die Farbgebung für Elemente auswählen, können Sie anstelle von Standardlistenelementen Schaltflächen oder Kacheln erstellen und die Größe von Slicerelementen an verschiedene Bildschirmgrößen und Layouts anpassen.

  1. Wählen Sie bei ausgewähltem Slicer für Bezirksleiter auf einer Seite im Bereich Visualisierungen das Symbol Format Screenshot des Formatsymbols. aus, um die Formatierungssteuerelemente anzuzeigen.

    Screenshot der Formatauswahl.

  2. Klicken Sie neben den einzelnen anzuzeigenden Kategorien auf die Dropdown-Pfeile, und bearbeiten Sie die Optionen.

Allgemeine Optionen

  1. Wählen Sie unter Format die Option Allgemein aus. Wählen Sie unter Konturfarbe eine rote Farbe aus, und ändern Sie dann Konturstärke in 2.

    Diese Einstellung ändert Farbe und Stärke der Kopfzeilen, Elementkonturen und Unterstriche.

  2. Für Ausrichtung ist Vertikal die Standardeinstellung. Wählen Sie Horizontal aus, um einen Slicer mit horizontal angeordneten Kacheln oder Schaltflächen sowie Scrollpfeilen zu erzeugen, über die auf Elemente zugegriffen werden kann, die nicht in den Slicer passen.

    Screenshot der allgemeinen Auswahl.

  3. Aktivieren Sie das Layout Dynamisch, um Größe und Anordnung der Slicerelemente entsprechend der Bildschirm- und Slicergröße zu ändern.

    Bei Slicern verhindert das dynamische Layout, dass Elemente auf kleinen Bildschirmen abgeschnitten werden. Es ist nur in horizontaler Ausrichtung verfügbar. Bei Schieberegler-Slicern für Bereiche wird durch die dynamische Formatierung die Art des Schiebereglers geändert. Zudem kann die Größe flexibler geändert werden. Beide Slicertypen werden zu kleinen Filtersymbolen.

    Screenshot zum Festlegen des dynamischen Layouts.

    Hinweis

    Durch dynamische Layoutänderungen können bestimmte, von Ihnen festgelegte Formatierungen von Überschriften und Elementen überschrieben werden.

  4. Legen Sie Position und Größe des Slicers unter X-Position, Y-Position, Breite und Höhe mit numerischer Genauigkeit fest, oder verschieben Sie den Slicer direkt im Zeichenbereich, und ändern Sie seine Größe.

    Experimentieren Sie mit verschiedenen Größen und Anordnungen der Elemente, und beachten Sie, wie sich die dynamische Formatierung entsprechend ändert. Diese Optionen sind nur verfügbar, wenn Sie die horizontale Ausrichtung auswählen.

    Screenshot der Optionen zu „Horizontal“.

Weitere Informationen zur horizontalen Ausrichtung und zum dynamischen Layout finden Sie unter Erstellen eines dynamischen Slicers mit anpassbarer Größe in Power BI.

Optionen für Auswahlsteuerelemente (nur bei Slicern für Listen)

  1. Legen Sie unter Auswahlsteuerelemente die Option Option "Alles auswählen" anzeigen auf Ein fest, um dem Slicer das Element Alle auswählen hinzuzufügen.

    Option "Alles auswählen" anzeigen ist standardmäßig deaktiviert. Falls aktiviert, werden beim Umschalten alle Elemente ausgewählt, oder ihre Auswahl wird aufgehoben. Wenn Sie alle Elemente auswählen, wird die Auswahl eines Elements durch Klicken oder Tippen darauf aufgehoben, wodurch ein Filter des Typs is-not (ist nicht) möglich wird.

    Screenshot der Auswahlsteuerelemente.

  2. Legen Sie Einfachauswahl auf Aus fest, damit mehrere Elemente ausgewählt werden können, ohne dass die STRG-TASTE gedrückt werden muss.

    Einfachauswahl ist standardmäßig aktiviert. Durch Klicken oder Tippen auf ein Element wird es ausgewählt. Wenn Sie die STRG-TASTE gedrückt halten, werden mehrere Elemente ausgewählt. Durch erneutes Klicken oder Tippen auf ein Element wird seine Auswahl aufgehoben.

Titeloptionen

Titel ist standardmäßig aktiviert. Diese Auswahl zeigt den Namen des Datenfelds oben im Slicer. Sie können auch den Titel bearbeiten, was besonders für Hierarchieslicer hilfreich ist. Weitere Informationen finden Sie unter Ändern des Titels im Artikel „Hinzufügen mehrerer Felder zu einem Hierarchieslicer“.

  • Formatieren Sie für diesen Artikel den Titeltext wie folgt:
    • Schriftfarbe: rot
    • Textgröße: 14 pt
    • Ausrichtung: Zentriert
    • Schriftfamilie: Arial Black

Optionen für Elemente

Die Optionen für Elemente sind nur für Listenslicer verfügbar.

  1. Formatieren Sie für diesen Artikel die Optionen für Elemente wie folgt:

    • Schriftfarbe: schwarz
    • Hintergrund: hellrot
    • Textgröße: 10 pt
    • Schriftfamilie: Arial
  2. Wählen Sie unter Kontur die Option Rahmen aus, um eine Umrandung für die einzelnen Elemente in der unter Allgemeine Optionen festgelegten Größe und Farbe zu zeichnen.

    Screenshot der Optionen für die Rahmenkontur.

    Tipp

    • Wenn Allgemein > Ausrichtung > Horizontal ausgewählt ist, werden nicht ausgewählte Elemente in den ausgewählten Text- und Hintergrundfarben angezeigt. Für ausgewählte Elemente wird der Systemstandard verwendet, normalerweise ein schwarzer Hintergrund mit weißem Text.
    • Bei Auswahl von Allgemein > Ausrichtung > Vertikal werden Elemente immer in den festgelegten Farben angezeigt, während Kontrollkästchen immer schwarz sind, wenn sie aktiviert werden.

Optionen für die Eingabe von Datumsangaben/numerischen Werten und Schieberegleroptionen

Optionen für die Eingabe von Datumsangaben/numerischen Werten und Schieberegleroptionen sind nur bei Schiebereglerslicern für Bereiche verfügbar.

  • Optionen für Slicer für Listen zur Eingabe von Datumsangaben/numerischen Werten sind mit den Optionen für Elemente identisch. Eine Ausnahme ist, dass es keine Optionen für Konturen und Unterstriche gibt.
  • Mit Optionen für Schieberegler können Sie die Farbe des Schiebereglers für Bereiche festlegen oder den Schieberegler deaktivieren, sodass nur die numerischen Eingaben bleiben.

Weitere Formatierungsoptionen

Die weiteren Formatierungsoptionen sind standardmäßig deaktiviert. Aktivieren Sie diesen Optionen, um Sie zu steuern:

  • Hintergrund: Fügt eine Hintergrundfarbe zum Slicer hinzu und legt dessen Transparenz fest.
  • Seitenverhältnis fixieren: Behält die relative Höhe und Breite des Slicers bei, wenn seine Größe geändert wird.
  • Rahmen: Fügt einen Rahmen um den Slicer hinzu und legt dessen Farbe fest. Dieser Slicerrahmen ist separat von den allgemeinen Einstellungen, die keinen Einfluss auf ihn haben.
  • Schatten: Fügt dem Schieberegler einen Schlagschatten hinzu.

Nächste Schritte

Weitere Informationen zu Slicern finden Sie in den folgenden Artikeln: