Windows PowerShell-SystemanforderungenWindows PowerShell System Requirements

In diesem Artikel werden die Systemanforderungen für Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0 und Windows PowerShell 5.1 undThis article lists the system requirements for Windows PowerShell 3.0, Windows PowerShell 4.0, Windows PowerShell 5.0, and Windows PowerShell 5.1. spezielle Features wie Windows PowerShell Integrated Scripting Environment (ISE), Common Information Model -Befehle (CIM) und Workflows aufgeführt.And, special features, such as Windows PowerShell Integrated Scripting Environment (ISE), Common Information Model (CIM) commands, and workflows.

Windows® 8.1 und Windows Server® 2012 R2 enthalten alle erforderlichen Programme.Windows® 8.1 and Windows Server® 2012 R2 include all required programs. Dieser Artikel ist für Benutzer früherer Releases von Windows gedacht.This article is designed for users of earlier releases of Windows.

BetriebssystemanforderungenOperating system requirements

Windows PowerShell 5.1Windows PowerShell 5.1

Windows PowerShell 5.1 wird unter den folgenden Windows-Versionen ausgeführt.Windows PowerShell 5.1 runs on the following versions of Windows. Installieren Sie Windows Management Framework 5.1, um Windows PowerShell 5.1 auszuführen.To run Windows PowerShell 5.1, install Windows Management Framework 5.1. Weitere Informationen finden Sie unter Installieren und Konfigurieren von WMF 5.1.For more information, see Install and Configure WMF 5.1.

Windows-VersionWindows version SystemanforderungenSystem requirement
Windows Server 2019Windows Server 2019 standardmäßig installiertInstalled by default
Windows Server 2016Windows Server 2016 standardmäßig installiertInstalled by default
Windows Server 2012 R2Windows Server 2012 R2 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2012Windows Server 2012 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2008 R2 mit Service Pack 1Windows Server 2008 R2 with Service Pack 1 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 10 Version 1607 und höherWindows 10 version 1607 and up standardmäßig installiertInstalled by default
Windows 10 Version 1507, 1511Windows 10 version 1507, 1511 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 8.1Windows 8.1 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 7 mit Service Pack 1Windows 7 with Service Pack 1 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1

Windows PowerShell 5.0Windows PowerShell 5.0

Windows PowerShell 5.0 wird unter den folgenden Versionen von Windows ausgeführt.Windows PowerShell 5.0 runs on the following versions of Windows. Installieren Sie Windows Management Framework 5.0, um Windows PowerShell 5.1 auszuführen.To run Windows PowerShell 5.0, install Windows Management Framework 5.1. Weitere Informationen finden Sie unter Installieren und Konfigurieren von WMF 5.1.For more information, see Install and Configure WMF 5.1. Windows Management Framework 5.1 ersetzt Windows Management Framework 5.0.Windows Management Framework 5.1 supersedes Windows Management Framework 5.0.

Windows-VersionWindows version SystemanforderungenSystem requirement
Windows Server 2019Windows Server 2019 höhere Version standardmäßig installiertHigher version installed by default
Windows Server 2016Windows Server 2016 höhere Version standardmäßig installiertHigher version installed by default
Windows Server 2012 R2Windows Server 2012 R2 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2012Windows Server 2012 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows Server 2008 R2 mit Service Pack 1Windows Server 2008 R2 with Service Pack 1 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 10 Version 1607 und höherWindows 10 version 1607 and up höhere Version standardmäßig installiertHigher version installed by default
Windows 10 Version 1507, 1511Windows 10 version 1507, 1511 standardmäßig installiertInstalled by default
Windows 8.1Windows 8.1 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1
Windows 7 mit Service Pack 1Windows 7 with Service Pack 1 Installieren von Windows Management Framework 5.1Install Windows Management Framework 5.1

Windows PowerShell 4.0Windows PowerShell 4.0

Windows PowerShell 4.0 wird unter den folgenden Versionen von Windows ausgeführt.Windows PowerShell 4.0 runs on the following versions of Windows. Installieren Sie die angegebene Version von Windows Management Framework für Ihr Betriebssystem, um Windows PowerShell 4.0 auszuführen.To run Windows PowerShell 4.0, install the specified version of the Windows Management Framework for your operating system.

Windows-VersionWindows version SystemanforderungenSystem requirement
Windows 8.1Windows 8.1 standardmäßig installiertInstalled by default
Windows Server 2012 R2Windows Server 2012 R2 standardmäßig installiertInstalled by default
Windows® 7 mit Service Pack 1Windows® 7 with Service Pack 1 Installieren von Windows Management Framework 4.0Install Windows Management Framework 4.0
Windows Server® 2008 R2 mit Service Pack 1Windows Server® 2008 R2 with Service Pack 1 Installieren von Windows Management Framework 4.0Install Windows Management Framework 4.0

Windows PowerShell 3.0Windows PowerShell 3.0

Windows PowerShell 3.0 wird unter den folgenden Versionen von Windows ausgeführt.Windows PowerShell 3.0 runs on the following versions of Windows. Installieren Sie die angegebene Version von Windows Management Framework für Ihr Betriebssystem, um Windows PowerShell 3.0 auszuführen.To run Windows PowerShell 3.0, install the specified version of the Windows Management Framework for your operating system.

Windows-VersionWindows version SystemanforderungenSystem requirement
Windows 8Windows 8 standardmäßig installiertInstalled by default
Windows Server 2012Windows Server 2012 standardmäßig installiertInstalled by default
Windows® 7 mit Service Pack 1Windows® 7 with Service Pack 1 Installieren von Windows Management Framework 3.0Install Windows Management Framework 3.0
Windows Server® 2008 R2 mit Service Pack 1Windows Server® 2008 R2 with Service Pack 1 Installieren von Windows Management Framework 3.0Install Windows Management Framework 3.0
Windows Server 2008 mit Service Pack 2Windows Server 2008 with Service Pack 2 Installieren von Windows Management Framework 3.0Install Windows Management Framework 3.0

Microsoft .NET Framework-AnforderungenMicrosoft .NET Framework requirements

In der folgenden Tabelle finden Sie die .NET Framework-Anforderungen für Windows PowerShell.The following table shows the .NET Framework requirements for Windows PowerShell.

VersionVersion .NET-Anforderung.NET requirement
Windows PowerShell 5.1Windows PowerShell 5.1 Erfordert die vollständige Installation von Microsoft .NET Framework 4.5.Requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 und Windows Server 2012 R2 enthalten standardmäßig Microsoft .NET Framework 4.5.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.
Windows PowerShell 5.0Windows PowerShell 5.0 Erfordert die vollständige Installation von Microsoft .NET Framework 4.5.Requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 und Windows Server 2012 R2 enthalten standardmäßig Microsoft .NET Framework 4.5.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.
Windows PowerShell 4.0Windows PowerShell 4.0 Erfordert die vollständige Installation von Microsoft .NET Framework 4.5.Requires the full installation of Microsoft .NET Framework 4.5. Windows 8.1 und Windows Server 2012 R2 enthalten standardmäßig Microsoft .NET Framework 4.5.Windows 8.1 and Windows Server 2012 R2 include Microsoft .NET Framework 4.5 by default.
Windows PowerShell 3.0Windows PowerShell 3.0 Erfordert die vollständige Installation von Microsoft .NET Framework 4.Requires the full installation of Microsoft .NET Framework 4. In Windows 8 und Windows Server 2012 ist Microsoft .NET Framework 4.5 standardmäßig enthalten, wodurch diese Anforderung erfüllt ist.Windows 8 and Windows Server 2012 include Microsoft .NET Framework 4.5 by default, which fulfills this requirement.

Verwenden Sie die folgenden Links, um Microsoft .NET Framework aus dem Microsoft Download Center herunterzuladen.Use the following links to download Microsoft .NET Framework from the Microsoft Download Center.

VersionVersion LinkLink
.NET Framework 4.5 (dotNetFx45_Full_setup.exe).NET Framework 4.5 (dotNetFx45_Full_setup.exe) Microsoft .NET Framework 4.5Microsoft .NET Framework 4.5
.NET Framework 4 (dotNetFx40_Full_setup.exe).NET Framework 4 (dotNetFx40_Full_setup.exe) Microsoft .NET Framework 4 (Webinstaller)Microsoft .NET Framework 4 (Web Installer)

Windows Management Framework 4.0Windows Management Framework 4.0

Windows PowerShell 5.0 erfordert Windows Management Framework 4.0 vorinstalliert unter Windows Server 2008 R2 SP1 und Windows 7 SP1.Windows PowerShell 5.0 requires Windows Management Framework 4.0 to be preinstalled on Windows Server 2008 R2 SP1 and Windows 7 SP1.

WS-Management 3.0WS-Management 3.0

Windows PowerShell 3.0 und Windows PowerShell 4.0 erfordern WS-Management 3.0, das den WinRM-Dienst und das WSMan-Protokoll unterstützt.Windows PowerShell 3.0 and Windows PowerShell 4.0 require WS-Management 3.0, which supports the WinRM service and WSMan protocol. Dieses Programm ist in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 und Windows Management Framework 3.0 enthalten.This program is included in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, and Windows Management Framework 3.0.

Windows-Verwaltungsinstrumentation 3.0 (Windows Management Instrumentation, WMI)Windows Management Instrumentation 3.0

Windows PowerShell 3.0 und Windows PowerShell 4.0 erfordern Windows Management Instrumentation 3.0 (Windows-Verwaltungsinstrumentation, WMI).Windows PowerShell 3.0 and Windows PowerShell 4.0 require Windows Management Instrumentation 3.0 (WMI). Dieses Programm ist in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0 und Windows Management Framework 3.0 enthalten.This program is included in Windows 8.1, Windows Server 2012 R2, Windows 8, Windows Server 2012, Windows Management Framework 4.0, and Windows Management Framework 3.0. Wenn dieses Programm nicht auf dem Computer installiert ist, werden Features, die WMI erfordern, wie z. B. CIM-Befehle, nicht ausgeführt.If this program isn't installed on the computer, features that require WMI, such as CIM commands, don't run.

Common Language Runtime 4.0Common Language Runtime 4.0

Windows PowerShell 3.0, Windows PowerShell 4.0 und Windows PowerShell 5.0 werden für Common Language Runtime (CLR) 4.0 kompiliert.Windows PowerShell 3.0, Windows PowerShell 4.0, and Windows PowerShell 5.0 are compiled against Common Language Runtime (CLR) 4.0.

Anforderungen an die grafische BenutzeroberflächeGraphical user interface requirements

Windows PowerShell ist eine konsolenbasierte Anwendung, die keine grafische Benutzeroberfläche erfordert.Windows PowerShell is a console-based application that doesn't require a graphical user interface. Die Anwendung eignet sich gut für Computer ohne Bildschirm oder Monitor bzw. ohne Benutzeroberfläche wie z. B. die Server Core-Installationsoptionen von Windows Server 2012 R2 oder Windows Server 2012.It's well suited to computers that don't have screens or monitors, or a user interface, such as the Server Core installation options of Windows Server 2012 R2 or Windows Server 2012.

Einige Elemente erfordern eine grafische Benutzeroberfläche.Some items require a graphical user interface. Weitere Informationen finden Sie im Hilfsartikel des jeweiligen Elements:For details, see the help article for each item.

Anforderungen an die Windows PowerShell-EngineWindows PowerShell engine requirements

Windows PowerShell 4.0 ist mit Windows PowerShell 3.0 und Windows PowerShell 2.0 abwärtskompatibel.Windows PowerShell 4.0 is designed to be backwards compatible with Windows PowerShell 3.0 and Windows PowerShell 2.0. Cmdlets, Anbieter, Snap-Ins, Module und Skripts, die für Windows PowerShell 2.0 und Windows PowerShell 3.0 geschrieben wurden, können unverändert in Windows PowerShell 4.0 ausgeführt werden.Cmdlets, providers, snap-ins, modules, and scripts written for Windows PowerShell 2.0 and Windows PowerShell 3.0 run unchanged in Windows PowerShell 4.0.

Doch aufgrund einer Änderung der Richtlinie für die Laufzeitaktivierung in Microsoft .NET Framework 4 können Windows PowerShell-Hostprogramme, die für Windows PowerShell 2.0 geschrieben und mit Common Language Runtime (CLR) 2.0 kompiliert wurden, nicht unverändert in Windows PowerShell 3.0 ausgeführt werden, das mit CLR 4.0 kompiliert wurde.However, due to a change in the runtime activation policy in Microsoft .NET Framework 4, Windows PowerShell host programs that were written for Windows PowerShell 2.0 and compiled with Common Language Runtime (CLR) 2.0 can't run without modification in Windows PowerShell 3.0, which is compiled with CLR 4.0.

Die Windows PowerShell 2.0-Engine erfordert mindestens Microsoft .NET Framework 2.0.50727.The Windows PowerShell 2.0 engine's minimum requirement is Microsoft .NET Framework 2.0.50727. Diese Anforderung wird durch Microsoft .NET Framework 3.5 Service Pack 1 erfüllt.This requirement is fulfilled by Microsoft .NET Framework 3.5 Service Pack 1. Diese Anforderung wird nicht durch Microsoft .NET Framework 4 und höhere Versionen von Microsoft .NET Framework erfüllt.This requirement isn't fulfilled by Microsoft .NET Framework 4 and later releases of Microsoft .NET Framework.

Informationen zum Hinzufügen oder Installieren von Windows PowerShell 2.0 Engine sowie zum Hinzufügen oder Installieren der erforderlichen Versionen von Microsoft .NET Framework finden Sie unter Installieren des Windows PowerShell 2.0-Moduls.For information about adding or installing the Windows PowerShell 2.0 engine, and adding or installing the required versions of the Microsoft .NET Framework, see Installing the Windows PowerShell 2.0 Engine. Informationen zum Starten von Windows PowerShell 2.0 Engine finden Sie unter Starten des Windows PowerShell 2.0-Moduls.For information about starting the Windows PowerShell 2.0 engine, see Starting the Windows PowerShell 2.0 Engine.

Windows Preinstallation EnvironmentWindows Preinstallation Environment

Windows PowerShell 2.0, Windows PowerShell 3.0 und Windows PowerShell 4.0 werden in Windows Preinstallation Environment (Windows PE) ausgeführt.Windows PowerShell 2.0, Windows PowerShell 3.0, and Windows PowerShell 4.0 run in the Windows Preinstallation Environment (Windows PE). Die folgenden Cmdlets werden jedoch nicht unterstützt.However, the following cmdlets aren't supported.

Der WinRM -Dienst ist nicht in Windows PE vorhanden.The WinRM service isn't present on Windows PE.

Weitere InformationenSee also

Installieren von Windows PowerShellInstalling Windows PowerShell

Starten von Windows PowerShellStarting Windows PowerShell

Windows Management FrameworkWindows Management Framework