Lernprogramm: Erstellen eines Beispielberichts in Power View

Wichtiger HinweisWichtig

Lesen Sie die aktuelle Power View-Dokumentation auf office.microsoft.com. Power View ist jetzt eine Funktion von Microsoft Excel 2013 und Bestandteil des Microsoft SQL Server 2012 Reporting Services-Add-Ins für die Enterprise Edition von Microsoft SharePoint Server 2010 und 2013.

In diesem Lernprogramm erstellen Sie mithilfe eines kleinen Beispielmodells, das in PowerPivot für Excel erstellt wurde, einen Power View-Bericht, der veranschaulicht, welche Möglichkeiten Ihnen mit Power View zur Verfügung stehen. Sie erstellen Tabellen und konvertieren sie in eine Reihe unterschiedlicher Visualisierungen. Sie erstellen Kacheln und fügen ihnen Visualisierungen hinzu. Sie erstellen mehrere Seiten oder Sichten im Bericht. Sie erstellen ein Blasendiagramm und fügen ihm eine Wiedergabeachse hinzu, um darzustellen, wie sich die Werte im Zeitverlauf ändern. Sie erstellen kleine Vielfache – ein Satz kleiner Diagramme, mit jeweils einem Diagramm pro Reihe, die die gleichen Achsen enthalten. Anschließend experimentieren Sie mit verschiedenen Möglichkeiten, die Daten in den Visualisierungen zu filtern. Am Ende exportieren Sie den Bericht nach PowerPoint.

Ein Bericht ähnlich demjenigen, den Sie durch das Ausführen der Schritte in diesem Lernprogramm erstellen können

Im Lernprogramm erstellter Power View-Bericht

Voraussetzungen

Voraussetzungen zum Ausführen dieses Lernprogramms:

HinweisHinweis

Das Beispieldatenmodell HelloWorld_Picnic ist ein sehr kleines Modell, das veranschaulicht, wie Eigenschaften von Datenmodellen die bestmögliche Darstellung der Daten in Power View-Berichten ermöglichen. Die Daten in diesem Szenario werden verwendet, um den Verbrauch von Nahrungsmitteln und Getränken für Picknicks zu planen und nachzuverfolgen. Weitere Informationen finden Sie unter Power View-Beispiele für SQL Server 2012.

In diesem Artikel

Bevor Sie das Lernprogramm starten

Starten des Lernprogramms

Festlegen des Titels

Balken- und Liniendiagramme

Kopieren und Einfügen einer Visualisierung

Hinzufügen einer zweiten Reihe zu einem Diagramm

Sortieren der Werte in einem Diagramm

Anordnen der Elemente in der Sicht

Hervorhebung und Slicer

Karten

Kacheln

Vergleichen von Hervorhebung und Slicer-Filterung

Hinzufügen einer weiteren Sicht

Blasendiagramme

Hinzufügen von Kategoriegruppenfarben zu einem Blasendiagramm

Kleine Vielfache

Sicht- und Visualisierungsfilter

Anzeigen des Berichts

Speichern des Berichts

Exportieren des Berichts nach PowerPoint

Bevor Sie das Lernprogramm starten

Bevor Sie das Lernprogramm starten können, speichern Sie die Datei "HelloWorldPicnicPowerViewRTM.xlsx" in einer:

  • SharePoint-Dokumentbibliothek. Wenn Sie sie in einer SharePoint-Dokumentbibliothek speichern, erstellen Sie eine freigegebene Datenquelle, die auf die Datei "HelloWorldPicnicPowerViewRTM.xlsx" zeigt, die Sie in der SharePoint-Dokumentbibliothek gespeichert haben.

  • PowerPivot-Katalog. Wenn Sie sie in einem PowerPivot-Katalog speichern, benötigt sie die freigegebene Datenquelle nicht. Sie können Power View direkt vom Katalog aus öffnen.

Speichern Sie die Bilder in der zugeordneten SharePoint-Dokumentbibliothek.

So erstellen Sie eine freigegebene Datenquellendatei (RSDS), die auf die PowerPivot-Datei (XLSX) verweist

  1. Erstellen Sie in "Freigegebene Dokumente" einen Ordner "HelloWorldPicnicSQL2012", und speichern Sie die Datei "HelloWorldPicnicPowerViewRTM.xlsx" dort.

  2. Klicken Sie im Ordner "HelloWorldPicnicSQL2012" auf die Registerkarte Dokumente, und klicken Sie auf den Pfeil neben Neues Dokument und dann auf Berichtsdatenquelle.

    Wenn die Option Berichtsdatenquelle auf der Registerkarte Neues Dokument nicht vorhanden ist, muss ein Benutzer mit den entsprechenden Berechtigungen auf der SharePoint-Website der Website diesen Inhaltstyp hinzufügen. Weitere Informationen finden Sie unter Hinzufügen von Berichtsserver-Inhaltstypen zu einer Bibliothek (Reporting Services im integrierten SharePoint-Modus).

  3. Geben Sie im Feld Name HelloWorldPicnicRSDS ein.

    Beachten Sie die RSDS-Dateierweiterung.

  4. Klicken Sie im Feld Datenquelltyp auf Microsoft-BI-Semantikmodell für Power View.

  5. Die Verbindungszeichenfolge für eine XLSX-Datei ist die vollständige URL zur Datei, einschließlich Dateiname. Beispiel:

    Data Source='http://<myserver>/Shared%20Documents/HelloWorldPicnicSQL2012/HelloWorldPicnicPowerViewRTM.xlsx'

  6. Klicken Sie unter Anmeldeinformationen auf Windows-Authentifizierung (integriert) oder SharePoint-Benutzer.

  7. Klicken Sie auf Verbindung testen.

    Es sollte eine Meldung angezeigt werden, dass der Verbindungstest erfolgreich war.

  8. Klicken Sie auf OK.

So speichern Sie die Bilder

  1. Erstellen Sie im Ordner "HelloWorldPicnicSQL2012" den Ordner "Images". Beispiel:

    http://<myserver>/Shared Documents/HelloWorldPicnicSQL2012/Images

  2. Speichern Sie im Bilderordner die Bilder, die Sie aus dem Download Center heruntergeladen haben. Weitere Informationen finden Sie im Abschnitt zu Voraussetzungen am Anfang dieses Lernprogramms.

  1. Öffnen Sie HelloWorldPicnicPowerViewRTM.xlsx in Excel.

  2. Klicken Sie auf der Registerkarte PowerPivot auf PowerPivot-Fenster.

    Wenn die Registerkarte "PowerPivot" nicht angezeigt wird, müssen Sie möglicherweise PowerPivot für Excel installieren.

  3. Suchen Sie im Arbeitsblatt Elemente die URL in den Spalten Photo, Drawing, Category Drawing und Category Photo.

    Die URL in der Spalte Photo ist z. B. http://localhost/Shared Documents/HelloWorldPicnicSQL2012/HelloWorldPicnicImages/rs_crescent_picnic_image_.

  4. Aktualisieren Sie in jeder Spalte localhost in der URL mit dem Namen des Servers.

Starten des Lernprogramms

  1. Wenn Sie "HelloWorldPicnicPowerViewRTM.xlsx" in einer SharePoint Server 2010-Dokumentbibliothek gespeichert haben, klicken Sie auf den Pfeil neben der freigegebenen Datenquelle HelloWorldPicnicRSDS.rsds, und klicken Sie dann auf Power View-Bericht erstellen.

    Wenn Sie "HelloWorldPicnicPowerViewRTM.xlsx" im PowerPivot-Katalog gespeichert haben, klicken Sie auf das Symbol Power View-Bericht erstellen für HelloWorldPicnic .

    Power View wird geöffnet, mit der leeren Ansicht in der Mitte, dem Menüband am oberen Rand und der Feldliste auf der rechten Seite. Im Feldabschnitt der Feldliste gibt es drei Tabellen. Die Tabellen sind zunächst reduziert, sodass nur ihre Namen angezeigt werden:

    • Dates

    • Elemente

    • Quantities

    Diese Tabellen bilden das Datenmodell, auf dem der Power View-Bericht basiert.

  2. Um die Tabellen zu erweitern, klicken Sie auf den Pfeil neben dem Tabellennamen.

    Anschließend werden die Felder in der jeweiligen Tabelle angezeigt. Zu diesen zählen möglicherweise berechnete Spalten (mit dem Sigma-Symbol ∑), Measures (mit einem kleinen Rechnersymbol markiert) und Zeilenbezeichnungsfelder (mit einem grau-weißen Symbol markiert).

Weitere Informationen zum Erstellen von berechneten Feldern und Measures finden Sie unter Measure-Feld und Non-Measure-Feld in Power View. Informationen zur Power View-Entwurfsumgebung im Allgemeinen finden Sie unter Power View-Entwurfserfahrung.

Festlegen des Titels

So ändern Sie Text und Formatierung des Titels

  1. Klicken Sie in das Standardtitelfeld, und geben Sie den Titel "Picnic items" ein.

  2. Markieren Sie den Text, klicken Sie auf die Schaltfläche Kursiv, und legen Sie den Text dann auf Segoe (Bold) fest.

  3. Ziehen Sie den Ziehpunkt auf der rechten Seite des Titeltextfelds, um dessen Größe auf die halbe Breite der Sicht in der linken oberen Ecke der Sicht festzulegen.

Balken- und Liniendiagramme

So erstellen Sie Balken- und Liniendiagramme

  1. Klicken Sie auf die leere Sicht.

  2. Ziehen Sie im Feldabschnitt der Feldliste in der Tabelle Items das Feld Category in die leere Sicht.

    Die Sicht enthält jetzt eine Tabelle mit einer Spalte.

  3. Ziehen Sie im Feldabschnitt der Feldliste in der Tabelle Quantities Sum of Qty Served in die einspaltige Tabelle Category.

    Die Tabelle enthält jetzt zwei Spalten mit einem Gesamtbetrag.

  4. Klicken Sie im Katalog Visualisierungen auf das Diagramm vom Typ Balken.

  5. Zeigen Sie auf den Rand des Diagramms, bis über einem der Ziehpunkte die Größenanpassungspfeile mit zwei Spitzen angezeigt werden. Ziehen Sie den Ziehpunkt, bis Sie alle Balken des Diagramms angezeigt werden.

  6. Zeigen Sie auf den Rand des Diagramms, bis das Handsymbol angezeigt wird. Das Handsymbol bedeutet, dass Sie das Diagramm verschieben können. Ziehen Sie das Diagramm in die linke untere Ecke des Berichts.

Balkendiagramm mit Ziehpunkten

Balkendiagramm mit Ziehpunkten

Kopieren und Einfügen einer Visualisierung

So kopieren Sie Elemente und fügen Sie ein

  1. Klicken Sie bei ausgewähltem Balkendiagramm im Menü Home auf Kopieren.

    Sie sehen möglicherweise eine Meldung, die Sie fragt, ob Sie es dieser Webanwendung ermöglichen möchten, auf die Zwischenablage zuzugreifen. Klicken Sie ggf. auf Ja.

  2. Klicken Sie außerhalb Balkendiagramm auf den leeren Zeichenbereich und dann auf Einfügen.

    Ein zweites Balkendiagramm wird in der Sicht eingefügt.

  3. Stellen Sie sicher, dass die Kopie des Diagramms ausgewählt ist. Klicken Sie im Layoutabschnitt der Feldliste im Feld Achse auf den Pfeil neben Kategorie und dann auf Feld entfernen.

  4. Klicken Sie im Feldabschnitt der Feldliste in der Tabelle Items auf den Dropdownpfeil neben dem Feld Distributors und dann auf Als Achse hinzufügen.

  5. Klicken Sie im Katalog Visualisierungen auf das Diagramm vom Typ Säule.

Hinzufügen einer zweiten Reihe zu einem Diagramm

  1. Klicken Sie im Feldabschnitt der Feldliste in der Tabelle Quantities auf den Dropdownpfeil neben dem Feld "Sum of Qty Consumed" und dann auf Zu Werten hinzufügen.

  2. Das Diagramm ist jetzt ein gestapeltes Säulendiagramm, wobei die Werte für "Qty Served" und "Qty Consumed" aufeinander gestapelt sind.

  3. Klicken Sie auf den Pfeil, um im Katalog Visualisierungen nach unten zu navigieren, und klicken Sie dann auf Karte.

    Jetzt stehen die Werte für "Qty Served" und "Qty Consumed" nebeneinander.

  4. Zeigen Sie auf den Rand des Diagramms, bis das Handsymbol angezeigt wird, und ziehen Sie dann das Diagramm in die rechte untere Ecke des Berichts.

  5. Zeigen Sie auf die obere rechte Ecke des Diagramms, bis über einem der Ziehpunkte die Größenanpassungspfeile mit zwei Spitzen angezeigt werden. Ziehen Sie den Ziehpunkt, bis das Diagramm halb so groß wie die Sicht und halb so breit ist.

Sortieren der Werte in einem Diagramm

  1. Wenn Sie auf das Verteilersäulendiagramm zeigen, sehen Sie sort by Distributor asc. Klicken Sie auf den Pfeil neben Distributors, und klicken Sie auf Qty Served.

    Jetzt werden die Leisten von der kleinste zur größten servierten Menge sortiert.

  2. Klicken Sie auf asc. Es ändert sich in desc, und die Leisten werden von der größten zur kleinsten servierten Menge sortiert.

Verschieben der Diagrammlegende

  • Mit dem ausgewählten Diagramm "Distributors" klicken Sie auf die Registerkarte Layout auf der Kontextregisterkarte Diagrammtools, klicken Sie auf Legende und dann auf Legende unten anzeigen.

Anordnen der Elemente in der Sicht

  1. Ziehen Sie das kleine Balkendiagramm "Serve" so, dass es im Vordergrund ist und sich in der rechten oberen Ecke des großen Verteilersäulendiagramms befindet.

    Standardmäßig befindet sich "Category", das erste Diagramm, das Sie erstellt haben, 'hinter' oder 'unter' dem zweiten Diagramm "Distributors".

  2. Klicken Sie bei weiterhin ausgewähltem Kategoriediagramm auf Eine Ebene nach vorne.

    Wenn das Kategoriediagramm nicht mehr ausgewählt ist und es jetzt völlig vom Verteilerdiagramm abgedeckt ist, wählen Sie einfach das Verteilerdiagramm aus, und klicken Sie auf Eine Ebene nach hinten.

Das Diagramm "Distributors" mit dem Diagramm "Categories" darüber und mit hervorgehobenen Früchten.

Balkendiagramm mit darüber gesetztem Säulendiagramm

Hervorhebung und Slicer

Sie können Daten im Bericht auf unterschiedliche Weise filtern und hervorheben. Dabei können Sie immer einen oder mehrere Werte auswählen.

So heben Sie ein Diagramm mit einem anderen Diagramm hervor

  • Klicken Sie im Kategorie-Balkendiagramm auf die Früchte-Leiste.

    Beachten Sie, dass die Werte im Distributors-Säulendiagramm hervorgehoben werden, um für jeden Verteiler die Menge Früchte anzuzeigen. Spalten für Verteiler ohne Frucht werden abgeblendet.

    TippTipp

    Um die Auswahl aufzuheben, klicken Sie in das Category-Diagramm, jedoch nicht auf eine Leiste.

So erstellen Sie einen Slicer

  1. Klicken Sie auf den leeren Teil der Sicht, damit keine der Visualisierungen ausgewählt ist.

  2. Wählen Sie in der Tabelle Items im Feldabschnitt der Feldliste Kategoriezeichnung aus.

  3. Klicken Sie auf der Registerkarte Entwurf auf Slicer.

    Der Slicer enthält vier Filterschaltflächen. Jede Schaltfläche enthält ein Bild für eine der vier Kategorien.

    HinweisHinweis

    Wenn Sie die Bilder der Kategorien nicht sehen, fehlen die Bilder möglicherweise. Lesen Sie den Abschnitt über das Speichern von Bildern unter Bevor Sie das Lernprogramm starten.

  4. Ziehen Sie diesen Slicer in die linke obere Ecke der Sicht, unter den Titel.

  5. Ändern Sie die Größe, damit Sie alle vier Kategorien sehen können.

So erstellen Sie einen zweiten Slicer

  1. Klicken Sie auf den leeren Teil der Sicht, damit keine der Visualisierungen ausgewählt ist.

  2. Wählen Sie in der Tabelle "Items" im Feldabschnitt der Feldliste Drawing aus.

  3. Klicken Sie auf der Registerkarte Entwurf auf Slicer.

    Dieser Slicer enthält Filterschaltflächen, eine für jedes Element, mit einem Bild für jedes Element.

  4. Ziehen Sie ihn rechts neben den Slicer "Kategoriezeichnung", und machen Sie ihn so groß, wie es die Sicht zulässt.

  5. Klicken Sie im Slicer "Kategoriezeichnung" auf eine der Kategorien.

    Beachten Sie, dass sich das Verhalten vom Hervorheben im Diagramm unterscheidet.

    • Jetzt werden alle Elemente in allen Visualisierungen des Berichts gefiltert und nicht nur hervorgehoben. Beispielsweise enthält das Balkendiagramm "Categories" jetzt nur einen Balken – die Kategorie, die Sie im Slicer ausgewählt haben. Das Säulendiagramm "Distributors" enthält jetzt nur die Spalten für die Verteiler in dieser Kategorie.

    • Es filtert die Elemente im anderen Slicer. Wenn Sie Getränke im Slicer "Kategoriezeichnung" auswählen, enthält der Slicer "Zeichnung" nur Getränke.

  6. Um wieder alle Werte anzuzeigen, klicken Sie in der rechten oberen Ecke des Slicers auf das Symbol Filter löschen.

Weitere Informationen finden Sie unter Filterung, Hervorhebung und Slicer in Power View.

Karten

So konvertieren Sie eine Tabelle in eine Karte

  1. Klicken Sie auf den leeren Teil der Sicht, um eine neue Visualisierung zu starten, und klicken Sie dann im Feldabschnitt der Feldliste auf den Tabellennamen Items.

  2. Es wird automatisch eine Tabelle mit den Feldern Category, Name und Color sowie Drawing erstellt.

    Diese sind die in dem Modell, nach dem dieser Bericht erstellt wird, definierten Standardfelder in der Tabelle.

  3. Klicken Sie in der ausgewählten Tabelle Items im Feldabschnitt der Feldliste auf das Feld Distributors.

    Es wird der Tabelle hinzugefügt.

  4. Klicken Sie bei ausgewählter Tabelle auf den Pfeil, um den Katalog Visualisierungen zu erweitern, und klicken Sie dann auf Karte.

  5. Ziehen Sie die Bildlaufleiste auf der rechten Seite der Karte, um einen Bildlauf durch die restlichen Karten durchzuführen.

    Beachten Sie, dass der Name und das Bild auffällig in jeder Karte angezeigt werden. Dies ist das Ergebnis der im Modell festgelegten Eigenschaften.

Kacheln

So erstellen Sie einen Kachelcontainer

  1. Ziehen Sie bei ausgewählten Karten das Feld Drawing aus den Feldern in der Karte, die im Feld Felder im Layoutabschnitt der Feldliste aufgelistet ist, in das Feld Kacheln nach im Layoutabschnitt.

    Hierdurch wird eine Reihe von Kacheln in einem Container erstellt, und zwar für jeden Wert im Feld Drawing eine Kachel. Beachten Sie, dass die Karte in der Kachel keine Bildlaufleiste mehr enthält. Sie wird nach dem Wert im Feld Drawing gefiltert.

    Nehmen Sie sich einen Moment Zeit, um auf die verschiedenen Früchte auf der Registerkartenleiste am oberen Rand des Kachelcontainers zu klicken. Achten Sie darauf, wie sich die Daten auf der Karte ändern.

  2. Ziehen Sie den Ziehpunkt auf der rechten Seite der Karte, um einen größeren Wert für die Höhe als für die Breite der Karte festzulegen.

  3. Zeigen Sie auf den Rand des Kachelcontainers, bis das Handsymbol angezeigt wird, und ziehen Sie dann den Container in die rechte obere Ecke des Berichts neben den Titel.

    TippTipp

    Kachelcontainer können durch Klicken auf den Rand gezogen werden, nicht durch Klicken auf die Registerkartenleiste.

    Tipps zum Auswählen, Verschieben und Ändern der Größe von Visualisierungen finden Sie unter "Arbeiten in der Sicht" unter Häufig gestellte Fragen, Problembehandlung, Tipps und Tricks zu Power View.

So fügen Sie dem Kachelcontainer Kacheln hinzu

  1. Wählen Sie den Kachelcontainer aus. Ziehen Sie den rechten Ziehpunkt des Kachelcontainers, um ihn dreimal so breit wie die Karte zu machen.

  2. Klicken Sie in den Kachelcontainer, jedoch nicht auf die Karte.

  3. Wählen Sie im Feldabschnitt der Feldliste in der Tabelle Dates das Feld Month Name aus.

    Hierdurch wird im Kachelcontainer eine neue Tabelle erstellt.

  4. Wählen Sie im Feldabschnitt der Feldliste in der Tabelle Items das Feld Name aus.

  5. Wählen Sie im Feldabschnitt der Feldliste in der Tabelle Quantities das Feld Sum of Qty Served.

  6. Klicken Sie im Katalog Visualisierungen auf das Diagramm vom Typ Linie.

    Das Liniendiagramm enthält eine Legende, jedoch benötigen Sie diese nicht, da das Diagramm nur eine Linie für das Nahrungsmittelelement in der Kachel enthält.

  7. Klicke Sie bei ausgewähltem Liniendiagramm auf der Registerkarte Layout der Kontextregisterkarte Diagrammtools auf Legende und dann auf Keine.

    Möglicherweise müssen Sie die Breite des Diagramms erhöhen, damit die Namen aller Monate angezeigt werden.

    Sie können die Größe der Karte und des Liniendiagramms im Kachelcontainer unabhängig vom Container ändern, jedoch müssen Sie eventuell zunächst die Größe des Containers erhöhen.

So experimentieren Sie mit Kacheln

  1. Klicken Sie auf die verschiedenen Speisen auf der Registerkartenleiste am oberen Rand des Kachelcontainers.

    Beachten Sie, wie sich die Karte und das Liniendiagramm auf den Kacheln ändern, um Werte für das ausgewählte Nahrungsmittel anzuzeigen.

    Aber beachten Sie auch, dass sich keine der anderen Visualisierungen in der Sicht ändert. Sie werden nicht vom Kachelcontainer gesteuert.

  2. Klicken Sie auf den Kachelcontainer, und klicken Sie auf der Registerkarte Entwurf in Kachelvisualisierungen auf Cover Flow.

    Möglicherweise müssen Sie die Größe des Kachelcontainers ändern, um die Karte und das Diagramm vollständig anzuzeigen.

  3. Klicken Sie wieder auf die Nahrungsmittelelemente im Cover Flow-Navigationslayout, oder ziehen Sie den Schieberegler, um Werte für unterschiedliche Nahrungsmittelelemente anzuzeigen.

Kachelcontainer mit Cover Flow-Navigation

Karte in Kachel mit Cover Flow-Navigation

Vergleichen von Hervorhebung und Slicer-Filterung

Da Sie jetzt mehrere andere Visualisierungen in der einen Sicht haben, können Sie sehen, wie sich Filtern und Hervorheben zwischen ihnen unterscheiden.

  1. Wählen Sie im Kategoriebalkendiagramm eine Leiste aus. Beachten Sie Folgendes:

    • Sie hebt verwandte Teile des anderen Diagramms hervor.

    • Sie filtert die Elemente in der Kachel.

    • Sie hat keine Auswirkungen auf die Slicer.

  2. Heben Sie diese Auswahl auf, indem Sie in das Balkendiagramm klicken, aber nicht auf eine Leiste.

  3. Wählen Sie im Slicer "Kategoriezeichnung" eine Kategorie aus. Beachten Sie Folgendes:

    • Filtert beide Diagramme und entfernt die nicht verknüpften Leisten und die Spalten.

    • Sie filtert die Elemente in der Kachel.

    • Filtert die Werte im Slicer "Zeichnung".

Hinzufügen einer weiteren Sicht

Der Bericht kann mehr als eine Sicht enthalten. Sie können ein Duplikat einer vorhandenen Sicht hinzufügen oder eine neue leere Sicht hinzufügen. Alle Sichten in einem Bericht basieren auf dem gleichen Modell.

So fügen Sie eine neue, leere Sicht hinzu

  • Klicken Sie auf der Registerkarte Home auf Neue Sicht.

  • Wählen Sie das Titeltextfeld aus, und drücken Sie ENTF.

Blasendiagramme

In Punktdiagrammen werden zwei Measures angezeigt, und in Blasendiagrammen werden drei Measures angezeigt.

So erstellen Sie ein Blasendiagramm

  1. Klicken Sie auf die neue leere Sicht, um eine neue Visualisierung zu starten.

  2. Wählen Sie im Feldabschnitt der Feldliste in der Tabelle Items das Feld Category aus.

  3. Wählen Sie im Feldabschnitt der Feldliste in der Tabelle Quantities die Measures Qty Served YTD (year-to-date, laufendes Jahr) und Sum of Qty Served aus.

    Beachten Sie, dass die Werte in jeder Spalte gleich sind, da für "Quantity Consumed YTD" kein Datum zum Verweisen angegeben ist.

  4. Klicken Sie auf die Diagrammschaltfläche Punkt.

  5. Ziehen Sie einen der Ziehpunkte, um die Größe des Punktdiagramms zu erhöhen.

  6. Ziehen Sie im Feldabschnitt der Feldliste in der Tabelle Quantities das Measure Sum of Qty Consumed in das Feld Größe im Layoutabschnitt Diagrammfelder.

    Dies ist eine Momentaufnahme der Gesamtbeträge. Die Werte auf den x- und y-Achsen sind die Gleichen.

    Wenn Sie eine Datumskomponente hinzufügen, können Sie erkennen, wie sich die Werte im Zeitverlauf ändern.

  7. Ziehen Sie im Feldabschnitt der Feldliste in der Tabelle Dates das Feld Month Name in das Feld Wiedergabeachse im Layoutabschnitt Diagrammfelder.

  8. Klicken Sie im Blasendiagramm auf den Wiedergabepfeil neben Month Name.

    Größe und Position der Blasen ändern sich entsprechend den Änderungen der zugehörigen Werte im Lauf der Monate. Beachten Sie, dass die Monate in der rechten oberen Ecke als Wasserzeichen angezeigt werden, dass sich die Blasen im Lauf der Monate nach rechts bewegen und dass die Menge im Lauf des Jahres (Qty Consumed YTD) zunimmt.

    HinweisHinweis

    Wenn das Blasendiagramm sehr klein ist, wird das Wasserzeichen möglicherweise nicht angezeigt.

  9. Klicken Sie auf eine der Blasen. Hierdurch werden zwei Aktionen ausgelöst:

    • Es wird eine Linie gezeichnet, die dem Pfad der Blase im Zeitverlauf entspricht.

    • Wenn es andere Visualisierungen in der Sicht gibt, wird der Wert der Blase in den anderen Tabellen im Bericht hervorgehoben und die Kacheln anhand dieses Werts gefiltert.

  10. Um die Blasen noch deutlicher anzuzeigen, können Sie das Diagramm vergrößern: Zeigen Sie auf die rechte obere Ecke des Diagramms, und klicken Sie auf das Popout-Symbol.

    Popout-Schaltfläche

    Popout (Symbol)

    Das Diagramm nimmt jetzt die gesamte Sicht ein, jedoch nur vorübergehend. Der Rest des Berichts wird darunter unverändert angezeigt, und wenn Sie erneut auf das Popout-Symbol klicken, wird die Visualisierung an der ursprünglichen Stelle im Bericht angezeigt.

  11. Klicken Sie erneut auf den Wiedergabepfeil, während eine Blase ausgewählt ist und das Diagramm den gesamten Zeichenbereich einnimmt.

  12. Beobachten Sie, wie sich die Blase auf ihrem Pfad bewegt.

    Blasendiagramm mit Wiedergabeachse und Datenbeschriftungen, den Pfad von Getränken nachzeichnend

    Blasendiagramm mit Blase zu Getränkeablaufverfolgung

  13. Um die ursprüngliche Größe des Blasendiagramms wiederherzustellen, klicken Sie erneut auf das Popout-Symbol.

  14. Ziehen Sie das Blasendiagramm in die linke obere Ecke der Sicht.

Hinzufügen von Kategoriegruppenfarben zu einem Punkt- oder Blasendiagramm

Manchmal werden die Informationen durch die Gruppierung in einem Punkt- oder Blasendiagramm nach Kategorie klarer.

So fügen Sie Kategoriegruppenfarben zu einem Blasendiagramm hinzu

  1. Ziehen Sie im Feldabschnitt der Feldliste das Namensfeld in das Feld "Details" im Layoutabschnitt der Feldliste, und ersetzen Sie das Kategoriefeld dort.

    Jetzt enthält das Blasendiagramm eine Blase für jedes Element. Es erstellt ein ausgelastetes Diagramm.

  2. Ziehen Sie das Kategoriefeld vom Feldabschnitt der Feldliste in das erste Farbfeld im Layoutabschnitt der Feldliste.

    Jetzt werden die Blasen abhängig von der Kategorie gefärbt, zu der sie gehören.

  3. Klicken Sie auf einen Kategorienamen in der Legende.

    Beachten Sie, dass die Elemente in dieser Kategorie im Blasendiagramm hervorgehoben werden.

Kleine Vielfache

Mit Kacheln und Slicern können Sie eine Reihe von nach einem bestimmten Wert gefilterten Diagrammen anzeigen. In diesem Lernprogramm filtern die Kacheln die Daten, um den Wert für eines der Nahrungsmittel anzuzeigen. Die Slicer filtern den Bericht nach einer oder mehreren Kategorien von Nahrungsmitteln.

Mit kleinen Vielfachen können Sie Daten in einer Reihe von kleinen Diagrammen nebeneinander anzeigen.

So erstellen Sie kleine Vielfache

  1. Klicken Sie auf den leeren Teil der Sicht neben dem Blasendiagramm, um eine neue Visualisierung zu starten.

  2. Klicken Sie im Feldabschnitt der Feldliste in der Tabelle Dates auf das Feld Month Name.

  3. Klicken Sie im Feldabschnitt der Feldliste in der Tabelle Quantities auf das Feld Sum of Qty Served.

  4. Klicken Sie im Katalog Visualisierungen auf das Diagramm vom Typ Linie.

    Dieses Liniendiagramm zeigt Mengen für alle Nahrungsmittel nach Monat an.

  5. Ziehen Sie den linken und den unteren Ziehpunkt, um das Diagramm zu vergrößern.

  6. Klicken Sie im Feldabschnitt der Feldliste in der Tabelle Items auf das Feld Name, und ziehen Sie es in das Feld Vielfache vertikal im Layoutabschnitt der Feldliste.

    Standardmäßig wurde eine Visualisierung erstellt, die jeweils neun Vielfache anzeigt. Sie stehen etwas dicht beieinander.

  7. Klicken Sie bei ausgewähltem kleinen Vielfachendiagramm auf der Registerkarte Layout der Kontextregisterkarte Diagrammtools auf Raster.

  8. Ziehen Sie die Maus, um drei Vielfache in horizontaler Richtung und zwei Vielfache in vertikaler Richtung auszuwählen.

    Jetzt werden sechs kleine Vielfache gleichzeitig angezeigt, daher werden die einzelnen kleinen Vielfachen deutlicher dargestellt.

  9. Um die Vielfachen noch deutlicher anzuzeigen, vergrößern Sie das Diagramm: Zeigen Sie auf die rechte obere Ecke des Diagramms, und klicken Sie auf das Popout-Symbol.

    Kleine Vielfache, die die Sicht ausfüllen

    Kleine Vielfache, die den Zeichenbereich ausfüllen

    Die kleinen Vielfachen füllen jetzt den gesamten Entwurfsbereich aus. Auch dies hat keine Auswirkungen auf die anderen Visualisierungen in der Sicht.

  10. Um die ursprüngliche Größe des Diagramms wiederherzustellen, klicken Sie erneut auf das Popout-Symbol.

  11. Ziehen Sie den kleinen Vielfachencontainer in die rechte untere Ecke der Sicht.

Sicht- und Visualisierungsfilter

Ähnlich wie Slicer filtern Sichtfilter die ganze Sicht, aber keine anderen Sichten in einem Bericht. Ein Vorteil von Sichtfiltern ist, dass sie in der Sicht keinen Platz erfordern. Ein weiterer Vorteil ist, dass erweiterte Filter eine weitaus größere Flexibilität bieten. Beispielsweise können Sie Teilwerte statt nur den gesamten Wert suchen.

Visualisierungsfilter sind ähnlich wie Sichtfilter, aber sie filtern einzelne Visualisierungen in einer Sicht und nicht die ganze Sicht.

So erstellen Sie einen Sichtfilter

  1. Klicken Sie auf der Registerkarte Home auf Filterbereich.

  2. Klicken Sie im Feldabschnitt der Feldliste in der Tabelle Dates auf Date, und ziehen Sie dieses Feld in den Filterbereich.

    Im einfachen Filtermodus können Sie einzelne Datumsangaben auswählen.

  3. Klicken Sie auf die Schaltfläche Erweiteter Filtermodus rechts neben dem Datum.

  4. Klicken Sie auf den Pfeil neben ist am oder nach und dann auf ist am oder vor.

  5. Klicken Sie auf den Kalender, und klicken Sie auf "31. August 2011".

  6. Klicken Sie auf Filter anwenden.

    Hierdurch werden Datumsangaben nach August 2011 entfernt.

So erstellen Sie einen Visualisierungsfilter

  1. Zeigen Sie auf die vertikalen Vielfache, und klicken Sie dann auf das Filtersymbol in der rechten oberen Ecke der Visualisierung.

    Beachten Sie, dass sich die Felder in der Visualisierung bereits im Filterbereich Diagramm befinden.

  2. Klicken Sie im Filterbereich auf Sum of Qty Served.

  3. Ziehen Sie das rechte Ende des Schiebereglers, damit der höchste Wert 400 beträgt.

    Beachten Sie, dass sich die Werteachse für die Vielfache jetzt geändert hat. Die höchste Zahl ist jetzt 400.

    Im Blasendiagramm ist der y-Wert, auch "Qty Served" unverändert - das Maximum beträgt immer noch 600.

Anzeigen des Berichts

Sie können den Bericht in der Vorschau anzeigen, und Sie können ihn im Präsentationsmodus anzeigen. In beiden Modi ist der Bericht weiterhin interaktiv. Wenn Sie auf Balken oder Säulen in den Diagrammen klicken, wird der Rest des Berichts entsprechend gefiltert und hervorgehoben. Die Feldliste und die Menübänder werden jedoch nicht angezeigt. Deshalb können Sie weder Felder hinzufügen noch Visualisierungen erstellen, und Sie können die Größe vorhandener Visualisierungen nicht ändern. Außerdem werden die Interaktionen nicht mit dem Bericht gespeichert.

So zeigen Sie den Bericht in der Vorschau an

  1. Klicken Sie auf der Registerkarte Home auf Lesemodus.

    Beachten Sie, dass der Filterbereich immer noch sichtbar ist.

  2. Klicken Sie auf die Symbole unten links oder auf die Zahlen unten rechts, um von einer Sicht zur anderen zu wechseln.

  3. Führen Sie einige der Interaktionen aus, die Sie zuvor im Lernprogramm ausgeführt haben:

    • Klicken Sie auf Leisten, Spalten oder Blasen in den Diagrammen.

    • Klicken Sie auf verschiedene Nahrungsmittel im Kachelcontainer.

    • Klicken Sie in einem Slicer auf ein Element.

  4. Anschließend können Sie in den Entwurfsmodus zurückkehren oder mit den Schaltflächen in der linken oberen Ecke in den Vollbildmodus wechseln. Klicken Sie auf Bericht bearbeiten.

So präsentieren Sie den Bericht

  1. Klicken Sie auf der Registerkarte Home auf Vollbild.

    Beachten Sie, dass der Filterbereich immer noch sichtbar ist.

  2. Führen Sie einige der Interaktionen aus, die Sie zuvor im Lesemodus versucht haben.

  3. Drücken Sie ESC, um den Vollbildmodus zu beenden.

Speichern des Berichts

So speichern Sie den Bericht

  1. Klicken Sie im Menü Datei auf Speichern oder Speichern unter.

    Das Dialogfeld Speichern unter enthält den Speicherort des Modells, anhand dessen der Bericht erstellt wird. Sie können diesen Speicherort ändern und den Bericht z. B. in einem Unterordner speichern, Sie müssen jedoch den Bericht auf demselben SharePoint-Server wie das Modell speichern.

  2. Geben Sie dem Bericht einen eindeutigen Namen.

    TippTipp

    Es wird ein Name empfohlen, der das Modell angibt, auf dessen Grundlage der Bericht erstellt wurde.

  3. Lassen Sie das Kontrollkästchen Include an image of each view in its current state as a preview for other users (in PowerPivot-Katalog und anderen Anwendungen) aktiviert. Weitere Informationen zu diesen Vorschaubildern finden Sie unter Auswählen, ob ein Bild jeder Sicht mit dem Bericht gespeichert werden soll.

Exportieren des Berichts nach PowerPoint

Sie können den Bericht nach PowerPoint exportieren. Er hat die gleiche Interaktivität, die er im Lesen- und im Vollbildmodus aufweist.

So exportieren Sie nach PowerPoint

  1. Klicken Sie im Menü Datei auf Nach PowerPoint exportieren.

  2. Blättern Sie an den Speicherort, an dem Sie die neue PowerPoint-Datei speichern möchten. Sie können die an einem beliebigen Speicherort ablegen, solange sie eine Verbindung mit dem auf dem SharePoint-Server gespeicherten Bericht herstellen kann.

  3. Öffnen Sie die PowerPoint-Präsentation.

    Jede Power View-Sicht wurde einer separaten Folie hinzugefügt. Im PowerPoint-Entwurfsmodus ist jede Folie eine statische Darstellung der Sicht.

    HinweisHinweis

    Wenn Sie nicht aus gewählt haben, ein Vorschaubild zu speichern, als Sie den Bericht gespeichert haben, wird keine statische Darstellung der Sicht im PowerPoint-Entwurfsmodus angezeigt.

  4. Nehmen Sie alle gewünschten Änderungen für die PowerPoint-Präsentation vor.

    HinweisHinweis

    Sie können die Größe der Power View-Sichten in PowerPoint ändern, aber Sie können die Sichten nicht bearbeiten.

  5. Klicken Sie in PowerPoint auf Diashow.

  6. Klicken Sie in der rechten unteren Ecke der Folie auf Zur interaktiven Nutzung hier klicken.

    Jetzt können Sie auf die gleiche Weise wie im Lese- und Vollbildmodi mit der Sicht interagieren.

Weitere Informationen finden Sie unter Erstellen, Speichern, Exportieren und Drucken von Power View-Berichten.

Nächste Schritte

Nachdem Sie jetzt dieses Lernprogramm abgeschlossen haben, können Sie in Power View mit eigenen Daten arbeiten. Weitere Informationen zum Erstellen von Datenmodellen für die Verwendung mit Power View finden Sie unter Lernprogramm: Optimieren eines PowerPivot-Beispielmodells für Power View-Berichte.

Siehe auch

Konzepte

Power View (SSRS)