Microsoft Visual C++ für Einsteiger

Veröffentlicht: 03. Jul 2000 | Aktualisiert: 15. Jun 2004

Von Ranga Narasimhan

Dieser Artikel wurde für Entwickler geschrieben, die sich bereits mit der Programmierung in C/C++ und Visual C++ auskennen. Er dient nicht als Handbuch für die Programmierung in C/C++.
Betrifft: Microsoft Visual C++, Version 6.0

Der Artikel wurde vorwiegend für die Visual C++ (VC++)-Umgebung konzipiert und stellt deren Konzepte und Anwendungsbereiche vor:

  • Erstellen eines einfachen, konsolenbasierten Win32-Programms mit Hilfe der Anwendungs-Assistenten.

  • Verstehen der Organisation von Projekten und Arbeitsbereichen.

  • Behandeln von Fehlern des Compilers bzw. Linkers.

Auf dieser Seite

Info zu Visual C++
Visual C++-Anwendungs-Assistenten
Konsolenprojekte oder Windows-Projekte?
Arbeitsbereich und Projekte
Erstellen einer Win32-Konsolenanwendung
Hinzufügen von Dateien zu einem Projekt
Navigation
Kompilieren und Linken
Bereinigen und Kopieren eines Projekts
Behandeln von Fehlern beim Erstellen
Hinzufügen von neuen und vorhandenen Projekten zu einem Arbeitsbereich
Tipps
Schlussfolgerung
Weitere Informationen

Info zu Visual C++

Microsoft ® Visual C++ 6.0 ist ein Mitglied der Visual Studio 6.0-Familie von Entwicklungsprodukten. Es ist in drei Editionen erhältlich: Standard, Professional und Enterprise. Weitere Informationen finden Sie unter "Visual C++-Editionen" in der MSDN Library.

Visual C++ (VC++) bietet eine integrierte Entwicklungsumgebung (Integrated Development Environment, IDE), mit deren Hilfe Sie 32-Bit-C/C++-Programme schreiben, erstellen und debuggen können. Außerdem ermöglicht es die einfache Navigation im Quellcode (weitere Informationen finden Sie in diesem Artikel unter ).

Visual C++-Anwendungs-Assistenten

VC++ enthält eine Reihe von Anwendungs-Assistenten, die Sie schrittweise durch das Erstellen eines neuen Programms leiten. Diese Anwendungs-Assistenten geben einige grundlegende Einstellungen und/oder Codeanweisungen vor und sparen somit einigen Zeitaufwand. Es ist wichtig, dass Sie den richtigen Anwendungs-Assistenten für den zu erstellenden Anwendungstyp wählen.

So zeigen Sie die Anwendungs-Assistenten an

  1. Klicken Sie im Menü Datei auf Neu.

  2. Klicken Sie auf die Registerkarte Projekte. Die Anwendungs-Assistenten werden wie in Abbildung 1 angezeigt.

  3. Wählen Sie Win32-Konsolenanwendung aus der Liste. Mit diesem Anwendungs-Assistenten können Sie ein Konsolenprogramm erstellen, das die Funktionen der Konsolen-API (die API ist die Schnittstelle zur Anwendungsprogrammierung) nutzt, die eine Zeichenmodusunterstützung in Konsolenfenstern bieten.

    Bild01

    Abbildung 1. Der Anwendungs-Assistent zum Erstellen einer Win32-Konsolenanwendung

    Tipp Weitere Informationen finden Sie in der MSDN Library unter "Übersicht: Erstellen eines Konsolenprogramms".

Konsolenprojekte oder Windows-Projekte?

Ein Konsolenprogramm wird immer an der MS-DOS-Eingabeaufforderung ausgeführt. Es handelt sich um ein 32-Bit-Programm, jedoch nicht um ein Windows-Programm. Als erste Funktion in einem C/C++-konsolenbasierten Programm wird die main()-Funktion aufgerufen:

int main(int argc, char *argv[])

Die erste aufgerufene Funktion in einem Windows-basierten Programm ist:

int WINAPI WinMain(HINSTANCE hInstance, HINSTANCE hPrevInstance, LPSTR lpCmdLine, int nCmdShow)

Eine Konsolenanwendung stellt keine Benutzeroberfläche, z.B. Dialogfelder, zur Verfügung. Als Einsteiger in die Programmierung mit C/C++ sollten Sie sich anfangs auf das Erstellen von Konsolenanwendungen konzentrieren.

Arbeitsbereich und Projekte

In VC++ werden Programme, die mit den Anwendungs-Assistenten erstellt werden, als Gruppe von Projekten in einem Arbeitsbereich organisiert. Ein Arbeitsbereich besteht also aus Projekten, und diese einzelnen Projekte enthalten Dateien. Projekte können Dateien gemeinsam nutzen. In der folgenden Abbildung wird diese Organisation verdeutlicht.

Bild02

Abbildung 2. Organisation in Arbeitsbereich und Projekte in Visual C++

Der Beispielbereich in der obigen Abbildung enthält drei Projekte: A, B und C. Diese Projekte können unterschiedliche C++-Dateien enthalten: z.B. a.cpp, b.cpp und c.cpp. Diese Dateien werden von den drei Projekten gemeinsam genutzt.

Die Arbeitsbereichinformationen werden in Dateien mit der Erweiterung .dsw gespeichert, die Projektinformationen in Dateien mit der Erweiterung .dsp. Die Anwendungs-Assistenten erstellen standardmäßig einen Arbeitsbereich und ein Projekt; das Hinzufügen weiterer Projekte zu einem Arbeitsbereich wird in einem nachfolgenden Abschnitt beschrieben. Weitere Informationen zu den Startdateien, die VC++ für Ihr Projekt anlegt, finden Sie in der MSDN Library unter "Dateitypen, die für Visual C++-Projekte erstellt werden".

So öffnen Sie einen Arbeitsbereich

  1. Klicken Sie im Menü Datei auf Arbeitsbereich öffnen.

  2. Suchen Sie nach der Arbeitsbereichsdatei mit der Erweiterung .dsw.

Alternativ dazu können Sie die Projektdatei (*.dsp) öffnen. Mit den Dateinamenerweiterungen .dsw und .dsp sind Shellerweiterungen verknüpft. Sie können also den Windows-Explorer verwenden, um nach DSW- oder DSP-Dateien zu suchen, und auf die entsprechende Datei doppelklicken, um den Arbeitsbereich in VC++ zu öffnen.

Erstellen einer Win32-Konsolenanwendung

Folgen Sie den unten angegebenen Schritten, um ein neues Konsolenprojekt zu erstellen.

So erstellen Sie ein neues Konsolenprojekt

  1. Klicken Sie im Menü Datei auf Neu und dann auf die Registerkarte Projekte.

  2. Klicken Sie auf Win32-Konsolenanwendung.

  3. Geben Sie den Speicherort für Ihr Projekt in das Feld Pfad ein.

  4. Geben Sie den Namen für Ihr Projekt in das Feld Projektname ein. Im Feld Pfad wird automatisch ein umgekehrter Schrägstrich hinter dem in Schritt 2 eingegebenen Projektnamen angefügt. Ihre Projektdateien werden in einem Unterverzeichnis des Speicherpfads abgelegt.
    Abbildung 3 zeigt ein Win32-Konsolenprojekt mit dem Namen "Testprogramm", das im Verzeichnis C:\Programme\Testprogramm erstellt wird:

    Bild03

    Abbildung 3. Erstellen eines neuen Konsolenprojekts

  5. Klicken Sie auf OK. Das Dialogfeld Win32-Konsolenanwendung – Schritt 1 von 1 wird angezeigt.

  6. Übernehmen Sie die Standardeinstellung (Ein leeres Projekt), und klicken Sie auf Fertigstellen. Über die anderen Optionen werden Dateien erstellt und zusätzliche Einstellungen hinzugefügt (siehe Abbildung 4).

    Bild04

    Abbildung 4. Das Dialogfeld "Win32-Konsolenanwendung – Schritt 1 von 1"

    Anmerkung für VC++ 5.0-Benutzer Dieses Dialogfeld ist bei Ihnen nicht vorhanden. Überspringen Sie also Schritt 6. Der Anwendungs-Assistent erstellt standardmäßig ein leeres Projekt.

  7. Im letzten Dialogfeld Informationen zum neuen Projekt wird der Inhalt und eine Zusammenfassung des gerade von Ihnen erstellten Projekts angezeigt. Klicken Sie auf OK.

VC++ erstellt die folgende Dateigruppe als Teil des Projekts "Testprogramm" und platziert diese im Verzeichnis C:\Programme\Testprogramm:

  • Testprogramm.DSW: Arbeitsbereichsdatei

  • Testprogramm.DSP: Projektdatei

  • Testprogramm.OPT: Arbeitsbereichkonfigurationsdatei

  • Testprogramm.NCB: Informationsdatei der Klassenansicht (enthält auch Informationen zur automatischen Vervollständigung)

Weitere Informationen zu den Startdateien, die VC++ für Ihr Projekt erzeugt, finden Sie in der MSDN Library unter "Dateitypen, die für Visual C++-Projekte erstellt werden".

Anmerkung Löschen Sie nicht die DSW- und DSP-Dateien. Die OPT- und NCB-Dateien können umbenannt oder gelöscht werden, da VC++ sie beim Öffnen des Arbeitsbereichs neu erzeugt.

Wenn Sie den vorgenannten Schritten folgen, wird ein Arbeitsbereich mit einem leeren Projekt erstellt. Ein leeres Projekt enthält noch keine Quelldateien. Sowohl das Projekt als auch der Arbeitsbereich haben den Namen "Testprogramm". Folgen Sie den hier genannten Schritten, um dem leeren Projekt eine Datei hinzuzufügen:

So fügen Sie dem leeren Projekt eine Datei hinzu

  1. Klicken Sie im Menü Datei auf Neu und dann auf die Registerkarte Dateien.

  2. Klicken Sie auf C++-Quellcodedatei.

  3. Geben Sie einen Dateinamen im Textfeld Dateiname an. Standardmäßig ist das Kontrollkästchen Dem Projekt hinzufügen aktiviert. Außerdem ist die Standard-Dateinamenerweiterung .cpp. Wenn Sie z.B. Test eingeben, lautet der Dateiname Test.cpp. Wenn Sie der Datei die Erweiterung .c geben möchten, müssen Sie dies angeben (siehe Abbildung 5).

    Bild05

    Abbildung 5. Das Dialogfeld "Neu"

  4. Klicken Sie auf OK.

  5. Geben Sie in der leeren Datei die folgende Codeanweisung ein:

        #include<stdio.h> 
        float ver; 
        void main() 
        { 
            ver = 6.0; 
            printf("Willkommen in Visual C++ %.1f\n",ver); 
        }
    
  6. Klicken Sie im Menü Erstellen auf Testprogramm.exe erstellen, oder drücken Sie die Taste F7. Hierdurch wird der Erstellungsvorgang gestartet, zu dem das Kompilieren und Linken des gesamten Projekts gehören. Wenn Sie viele Dateien im Projekt haben, werden alle Dateien erstellt. Der Fortschritt des Erstellungsvorgangs wird im Fenster Ausgabe am unteren Rand der VC++-IDE angezeigt. Für dieses Projekt sollte Folgendes angezeigt werden (siehe Abbildung 6):

    Bild06

    Abbildung 6. Das Fenster "Ausgabe"

Die Einzelheiten im Abbildung 6 zeigen, dass die ausführbare Datei Testprogramm.exe erfolgreich ohne Fehler und Warnungen erstellt wurde. Sobald ein Fehler während der Erstellung auftritt, wird eine Fehlermeldung in diesem Fenster ausgegeben. Außerdem sehen Sie die Zeile Konfiguration: Testprogramm – Win32 Debug. Dies ist die Standardkonfiguration. Sie kann in die Konfiguration Win32 Release oder eine benutzerdefinierte Konfiguration geändert werden. Weitere Informationen finden Sie unter .

Wenn Sie nur die geöffnete Datei kompilieren möchten, müssen Sie den Befehl Kompilieren von Test.cpp aus dem Menü Erstellen wählen. Über diese Aktion wird keine ausführbare Datei erzeugt. Weitere Informationen finden Sie unter in diesem Artikel.

So führen Sie "Testprogramm.exe" aus

  1. Klicken Sie im Menü Erstellen auf Ausführen von Testprogramm.exe, oder drücken Sie STRG+F5. Es wird eine MS-DOS-Eingabeaufforderung mit dem Text Willkommen in Visual C++ 6.0 angezeigt.

  2. Drücken Sie eine beliebige Taste, um fortzufahren.

Hinzufügen von Dateien zu einem Projekt

Wie bereits erwähnt, kann ein Projekt viele Dateien mit verschiedenen Erweiterungen hosten, z.B. .h, .rc usw. Wenn Sie dem Konsolenprojekt Testprogramm eine Header-Datei (.h) hinzufügen möchten (siehe "Erstellen einer Win32-Konsolenanwendung"), müssen Sie das hier genannte Verfahren einhalten.

So fügen Sie dem Konsolenprojekt "Testprogramm" eine Header-Datei (.h) hinzu

  1. Klicken Sie im Menü Datei auf Neu und dann auf die Registerkarte Dateien.

  2. Klicken Sie auf C/C++-Header-Datei.

  3. Geben Sie den Namen für Ihre Datei in das Feld Dateiname ein. Die Standard-Dateinamenerweiterung ist .h. Wenn Sie z.B. test eingeben, lautet der Dateiname test.h. Wenn Sie der Datei eine andere Erweiterung geben möchten, müssen Sie dies angeben.

  4. Klicken Sie auf OK. Anmerkung Standardmäßig ist das Kontrollkästchen Dem Projekt hinzufügen aktiviert. Deaktivieren Sie dieses Kontrollkästchen bitte nicht; anderenfalls kann die Datei während des Erstellungsvorgangs nicht gebaut werden.

So fügen Sie vorhandene Dateien hinzu

  1. Öffnen Sie in VC++ das Projekt, dem Sie Dateien hinzufügen möchten.

  2. Klicken Sie im Menü Projekt auf Dem Projekt hinzufügen.

  3. Klicken Sie auf Dateien.

  4. Wählen Sie im Dialogfeld Dateien in Projekt einfügen die Datei(en) aus, und klicken Sie auf OK.

So können Sie vorhandene Dateien wieder verwenden. Die Codewiederverwendung macht C++ zu einer extrem leistungstarken Programmiersprache.

Die Navigation ist ein Kinderspiel in VC++, wenn Sie das Fenster Arbeitsbereich verwenden. Sie starten dieses Fenster, indem Sie im Menü Ansicht den Befehl Arbeitsbereich wählen. Nachdem Sie das Konsolenprojekt Testprogramm erstellt haben (siehe "Erstellen einer Win32-Konsolenanwendung"), werden Sie feststellen, dass das Fenster Arbeitsbereich zwei Registerkarten enthält: Klassen und Dateien (siehe Abbildung 7).

Bild07

Abbildung 7. Das Fenster "Arbeitsbereich"

Klassen

Auf der Registerkarte Klassen werden die C++-Klassen und die globalen Daten angezeigt, die im Projekt vorliegen. Für das Projekt Testprogramm werden die Testprogramm Klassen angezeigt (wie in Abbildung 7). Erweitern Sie diesen Knoten, indem Sie auf das Pluszeichen (+) klicken. Es wird ein Ordner Global sichtbar. Erweitern Sie diesen Ordner auf die Einträge main und ver. Wenn Sie die Datei mit der main-Funktion abrufen möchten, doppelklicken Sie auf main. Die Datei Test.cpp wird geöffnet. Das Caretzeichen wird in die main-Funktion positioniert.

Weitere Informationen zur Klassenansicht finden Sie unter "Übersicht: Klassenansicht" in der MSDN Library.

Dateien

Auf der Registerkarte Dateien werden die Dateien angezeigt, die zu Ihrem Projekt gehören. Für das Projekt Testprogramm werden die Testprogramm Dateien angezeigt. Wenn Sie den Knoten erweitern (durch Klicken auf das +-Zeichen), sehen Sie Quellcodedateien, Header-Dateien und Ressourcendateien. Da das Projekt nur eine einzige Datei enthält (Test.cpp), sollten Sie diese unter dem Ordner Quellcodedateien sehen. Wenn Sie eine weitere Datei hinzufügen, z.B. test.h, muss diese unter dem Ordner Header-Dateien erscheinen. Diese Ordner enthalten Dateien mit den entsprechenden Erweiterungen; die Quellcodedateien haben normalerweise die Dateiendung .c oder .cpp, die Header-Dateien enden auf .h. Wenn Sie eine Datei im Quellcode-Editor öffnen möchten, können Sie auf diese Datei doppelklicken (siehe Abbildung 8).

Bild08

Abbildung 8. Die Registerkarte "Dateien"

Weitere Informationen zur Dateienansicht finden Sie unter "Dateien (Dateiansicht)" in der MSDN Library.

Sie können auch die Assistentenleiste zur Navigation verwenden. Aktivieren Sie diese wie folgt:

So aktivieren Sie die Assistentenleiste

  1. Klicken Sie im Menü Extras auf Anpassen.

  2. Klicken Sie auf die Registerkarte Symbolleisten.

  3. Klicken Sie im Listenfeld Symbolleisten auf Assistentenleiste (im linken Fensterausschnitt).

Weitere Informationen finden Sie unter "Übersicht: Die Assistentenleiste" in der MSDN Library.

Kompilieren und Linken

Beim Kompilieren werden Objektdateien (OBJ-Dateien) und andere temporäre Dateien erstellt. Der VC++-Compiler CL.EXE empfängt alle Projektdateien als Eingabe, um für diese Dateien die entsprechenden Objektdateien zu erzeugen. Für das im vorherigen Abschnitt erstellte Konsolenprojekt wird ein Zielverzeichnis unter C:\Programme\Testprogramm erstellt, je nachdem, welche Konfiguration Sie gewählt haben. In diesem Verzeichnis werden Objektdateien, temporäre Dateien und ausführbare Dateien gespeichert.

Die Standardkonfiguration lautet Win32 Debug. In dieser Konfiguration wird die ausführbare Datei im Verzeichnis C:\Programme\Testprogramm\Debug gespeichert. In der Debugkonfiguration enthalten Ihre Codeanweisungen Debuginformationen, mit denen Sie Ihre Anwendung problemlos testen können. In der Debugkonfiguration ist der Code nicht optimiert. Die andere Konfiguration, die VC++ zur Verfügung stellt, ist der Typ Win32 Release. Diese Konfiguration verfügt über Einstellungen zur Codeoptimierung und enthält keine Debuginformationen. Code, der mit dem Release-Typ gebaut wird, befindet sich nach dem Kompilieren im Verzeichnis C:\Programme\Testprogramm\Release. Weitere Informationen finden Sie unter "Projekt-Arbeitsbereichsansichten" in der MSDN Library.

Der Linker (LINK.EXE) hat die Funktion, die OBJ-Dateien und anderen temporären Dateien als Eingabe zu übernehmen und die endgültige EXE-Datei zu erzeugen. Während des Erstellungsvorgangs wird erst der Compiler und dann der Linker ausgeführt. Wenn Sie eine ausführbare Datei erzeugen möchten, müssen Sie das Projekt erstellen. Wenn Sie nur die Datei kompilieren, wird eine OBJ-Datei erzeugt.

Dieser Erstellungsvorgang kann am besten anhand des folgenden Diagramms (Abb. 9) veranschaulicht werden.

Bild09

Abbildung 9. Diagrammmäßige Darstellung des Erstellungsvorgangs

In dem in Abbildung 10 dargestellten Fenster Ausgabe werden die Ergebnisse des Erstellens angezeigt.

Bild10

Abbildung 10. Das Fenster "Ausgabe" mit den Ergebnissen des Erstellens

In diesem Fall enthält das Verzeichnis C:\Programme\Testprogramm\Debug die ausführbare Datei Testprogramm.exe.

Die Erstellungsergebnisse werden außerdem noch in einer Datei mit der Erweiterung .plg gespeichert. Beim Projekt Testprogramm sind diese Informationen also in der Datei Testprogramm.plg enthalten. Weitere Informationen finden Sie unter "Kompilieren und Binden" in der MSDN Library.

Bereinigen und Kopieren eines Projekts

Sie bereinigen ein Projekt, indem Sie im Menü Erstellen auf Bereinigen klicken. Durch das Bereinigen eines Projekts werden alle Dateien aus dem Zielverzeichnis (dies kann je nach Konfiguration des Projekts entweder das Verzeichnis Debug oder das Verzeichnis Release sein) sowie die ausführbare Datei entfernt. Wenn Sie Ihr Projekt an einen anderen Speicherort kopieren möchten (z.B. auf Diskette), sollten Sie das Projekt ggf. bereinigen. So reduzieren Sie die Größe des Projekts und beschleunigen damit die Kopiervorgänge. Für das Projekt Testprogramm könnten Sie z.B. das gesamte Verzeichnis per Drag & Drop an den neuen Speicherort verschieben. Wenn Sie die ausführbare Datei nach einem Bereinigungsvorgang erzeugen möchten, müssen Sie sie neu erstellen.

Behandeln von Fehlern beim Erstellen

Es gibt viele Gründe, warum es im Compiler bzw. Linker zu Fehlern kommen kann. Unter Umständen wurden nicht die richtigen Header-Dateien eingebunden, es wurden Fehler bei der Eingabe gemacht, die Schalter des Compilers/Linkers wurden nicht korrekt verwendet, o.Ä. Alle Informationen bezüglich Fehlern, gleich welcher Art, werden in das Fenster Ausgabe geschrieben.

Nehmen wir an, Sie haben alle Anweisungen unter in diesem Artikel beachtet und das Projekt Testprogramm erstellt. Lassen Sie uns nun einen Fehler in die Datei Test.cpp einbauen. Löschen Sie den Inhalt der Datei, und geben Sie die folgenden Codezeilen ein:

#include<stdio.h> 
float ver; 
void main() 
{ 
      ver = 6.0; 
      print("Willkommen in Visual C++ %.1f\n",ver); //wir haben printf durch print ersetzt 
} 

Erstellen Sie das Projekt. Im Fenster Ausgabe wird daraufhin die folgende Fehlermeldung angezeigt (in Abb. 11):

Bild11

Abbildung 11. Das Fenster "Ausgabe" mit einer Fehlermeldung

Im Fenster ist zu sehen, dass der Fehler in Zeile 8 der Datei Test.cpp auftrat. Sie gelangen dorthin, indem Sie entweder auf die angezeigte Fehlermeldung doppelklicken oder die Taste F4 drücken. Dies ist besonders nützlich, wenn Sie mit großen Dateien arbeiten.

Jede Fehlernummer hat eine bestimmte Bedeutung. Sie kann aus dem Hilfesystem von VC++ (MSDN Library) ermittelt werden. In diesem Fall hat der Fehler die Nummer C2065. Sie können die verschiedenen Ursachen für diesen Fehler anzeigen, indem Sie Folgendes tun:

So ermitteln Sie die Ursache eines Fehlers

  1. Setzen Sie mit der Maus das Caretzeichen (^) der Tastatur in den Fehlercode für den Compiler-Fehler C2065 im Fenster Ausgabe. Vergewissern Sie sich, dass das Caretzeichen im Fehlercode blinkt; anderenfalls werden Sie nicht zum richtigen Hilfethema geführt.

  2. Drücken Sie die Taste F1.

  3. Für C2065 gibt es zwei Themen. Wählen Sie das Thema, bei dem Visual C++-Programmierhandbuch als Speicherort angegeben wird. Das Thema wird auf der rechten Seite angezeigt. Als Tipp wird angegeben, "dass der Name des Bezeichners richtig geschrieben sein muss." Wir wissen, dass dies unser Fehler ist.

Alternativ dazu können Sie die folgenden Schritte durchführen, um die gleichen Informationen zu erhalten:

  1. Klicken Sie in VC++ im Menü Hilfe auf Index.

  2. Geben Sie C2065 in das Feld Zu suchendes Schlüsselwort ein. Das mit dem Schlüsselwort verknüpfte Hilfethema wird in einem Listenfeld unter dem Bearbeitungsfeld angezeigt.

  3. Doppelklicken Sie auf C2065. Für C2065 gibt es zwei Themen.

  4. Wählen Sie das Thema, bei dem Visual C++-Programmierhandbuch als Speicherort angegeben wird. Das Thema wird auf der rechten Seite angezeigt. Als Tipp wird angegeben, "dass der Name des Bezeichners richtig geschrieben sein muss." Wir wissen, dass dies unser Fehler ist.

Die Informationen in printf werden in der Header-Datei stdio.h gespeichert, die in der ersten Zeile angegeben ist. Wenn Sie die Datei stdio.h öffnen, werden Sie feststellen, dass es keine Funktion mit dem Namen print gibt. Das ist die Ursache für den Compiler-Fehler. Würde es eine Funktion mit dem Namen print geben, hätte der Compiler womöglich keinen Fehler zurückgegeben. Das Laufzeitverhalten der EXE-Datei hätte allerdings u.U. zu unerwarteten Ergebnissen führen können.

Die Fehlernummern können Sie der MSDN Library entnehmen. Sie können die MSDN Library Online über den folgenden Hyperlink aufrufen: MSDN Library.

Hinzufügen von neuen und vorhandenen Projekten zu einem Arbeitsbereich

In den folgenden Abschnitten wird erläutert, wie Sie ein neues Projekt und ein vorhandenes Projekt hinzufügen.

Hinzufügen von neuen Projekten

Sie fügen dem vorhandenen Arbeitsbereich ein neues Projekt auf die gleiche Weise hinzu, wie Sie es beim Erstellen des Projekts Testprogramm gelernt haben (siehe ). Es gibt allerdings eine Ausnahme:

  • Wählen Sie im Dialogfeld Neu die Option Hinzufügen zu akt. Arbeitsbereich. Sie werden bemerken, dass sich der Projektspeicherort daraufhin unmittelbar ändert.

Wenn Sie z.B. ein neues Projekt mit dem Namen WeiteresTestprogramm in das Projekt Testprogramm einfügen, wird durch das Aktivieren der Option Hinzufügen zu akt. Arbeitsbereich der Pfad von C:\Programme\WeiteresTestprogramm in C:\Programme\Testprogramm \WeiteresTestprogramm geändert (siehe Abbildung 12).

Bild12

Abbildung 12. Hinzufügen eines neuen Projekts zu einem vorhandenen Arbeitsbereich

Hinzufügen von vorhandenen Projekten

Folgen Sie den unten angegebenen Schritten, um ein vorhandenes Projekt hinzuzufügen.

So fügen Sie vorhandene Projekte hinzu

  1. Klicken Sie im Menü Projekt auf Projekt in den Arbeitsbereich einfügen.

  2. Wählen Sie im Dialogfeld Projekte in Arbeitsbereich einfügen das bzw. die einzufügende(n) Projekt(e) aus. In diesem Schritt sollten Sie nach der bzw. den DSP-Datei(en) suchen, die das bzw. die Projekt(e) darstellen.

Wenn Sie einem vorhandenen Projekt ein Projekt hinzufügen, werden im Fenster Arbeitsbereich alle Projekte angezeigt. Durch das Hinzufügen des Projekts "WeiteresTestprogramm" zum Projekt Testprogramm werden in der Dateiansicht beide Projekte angezeigt (siehe Abbildung 13).

Bild13

Abbildung 13. Hinzufügen zu einem vorhandenen Projekt

Beachten Sie, dass WeiteresTestprogramm Dateien fett dargestellt ist. Das bedeutet, dass dies das aktive Projekt ist. Wenn Sie eine Erstellung starten, wird das aktive Projekt erstellt. Sie können das aktive Projekt einstellen, indem Sie im Menü Projekt auf Aktives Projekt festlegen klicken.

Weitere Informationen finden Sie unter "Homepage: Arbeiten mit Projekten" in der MSDN Library.

Tipps

  • Vermeiden Sie die folgenden Aktionen:

    • Direktes Erstellen eines Projekts auf einer Diskette und anschließendes Erstellen. Der Speicherplatz wird in diesem Fall knapp.

    • Zweimaliges Öffnen des gleichen Projekts in verschiedenen Instanzen von VC++ auf dem gleichen Computer.

    • Löschen und Ändern der DSP- und DSW-Dateien in VC++. Weitere Informationen zu den Startdateien, die VC++ für Ihr Projekt erzeugt, finden Sie in der MSDN Library unter "Dateitypen, die für Visual C++-Projekte erstellt werden".

  • Wenden Sie die neuesten Service Packs für VC++ an. Service Packs können unter http://msdn.microsoft.com/vstudio/sp/vs6sp3/default.asp bestellt oder downgeloadet werden.

  • Wenn Sie eine Liste der Tastenkombinationen benötigen, klicken Sie auf Hilfe &#124 Tastaturbelegung.

Schlussfolgerung

In diesem Artikel wurden die grundlegenden Konzepte der Navigation durch die Visual C++-IDE und das Erstellen eines einfachen C/C++-Programms anhand von leicht verständlichen Beispielen demonstriert. Für weitere Übungszwecke haben wir eine Liste mit Referenzen zusammengestellt. Mit diesem Artikel möchten wir die anfänglichen Barrieren abbauen, die sich neuen Programmierern stellen, wenn diese versuchen, C/C++-Programme mit Visual C++ zu erstellen.

Weitere Informationen

Lesen Sie die folgenden Referenzmaterialien, wenn Sie weitere Informationen zu VC++ benötigen:

Weitere Informationen zur C++-Programmierung finden Sie hier: