Erstellen von Projekten und Projektmappen

Wenn Sie ein Projekt erstellen, erstellt Visual Studio dafür eine Projektmappe.Informationen zum Erstellen einer Projektmappe mit mehreren Projekten finden Sie unter Gewusst wie: Erstellen von Projektmappen mit mehreren Projekten.Informationen zum Erstellen eines Projekts aus vorhandenen Codedateien finden Sie unter Gewusst wie: Erstellen von Projekten aus vorhandenen Codedateien.

HinweisHinweis

Wenn Ihre Antivirensoftware eine Warnung ausgibt, in der angeboten wird, ein von der Projektvorlage oder vom Assistenten ausgeführtes Skript zu sperren, sollten Sie diese Option nicht aktivieren, da Visual Studio andernfalls beendet wird.Sie können die Anzeige dieser Meldung bei Ausführung dieses Skripts unterbinden, indem Sie in der Antivirensoftware die Einstellung für das Blockieren von Skripts deaktivieren.Bedenken Sie jedoch, dass dadurch jedes Skript zugelassen wird und nicht nur Skripts für Visual Studio.

HinweisHinweis

Die Beschreibungen in diesem Thema basieren auf der Visual Studio Professional-Edition.Die Dialogfelder und Menübefehle können von den hier beschriebenen abweichen (je nach Ihren aktiven Einstellungen oder der Visual Studio-Edition).Klicken Sie im Menü Extras auf Einstellungen importieren und exportieren, um die Einstellungen zu ändern.Weitere Informationen finden Sie unter Anpassen der Entwicklungseinstellungen in Visual Studio.

Projekte und Vorlagen

In Visual Studio werden neue Projekte anhand der Benutzereingabe über Projektvorlagen generiert.Jede Vorlage stellt einen anderen Projekttyp dar.Einzelne Dateien, die Benutzer Projekten hinzufügen, werden anhand von Elementvorlagen generiert.

Installierte Projektvorlagen können Sie im Dialogfeld Neues Projekt suchen, indem Sie in der Erweiterungsliste links unter Installiert navigieren.Sie können unter Zuletzt zu Projekttypen navigieren, die Sie zuletzt verwendet haben, oder unter Online zu Vorlagen, die Sie herunterladen und installieren können.

Zudem können Sie auch das Suchfeld rechts oben im Dialogfelds verwenden, um nach Projektvorlagen zu suchen.Bei der Suche wird der mittlere Bereich je nach ausgewählter Kategorie mit Ergebnissen aus den Listen der zuletzt verwendeten, installierten oder Onlinevorlagen aufgefüllt.Weitere Informationen finden Sie unter Erstellen von Projekten aus Vorlagen.

Erstellen von Projekten

Wenn ein Projekt erstellt wird, wird automatisch eine Projektmappe generiert, sofern das Projekt nicht bereits Teil einer Projektmappe ist.

So erstellen Sie ein Projekt zusammen mit der Mappe für dieses Projekt

  1. Klicken Sie im Menü Datei auf Neu und anschließend auf Projekt.

    TippTipp

    Abhängig von den ausgewählten Entwicklungseinstellungen können die Optionen Datei und dann Neues Projekt angezeigt werden.Weitere Informationen zu den Einstellungen finden Sie unter Anpassen der Entwicklungseinstellungen in Visual Studio.

    Das Dialogfeld Neues Projekt wird geöffnet.

  2. Wählen Sie im linken Bereich Installiert aus, und wählen Sie in der erweiterten Liste eine Kategorie der Projekttypen aus.

    Wenn Sie vor Kurzem ein Projekt desselben Typs erstellt haben, wählen Sie stattdessen Zuletzt aus, um schneller zu navigieren.

  3. Wählen Sie im mittleren Bereich eine Projektvorlage aus.

    Eine Beschreibung der ausgewählten Vorlage wird im rechten Bereich angezeigt.

  4. Geben Sie im Feld Name einen Namen für das neue Projekt ein.

    HinweisHinweis

    Für manche Projekttypen ist das Feld Name nicht verfügbar, da der Projektname durch die Angabe des Speicherorts festgelegt wird.Beispielsweise werden die Namen von Webanwendungen und XML-Webdiensten, die sich auf einem Webserver befinden, vom Namen des auf dem Server angegebenen virtuellen Verzeichnisses abgeleitet.

  5. Wählen Sie im Feld Speicherort einen Speicherort aus.

    HinweisHinweis

    Wenn Sie ein temporäres Projekt erstellen, ist das Feld Speicherort möglicherweise nicht verfügbar.Weitere Informationen finden Sie unter Temporäre Projekte.

  6. Falls verfügbar, geben Sie in der Liste Projektmappe an, ob eine Projektmappe erstellt oder das Projekt der Projektmappe, die in Projektmappen-Explorer geöffnet ist, hinzugefügt werden soll.

  7. Geben Sie im Feld Projektmappenname einen Namen für die Projektmappe ein.

    Visual Studio verwendet diesen Namen ggf. für den Namespace des fertig gestellten Projekts.Der Projektmappenname stimmt standardmäßig mit dem Projektnamen überein.

  8. Stellen Sie sicher, dass das Kontrollkästchen Projektmappenverzeichnis erstellen aktiviert ist.

  9. Klicken Sie auf OK.

Über das Dropdownmenü für die .NET Framework-Version im oberen Teil des Dialogfelds Neues Projekt können Sie ein Projekt für frühere Versionen von .NET Framework erstellen.Legen Sie diesen Wert vor dem Auswählen einer Projektvorlage fest, da nur Vorlagen angezeigt werden, die mit dieser .NET Framework-Version kompatibel sind.

Sie müssen im System .NET Framework 3.5 installiert haben, um auf frühere Frameworkversionen als 4 auf zugreifen zu können.

Erstellen von Projektmappen aus Onlinebeispielen

Sie können Visual Studio verwenden, um Beispiele für vollständige, gepackte Anwendungen von der MSDN Code Gallery herunterzuladen und zu installieren.

Sie können jedes Beispiel einzeln oder aber ein Beispielpaket herunterladen, das Beispiele enthält, die eine Technologie oder ein Thema gemeinsam haben.Sie erhalten eine Benachrichtigung, wenn Quellcodeänderungen für ein Beispiel veröffentlicht werden, das Sie herunterladen.

Weitere Informationen finden Sie unter Visual Studio-Beispiele.

Erstellen von leeren Projektmappen

Zwar muss sich ein Projekt in einer Projektmappe befinden, doch können Sie auch eine Projektmappe ohne Projekte erstellen.

So erstellen Sie eine leere Projektmappe

  1. Klicken Sie im Menü Datei auf Neu und dann auf Neues Projekt.

  2. Wählen Sie im linken Bereich Installiert aus, und wählen Sie Andere Projekttypen und dann in der erweiterten Liste Visual Studio-Projektmappen aus.

  3. Wählen Sie im mittleren Bereich die Option Leere Projektmappe aus.

  4. Legen Sie für die Projektmappe die Werte Name und Speicherort fest, klicken Sie dann auf OK.

Nachdem Sie eine leere Projektmappe erstellt haben, können Sie dieser neue oder vorhandene Projekte oder Elemente hinzufügen, indem Sie im Menü Projekt den Befehl Neues Element hinzufügen oder Vorhandenes Element hinzufügen auswählen.

Löschen von Projektmappen

Sie können eine Projektmappe dauerhaft löschen, jedoch aber nicht in Visual Studio.Bevor Sie eine Projektmappe löschen, verschieben Sie alle Projekte, die möglicherweise wiederverwendet werden sollen, in eine andere Projektmappe.Löschen Sie dann im Datei-Explorer das Verzeichnis, in dem die SLN- und die SUO-Projektmappendateien gespeichert sind.

HinweisHinweis

Die SUO-Datei ist eine versteckte Datei, die bei Verwendung der standardmäßigen Datei-Explorer-Einstellungen nicht angezeigt wird.

So löschen Sie eine Projektmappe

  1. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf die zu löschende Projektmappe, und wählen Sie Ordner in Datei-Explorer öffnen aus.

  2. Navigieren Sie im Datei-Explorer eine Ebene höher.

  3. Wählen Sie das Verzeichnis mit der Projektmappe aus, und drücken Sie ENTF.

Siehe auch

Aufgaben

Gewusst wie: Erstellen von Projektmappen mit mehreren Projekten

Konzepte

Projektmappen und Projekte