Importieren aus PowerPivotImport from Power Pivot

GILT FÜR:JaSQL Server 2017 Analysis ServicesJaAzure Analysis ServicesAPPLIES TO:yesSQL Server Analysis ServicesyesAzure Analysis Services

In diesem Artikel wird beschrieben, wie ein neues tabellarisches Modellprojekt erstellt, durch das Importieren von Metadaten und Daten aus einer Power PivotPower Pivot Arbeitsmappe mithilfe des Imports von Power PivotPower Pivot -Projektvorlage in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).This article describes how to create a new tabular model project by importing the metadata and data from a Power PivotPower Pivot workbook by using the Import from Power PivotPower Pivot project template in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Erstellen eines neuen tabellarischen Modells aus einer PowerPivot für Excel-DateiCreate a new Tabular Model from a Power Pivot for Excel file

Wenn Sie ein neues Projekt für tabellarische Modelle erstellen, indem Sie Daten aus einer Power PivotPower Pivot -Arbeitsmappe importieren, werden die Metadaten zur Definition der Arbeitsmappenstruktur verwendet, um die Struktur des tabellarischen Modellprojekts in SQL Server DatatoolsSQL Server Data Toolszu erstellen und zu definieren.When creating a new tabular model project by importing from a Power PivotPower Pivot workbook, the metadata that defines the structure of the workbook is used to create and define the structure of the tabular model project in SQL Server DatatoolsSQL Server Data Tools. Objekte wie Tabellen, Spalten, Measures und Beziehungen werden beibehalten und im tabellarischen Modellprojekt genauso dargestellt wie in der Power PivotPower Pivot -Arbeitsmappe.Objects such as tables, columns, measures, and relationships are retained and will appear in the tabular model project as they are in the Power PivotPower Pivot workbook. An der XLSX-Arbeitsmappendatei werden keine Änderungen vorgenommen.No changes are made to the .xlsx workbook file.

Hinweis

Verknüpfte Tabellen werden in tabellarischen Modellen nicht unterstützt.Tabular models do not support linked tables. Wenn Daten aus einer Power PivotPower Pivot -Arbeitsmappe importiert werden, die eine verknüpfte Tabelle enthält, werden die Daten der verknüpften Tabelle wie kopierte/eingefügte Daten behandelt und in der Datei „Model.bim“ gespeichert.When importing from a Power PivotPower Pivot workbook that contains a linked table, linked table data is treated as copy\pasted data and stored in the Model.bim file. Wenn Sie Eigenschaften für eine kopierte/eingefügte Tabelle anzeigen, sind die Eigenschaft Quelldaten und das Dialogfeld Tabelleneigenschaften im Menü Tabelle deaktiviert.When viewing properties for a copy\pasted table, the Source Data property is disabled and the Table Properties dialog on the Table menu is disabled.

Die Anzahl der Zeilen, die den im Modell eingebetteten Daten hinzugefügt werden können, ist auf 10.000 Zeilen beschränkt.There is a limit of 10,000 rows that can be added to the data embedded in the model. Wenn Sie ein Modell aus Power PivotPower Pivot importieren und der Fehler „Daten wurden abgeschnitten.If you import a model from Power PivotPower Pivot and see the error, “Data was truncated. Eingefügte Tabellen dürfen nicht mehr als 10.000 Zeilen umfassen“ angezeigt wird, überprüfen Sie das Power PivotPower Pivot -Modell, indem Sie die eingebetteten Daten in eine andere Datenquelle verschieben, beispielsweise eine Tabelle in SQL Server, und einen Neuimport ausführen.Pasted tables cannot contain more than 10000 rows” you should revise the Power PivotPower Pivot model by moving the embedded data into another data source, such as a table in SQL Server, and then re-import.

Abhängig davon, ob die Arbeitsbereichsdatenbank auf einer Analysis Services-Instanz auf demselben Computer (lokal) wie SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) oder auf einer Analysis Services-Remoteinstanz gespeichert ist, müssen bestimmte Punkte berücksichtigt werden.There are special considerations depending on whether or not the workspace database is on an Analysis Services instance on the same computer (local) as SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) or is on a remote Analysis Services instance..

Wenn die Arbeitsbereichsdatenbank auf einer lokalen Instanz von Analysis Services gespeichert ist, können Sie sowohl die Metadaten als auch die Daten aus der Power PivotPower Pivot -Arbeitsmappe importieren.If the workspace database is on a local instance of Analysis Services, you can import both the metadata and data from the Power PivotPower Pivot workbook. Die Metadaten werden aus der Arbeitsmappe kopiert und zum Erstellen des tabellarischen Modellprojekts verwendet.The metadata is copied from the workbook and used to create the tabular model project. Anschließend werden die Daten aus der Arbeitsmappe kopiert und in der Arbeitsbereichsdatenbank des Projekts gespeichert (mit Ausnahme von kopierten/eingefügten Daten, die in der Datei Model.bim gespeichert werden).The data is then copied from the workbook and stored in the project’s workspace database (except for copy/pasted data, which is stored in the Model.bim file).

Wenn die Arbeitsbereichsdatenbank auf einer Analysis Services-Remoteinstanz gespeichert ist, können Sie keine Daten aus einer Power PivotPower Pivot für Excel-Arbeitsmappe importieren.If the workspace database is on a remote Analysis Services instance, you cannot import data from a Power PivotPower Pivot for Excel workbook. Sie können jedoch die Metadaten der Arbeitsmappe importieren. Zu diesem Zweck wird ein Skript auf der Analysis Services-Remoteinstanz ausgeführt.You can still import the workbook metadata; however, this will cause a script to be run on the remote Analysis Services instance. Sie sollten nur Metadaten aus vertrauenswürdigen Power PivotPower Pivot -Arbeitsmappen importieren.You should only import metadata from a trusted Power PivotPower Pivot workbook. Die Daten müssen aus den in den Datenquellenverbindungen definierten Quellen importiert werden.Data must be imported from sources defined in the data source connections. Kopierte/eingefügte Daten und Daten aus verknüpften Tabellen in der Power PivotPower Pivot -Arbeitsmappe müssen kopiert und in das tabellarische Modellprojekt eingefügt werden.Copy/pasted and linked table data in the Power PivotPower Pivot workbook must be copied and pasted into the tabular model project.

So erstellen Sie ein neues tabellarisches Modellprojekt aus einer PowerPivot für Excel-DateiTo create a new tabular model project from a Power Pivot for Excel file

  1. Klicken Sie in SQL Server DatatoolsSQL Server Data Toolsauf das Menü Datei , auf Neuund dann auf Projekt.In SQL Server DatatoolsSQL Server Data Tools, on the File menu, click New, and then click Project.

  2. Klicken Sie im Dialogfeld Neues Projekt unter Installierte Vorlagen auf Business Intelligence und dann auf Von Power PivotPower Pivot importieren.In the New Project dialog box, under Installed Templates, click Business Intelligence, and then click Import from Power PivotPower Pivot.

  3. Geben Sie unter Nameeinen Namen für das Projekt ein. Geben Sie dann einen Speicherort und einen Projektmappennamen an, und klicken Sie auf OK.In Name, type a name for the project, then specify a location and solution name, and then click OK.

  4. Wählen Sie im Dialogfeld Öffnen die Power Pivot für ExcelPower Pivot for Excel -Datei aus, die die zu importierenden Modellmetadaten und -daten enthält, und klicken Sie dann auf Öffnen.In the Open dialog box, select the Power Pivot für ExcelPower Pivot for Excel file that contains the model metadata and data you want to import, and then click Open.

Siehe auchSee Also

Arbeitsbereichsdatenbank Workspace Database
Kopieren und Einfügen von DatenCopy and Paste Data