Verwenden von Jupyter Notebooks in Azure Data StudioUse Jupyter Notebooks in Azure Data Studio

Anwendungsbereich:Applies to: JaSQL Server 2019 (15.x)SQL Server 2019 (15.x)yesSQL Server 2019 (15.x)SQL Server 2019 (15.x)Anwendungsbereich:Applies to: JaSQL Server 2019 (15.x)SQL Server 2019 (15.x)yesSQL Server 2019 (15.x)SQL Server 2019 (15.x)

Jupyter Notebook ist eine Open Source-Webanwendung, mit der Sie Dokumente erstellen und freigeben können, die Livecode, Gleichungen, Visualisierungen und beschreibenden Text enthalten.Jupyter Notebook is an open-source web application that allows you to create and share documents containing live code, equations, visualizations, and narrative text. Die Nutzung umfasst Folgendes: Bereinigung und Transformation von Daten, numerische Simulation, statistische Modellierung, Datenvisualisierung und Machine Learning.Usage includes data cleaning and transformation, numerical simulation, statistical modeling, data visualization, and machine learning.

In diesem Artikel wird beschrieben, wie Sie in der neuesten Version von Azure Data Studio ein Notebook erstellen und wie Sie mithilfe von verschiedenen Kernels mit der Erstellung eigener Notebooks beginnen.This article describes how to create a new notebook in the latest release of Azure Data Studio and how to start authoring your own notebooks using different kernels.

Sehen Sie sich dieses kurze fünfminütige Video an, um eine Einführung in Notebooks in Azure Data Studio zu erhalten:Watch this short 5-minute video for an introduction to notebooks in Azure Data Studio:

Erstellen eines NotebooksCreate a notebook

Es gibt mehrere Möglichkeiten, ein neues Notebook zu erstellen.There are multiple ways to create a new notebook. In jedem Fall wird eine neue Datei mit dem Namen Notebook-1.ipynb geöffnet.In each case, a new file named Notebook-1.ipynb opens.

  • Navigieren Sie in Azure Data Studio zum Menü „Datei“ , und klicken Sie auf Neues Notebook.Go to the File Menu in Azure Data Studio and select New Notebook.

    Neues Dateinotebook

  • Klicken Sie mit der rechten Maustaste auf eine SQL Server-Verbindung, und klicken Sie auf Neues Notebook.Right-click a SQL Server connection and select New Notebook.

    Neues Servernotebook

  • Öffnen Sie die Befehlspalette (STRG+UMSCHALT+P), geben Sie „Neues Notebook“ ein, und wählen Sie den Befehl Neues Notebook aus.Open the command palette (Ctrl+Shift+P), type "new notebook", and select the New Notebook command.

    Neues Notebook „Befehlspalette“

Herstellen einer Verbindung mit einem KernelConnect to a kernel

Azure Data Studio-Notebooks unterstützen eine Reihe unterschiedlicher Kernels, einschließlich SQL Server, Python, PySpark und anderen.Azure Data Studio notebooks support a number of different kernels, including SQL Server, Python, PySpark, and others. Jeder Kernel unterstützt eine andere Sprache in den Codezellen Ihres Notebooks.Each kernel supports a different language in the code cells of your notebook. Wenn Sie z. B. eine Verbindung mit dem SQL Server-Kernel hergestellt haben, können Sie T-SQL-Anweisungen in eine Notebook-Codezelle eingeben und ausführen.For example, when connected to the SQL Server kernel, you can enter and run T-SQL statements in a notebook code cell.

Die Anweisung Anfügen an stellt den Kontext für den Kernel bereit.Attach to provides the context for the kernel. Wenn Sie z. B. SQL-Kernel verwenden, können Sie die Anweisung „Anfügen an“ für jede der SQL Server-Instanzen verwenden.For example, if you're using SQL Kernel, then you can attach to any of your SQL Server instances. Wenn Sie Python3-Kernel verwenden, fügen Sie an localhost an, und Sie können diesen Kernel für Ihre lokale Python-Entwicklung verwenden.If you're using Python3 Kernel you attach to localhost and you can use this kernel for your local Python development.

Der SQL-Kernel kann auch verwendet werden, um eine Verbindung mit PostgreSQL-Serverinstanzen herzustellen.SQL Kernel can also be used to connect to PostgreSQL server instances. Wenn Sie ein PostgreSQL-Entwickler sind und eine Verbindung zwischen Ihren Notebooks und Ihrem PostgreSQL-Server herstellen möchten, müssen Sie die PostgreSQL-Erweiterung im Marketplace der Azure Data Studio-Erweiterung herunterladen und mit dem PostgreSQL-Server verbinden.If you're a PostgreSQL developer and want to connect the notebooks to your PostgreSQL Server, then download the PostgreSQL extension in the Azure Data Studio extension Marketplace and connect to the PostgreSQL server.

Wenn Sie mit dem Big Data-Cluster von SQL Server 2019 verbunden sind, ist die Standardanweisung Anfügen an der Endpunkt des Clusters.If you're connected to SQL Server 2019 big data cluster, the default Attach to is the end point of the cluster. Sie können Python-, Scala-und R-Code über Spark-Compute des Clusters verwenden.You can submit Python, Scala, and R code using the Spark compute of the cluster.

KernelKernel BESCHREIBUNGDescription
SQL-KernelSQL Kernel Schreiben Sie SQL-Code für Ihre relationale Datenbank.Write SQL Code targeted at your relational database.
PySpark3- und PySpark-KernelPySpark3 and PySpark Kernel Schreiben Sie Python-Code mithilfe von Spark-Computing aus dem Cluster.Write Python code using Spark compute from the cluster.
Spark-KernelSpark Kernel Schreiben Sie Scala- und R-Code mithilfe von Spark-Computing aus dem Cluster.Write Scala and R code using Spark compute from the cluster.
Python-KernelPython Kernel Schreiben Sie Python-Code für die lokale Entwicklung.Write Python code for local development.

Weitere Informationen zu bestimmten Kernels finden Sie unter:For more information on specific kernels, see:

Hinzufügen einer CodezelleAdd a code cell

Mit Codezellen können Sie Code innerhalb des Notebooks interaktiv ausführen.Code cells allow you to run code interactively within the notebook.

Fügen Sie eine neue Codezelle hinzu, indem Sie auf der Symbolleiste auf den Befehl +Zelle klicken und Codezelle auswählen.Add a new code cell by clicking the +Cell command in the toolbar and selecting Code cell. Nach der aktuell ausgewählten Zelle wird eine neue Codezelle hinzugefügt.A new code cell is added after the currently selected cell.

Geben Sie den Code für den ausgewählten Kernel in die Zelle ein.Enter code in the cell for the selected kernel. Wenn Sie z. B. den SQL-Kernel verwenden, können Sie T-SQL-Befehle in die Codezelle eingeben.For example, if you're using the SQL kernel, you can enter T-SQL commands in the code cell.

Die Eingabe von Code mit dem SQL-Kernel ähnelt einem SQL-Abfrage-Editor.Entering code with the SQL kernel is similar to a SQL query editor. Die Codezelle unterstützt ein modernes SQL-Programmierverfahren mit integrierten Features, wie einem umfangreichen SQL-Editor, IntelliSense und integrierten Codeausschnitten.The code cell supports a modern SQL coding experience with built-in features such as a rich SQL editor, IntelliSense, and built-in code snippets. Mit Codeausschnitten können Sie die richtige SQL-Syntax zum Erstellen von Datenbanken, Tabellen, Ansichten, gespeicherten Prozeduren und zum Aktualisieren vorhandener Datenbankobjekte generieren.Code snippets allow you to generate the proper SQL syntax to create databases, tables, views, stored procedures, and to update existing database objects. Verwenden Sie Codeausschnitte, um schnell Kopien der Datenbank zu Entwicklungs- oder Testzwecken zu erstellen und Skripts zu generieren und auszuführen.Use code snippets to quickly create copies of your database for development or testing purposes and to generate and execute scripts.

SQL-Kernel

Hinzufügen einer TextzelleAdd a text cell

Mithilfe von Textzellen können Sie Ihren Code dokumentieren, indem Sie zwischen Codezellen Markdowntextblöcke hinzufügen.Text cells allow you to document your code by adding Markdown text blocks in between code cells.

Fügen Sie eine neue Textzelle hinzu, indem Sie auf der Symbolleiste auf den Befehl +Zelle klicken und Textzelle auswählen.Add a new text cell by clicking the +Cell command in the toolbar and selecting Text cell.

Die Zelle beginnt im Bearbeitungsmodus, in dem Sie Markdowntext eingeben können.The cell starts in edit mode in which you can type Markdown text. Während Sie die Eingabe vornehmen, erscheint eine Vorschau.As you type, a preview is shown below.

Markdown-Zelle

Wenn Sie außerhalb der Textzelle klicken, wird der Markdowntext angezeigt.Selecting outside the text cell shows the Markdown text.

Markdown-Text

Wenn Sie noch mal in die Textzelle klicken, wird in den Bearbeitungsmodus gewechselt.If you click in the text cell again, it changes to edit mode.

Ausführen einer ZelleRun a cell

Klicken Sie zur Ausführung einer einzelnen Zelle auf Zelle ausführen (der runde schwarze Pfeil) links neben der Zelle, oder wählen Sie die Zelle aus, und drücken Sie F5.To run a single cell, click Run cell (the round black arrow) to the left of the cell or select the cell and press F5. Sie können alle Zellen im Notebook ausführen, indem Sie auf Alle ausführen auf der Symbolleiste klicken. Die Zellen werden nacheinander ausgeführt, und die Ausführung wird beendet, wenn ein Fehler in einer Zelle auftritt.You can run all cells in the notebook by clicking Run all in the toolbar - the cells are run one at a time and execution stops if an error is encountered in a cell.

Die Ergebnisse aus der Zelle werden unterhalb der Zelle angezeigt.Results from the cell are shown below the cell. Klicken Sie auf der Symbolleiste auf die Schaltfläche Ergebnisse löschen, wenn Sie die Ergebnisse aller ausgeführten Zellen im Notebook löschen möchten.You can clear the results of all the executed cells in the notebook by selecting the Clear Results button in the toolbar.

Speichern eines NotebooksSave a notebook

Führen Sie zum Speichern eines Notebooks eine der folgenden Aktionen aus.To save a notebook, do one of the following.

  • Drücken Sie STRG+S.Type Ctrl+S
  • Wählen Sie im Menü „Datei“ die Option Speichern aus.Select Save from the File menu
  • Wählen Sie im Menü „Datei“ die Option Speichern unter aus.Select Save As... from the File menu
  • Wählen Sie im Menü „Datei“ die Option Alle speichern aus. Dadurch werden alle offenen Notebooks gespeichert.Select Save All from the File menu - this saves all open notebooks
  • Geben Sie in der Befehlspalette Datei: Speichern ein.In the command palette, enter File: Save

Notebooks werden als .ipynb-Dateien gespeichert.Notebooks are saved as .ipynb files.

Vertrauenswürdig und nicht vertrauenswürdigTrusted and Non Trusted

In Azure Data Studio geöffnete Notebooks gelten standardmäßig als Vertrauenswürdig.The notebooks open in Azure Data Studio are defaulted to Trusted.

Wenn Sie ein Notebook aus einer anderen Quelle öffnen, wird es im Modus Nicht vertrauenswürdig geöffnet, und Sie können es dann als Vertrauenswürdig einstufen.If you open a notebook from some other source, it opens in Non-Trusted mode and then you can make it Trusted.

BeispieleExamples

In den folgenden Beispielen wird die Verwendung verschiedener Kernel zum Ausführen eines einfachen Hallo Welt-Befehls veranschaulicht.The following examples demonstrate using different kernels to run a simple "Hello World" command. Wählen Sie den Kernel aus, geben Sie den Beispielcode in eine Zelle ein, und klicken Sie auf Zelle ausführen.Select the kernel, enter the example code in a cell, and click Run cell.

PySparkPyspark

Spark-Anwendung

Spark | Scala-SpracheSpark | Scala language

Spark-Kernel/Scala-Sprache

Spark | R-SpracheSpark | R language

Spark R

Python 3Python 3

Lokaler Python-Kernel

Nächste SchritteNext steps