Verwenden von Notebooks in SQL Server 2019 (Vorschauversion)How to use notebooks in SQL Server 2019 preview

Dieses Thema gilt für: JaSQL Server NeinAzure SQL-DatenbankNeinAzure Synapse Analytics (SQL DW) NeinParallel Data Warehouse THIS TOPIC APPLIES TO:yesSQL Server noAzure SQL DatabasenoAzure Synapse Analytics (SQL DW) noParallel Data Warehouse

In diesem Artikel wird beschrieben, wie Sie die Notebookumgebung in der neuesten Version von Azure Data Studio starten und wie Sie mit der Erstellung eigener Notebooks beginnen.This article describes how to launch the Notebook experience in the latest release of Azure Data Studio and how to start authoring your own notebooks. Außerdem wird gezeigt, wie Notebooks mithilfe verschiedener Kernel geschrieben werden.It also shows how to write Notebooks using different kernels.

Verbindung mit SQL Server herstellenConnect to SQL Server

Sie können in Azure Data Studio eine Verbindung mit dem Microsoft SQL Server-Verbindungstyp herstellen.You can connect to the Microsoft SQL Server connection type in Azure Data Studio. In Azure Data Studio können Sie auch F1 drücken und auf Neue Verbindung klicken, um eine Verbindung mit dem SQL Server herzustellen.In Azure Data Studio, you can also press F1, and click New Connection and connect to your SQL Server.

Verbindungsinformationen

Starten von NotebooksLaunch Notebooks

Es gibt mehrere Möglichkeiten, ein neues Notebook zu starten.There are multiple ways to launch a new notebook.

  • Navigieren Sie in Azure Data Studio zum Menü „Datei“ , und klicken Sie dann auf New Notebook (Neues Notebook).Go to the File Menu in Azure Data Studio and then click on New Notebook.

    Neues Notebook

  • Klicken Sie mit der rechten Maustaste auf die SQL Server-Verbindung, und starten Sie dann New Notebook (Neues Notebook).Right click on the SQL Server connection and then launch New Notebook.

    Neues Notebook

  • Öffnen Sie die Befehlspalette (STRG+UMSCHALT+P), und geben Sie dann New Notebook (Neues Notebook) ein.Open the command palette (Ctrl+Shift+P)) and then type in New Notebook. Eine neue Datei mit dem Namen Notebook-1.ipynb wird geöffnet.A new file named Notebook-1.ipynb opens.

Unterstützte Kernel und Anfügen an KontextSupported kernels and attach to context

SQL-Kernel werden von der Notebookinstallation in Azure Data Studio nativ unterstützt.The Notebook Installation in Azure Data Studio natively supports SQL Kernel. Wenn Sie SQL-Entwickler sind und Notebooks verwenden möchten, wäre dies der ausgewählte Kernel.If you are a SQL developer and would like to use Notebooks, then this would be your chosen Kernel.

Der SQL-Kernel kann auch verwendet werden, um eine Verbindung mit PostgreSQL-Serverinstanzen herzustellen.The SQL Kernel can also be used to connect to PostgreSQL server instances. Wenn Sie ein PostgreSQL-Entwickler sind und eine Verbindung zwischen Ihren Notebooks und Ihrem PostgreSQL-Server herstellen möchten, müssen Sie die PostgreSQL-Erweiterung im Marketplace der Azure Data Studio-Erweiterung herunterladen und dann New Notebook (Neues Notebook) starten, um eine Notebookinstanz für die Verbindung mit dem PostgreSQL-Server zu öffnen.If you are a PostgreSQL developer and would like to connect the notebooks to your PostgreSQL Server, then download the PostgreSQL extension in the Azure Data Studio extension marketplace and then launch New Notebook to open a notebook instance to connect to the PostgreSQL server.

PostgreSQL-Verbindung

SQL-KernelSQL Kernel

In den Codezellen im Notebook unterstützen wir, ähnlich wie bei unserem Abfrage-Editor, moderne SQL-Codierungsfunktionen, die Ihre täglichen Aufgaben mit integrierten Funktionen, wie z. B. einem umfangreichen SQL-Editor, IntelliSense und integrierten Codeausschnitten, vereinfachen.In the code cells within the Notebook, similar to our query editor, we support modern SQL coding experience that makes your everyday tasks easier with built-in features such as a rich SQL editor, IntelliSense, and built-in code snippets. Mit Codeausschnitten können Sie die richtige SQL-Syntax zum Erstellen von Datenbanken, Tabellen, Ansichten, gespeicherten Prozeduren usw. und zum Aktualisieren vorhandener Datenbankobjekte generieren.Code snippets allow you to generate the proper SQL syntax to create databases, tables, views, stored procedures, etc., and to update existing database objects. Verwenden Sie Codeausschnitte, um schnell Kopien der Datenbank zu Entwicklungs- oder Testzwecken zu erstellen und Skripts zu generieren und auszuführen.Use code snippets to quickly create copies of your database for development or testing purposes and to generate and execute scripts.

Klicken Sie auf Ausführen, um jede Zelle auszuführen.Click Run to execute each cell.

SQL-Kernel zum Herstellen einer Verbindung mit der SQL Server-InstanzSQL Kernel to connect to SQL Server instance

SQL-Kernel

AbfrageergebnisseQuery Results

Abfrageergebnisse

SQL-Kernel zum Herstellen einer Verbindung mit der PostgreSQL-ServerinstanzSQL Kernel to connect to PostgreSQL Server instance

PostgreSQL-Verbindung

AbfrageergebnisseQuery Results

Abfrageergebnisse

Klicken Sie in der Symbolleiste auf den Befehl +Text, wenn Sie dem vorhandenen Notebook, das an den SQL-Kernel angefügt ist, Textzellen hinzufügen möchten.If you would like to add text cells to your existing Notebook attached to the SQL Kernel, click the +Text command in the toolbar.

Notebook-Symbolleiste

Die Zelle wechselt in den Bearbeitungsmodus. Geben Sie nun „Markdown“ ein, und Ihnen wird gleichzeitig die Vorschauversion angezeigt.The cell changes to edit mode and now type markdown and you will see the preview at the same time

Markdown-Zelle

Wenn Sie außerhalb der Textzelle klicken, wird der Markdowntext angezeigt.Clicking outside the text cell will show the markdown text.

Markdown-Text

Konfigurieren von Python für NotebooksConfigure Python for Notebooks

Wenn Sie in der Dropdownliste „Kernel“ einen anderen Kernel als SQL auswählen, erhalten Sie die Aufforderung Configure Python for Notebooks (Konfigurieren von Python für Notebooks).When you select any of the other kernels apart from SQL from the kernel dropdown, this prompts you to Configure Python for Notebooks. Die Notebookabhängigkeiten werden an einem angegebenen Speicherort installiert, Sie können den Installationspfad jedoch auch festlegen.The Notebook dependencies get installed in a specified location but you can decide whether to set the installation location. Diese Installation kann einige Zeit in Anspruch nehmen. Es wird empfohlen, die Anwendung erst zu schließen, wenn die Installation abgeschlossen ist.This installation can take some time and it is recommended to not close the application until the installation is complete. Nachdem die Installation abgeschlossen ist, können Sie mit dem Schreiben von Code in der unterstützten Sprache beginnen.Once the installation finishes, you can start writing code in the supported language.

Konfigurieren von Python

Nachdem die Installation erfolgreich abgeschlossen wurde, werden unter „Task History“ (Aufgabenverlauf) eine Benachrichtigung sowie der Speicherort des im Ausgabeterminal ausgeführten Jupyter-Back-End-Servers angegeben.Once the installation succeeds, you will find a notification in the Task History along with the location of the Jupyter backend server running in the Output Terminal.

Jupyter-Back-End

KernelKernel und BeschreibungDescription
SQL-KernelSQL Kernel Schreiben Sie SQL-Code für Ihre relationale Datenbank.Write SQL Code targeted at your relational database.
PySpark3- und PySpark-KernelPySpark3 and PySpark Kernel Schreiben Sie Python-Code mithilfe von Spark-Computing aus dem Cluster.Write Python code using Spark compute from the cluster.
Spark-KernelSpark Kernel Schreiben Sie Scala- und R-Code mithilfe von Spark-Computing aus dem Cluster.Write Scala and R code using Spark compute from the cluster.
Python-KernelPython Kernel Schreiben Sie Python-Code für die lokale Entwicklung.Write Python code for local development.

Attach to stellt den Kontext für den anzufügenden Kernel bereit.Attach to provides the context for the Kernel to attach. Wenn Sie SQL-Kernel verwenden, können Sie Attach to für eine beliebige SQL Server-Instanz verwenden.If you are using SQL Kernel, then you can Attach to any of your SQL Server instances.

Wenn Sie Python3-Kernel verwenden, ist Attach to localhost.If you are using Python3 Kernel the Attach to is localhost. Sie können diesen Kernel für Ihre lokale Python-Entwicklung verwenden.You can use this kernel for your local Python development.

Wenn Sie mit dem Big-Data-Cluster von SQL Server 2019 verbunden sind, ist Attach to standardmäßig der Endpunkt des Clusters und ermöglicht Ihnen das Übermitteln von Python-, Scala- und R-Code mithilfe von Spark-Computing des Clusters.When you are connected to SQL Server 2019 big data cluster, the default Attach to is that end point of the cluster and will let you submit Python, Scala and R code using the Spark compute of the cluster.

Codezellen und MarkdownzellenCode Cells and Markdown Cells

Fügen Sie eine neue Codezelle hinzu, indem Sie auf der Symbolleiste auf den Befehl +Code klicken.Add a new code cell by clicking the +Code command in the toolbar.

Fügen Sie eine neue Codezelle hinzu, indem Sie auf der Symbolleiste auf den Befehl +Text klicken.Add a new text cell by clicking the +Text command in the toolbar.

Notebook-Symbolleiste

Die Zelle wechselt in den Bearbeitungsmodus. Geben Sie nun „Markdown“ ein, und Ihnen wird gleichzeitig die Vorschauversion angezeigt.The cell changes to edit mode and now type markdown and you will see the preview at the same time

Markdown-Zelle

Wenn Sie außerhalb der Textzelle klicken, wird der Markdowntext angezeigt.Clicking outside the text cell will show the markdown text.

Markdown-Text

Vertrauenswürdig und nicht vertrauenswürdigTrusted and Non Trusted

In Azure Data Studio geöffnete Notebooks gelten standardmäßig als Vertrauenswürdig.Notebooks open in Azure Data Studio are default Trusted.

Wenn Sie ein Notebook aus einer anderen Quelle öffnen, wird es im Modus , Nicht vertrauenswürdig geöffnet, und Sie können es dann als Vertrauenswürdig einstufen.If you open a Notebook from some other source, it will be opened in Non Trusted mode and then you can make it Trusted.

Ausführen von ZellenRun Cells

Klicken Sie auf der Symbolleiste auf die Schaltfläche Run Cells (Zellen ausführen), wenn Sie alle Zellen im Notebook ausführen möchten.If you want to run all cells in the Notebook then click on the Run Cells button in the toolbar.

Markdown-Text

Ergebnisse löschenClear Results

Klicken Sie auf der Symbolleiste auf die Schaltfläche Ergebnisse löschen, wenn Sie die Ergebnisse aller ausgeführten Zellen im Notebook löschen möchten.If you want to clear the results of all the executed cells in the Notebook,then you can click on the Clear Results button in the toolbar.

Markdown-Text

SpeichernSave

Führen Sie zum Speichern des Notebooks eine der folgenden Aktionen aus:To save the notebook do one of the following.

  • Drücken Sie STRG+S.Select Ctrl+S
  • Klicken Sie auf Datei > Speichern.Click File > Save
  • Klicken Sie auf Datei > Speichern unter.Click File > Save As...
  • Klicken Sie auf Datei > Alle speichern.Click File > Save All
  • Geben Sie in der Befehlspalette Datei: Speichern ein.In the command palette, enter File: Save

Pyspark3/PySpark-KernelPyspark3/PySpark kernel

Wählen Sie den PySpark Kernel aus, und geben Sie in der Zelle den folgenden Code ein.Choose the PySpark Kernel and in the cell type in the following code.

Klicken Sie auf Ausführen.Click Run.

Die Spark-Anwendung wird gestartet, und es wird die folgende Ausgabe zurückgegeben:The Spark Application is started and returns the following output:

Spark-Anwendung

Spark-Kernel | Scala-SpracheSpark kernel | Scala language

Wählen Sie den Spark|Scala Kernel aus, und geben Sie in der Zelle den folgenden Code ein.Choose the Spark|Scala Kernel and in the cell type in the following code.

Spark-Kernel/Scala-Sprache

Sie können auch die Zelloptionen anzeigen, indem Sie auf das Symbol „Optionen“ unterhalb von „–“ klicken.You can also view the "Cell Options" when you click on the options icon below –

Zelloptionen

Spark-Kernel | R-SpracheSpark kernel | R language

Wählen Sie in der Dropdownliste der Kernels „Spark | R“ aus.Choose the Spark | R in the dropdown for the kernels. Geben Sie in der Zelle den Code ein, oder fügen Sie ihn ein.In the cell, type or paste in the code. Klicken Sie auf Ausführen, um die folgende Ausgabe anzuzeigen.Click Run to see the following output.

Spark R

Lokaler Python-KernelLocal Python kernel

Wählen Sie den lokalen Python-Kernel aus, und geben Sie in der Zelle Folgendes ein:Choose the local Python Kernel and in the cell type in -

Lokaler Python-Kernel

Verwalten von PaketenManage Packages

Zu den Dingen, die wir für die lokale Python-Entwicklung optimiert haben, gehört die Möglichkeit, Pakete zu Installieren, die Kunden für Ihre Szenarios benötigen.One of the things we optimized for local Python development was to include the ability to install packages which customers would need for their scenarios. Die allgemeinen Pakete wie pandas, numpy usw. sind standardmäßig integriert. Wenn Sie jedoch ein Paket erwarten, das nicht enthalten ist, schreiben Sie den folgenden Code in die Notebookzelle:By default, we include the common packages like pandas, numpy etc., but if you are expecting a package that is not included then write the following code in the notebook cell:

import <package-name>

Wenn Sie diesen Befehl ausführen, wird Module not found zurückgegeben.When you run this command, Module not found is returned. Wenn das Paket vorhanden ist, wird der Fehler nicht angezeigt.If your package exists, then you will not get the error.

Wenn der Fehler Module not Found (Modul nicht gefunden) zurückgegeben wird, klicken Sie auf Manage Packages (Pakete verwalten), um das Terminal zu starten.If it returns a Module not Found error, then click on Manage Packages to launch the terminal. Sie können Pakete jetzt lokal installieren.You can now install packages locally. Verwenden Sie die folgenden Befehle, um die Pakete zu installieren:Use the following commands to install the packages:

./pip install <package-name>

Tipp

Befolgen Sie zum Installieren von Paketen unter Mac die Anweisungen im Terminalfenster.On Mac please follow the instructions in the Terminal window for installing packages.

Nachdem das Paket installiert wurde, können Sie in die Notebookzelle wechseln und den folgenden Befehl eingeben:After the package is installed, you should be able to go in the Notebook cell and type in following command:

import <package-name>

Verwenden Sie den folgenden Code aus dem Terminal, um Pakete zu deinstallieren:To uninstall a package, use the following command from your terminal:

./pip uninstall <package-name>

Nächste SchritteNext steps

Informationen zum Arbeiten mit einem vorhandenen Notebook finden Sie unter Vorgehensweise: Verwalten von Notebooks in Azure Data Studio.To learn how to work with an existing notebook, see How to manage notebooks in Azure Data Studio.