Verwalten von Notebooks in Azure Data StudioHow to manage notebooks in Azure Data Studio

Dieses Thema gilt für: JaSQL Server NeinAzure SQL-DatenbankNeinAzure Synapse Analytics (SQL DW) NeinParallel Data Warehouse THIS TOPIC APPLIES TO:yesSQL Server noAzure SQL DatabasenoAzure Synapse Analytics (SQL DW) noParallel Data Warehouse

In diesem Artikel erfahren Sie, wie Sie Notebookdateien in Azure Data Studio mit SQL Server öffnen und speichern.This article shows you how to open and save notebook files in Azure Data Studio with SQL Server. Sie erfahren außerdem, wie Sie die Verbindung mit Ihrem SQL Server-Big Data-Cluster ändern.It also demonstrates how to change your connection to your SQL Server big data cluster.

VoraussetzungenPrerequisites

In diesem Artikel wird davon ausgegangen, dass Sie bereits über ein Notebook verfügen, das Sie in Azure Data Studio verwenden möchten.This article assumes that you already have a notebook that you want to use in Azure Data Studio. Informationen zum Erstellen eines Notebooks finden Sie unter Verwenden von Notebooks in SQL Server .If you want to create a notebook, see How to use notebooks in SQL Server. Um Notebooks in Azure Data Studio verwenden zu können, müssen folgende Voraussetzungen erfüllt sein:To use notebooks in Azure Data Studio, you must meet the following prerequisites:

Öffnen eines NotebooksOpen a notebook

Es gibt verschiedene Möglichkeiten, das Dialogfeld Notebook öffnen anzuzeigen.There are several ways to open the Open Notebook dialog. Die können das Menü „Datei“, das Dashboard und die Befehlspalette verwenden.You can use the File menu, the Dashboard, and the Command Palette. Diese Methoden werden in den nächsten Abschnitten beschrieben.The following sections describe each method.

Menü „Datei“File menu

Wählen Sie im Menü „Datei“ die Option Datei öffnen aus (STRG+O unter Windows und BEFEHLSTASTE+O unter Mac).Select File Open from the File menu Ctrl+O (in Windows) and Cmd+O (in Mac).

Anzeigen des Dialogfelds „Datei öffnen“ durch Auswählen von „Datei öffnen“

DashboardDashboard

Klicken Sie auf dem Dashboard auf Notebook öffnen, um das Dialogfeld „Datei öffnen“ anzuzeigen.Click Open Notebook in the dashboard to open the File Open dialog.

Anzeigen des Dialogfelds „Datei öffnen“ durch Auswählen von „Notebook öffnen“ auf dem Dashboard

BefehlspaletteCommand Palette

Verwenden Sie den Befehl File: Open aus der Befehlspalette, indem Sie STRG+UMSCHALT+P (unter Windows) oder BEFEHLSTASTE+P (unter Mac) drücken.Use command File: Open from command palette by typing Ctrl+Shift+P (in Windows) and Cmd+Shift+P (in Mac).

Anzeigen des Dialogfelds „Datei öffnen“ durch Eingeben von „File:Open“ in der Befehlspalette

Speichern eines NotebooksSave a notebook

Zurzeit gibt es nur eine Möglichkeit, ein Notebook zu speichern.There is currently one way to save a notebook. Sie müssen in der Symbolleiste des Notebooks die Option Speichern auswählen.You must select Save from the notebook toolbar.

Speichern einer Datei durch Klicken auf „Speichern“ in der Symbolleiste des Notebooks

Hinweis

Mit den folgenden Methoden werden Änderungen an Notebooks derzeit nicht gespeichert:The following methods currently do not save changes to notebooks:

  • Befehle Datei speichern, Datei speichern unter... und Alle Dateien speichern im Menü „Datei“.File Save, File Save As... and File Save All commands from the File menu.
  • File: Save-Befehle, die in der Befehlspalette eingegeben werden.File: Save commands entered in the command palette.

Ändern des Big Data-ClustersChange the big data cluster

So ändern Sie den SQL Server-Big Data-Cluster für ein Notebook:To change the SQL Server big data cluster for a notebook:

  1. Klicken Sie in der Symbolleiste des Notebooks auf das Menü Anfügen an.Click the Attach to menu from the notebook toolbar.

    Klicken auf das Menü „Anfügen an“ in der Symbolleiste des Notebooks

  2. Klicken Sie im Menü Anfügen an auf einen Server.Click a server from the Attach to menu.

    Auswählen eines Servers im Menü „Anfügen an“

Nächste SchritteNext steps

Weitere Informationen zu Notebooks in Azure Data Studio finden Sie unter Verwenden von Notebooks in SQL Server 2019.For more information about notebooks in Azure Data Studio, see How to use notebooks in SQL Server 2019.