Microsoft Connectors für Oracle und Teradata von Attunity für Integration Services (SSIS)Microsoft Connectors for Oracle and Teradata by Attunity for Integration Services (SSIS)

GILT FÜR: JaSQL Server JaSSIS Integration Runtime in Azure Data Factory JaAzure Synapse Analytics (SQL DW)APPLIES TO: yesSQL Server yesSSIS Integration Runtime in Azure Data Factory yesAzure Synapse Analytics (SQL DW)

Hinweis

Atunity-Connectors für Oracle und Teradata unterstützen SQL Server 2017 und niedriger.Atunity Connectors for Oracle and Teradata support SQL Server 2017 and below.

Holen Sie sich hier die neuesten Connectors für Oracle und Teradata von SQL Server 2019:From SQL Server 2019, get latest connectors for Oracle and Teradata here:

Sie können Connectors von Attunity für Integration Services herunterladen, die die Leistung verbessern, wenn Daten in oder aus Oracle oder Teradata in ein SSIS-Paket geladen werden.You can download connectors for Integration Services by Attunity that optimize performance when loading data to or from Oracle or Teradata in an SSIS package.

Herunterladen der neuesten Attunity-ConnectorsDownload the latest Attunity connectors

Laden Sie die neuesten Versionen der Connectors unter folgendem Link herunter:Get the latest version of the connectors here:
Microsoft Connectors v5.0 for Oracle and Teradata (Microsoft Connectors Version 5.0 für Oracle und Teradata) Microsoft Connectors v5.0 for Oracle and Teradata

Problem: Die Attunity-Connectors werden in der SSIS-Toolbox nicht angezeigtIssue - The Attunity connectors aren't visible in the SSIS Toolbox

Damit die Attunity-Connectors in der SSIS-Toolbox angezeigt werden, müssen Sie stets die Version der Connectors installieren, die auf dieselbe SQL Server-Version ausgerichtet ist wie die auf Ihrem Computer installierten SQL Server Data Tools (SSDT).To see the Attunity connectors in the SSIS Toolbox, you always have to install the version of the connectors that targets the same version of SQL Server as the version of SQL Server Data Tools (SSDT) installed on your computer. (Es dürfen auch frühere Versionen der Connectors installiert sein.) Diese Anforderung steht nicht mit der SQL Server-Version in Zusammenhang, auf die Ihre SSIS-Projekte und -Pakete ausgerichtet sind.(You may also have earlier versions of the connectors installed.) This requirement is independent of the version of SQL Server that you want to target in your SSIS projects and packages.

Wenn z.B. die neueste SSDT-Version installiert ist, ist Version 17 von SSDT mit einer Buildnummer installiert, die mit der Zahl 14 beginnt.For example, if you've installed the latest version of SSDT, you have version 17 of SSDT with a build number that starts with 14. In dieser Version von SSDT wird die SQL Server 2017-Unterstützung hinzugefügt.This version of SSDT adds support for SQL Server 2017. Sie müssen die neuste Version von Attunity-Connectors (Version 5.0) installieren, wenn Sie Attunity Connectors in der SSIS-Paketentwicklung abrufen und verwenden möchten, sogar wenn Sie diese auf eine frühere SQL Server-Version ausrichten möchten.To see and use the Attunity connectors in SSIS package development - even if you want to target an earlier version of SQL Server - you also have to install the latest version of the Attunity connectors, version 5.0. In dieser Version der Connectors wird außerdem die SQL Server 2017-Unterstützung hinzugefügt.This version of the connectors also adds support for SQL Server 2017.

Überprüfen Sie die in Visual Studio installierte Version von SSDT unter Hilfe | Info zu Microsoft Visual Studio oder unter Programme und Funktionen in den Einstellungen.Check the installed version of SSDT in Visual Studio from Help About Microsoft Visual Studio, or in Programs and Features in the Control Panel. Installieren Sie anschließend die zugehörige Version der Attunity-Connectors aus der folgenden Tabelle.Then install the corresponding version of the Attunity connectors from the following table.

SSDT-VersionSSDT version SSDT-BuildnummerSSDT build number Zielversion von SQL ServerTarget SQL Server version Erforderliche Connectors-VersionRequired version of Connectors
1717 Beginnt mit 14Starts with 14 SQL Server 2017SQL Server 2017 Microsoft Connectors v5.0 for Oracle and Teradata (Microsoft Connectors Version 5.0 für Oracle und Teradata)
Microsoft Connectors v5.0 for Oracle and Teradata
1616 Beginnt mit 13Starts with 13 SQL Server 2016SQL Server 2016 Microsoft Connectors v4.0 for Oracle and Teradata (Microsoft Connectors Version 4.0 für Oracle und Teradata)
Microsoft Connectors v4.0 for Oracle and Teradata

Herunterladen der neuesten SQL Server Data Tools (SSDT)Download the latest SQL Server Data Tools (SSDT)

Laden Sie die neueste Version von SSDT unter folgendem Link herunter:Get the latest version of SSDT here:
Download der neuesten SQL Server-Datatools Download SQL Server Data Tools (SSDT)