SQL Server Integration Services-Projekte und Projektmappen (SSIS)Integration Services (SSIS) Projects and Solutions

SQL ServerSQL Server stellt SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) für die Entwicklung von Integration ServicesIntegration Services -Paketen bereit. provides SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) for the development of Integration ServicesIntegration Services packages.

Integration ServicesIntegration ServicesPakete werden in Projekten befinden. packages reside in projects. Sie müssen die Integration ServicesIntegration Services -Umgebung installieren, um SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) -Projekte zu erstellen und zu verwenden.To create and work with Integration ServicesIntegration Services projects, you must install the SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) environment. Weitere Informationen finden Sie unter Installieren von Integration Services.For more information, see Install Integration Services.

Wenn Sie ein neues Integration ServicesIntegration Services -Projekt in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)erstellen, enthält das Dialogfeld Neues Projekt die Vorlage Integration Services-Projekt .When you create a new Integration ServicesIntegration Services project in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the New Project dialog box includes an Integration Services Project template. Diese Projektvorlage erstellt ein neues Projekt, das ein einzelnes Paket enthält.This project template creates a new project that contains a single package.

Projekte und ProjektmappenProjects and solutions

Projekte werden in Projektmappen gespeichert.Projects are stored in solutions. Sie können zuerst eine Projektmappe erstellen und dann ein Integration ServicesIntegration Services -Projekt hinzufügen.You can create a solution first and then add an Integration ServicesIntegration Services project to the solution. Falls keine Projektmappe vorhanden ist, erstellt SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) automatisch eine Projektmappe für Sie, wenn Sie das Projekt erstellen.If no solution exists, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) automatically creates one for you when you first create the project. Eine Projektmappe kann mehrere Projekte unterschiedlichen Typs enthalten.A solution can contain multiple projects of different types.

Tipp

Standardmäßig wird bei der Erstellung eines neuen Projekts in SQL Server Data ToolsSQL Server Data Tools, die Projektmappe nicht im gezeigt Projektmappen-Explorer Bereich.By default, when you create a new project in SQL Server Data ToolsSQL Server Data Tools, the solution is not shown in Solution Explorer pane. Um dieses Standardverhalten zu ändern, klicken Sie im Menü Extras auf Optionen.To change this default behavior, on the Tools menus, click Options. Erweitern Sie im Dialogfeld Optionen den Eintrag Projekte und Projektmappen, und klicken Sie dann auf Allgemein.In the Options dialog box, expand Projects and Solutions, and then click General. Wählen Sie auf der Seite Allgemein die Option Projektmappe immer anzeigenaus.On the General page, select Always show solution.

Lösungen enthalten ProjekteSolutions contain projects

Eine Projektmappe ist ein Container, in dem die Projekte gruppiert und verwaltet werden, die Sie zum Entwickeln von End-to-End-Unternehmenslösungen verwenden.A solution is a container that groups and manages the projects that you use when you develop end-to-end business solutions. Mithilfe einer Projektmappe können Sie mehrere Projekte als Einheit verwalten und zusammenhängende Projekte für eine Unternehmenslösung zusammenbringen.A solution lets you handle multiple projects as one unit and to bring together one or more related projects that contribute to a business solution.

Projektmappen können unterschiedliche Projekttypen enthalten.Solutions can include different types of projects. Wenn Sie SSISSSIS -Designer zum Erstellen eines Integration ServicesIntegration Services -Pakets verwenden, arbeiten Sie in einem Integration ServicesIntegration Services -Projekt in einer von SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)bereitgestellten Projektmappe.If you want to use SSISSSIS Designer to create an Integration ServicesIntegration Services package, you work in an Integration ServicesIntegration Services project in a solution provided by SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Wenn Sie eine neue Projektmappe erstellen, fügt SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) dem Projektmappen-Explorer einen Projektmappenordner hinzu und erstellt Dateien mit den Dateierweiterungen „.sln“ und „.suo“.When you create a new solution, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) adds a Solution folder to Solution Explorer, and creates files that have the extensions, .sln and .suo:

  • Die SLN-Datei enthält Informationen zur Projektmappenkonfiguration und führt die Projekte in der Projektmappe auf.The *.sln file contains information about the solution configuration and lists the projects in the solution.

  • Die SUO-Datei enthält Informationen zu Ihren Einstellungen für das Verwenden der Projektmappe.The *.suo file contains information about your preferences for working with the solution.

    Zwar wird von SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) beim Erstellen eines neuen Projekts automatisch eine Projektmappe erstellt, jedoch können Sie auch eine leere Projektmappe erstellen und später Projekte hinzufügen.While SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) automatically creates a solution when you create a new project, you can also create a blank solution, and then add projects later.

Integration Services-Projekte enthalten PaketeIntegration Services projects contain packages

Ein Projekt ist ein Container, in dem Sie Integration ServicesIntegration Services -Pakete entwickeln.A project is a container in which you develop Integration ServicesIntegration Services packages.

In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)werden in Integration ServicesIntegration Services -Projekten die mit dem Paket verknüpften Dateien gespeichert und gruppiert.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), an Integration ServicesIntegration Services project stores and groups the files that are related to the package. Beispielsweise enthält ein Projekt die zum Erstellen einer bestimmten ETL-Projektmappe (Extract, Transfer, And Load) erforderlichen Dateien.For example, a project includes the files that are required to create a specific extract, transfer, and load (ETL) solution.

Vor dem Erstellen eines Integration ServicesIntegration Services -Projekts sollten Sie sich mit den grundlegenden Inhalten dieser Art von Projekten vertraut machen.Before you create an Integration ServicesIntegration Services project, you should become familiar with the basic contents of this kind of project. Wenn Sie die Inhalte eines Projekts verstanden haben, können Sie ein Integration ServicesIntegration Services -Projekt erstellen und verwenden.After you understand what a project contains, you can begin creating and working with an Integration ServicesIntegration Services project.

Ordner in SQL Server Integration Services-ProjektenFolders in Integration Services projects

Im folgenden Diagramm werden die Ordner in einem Integration ServicesIntegration Services -Projekt in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)veranschaulicht.The following diagram shows the folders in an Integration ServicesIntegration Services project in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Ordner in einem Integration Services-ProjektFolders in an Integration Services project

In der folgende Tabelle werden die Ordner in einem Integration ServicesIntegration Services -Projekt beschrieben.The following table describes the folders that appear in an Integration ServicesIntegration Services project.

OrdnerFolder DescriptionDescription
SSISSSIS Pakete Packages Enthält Pakete.Contains packages. Weitere Informationen finden Sie unter Integration Services-Pakete (SSIS).For more information, see Integration Services (SSIS) Packages.
SonstigesMiscellaneous Enthält Dateien, die sich von Paketdateien unterscheiden.Contains files other than package files.

Dateien in SQL Server Integration Services-ProjektenFiles in Integration Services projects

Wenn Sie einer Projektmappe ein neues oder vorhandenes Integration ServicesIntegration Services -Projekt hinzufügen, erstellt SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) Projektdateien mit den Erweiterungen DTPROJ, DTPROJ.USER und DATABASE.When you add a new or an existing Integration ServicesIntegration Services project to a solution, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) creates project files that have the extensions .dtproj and .dtproj.user and .database.

  • Die DTPROJ-Datei enthält Informationen zu Projektkonfigurationen und Elementen wie Pakete.The *.dtproj file contains information about project configurations and items such as packages.

  • Die DTPROJ.USER-Datei enthält Informationen zu Ihren Einstellungen für das Verwenden dieses Projekts.The *.dtproj.user file contains information about your preferences for working with the project.

  • Die DATABASE-Datei enthält Informationen, die SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) zum Öffnen des Integration ServicesIntegration Services -Projekts benötigt.The *.database file contains information that SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) requires to open the Integration ServicesIntegration Services project.

Versionsauswahl in Integration Services-ProjektenVersion targeting in Integration Services projects

In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)können Sie Pakete für SQL Server 2016, SQL Server 2014 oder SQL Server 2012 erstellen, verwalten und ausführen.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), you can create, maintain, and run packages that target SQL Server 2016, SQL Server 2014, or SQL Server 2012.

Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf ein Integration Services-Projekt, und wählen Sie Eigenschaften aus, um die Eigenschaftsseiten für das Projekt zu öffnen.In Solution Explorer, right-click on an Integration Services project and select Properties to open the property pages for the project. Klicken Sie in der Registerkarte Allgemein in den Konfigurationseigenschaftenauf die Eigenschaft TargetServerVersion , und wählen Sie dann SQL Server 2016, 2014 oder 2012 aus.On the General tab of Configuration Properties, select the TargetServerVersion property, and then choose SQL Server 2016, SQL Server 2014, or SQL Server 2012.

TargetServerVersion-Eigenschaft im Dialogfeld ProjektTargetServerVersion property in project properties dialog box

Erstellen eines neuen SQL Server Integration Services-ProjektsCreate a new Integration Services project

  1. Öffnen Sie SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).Open SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

  2. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Projekt.On the File menu, point to New, and then click Project.

  3. Wählen Sie im Dialogfeld Neues Projekt im Bereich Vorlagen die Vorlage Integration Services-Projekt aus.In the New Project dialog box, in the Templates pane, select the Integration Services Project template.

    Die Integration Services-Projekt -Vorlage erstellt ein Integration ServicesIntegration Services -Projekt, das ein einzelnes, leeres Paket enthält.The Integration Services Project template creates an Integration ServicesIntegration Services project that contains a single, empty package.

  4. (Optional) Bearbeiten Sie den Projektnamen und den Speicherort.(Optional) Edit the project name and the location.

    Der Projektmappenname wird automatisch aktualisiert und an den Projektnamen angepasst.The solution name is automatically updated to match the project name.

  5. Um einen separaten Ordner für die Projektmappendatei zu erstellen, aktivieren Sie das Kontrollkästchen Projektmappenverzeichnis erstellen.To create a separate folder for the solution file, select Create directory for solution. Diese Option ist die Standardeinstellung.This is the default option.

  6. Wenn die Software für die Quellcodeverwaltung auf dem Computer installiert ist, wählen Sie Zur Quellcodeverwaltung hinzufügen aus, um das Projekt der Quellcodeverwaltung zuzuordnen.If source control software is installed on the computer, select Add to source control to associate the project with source control.

  7. Falls es sich bei der Software für die Quellcodeverwaltung um MicrosoftMicrosoft Visual SourceSafe handelt, wird das Dialogfeld Visual SourceSafe-Anmeldung geöffnet.If the source control software is MicrosoftMicrosoft Visual SourceSafe, the Visual SourceSafe Login dialog box opens. Stellen Sie im Dialogfeld Visual SourceSafe-Anmeldungeinen Benutzernamen, ein Kennwort und den Namen der MicrosoftMicrosoft Visual SourceSafe-Datenbank bereit.In Visual SourceSafe Login, provide a user name, a password, and the name of the MicrosoftMicrosoft Visual SourceSafe database. Klicken Sie auf Durchsuchen , um die Datenbank zu suchen.Click Browse to locate the database.

    HINWEIS: Klicken Sie im Menü Extras auf Optionen, und erweitern Sie den Knoten Quellcodeverwaltung, um das ausgewählte Quellcodeverwaltungs-Plug-In anzuzeigen und zu ändern und um die Umgebung für die Quellcodeverwaltung zu konfigurieren.NOTE: To view and change the selected source control plug-in and to configure the source control environment, click Options on the Tools menu, and then expand the Source Control node.

  8. Klicken Sie auf OK , um die Projektmappe dem Projektmappen-Explorer und das Projekt der Projektmappe hinzuzufügen.Click OK to add the solution to Solution Explorer and add the project to the solution.

Wählen der Zielversion eines Projekt und der zugehörigen PaketeChoose the target version of a project and its packages

  1. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf ein Integration Services-Projekt, und wählen Sie Eigenschaften aus, um die Eigenschaftsseiten für das Projekt zu öffnen.In Solution Explorer, right-click on an Integration Services project and select Properties to open the property pages for the project.

  2. Klicken Sie in der Registerkarte Allgemein in den Konfigurationseigenschaftenauf die Eigenschaft TargetServerVersion , und wählen Sie dann SQL Server 2016, 2014 oder 2012 aus.On the General tab of Configuration Properties, select the TargetServerVersion property, and then choose SQL Server 2016, SQL Server 2014, or SQL Server 2012.

    TargetServerVersion-Eigenschaft im Dialogfeld ProjektTargetServerVersion property in project properties dialog box

    Sie können Pakete für SQL Server 2016, SQL Server 2014 oder SQL Server 2012 erstellen, verwalten und ausführen.You can create, maintain, and run packages that target SQL Server 2016, SQL Server 2014, or SQL Server 2012.

Importieren Sie ein vorhandenes Projekt mit dem Import-Projekt-AssistentenImport an existing project with the Import Project Wizard

  1. Klicken Sie in Visual StudioVisual Studioim Menü Datei > auf Neu Projekt .In Visual StudioVisual Studio, click New > Project on the File menu.

  2. Erweitern Sie im Bereich Installierte Vorlagen des Fensters Neues Projekt Business Intelligence, und klicken Sie auf Integration Services.In the Installed Templates area of the New Project window, expand Business Intelligence, and click Integration Services.

  3. Wählen Sie Integration Services-Assistent zum Importieren von Projekten aus der Liste der Projekttypen aus.Select Integration Services Import Project Wizard from the project types list.

  4. Geben Sie einen Namen für das neu zu erstellende Projekt im Textfeld Name ein.Type a name for the new project to be created in the Name text box.

  5. Geben Sie den Pfad oder Speicherort für das Projekt im Textfeld Speicherort ein, oder klicken Sie auf Durchsuchen , um ihn auszuwählen.Type the path or location for the project in the Location text box, or click Browse to select one.

  6. Geben Sie einen Namen für die Projektmappe im Textfeld Projektmappenname ein.Type a name for the solution in the Solution name text box.

  7. Klicken Sie auf OK , um das Dialogfeld Integration Services-Assistent zum Importieren von Projekten zu starten.Click OK to launch the Integration Services Import Project Wizard dialog box.

  8. Klicken Sie auf Weiter , um zur Seite Quelle auswählen zu wechseln.Click Next to switch to the Select Source page.

  9. Wenn Sie aus einer ISPAC-Datei importieren, geben Sie den Pfad einschließlich Dateinamen im Textfeld Pfad ein.If you are importing from an .ispac file, type the path including file name in the Path text box. Klicken Sie auf Durchsuchen , um zu dem Ordner zu navigieren, in dem die Projektmappe gespeichert werden soll. Geben Sie den Dateinamen im Textfeld Dateiname ein, und klicken Sie auf Öffnen.Click Browse to navigate to the folder where you want the solution to be stored and type file name in the File name text box, and click Open.

    Wenn Sie aus einem Integration Services-Katalogimportieren, geben Sie den Datenbankinstanznamen im Textfeld Servername ein, oder klicken Sie auf Durchsuchen und wählen Sie die Datenbankinstanz aus, die den Katalog enthält.If you are importing from an Integration Services Catalog, type the database instance name in the Server name text box or click Browse and select the database instance that contains the catalog.

    Klicken Sie auf Durchsuchen neben dem Textfeld Pfad , erweitern Sie den Ordner im Katalog, wählen Sie das Projekt aus, das Sie importieren möchten, und klicken Sie auf OK.Click Browse next to Path text box, expand folder in the catalog, select the project you want to import, and click OK.

    Klicken Sie auf Weiter , um zur Seite ///Überprüfen zu wechseln.Click Next to switch to the Review page.

  10. Überprüfen Sie die Informationen, und klicken Sie auf Importieren , um ein Projekt auf Grundlage des vorhandenen Projekts zu erstellen, das Sie ausgewählt haben.Review the information and click Import to create a project based on the existing project you selected.

  11. Optional: Klicken Sie auf Bericht speichern , um die Ergebnisse in einer Datei zu speichern.Optional: click Save Report to save the results to a file

  12. Klicken Sie auf Schließen , um das Dialogfeld Integration Services-Assistent zum Importieren von Projekten zu schließen.Click Close to close the Integration Services Import Project Wizard dialog box.

Hinzufügen eines Projekts zu einer ProjektmappeAdd a project to a solution

Beim Hinzufügen eines Projekts können Sie mit Integration ServicesIntegration Services ein neues, leeres Projekt erstellen oder ein bereits für eine andere Projektmappe erstelltes Projekt hinzufügen.When you add a project, you can have Integration ServicesIntegration Services create a new, blank project, or you can add a project that you have already created for a different solution. Sie können ein Projekt nur einer vorhandenen Projektmappe hinzufügen, wenn die Projektmappe in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)sichtbar ist.You can only add a project to an existing solution when the solution is visible in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT).

Hinzufügen eines neuen Projekts zu einer ProjektmappeAdd a new project to a solution

  1. Öffnen Sie in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)die Projektmappe, der Sie ein neues Integration ServicesIntegration Services -Projekt hinzufügen möchten, und führen Sie eine der folgenden Aktionen aus:In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution to which you want to add a new Integration ServicesIntegration Services project, and do one of the following:

    • Klicken Sie mit der rechten Maustaste auf die Projektmappe, klicken Sie auf Hinzufügen, und klicken Sie dann auf Neues Projekt.Right-click the solution, click Add, and then click New Project.

    • Zeigen Sie im Menü Datei auf Hinzufügen, und klicken Sie dann auf Neues Projekt.On the File menu, point to Add, and then click New Project.

  2. Klicken Sie im Dialogfeld Neues Projekt hinzufügen im Fensterbereich Vorlagen auf Integration Services-Projekt .In the Add New Project dialog box, click Integration Services Project in the Templates pane.

  3. Bearbeiten Sie optional den Projektnamen und den Speicherort.Optionally, edit the project name and location.

  4. Klicken Sie auf OK.Click OK.

Hinzufügen eines vorhandenen Projekts zu einer ProjektmappeAdd an existing project to a solution

  1. Öffnen Sie in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)die Projektmappe, der Sie ein vorhandenes Integration ServicesIntegration Services -Projekt hinzufügen möchten, und führen Sie eine der folgenden Aktionen aus:In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution to which you want to add an existing Integration ServicesIntegration Services project, and do one of the following:

    • Klicken Sie mit der rechten Maustaste auf die Projektmappe, zeigen Sie auf Hinzufügen, und klicken Sie dann auf Vorhandenes Projekt.Right-click the solution, point to Add, and then click Existing Project.

    • Klicken Sie im Menü Datei auf Hinzufügen, und klicken Sie dann auf Vorhandenes Projekt.On the File menu, click Add, and then click Existing Project.

  2. Suchen Sie im Dialogfeld Vorhandenes Projekt hinzufügen das Projekt, das Sie hinzufügen möchten, und klicken Sie dann auf Öffnen.In the Add Existing Project dialog box, browse to locate the project you want to add, and then click Open.

  3. Das Projekt wird dem Projektmappenordner im Projektmappen-Explorerhinzugefügt.The project is added to the solution folder in Solution Explorer.

Entfernen Sie ein Projekt aus einer ProjektmappeRemove a project from a solution

Sie können ein Projekt aus einer Projektmappe nur entfernen, wenn die Projektmappe in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)sichtbar ist.You can only remove a project from a solution when the solution is visible in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT). Nachdem die Projektmappe sichtbar ist, können alle Projekte, außer einem Projekt, entfernt werden.After the solution is visible, you can remove all except one project. Sobald nur ein Projekt verbleibt, wird der Projektmappenordner in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) nicht mehr angezeigt, und das Löschen des letzten Projekts ist nicht möglich.As soon as only one project remains, SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) no longer displays the solution folder and you cannot remove the last project.

  1. Öffnen Sie in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)die Projektmappe, aus der Sie ein Integration ServicesIntegration Services -Projekt entfernen möchten.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution from which you want to remove an Integration ServicesIntegration Services project.

  2. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf das Projekt, und klicken Sie dann auf Projekt entladen.In Solution Explorer, right-click the project, and then click Unload Project.

  3. Klicken Sie auf OK , um das Entfernen zu bestätigen.Click OK to confirm the removal.

Hinzufügen eines Elements zu einem ProjektAdd an item to a project

  1. Öffnen Sie in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)die Projektmappe mit dem Integration ServicesIntegration Services -Projekt, dem Sie ein Element hinzufügen möchten.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the solution that contains the Integration ServicesIntegration Services project to which you want to add an item.

  2. Klicken Sie im Projektmappen-Explorer mit der rechten Maustaste auf das Projekt, zeigen Sie auf Hinzufügen, und führen Sie eine der folgenden Aktionen aus:In Solution Explorer, right-click the project, point to Add, and do one of the following:

    • Klicken Sie auf Neues Element, und wählen Sie im Bereich Vorlagen im Dialogfeld Neues Element hinzufügen eine Vorlage aus.Click New Item, and then select a template from the Templates pane in the Add New Item dialog box.

    • Klicken Sie auf Vorhandenes Element, suchen Sie im Dialogfeld Vorhandenes Element hinzufügen nach dem Element, das Sie dem Projekt hinzufügen möchten, und klicken Sie dann auf Hinzufügen.Click Existing Item, browse in the Add Existing Item dialog box to locate the item you want to add to the project, and then click Add.

  3. Das neue Element wird im Projektmappen-Explorer im entsprechenden Ordner angezeigt.The new item appears in the appropriate folder in Solution Explorer.

Kopieren von ProjektelementenCopy project items

Sie können Objekte im Kopieren einer Integration ServicesIntegration Services Projekt oder zwischen Integration ServicesIntegration Services Projekte.You can copy objects within an Integration ServicesIntegration Services project or between Integration ServicesIntegration Services projects. Sie können Objekte auch zwischen anderen Typen von SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) -Projekten, Reporting ServicesReporting Services und Analysis ServicesAnalysis Serviceskopieren.You can also copy objects between the other types of SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) projects, Reporting ServicesReporting Services and Analysis ServicesAnalysis Services. Für den Kopiervorgang zwischen den Projekten müssen die Projekte Teil derselben SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) -Projektmappe sein.To copy between projects, the project must be part of the same SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) solution.

  1. Öffnen Sie in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)das Integration ServicesIntegration Services -Projekt bzw. die Projektmappe, mit dem bzw. mit der Sie arbeiten möchten.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), open the Integration ServicesIntegration Services project or solution that you want to work with.

  2. Erweitern Sie das Projekt und den Elementordner, aus dem Sie kopieren möchten.Expand the project and item folder to copy from.

  3. Klicken Sie mit der rechten Maustaste auf das Element, und klicken Sie anschließend auf Kopieren.Right-click the item and click Copy.

  4. Klicken Sie mit der rechten Maustaste auf das Integration ServicesIntegration Services-Projekt, in das kopiert werden soll, und klicken Sie auf Einfügen.Right-click the Integration ServicesIntegration Services project to copy to and click Paste.

    Die Elemente werden automatisch in den richtigen Ordner kopiert.The items are automatically copied to the correct folder. Wenn Sie in das Integration ServicesIntegration Services -Projekt Elemente kopieren, die keine Pakete darstellen, werden die Elemente in den Ordner Sonstiges kopiert.If you copy items to the Integration ServicesIntegration Services project that are not packages, the items are copied to the Miscellaneous folder.