MSSQLSERVER_948

Anwendungsbereich: JaSQL Server (alle unterstützten Versionen)

Details

attribute Wert
Produktname SQL Server
Ereignis-ID 948
Ereignisquelle MSSQLSERVER
Komponente SQLEngine
Symbolischer Name Nicht verfügbar
Meldungstext Die '%.*ls'-Datenbank kann nicht geöffnet werden, weil sie die Version %d aufweist. Dieser Server unterstützt Version %d und früher. Ein Herabstufungspfad wird nicht unterstützt.

Erklärung

Bestimmte funktionen in SQL Server wirken sich auf die Struktur der Datenbankdateien aus. Wenn Sie eine Datenbank an eine andere Instanz von SQL Server anfügen, ist das Dateiformat möglicherweise mit einer anderen Version von Datenbank-Engine nicht kompatibel.

Dieser Fehler kann beispielsweise verursacht werden, wenn das vardecimal-Speicherformat in einer höheren Version von SQL Server verwendet wird und dann versucht wird, die Datenbankdateien in einer niedrigeren Version als SQL Server 2005 (9.x) Service Pack 2 anzufügen.

Benutzeraktion

Ermitteln Sie die Version von SQL Server, die auf dem ursprünglichen Server ausgeführt wird. Klicken Sie in SQL Server Management Studio mit der rechten Maustaste auf den Server und dann auf Eigenschaften, oder geben Sie in einem Abfragefenster SELECT @@VERSION ein. Öffnen Sie die Datenbank mithilfe der ursprünglichen Version von SQL Server. Ermitteln Sie die funktionen, die für die ursprüngliche Datenbank in der Instanz von SQL Server aktiviert sind. Ändern Sie diese Einstellungen, um mit der Version von SQL Server zu arbeiten, in der die Datenbank angefügt wird.