Abfrage-Editor des Datenbankmoduls (SQL Server Management Studio)Database Engine Query Editor (SQL Server Management Studio)

Mithilfe des DatenbankmodulDatabase Engine -Abfrage-Editors können Sie Skripts mit Transact-SQLTransact-SQL -Anweisungen erstellen und ausführen.Use the DatenbankmodulDatabase Engine Query Editor to create and run scripts containing Transact-SQLTransact-SQL statements. Der Editor unterstützt auch das Ausführen von Skripts, die sqlcmd -Befehle enthalten.The editor also supports running scripts that contain sqlcmd commands.

F1-Hilfe für Transact-SQLTransact-SQL F1 Help

Der DatenbankmodulDatabase Engine -Abfrage-Editor unterstützt bei der Auswahl von F1 den Link zu einem Referenzthema einer bestimmten Transact-SQLTransact-SQL -Anweisung.The DatenbankmodulDatabase Engine Query Editor supports linking you to the reference topic for a specific Transact-SQLTransact-SQL statement when you select F1. Markieren Sie hierzu den Namen einer Transact-SQL-Anweisung, und wählen Sie dann F1 aus.To do so, highlight the name of a Transact-SQL statement and then select F1. Das Hilfesuchmodul sucht dann nach einem Thema mit einem F1-Hilfeattribut, das der markierten Zeichenfolge entspricht.The help search engine will then search for a topic that has an F1 help attribute that matches the string you highlighted.

Wenn das Hilfesuchmodul kein Thema mit einem F1-Hilfeschlüsselwort findet, das genau der markierten Zeichenfolge entspricht, wird dieses Thema angezeigt.If the help search engine does not find a topic with an F1 help keyword that exactly matches the string you highlighted, then this topic is displayed. In diesem Fall gibt es zwei Ansätze zum Suchen der gewünschten Hilfe:In that case, there are two approaches to finding the help you are looking for:

  • Kopieren Sie die markierte Zeichenfolge aus dem Editor, fügen Sie diese in der SQL Server-Onlinedokumentation in die Registerkarte "Suchen" ein, und führen Sie eine Suche aus.Copy and paste the editor string you highlighted into the search tab of SQL Server Books Online and do a search.

  • Markieren Sie nur den Teil der Transact-SQL-Anweisung, die am ehesten zu einem F1-Hilfeschlüsselwort passt, das auf ein Thema angewendet wird, und wählen Sie erneut F1 aus.Highlight only the part of the Transact-SQL statement likely to match an F1 help keyword applied to a topic and select F1 again. Für das Suchmodul ist eine genaue Übereinstimmung zwischen der markierten Zeichenfolge und einem einem Thema zugewiesenen F1-Hilfeschlüsselwort erforderlich.The search engine requires an exact match between the string you highlighted and an F1 help keyword assigned to a topic. Enthält die markierte Zeichenfolge für Ihre Umgebung eindeutige Elemente, z. B. Spalten- oder Parameternamen, erhält das Suchmodul keine Übereinstimmung.If the string you highlighted contains elements unique to your environment, such as column or parameter names, the search engine will not get a match. Zu den Zeichenfolgen, die markiert werden können, gehören die folgenden:Examples of the strings to highlight include:

    • Der Name einer Transact-SQL-Anweisung, zum Beispiel SELECT, CREATE DATABASE oder BEGIN TRANSACTION.The name of a Transact-SQL statement, such as SELECT, CREATE DATABASE or BEGIN TRANSACTION.

    • Der Name einer integrierten Funktion, zum Beispiel SERVERPROPERTY oder @@VERSION.</span><span class="sxs-lookup">The name of a built-in function, such as SERVERPROPERTY, or @@VERSION.</span></span>

    • Der Name einer im System gespeicherten Prozedurtabelle oder einer Sicht, z. B. "sys.data_spaces" oder "sp_tableoption".The name of a system stored procedure table, or view, such as sys.data_spaces or sp_tableoption.

Arbeiten mit dem Datenbankmodul-Abfrage-EditorWorking With the Database Engine Query Editor

Der DatenbankmodulDatabase Engine-Abfrage-Editor ist einer von vier in SQL Server Management StudioSQL Server Management Studio implementierten Editoren.The DatenbankmodulDatabase Engine Query Editor is one of four editors implemented in SQL Server Management StudioSQL Server Management Studio. Eine Beschreibung der im DatenbankmodulDatabase Engine-Abfrage-Editor implementierten Funktionalität und der Hauptaufgaben, die Sie mit dem Editor ausführen können, finden Sie unter Abfrage-Editor des Datenbankmoduls (SQL Server Management Studio).For a description of the functionality implemented in the DatenbankmodulDatabase Engine Query Editor and the main tasks you can perform using the editor, see Query and Text Editors (SQL Server Management Studio).

SQL-Editor-SymbolleisteSQL Editor Toolbar

Wenn der DatenbankmodulDatabase Engine -Abfrage-Editor geöffnet ist, wird die SQL-Editor-Symbolleiste mit den folgenden Schaltflächen angezeigt:When the DatenbankmodulDatabase Engine Query Editor is open, the SQL Editor toolbar appears with the following buttons.

ConnectConnect
Öffnet das Dialogfeld Verbindung mit Server herstellen .Opens the Connect to Server dialog box. Mithilfe dieses Dialogfelds können Sie eine Verbindung mit einem Server herstellen.Use this dialog box to establish a connection to a server.

TrennenDisconnect
Trennt den aktuellen Abfrage-Editor vom Server.Disconnects the current Query Editor from the server.

Verbindung ändernChange Connection
Öffnet das Dialogfeld Verbindung mit Server herstellen .Opens the Connect to Server dialog box. Mithilfe dieses Dialogfelds können Sie eine Verbindung mit einem anderen Server herstellen.Use this dialog box to establish a connection to a different server.

Neue Abfrage mit aktueller VerbindungNew Query with Current Connection
Öffnet ein neues Abfrage-Editor-Fenster und verwendet die Verbindungsinformationen des aktuellen Abfrage-Editor-Fensters.Opens a new Query Editor window and uses the connection information from the current Query Editor window.

Verfügbare DatenbankenAvailable Databases
Wechselt die Verbindung zu einer anderen Datenbank auf demselben Server.Change the connection to a different database on the same server.

ExecuteExecute
Führt den ausgewählten bzw. (wenn kein Code ausgewählt ist) den gesamten Code im Abfrage-Editor aus.Executes the selected code or, if no code is selected, executes all the code in the Query Editor.

DebuggenDebug
Aktiviert den Transact-SQLTransact-SQL -Debugger.Enables the Transact-SQLTransact-SQL debugger. Dieser Debugger unterstützt Debugoperationen, wie das Festlegen von Breakpoints, das Beobachten von Variablen und die schrittweise Ausführung von Code.This debugger supports debugging actions such as setting breakpoints, watching variables, and stepping through code.

Ausführung der Abfrage abbrechenCancel Executing Query
Sendet eine Abbruchsanforderung an den Server.Sends a cancellation request to the server. Einige Abfragen können nicht sofort abgebrochen werden, sondern müssen auf angemessene Bedingungen für einen Abbruch warten.Some queries cannot be canceled immediately, but must wait for a suitable cancellation condition. Beim Abbruch von Transaktionen können Verzögerungen auftreten, während für die Transaktionen ein Rollback ausgeführt wird.When transactions are canceled, delays might occur while transactions are rolled back.

AnalysierenParse
Überprüft die Syntax des ausgewählten Codes.Check the syntax of the selected code. Wenn kein Code ausgewählt ist, wird die Syntax des gesamten Codes im Abfrage-Editor-Fenster geprüft.If no code is selected, checks the syntax of the all code in the Query Editor window.

Geschätzten Ausführungsplan anzeigenDisplay Estimated Execution Plan
Fordert einen Abfrageausführungsplan vom Abfrageprozessor an, ohne die Abfrage tatsächlich auszuführen. Der Plan wird im Fenster Ausführungsplan angezeigt.Requests a query execution plan from the query processor without actually executing the query, and displays the plan in the Execution plan window. Dieser Plan verwendet Indexstatistiken als Schätzung für die Anzahl der zu erwartenden Zeilen, die während der einzelnen Schritte der Abfrageausführung zurückgegeben werden.This plan uses index statistics as an estimate of the number of rows that are expected to be returned during each part of the query execution. Der tatsächlich verwendete Abfrageplan kann sich vom geschätzten Ausführungsplan unterscheiden.The actual query plan that is used can be different from the estimated execution plan. Dieser Fall kann eintreten, wenn die Anzahl der zurückgegebenen Zeilen erheblich von der Schätzung abweicht und der Abfrageprozessor den Plan aus Effizienzgründen ändert.This can occur if the number of rows that are returned is significantly different from the estimate, and the query processor changes the plan to be more efficient.

AbfrageoptionenQuery Options
Öffnet das Dialogfeld Abfrageoptionen .Opens the Query Options dialog box. Mithilfe dieses Dialogfelds konfigurieren Sie die Standardoptionen für die Abfrageausführung und die Abfrageergebnisse.Use this dialog box to configure the default options for query execution and for query results.

IntelliSense aktiviertIntelliSense Enabled
Gibt an, ob die IntelliSense-Funktionalität im DatenbankmodulDatabase Engine -Abfrage-Editor verfügbar ist.Specifies whether IntelliSense functionality is available in the DatenbankmodulDatabase Engine Query Editor.

Tatsächlichen Ausführungsplan einschließenInclude Actual Execution Plan
Führt die Abfrage aus und gibt die Abfrageergebnisse sowie den Ausführungsplan, der für die Abfrage verwendet wurde, zurück.Executes the query, returns the query results, and the execution plan that was used for the query. Letzterer wird im Fenster Ausführungsplan als grafischer Abfrageplan angezeigt.These appear as a graphical query plan in the Execution plan window.

Clientstatistiken einschließenInclude Client Statistics
Schließt das Fenster Clientstatistiken ein, das Statistiken zu der Abfrage, den Netzwerkpaketen und der verstrichenen Zeit für die Abfrage enthält.Includes a Client Statistics window that contains statistics about the query and about the network packets, and the elapsed time of the query.

Ergebnisse in TextResults to Text
Gibt die Abfrageergebnisse als Text im Fenster Ergebnisse zurück.Returns the query results as text in the Results window.

Ergebnisse in RasterResults to Grid
Gibt die Abfrageergebnisse als ein oder mehrere Raster im Fenster Ergebnisse zurück.Returns the query results as one or more grids in the Results window.

Ergebnisse in DateiResults to File
Wenn die Abfrage ausgeführt wird, wird das Dialogfeld Ergebnisse speichern geöffnet.When the query executes, the Save Results dialog box opens. Wählen Sie unter Speichern inden Ordner aus, in dem Sie die Datei speichern möchten.In Save In, select the folder in which you want to save the file. Geben Sie unter Dateinameden Namen der Datei ein, und klicken Sie dann auf Speichern , um die Abfrageergebnisse als Berichtsdatei mit der Dateierweiterung ".rpt" zu speichern.In File name, type the name of the file, and then click Save to save the query results as a Report file that has the .rpt extension. Klicken Sie auf den Pfeil nach unten auf der Schaltfläche Speichern , und klicken Sie anschließend auf Mit Codierung speichern, um erweiterte Optionen anzugeben.For advanced options, click the down-arrow on the Save button, and then click Save with Encoding.

Auswahl kommentierenComment Selection
Markiert die aktuelle Zeile als Kommentar, indem am Zeilenanfang ein Kommentaroperator (--) hinzugefügt wird.Makes the current line a comment by adding a comment operator (--) at the beginning of the line.

Auskommentierung der Auswahl aufhebenUncomment Selection
Markiert die aktuelle Zeile als aktive Quellanweisung, indem alle Kommentaroperatoren (--) am Zeilenanfang entfernt werden.Makes the current line an active source statement by removing any comment operator (--) at the beginning of the line.

Zeileneinzug verkleinernDecrease Line Indent
Verschiebt durch das Entfernen von Leerzeichen am Zeilenanfang den Text der Zeile nach links.Moves the text of the line to the left by removing blanks at the beginning of the line.

Zeileneinzug vergrößernIncrease Line Indent
Verschiebt durch das Hinzufügen von Leerzeichen am Zeilenanfang den Text der Zeile nach rechts.Moves the text of the line to the right by adding blanks at the beginning of the line.

Werte für Vorlagenparameter angebenSpecify Values for Template Parameters
Öffnet ein Dialogfeld, in dem Sie Werte für Parameter in gespeicherten Prozeduren und Funktionen festlegen können.Opens a dialog box that you can use to specify values for parameters in stored procedures and functions.

Sie können die SQL-Editor-Symbolleiste auch hinzufügen, indem Sie im Menü Ansicht nacheinander Symbolleistenund SQL-Editorauswählen.You can also add the SQL Editor toolbar by selecting the View menu, selecting Toolbars, and then selecting SQL Editor. Wenn Sie die SQL-Editor-Symbolleiste hinzufügen, ohne dass ein Fenster des DatenbankmodulDatabase Engine -Abfrage-Editors geöffnet ist, steht keine der Schaltflächen zur Verfügung.If you add the SQL Editor toolbar when no DatenbankmodulDatabase Engine Query Editor windows are open, all the buttons are unavailable.

SQL-Editor-SymbolleisteSQL Editor Toolbar

Wenn ein DatenbankmodulDatabase Engine -Abfrage-Editor-Fenster geöffnet ist, können Sie die Symbolleiste Debuggen hinzufügen, indem Sie im Menü Ansicht zuerst Symbolleistenund dann Debuggenauswählen.When a DatenbankmodulDatabase Engine Query Editor window is open, you can add the Debug toolbar by selecting the View menu, selecting Toolbars, and then selecting Debug. Wenn Sie die Symbolleiste Debuggen hinzufügen, ohne dass ein Fenster des DatenbankmodulDatabase Engine -Abfrage-Editors geöffnet ist, steht keine der Schaltflächen zur Verfügung.If you add the Debug toolbar when no DatenbankmodulDatabase Engine Query Editor windows are open, all the buttons are unavailable.

ContinueContinue
Führt den Code im DatenbankmodulDatabase Engine -Abfrage-Editor-Fenster bis zu einem Breakpoint aus.Runs the code in the DatenbankmodulDatabase Engine Query Editor window until a breakpoint is encountered.

Alle unterbrechenBreak All
Stellt den Debugger so ein, dass im Falle einer Unterbrechung alle Prozesse angehalten werden, an die der Debugger angefügt ist.Sets the debugger to break all processes to which the debugger is attached when a break occurs.

Debuggen beendenStop Debugging
Deaktiviert den Debugmodus für das ausgewählte DatenbankmodulDatabase Engine -Abfrage-Editor-Fenster und stellt den Standardausführungsmodus wieder her.Takes the selected DatenbankmodulDatabase Engine Query Editor window out of debug mode, and restores the standard execution mode.

Nächste Anweisung anzeigenShow Next Statement
Verschiebt den Cursor zur nächsten auszuführenden Anweisung.Moves the cursor to the next statement to be executed.

EinzelschrittStep Into
Die nächste Anweisung wird ausgeführt.The next statement is run. Wenn die nächste Anweisung eine gespeicherte Transact-SQL-Prozedur, eine Funktion oder einen Trigger aufruft, zeigt der Debugger ein neues Abfrage-Editor -Fenster an, das den Code des Moduls enthält.If the statement invokes a Transact-SQL stored procedure, function, or trigger, the debugger displays a new Query Editor window that contains the code of the module. Das Fenster befindet sich im Debuggingmodus, und die Ausführung hält bei der ersten Anweisung im Modul an.The window is in debug mode, and execution pauses on the first statement in the module. Sie können sich dann durch das Modul bewegen, indem Sie z. B. Breakpoints festlegen oder den Code schrittweise durchlaufen.You can then move through the module, for example, by setting breakpoints or stepping through the code.

ProzedurschrittStep Over
Die nächste Anweisung wird ausgeführt.The next statement is run. Wenn die Anweisung eine gespeicherte Transact-SQL-Prozedur, eine Funktion oder einen Trigger aufruft, wird das Modul bis zum Ende ausgeführt, und die Ergebnisse werden an den aufrufenden Code zurückgegeben.If the statement invokes a Transact-SQL stored procedure, function, or trigger, the module is run until it finishes and the results are returned to the calling code. Wenn Sie sicher sind, dass im Modul keine Fehler vorliegen, können Sie es überspringen.If you are sure there are no errors in the module, you can step over it. Die Ausführung hält bei der Anweisung an, die dem Aufruf des Moduls folgt.Execution pauses on the statement that follows the call to the module.

RücksprungStep Out
Springt zur nächsthöheren Aufrufebene (Funktion, gespeicherte Prozedur oder Trigger) zurück.Step back to the next highest calling level (function, stored procedure, or trigger). Die Ausführung hält bei der Anweisung an, die dem Aufruf der gespeicherten Prozedur, der Funktion oder dem Trigger folgt.Execution pauses on the statement that follows the call to the stored procedure, function, or trigger.

WindowsWindows
Öffnet entweder das Fenster Breakpoint oder das Direktfenster .Opens either the Breakpoint window or the Immediate window.

Siehe auchSee Also

Tastenkombinationen für SQL Server Management StudioSQL Server Management Studio Keyboard Shortcuts