Verwenden einer Office Data Connection (.odc) mit BerichtenUse an Office Data Connection (.odc) with Reports

Bei beschränkten Szenarien können Sie eine vorhandene Office Data Connection (.odc)-Datei verwenden, um Verbindungsinformationen für einen Reporting ServicesReporting Services -Bericht bereitzustellen.For limited scenarios, you can use an existing Office Data Connection (.odc) file to provide connection information to a Reporting ServicesReporting Services report. Sie können beim Erstellen einer freigegebenen Datenquelle eine ODC-Datei statt einer RSDS-Datei verwenden.An .odc file can be used in place of an .rsds file when you create a shared data source. Eine ODC-Datei wird vom Berichtsserver auf dieselbe Weise verwendet wie eine RSDS-Datei. Die Datei wird gelesen, um den Datenquellentyp, eine Verbindungszeichenfolge und Anmeldeinformationen abzurufen.The report server uses an .odc file in the same way it uses an .rsds file; it reads the file for the data source type, a connection string, and credential information.

Nicht alle ODC-Dateien können für einen Reporting ServicesReporting Services -Bericht verwendet werden.Not all .odc files can be used with a Reporting ServicesReporting Services report. Anhand der Datenverarbeitungserweiterung und der Merkmale des Berichts und der ODC-Datei wird bestimmt, ob eine ODC-Datei verwendet werden kann:The data processing extension and characteristics of the report and .odc file determine whether an .odc can be used:

  • Der Bericht muss für die Verwendung mit einem OLE DB- oder ODBC-Datenanbieter entworfen sein.The report must be designed to work with an OLE DB or ODBC data provider. Wenn Sie den Bericht mithilfe einer anderen Datenverarbeitungserweiterung erstellt haben, enthält der Bericht oder enthalten dessen Dateien möglicherweise Funktionen, die nicht vom OLE DB- oder ODBC-Datenanbieter unterstützt werden.If you used a different data processing extension to create the report, the report or its queries might include functionality that is not supported by the OLE DB or ODBC data provider.

  • Die ODC-Datei muss über die erwarteten Elemente und die erwartete Struktur verfügen.The .odc file must have the expected elements and structure. Der Datenanbieter und die Einstellungen für die Anmeldeinformationen müssen explizit in der Datei festgelegt sein, damit sie vom Berichtsserver gelesen werden können.The data provider and credential settings must be set explicitly in the file so that they can be read by the report server. Die einfachste Methode, diese Werte festzulegen, besteht darin, die ODC-Datei vor dem Hochladen in die SharePoint-Bibliothek zu exportieren.The best way to set these values is to export the .odc file before uploading it to the SharePoint library.

  • Die ODC-Datei muss den Verbindungstyp OLE DB oder ODBC angeben.The .odc file must specify a connection type of OLE DB or ODBC.

  • In der ODC-Datei muss eine Verbindungszeichenfolge angegeben sein.The .odc file must specify a connection string.

  • Die Anmeldeinformationen können auf None, Storedoder Integratedfestgelegt werden.Credentials can be set to None, Stored, or Integrated. Wenn die Methode für die Anmeldeinformationen auf Storedfestgelegt ist, wird der Benutzer vom Berichtsserver zur Eingabe seiner Anmeldeinformationen aufgefordert, und es werden nicht die gespeicherten Anmeldeinformationen verwendet.If the credentials method is set to Stored, the report server will prompt the user for credentials instead of using the stored credentials. Vom Berichtsserver können wie in einer ODC-Datei definiert keine gespeicherten Anmeldeinformationen verwendet werden.The report server cannot use stored credentials as defined in the .odc file.

  • Die Datenquelle muss über ein Schema verfügen, das mit dem zum Erstellen des Berichts verwendeten Schema identisch ist.The data source must have schema that is identical to the one used to create the report. Wenn die Datenstrukturen unterschiedlich sind, wird der Bericht nicht ausgeführt.If the data structures are different, the report will not run.

  • Die ODC-Datei muss in MicrosoftMicrosoft Office 2007 erstellt werden. (Ältere Versionen von ODC-Dateien sind nicht kompatibel mit Berichtsdefinitionsdateien.)The .odc file must be created in MicrosoftMicrosoft Office 2007 (older versions of .odc are not compatible with report definition files).

    Sie können keine ODC-Dateien verwenden, in denen Verbindungen mit Datenquellen angegeben sind, die auf einem Berichtsserver nicht verarbeitet werden können. Dies gilt auch, wenn die Datenquellentypen der ODC-Datei unterstützen Datenquellentypen ähneln.You cannot use .odc files that specify connections to data sources that cannot be processed on a report server, even if the .odc data source types look similar to supported data source types. Insbesondere, wenn Sie eine ODC-Datei in Microsoft Excel 2007 erstellt haben, die Daten aus Microsoft Access, dem Web oder einer Textdatei abruft, können Sie mit dieser ODC-Datei keine Daten für einen Bericht bereitstellen.Specifically, if you created an .odc file in Microsoft Excel 2007 that retrieves data from Microsoft Access, the Web, or a text file, you cannot use that .odc file to provide data to a report.

    Berichte und Modelle des Berichts-Generators werden für ODC-Dateien nicht unterstützt.Report Builder reports and models do not work with .odc file. Sie können eine ODC-Datei nicht zum Generieren eines Modells verwenden, und Sie können das Modell nicht so konfigurieren, dass eine freigegebene Datenquelle mit einem Link zu einer ODC-Datei verwendet wird.You cannot use an .odc file to generate a model, and you cannot configure the model to use a shared data source that links to an .odc file.

    Wenn Sie nicht mit ODC-Dateien vertraut sind, können Sie die folgenden Anweisungen zum Erstellen und Exportieren einer ODC-Datei verwenden.If you are not familiar with .odc files, you can use the following instructions to create and export one. Eine einfache Möglichkeit, eine ODC-Datei für eine OLE DB-Datenquelle zu erstellen, besteht im Verwenden von Excel 2007 und dem Datenverbindungs-Assistenten.One easy way to create an .odc file for an OLE DB data source is to use Excel 2007 and the Data Connection Wizard. Beachten Sie, dass vom Assistenten keine Datenquelle erstellt wird. Sie müssen über eine externe Datenquelle verfügen, die bereits definiert ist.Note that the wizard does not create a data source; you must have an external data source that is already defined.

    Eine vorhandene ODC-Datei sollte nur verwendet werden, wenn sie vollständig mit dem Bericht und den Abfragen kompatibel ist.An existing .odc file should only be used if it is fully compatible with the report and queries. Wenn Fehler auftreten, die beträchtliche Änderungen am Bericht oder an der ODC-Datei erfordern, sollten Sie eine neue RSDS-Datei für den Bericht erstellen.If you run into errors that require significant modifications to either the report or to the .odc file, you should create a new .rsds file for the report. Weitere Informationen zum Erstellen einer freigegebenen Datenquelle finden Sie unter Erstellen und Verwalten von freigegebenen Datenquellen (Reporting Services im integrierten SharePoint-Modus).For more information about how to create a shared data source that uses an .rsds file, see Create and Manage Shared Data Sources (Reporting Services in SharePoint Integrated Mode).

So erstellen und exportieren Sie eine ODC-DateiTo create and export an .odc file

  1. Starten Sie Excel 2007.Start Excel 2007.

  2. Klicken Sie auf der Registerkarte Daten in der Gruppe Externe Daten auf Aus anderen Quellen, und klicken Sie anschließend auf Vom Datenverbindungs-Assistent.On the Data tab, in the Get External Data group, click From Other Sources, and then click From Data Connection Wizard.

  3. Wählen Sie Weitere/erweiterteaus, und klicken Sie anschließend auf Weiter.Select Other/Advanced, and then click Next.

  4. Wählen Sie Microsoft OLE DB Provider for SQL Serveraus, und klicken Sie anschließend auf Weiter.Select Microsoft OLE DB Provider for SQL Server, and then click Next.

  5. Geben Sie den Namen des Servers (standardmäßig der Netzwerkname des Computers) und ein Benutzerkonto ein, das über eine gültige Anmeldung und Datenbankberechtigungen verfügt.Enter the name of the server (by default, it is the network name of the computer) and a user account that has a valid login and database permissions. Klicken Sie auf Weiter.Click Next.

  6. Wählen Sie eine Datenbank aus, und klicken Sie anschließend auf OK , um das Dialogfeld Datenlinkeigenschaften zu schließen.Select a database, and then click OK to close the Data Link dialog box.

  7. Das Kontrollkästchen Mit einer ausgewählten Tabelle verbinden: ist standardmäßig aktiviert.The Connect to specific table check box is selected by default. Es wird zum Abrufen von Daten aus einer spezifischen Tabelle verwendet.It is used to retrieve data from a specific table. Es werden alle Abfragen in einer ODC-Datei vom Berichtsserver ignoriert. Daher ist es nicht ausschlaggebend, ob Sie das Kontrollkästchen aktivieren oder deaktivieren.The report server ignores all queries in an .odc file, so it does not matter whether you select or clear the check box. Abfragen, mit denen Daten für einen Bericht abgerufen werden, befinden sich in der Berichtsdefinitionsdatei, nicht in externen Dateien.Queries that retrieve data for a report are included in a report definition file and not in external files.

  8. Während die Verbindung geöffnet ist, können Sie Eigenschaften bearbeiten und die Verbindungsdatei exportieren.While the connection is open, you can edit properties and export it. Klicken Sie auf der Registerkarte Daten in der Gruppe Verbindungen auf Eigenschaften, und klicken Sie anschließend neben dem Namen der Verbindung auf die Schaltfläche Verbindungseigenschaften .On the Data tab, in the Connections group, click Properties, and then click the Connection Properties button next to the connection name.

  9. Klicken Sie auf der Registerkarte Definition auf Verbindungsdatei exportieren.On the Definition tab, click Export Connection File.

  10. Geben Sie einen Namen für die Datei ein, und klicken Sie dann auf Speichern.Enter a name for the file, and then click Save. Schließen Sie die Anwendung und alle geöffneten Dateien.Close the application and all open files.

So laden Sie eine ODC-Datei hoch und verwenden SieTo upload and use an .odc file

  1. Öffnen Sie die Bibliothek, in die Sie die Verbindungsdatei hochladen möchten.Open the library into which you want to upload the connection file.

  2. Klicken Sie im Menü Upload auf Dokumentupload.On the Upload menu, click Upload document.

  3. Klicken Sie auf Durchsuchen.Click Browse.

  4. Wählen Sie die von Ihnen erstellte ODC-Datei aus.Select the .odc file you created. Die ODC-Datei befindet sich standardmäßig im Ordner Meine Dateien unter Meine Datenquellen.By default, the .odc file is in the My Documents folder, in My Data Sources.

  5. Klicken Sie auf Öffnen , um die Datei auszuwählen, und klicken Sie auf OK , um die Auswahl zu speichern.Click Open to select the file, click OK to save the selection. Die Eigenschaftenseite für das neue Element wird automatisch geöffnet.The properties page for the new item opens automatically.

  6. Wählen Sie unter Inhaltstyp die Option Berichtsdatenquelleaus, und klicken Sie anschließend auf OK.In Content Type, select Report Data Source, and then click OK.

  7. Zeigen Sie auf einen Bericht.Point to a report.

  8. Klicken Sie auf den Pfeil nach unten, und wählen Sie Datenquellen verwaltenaus.Click the down arrow, and select Manage Data Sources.

  9. KIicken Sie auf den Namen der Datenquelle.Click the data source name.

  10. Wenn für den Bericht benutzerdefinierte Datenquelleninformationen verwendet werden, klicken Sie auf Freigegeben.If the report uses custom data source information, click Shared.

  11. Klicken Sie unter Datenquellenlinkauf die Schaltfläche zum Durchsuchen (...).In Data Source Link, click the browse (...) button.

  12. Wählen Sie die von Ihnen soeben hochgeladene ODC-Datei aus.Select the .odc file you just uploaded.

  13. Klicken Sie auf OK , um die Datei auszuwählen, und klicken Sie anschließend auf OK , um die Änderungen zu speichern.Click OK to select the file, and then click OK to save your changes.

    Wenn Sie versuchen, diese Schritte für die AdventureWorks2012AdventureWorks2012 -Beispieldatenbank und -Beispielberichte auszuführen, sollten Sie beachten, dass nur der Bericht Company Sales sofort mit einer ODC-Datei verwendet werden kann.If you are trying these steps with the AdventureWorks2012AdventureWorks2012 sample database and sample reports, be aware that only the Company Sales report will work out-of-the-box with an .odc file. Die anderen Beispielberichte enthalten Abfrageparameter und Funktionen, die den OLE DB-Anbieter nicht unterstützen.The other sample reports contain query parameters and features that do not work with the OLE DB provider. Sie können die Berichte jedoch für den OLE DB-Anbieter aufbereiten, wenn Sie sie zuerst im Berichts-Designer ändern.However, you can make the reports work with the OLE DB provider if you modify them first in Report Designer.

Siehe auchSee Also

Erstellen, Ändern und Löschen von freigegebenen Datenquellen (SSRS)Create, Modify, and Delete Shared Data Sources (SSRS)