Reporting Services in SQL Server-Datentools (SSDT)Reporting Services in SQL Server Data Tools (SSDT)

SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. environment for creating business intelligence solutions. SSDT verfügt über die Erstellungsumgebung des Bericht-Designers, in dem Sie paginierte Reporting ServicesReporting Services -Berichtsdefinitionen, freigegebene Datenquellen, freigegebene Datasets und Berichtsteile öffnen, ändern, vorher ansehen, speichern und bereitstellen können.SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)nicht ist mit SQL Server enthalten. is not included with SQL Server. Herunterladen von SQL Server Data Tools.Download SQL Server Data Tools.

In diesem Thema werden die SQL Server Data ToolsSQL Server Data Tools -Lösungen, -Projekte, -Projektvorlagen und -Konfigurationen beschrieben, die für Reporting ServicesReporting Servicesverwendet werden, sowie die Ansichten, Menüs, Symbolleisten und Tastenkombinationen, die Sie im Berichts-Designer verwenden können.This topic describes SQL Server Data ToolsSQL Server Data Tools solutions, projects, project templates, and configurations used for Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

Eine Einführung in das Entwerfen von Berichten finden Sie unter Entwerfen von Berichten mithilfe des Berichts-Designers (SSRS).To get started designing reports, see Design Reports with Report Designer (SSRS).

Lösungen und Projekte Solutions and Projects

Ein Berichtsprojekt dient als Container für Berichtsdefinitionen und Ressourcen.A report project acts as a container for report definitions and resources. Jede Datei im Berichtsprojekt wird bei der Bereitstellung des Projekts auf dem Berichtsserver veröffentlicht.Every file in the report project is published to the report server when the project is deployed. Wenn Sie zum ersten Mal ein Projekt erstellen, wird zusätzlich eine Projektmappe als Container für das Projekt erstellt.When you create a project for the first time, a solution is also created as a container for the project. Sie können mehrere Projekte zu einer Projektmappe hinzufügen.You can add multiple projects to a single solution.

Konfigurationen Configurations

Wenn Sie mehrere Sätze von Projekteigenschaften für unterschiedliche Bereitstellungsvarianten (etwa Test- und Produktionsberichtsserver im Unternehmen) erstellen möchten, verwenden Sie den Konfigurations-Manager.To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. Weitere Informationen finden Sie unter Bereitstellung und Versionsunterstützung in SQL Server Data Tools (SSRS)enthalten.For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

Berichtsserverprojekte Report Server Projects

Bei der Installation von Reporting ServicesReporting Serviceswerden die folgenden Projektvorlagen in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)verfügbar gemacht:When you install Reporting ServicesReporting Services, the following project templates are made available in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT):

  • Berichtsserverprojekt.Report Server Project. Wenn Sie ein Berichtsserverprojekt auswählen, wird der Berichts-Designer geöffnet.When you select a Report Server Project, Report Designer opens. Bei einem Berichtsserverprojekt handelt es sich um eine von Visual StudioVisual Studio installierte Business Intelligence-Projektvorlage, die über das Dialogfeld Neues Projekt aufgerufen werden kann.A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. Weitere Informationen finden Sie unter Hinzufügen eines neuen oder vorhandenen Berichts zu einem Berichtsprojekt (SSRS). Berichtsserverprojekteigenschaften gelten für alle Berichte und alle freigegebenen Datenquellen in einem SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)-Projekt.For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT) project. Zu diesen Eigenschaften zählen die URL für den Berichtsserver sowie die Ordnernamen für Berichte und freigegebene Datenquellen.These properties include the URL for the report server and the folder names for reports and shared data sources. Verwenden Sie das Dialogfeld Eigenschaftenseiten für Projekt , um die aktuellen Eigenschaftenwerte anzuzeigen.Use the Project Property Pages dialog box to view the current property values. Klicken Sie zum Öffnen dieses Dialogfelds im Menü Projekt auf Eigenschaften.To open this dialog box, on the Project menu, click Properties.

  • Berichtsserverprojekt-Assistent.Report Server Project Wizard. Wenn Sie ein Berichtsserver-Assistenten-Projekt auswählen, wird automatisch ein Berichtsserverprojekt erstellt und der Berichts-Assistent geöffnet.When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. Mithilfe des Assistenten können Sie einen Bericht erstellen. Befolgen Sie hierzu die Anweisungen auf den einzelnen Seiten, um eine Verbindungszeichenfolge für eine Datenquelle zu erstellen, Datenquellen-Anmeldeinformationen festzulegen, eine Abfrage zu entwerfen, einen Tabellen- oder Matrixdatenbereich hinzuzufügen, Berichtsdaten und -gruppen anzugeben, Schriftart und Farbe auszuwählen, den Bericht auf einem Berichtsserver zu veröffentlichen und den Bericht lokal in der Vorschau anzuzeigen.In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. Nachdem Sie mithilfe des Assistenten einen Bericht erstellt haben, können Sie die Berichtsdaten und den Berichts-Designer ändern, und zwar mithilfe des Berichts-Designers im Berichtsserverprojekt.After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

    Neue Projektvorlagen in SSDTNew Project templates in SSDT

Fenster und Bereiche des Berichts-Designers Report Designer Windows and Panes

Im Berichts-Designer werden zwei Ansichten unterstützt: Entwurf zum Definieren der Berichtsdaten und des Berichtslayouts sowie Vorschau zum Anzeigen einer gerenderten Ansicht des Berichts.Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the the report. In jeder Ansicht können Sie mehrere Fenster anzeigen, die Sie beim Entwerfen unterstützen. Außerdem können Sie einen gerenderten Bericht anzeigen.In each view, you can display multiple windows to help you design or view a rendered report.

Berichtsdatenbereich Report Data Pane

im Berichtsdatenbereich werden integrierte Felder, Datenquellen, Datasets, Feldauflistungen, Berichtsparameter und Bilder angezeigt.The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

Verwenden Sie den Berichtsdatenbereich, um Folgendes anzuzeigen:Use the Report Data pane to view:

  • Integrierte Felder Vordefinierte Berichtsdefinitionen, etwa den Namen des Berichts oder den Zeitpunkt der Berichtsverarbeitung.Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • Datenquellen Eine Datenquelle stellt einen Namen und eine Verbindung zu einer Quelle mit Daten dar.Data sources A data source represents a name and connection to a source of data.

  • Datasets Jedes Dataset enthält eine Abfrage, aus der hervorgeht, welche Daten aus der Datenquelle abgerufen werden sollen.Datasets Each dataset includes a query that specifies which data to retrieve from the data source. Erweitern Sie das Dataset, um die von der Datasetabfrage angegebene Feldauflistung anzuzeigen.Expand the dataset to view the collection of fields specified by the dataset query.

    In einigen Abfrage-Designern für mehrdimensionale Datenquellen können Sie im Filterbereich Filter angeben und auswählen, ob Berichtsparameter erstellt werden sollen.In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. Wenn Sie die Berichtsparameteroption angeben, wird automatisch ein spezielles Dataset erstellt, um die Liste mit den gültigen Werten des Parameters aufzufüllen.If you specify the report parameter option, a special dataset is automatically created to populate the parameter’s valid values list. Standardmäßig wird dieses Dataset nicht im Berichtsdatenbereich angezeigt.By default, the dataset does not appear in the Report Data Pane. Weitere Informationen finden Sie unter Anzeigen von ausgeblendeten Datasets für Parameterwerte für mehrdimensionale Daten (Berichts-Generator und SSRS).For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • Berichtsparameter Die Liste der Berichtsparameter.Report parameters The list of report parameters. Parameter können manuell oder automatisch erstellt werden, wenn eine Datasetabfrage Abfrageparameter einschließt.Parameters can be created manually or automatically when a dataset query includes query parameters.

  • Bilder Die Liste der Bilder, die als Bildberichtselement in einen Bericht eingeschlossen werden können.Images The list of images that are available to include as an Image report item in a report.

    Datenquellen und Datasets im Berichtsdatenbereich stellen die Elemente in der Berichtsdefinition dar.Data sources and datasets in the Report Data pane represent the elements in the report definition. Der Berichtsdatenbereich ist eine Funktion, die von mehreren Berichtserstellungsumgebungen unterstützt wird.The Report Data pane is a feature supported by multiple report authoring environments. Im Berichts-Generator ist dies der einzige Bereich der zum Verwalten von Datenquellen und Datasets verfügbar ist.In Report Builder, it is the only pane available for managing data sources and datasets. In Berichts-Designer kann der Berichtsdatenbereich mit dem Projektmappen-Explorer verwendet werden, der freigegebene Datenquellen und freigegebene Datasets als Dateien auflistet.In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. Freigegebene Datenquellen und freigegebene Datasets im Berichtsdatenbereich müssen auf ihre entsprechenden freigegebenen Datenquellen und freigegebenen Datasets im Projektmappen-Explorer zeigen.Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. Die Elemente des Berichtsdatenbereichs enthalten dann einen Verweis auf die Datendateien im Projektmappen-Explorer.The Report Data pane elements then contain a reference to the data files in Solution Explorer. Die Projekteigenschaften bestimmen, ob die freigegebenen Datenquellen und freigegebenen Datasets auf der Berichtsserver- oder SharePoint-Website bereitgestellt werden.The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. Weitere Informationen finden Sie unter Konvertieren von Datenquellen (Berichts-Generator und SSRS).For more information, see Convert Data Sources (Report Builder and SSRS).

Hinweis

Wenn der Berichtsdatenbereich nicht angezeigt wird, klicken Sie in den Entwurfsbereich und dann im Menü Sicht auf Berichtsdaten.If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. Wenn der Berichtsdatenbereich unverankert ist, können Sie ihn verankern.If the Report Data pane is floating, you can anchor it. Weitere Informationen finden Sie unter Andocken des Berichtsdatenbereichs im Berichts-Designer (SSRS).For more information, see Dock the Report Data Pane in Report Designer (SSRS).

Gruppierungsbereich Grouping Pane

Verwenden Sie den Gruppierungsbereich, um Gruppen für einen Tablix-Datenbereich zu definieren.Use the Grouping pane to define groups for a tablix data region. Sie können Zeilengruppen und Detailgruppen für Tabellen sowie Zeilen- und Spaltengruppen für Matrizen definieren.You can define row groups and detail groups for tables and row and column groups for matrices. Sie können den Gruppierungsbereich nicht verwenden, um Gruppen für Diagramme und andere Datenbereiche zu definieren.You cannot use the Grouping pane to define groups for Charts or other data regions. Weitere Informationen finden Sie unter Grundlegendes zu Gruppen (Berichts-Generator und SSRS).For more information, see Understanding Groups (Report Builder and SSRS).

Der Gruppierungsbereich unterstützt zwei Modi:The Grouping pane has two modes:

  • Standard.Default. Verwenden Sie das Dialogfeld Standard , um alle Zeilen- und Spaltengruppen in einem hierarchischen Format anzuzeigen, das die Beziehung zwischen übergeordneten Gruppen, untergeordneten Gruppen, angrenzenden Gruppen und Detailgruppen aufzeigt.Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. Eine untergeordnete Gruppe wird im Vergleich zu ihrer übergeordneten Gruppe unter und auf der nächsten Einzugsebene angezeigt.A child group appears under and at the next indent level compared to its parent group. Eine angrenzende Gruppe wird auf der gleichen Einzugsebene wie ihre Peergruppen oder gleichgeordneten Gruppen angezeigt.An adjacent group appears at the same indent level as its peer or sibling groups.

    Verwenden Sie den Standardmodus, um Gruppen hinzuzufügen, zu bearbeiten oder zu löschen.Use default mode to add, edit, or delete groups. Für Gruppen, die auf einem einzelnen Datasetfeld basieren, ziehen Sie das Feld in die Bereiche für Zeilengruppen und Spaltengruppen.For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. Sie können die Gruppe über oder unter einer vorhandenen Gruppe einfügen.You can insert the group above or below an existing group. Zum Hinzufügen einer angrenzenden Gruppe klicken Sie mit der rechten Maustaste auf die gleichgeordnete Gruppe, und verwenden Sie dann das Kontextmenü.To add an adjacent group, right-click the sibling group, and use the shortcut menu. Um anzuzeigen, welche Tablixzellen zu einer Gruppe gehören, wählen Sie die Gruppe im Gruppierungsbereich aus.To display which tablix cells belong to a group, select the group in the Grouping pane.

  • Erweitert.Advanced. Verwenden Sie das Dialogfeld Erweitert , um statische und dynamische Zeilen- und Gruppenelemente des ausgewählten Tablix-Datenbereichs anzuzeigen.Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. Sie müssen Gruppenelemente verwenden, um Eigenschaften zur Steuerung der Sichtbarkeit der Zeilen und Spalten für eine Gruppe oder ein Gruppenmitglied oder die Regeln festzulegen, die von Renderern verwendet werden, um Gruppen auf einer Seite zusammenzuhalten.You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. Gruppenelemente werden in der Entwurfsoberfläche als Zellen in den Zeilen- und Spaltengruppenbereichen angezeigt.Group members appear on the design surface as cells in the row group and column group areas.

Hinweis

Klicken Sie mit der rechten Maustaste auf den Pfeil nach unten, der sich rechts neben dem Symbol Spaltengruppen befindet, um zwischen den Modi Standard und Erweitert umzuschalten.To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

Weitere Informationen finden Sie unter Grouping Pane.For more information, see Grouping Pane.

Toolbox Toolbox

Die Toolbox enthält Berichtselemente, die Sie auf die Entwurfsoberfläche ziehen können.The Toolbox contains report items that you can drag to the design surface. Datenbereiche sind Berichtselemente, die Sie verwenden, um die Daten im Bericht zu organisieren.Data regions are report items that you use to organize data on the report. Tabelle, Matrix, Liste, Diagramm, Messgerät, Datenleiste, Sparkline und Indikator sind Datenbereiche.Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. Andere Berichtselemente schließen Karte, Textfeld, Rechteck, Linie, Bild und Unterbericht ein.Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. Diese Liste kann auch benutzerdefinierte Berichtselemente enthalten, wenn diese vom Systemadministrator installiert und registriert wurden.Custom report items might also appear on this list if they have been installed and registered by your system administrator.

Eigenschaftenbereich Properties Pane

Der Eigenschaftenbereich ist ein Standardfenster von Visual StudioVisual Studio , in dem die Eigenschaftsnamen und Werte für das aktuell auf der Entwurfsoberfläche ausgewählte Berichtselement angezeigt werden.The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. In den meisten Fällen entsprechen Eigenschaftsnamen den Elementen und Attributen in der RDL-Datei (Report Definition Language, Berichtsdefinitionssprache).In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. Die am häufigsten verwendeten Eigenschaften können im Dialogfeld Eigenschaften für das ausgewählte Element festgelegt werden.The most commonly used properties can be set by using the Properties dialog box for the selected item. Zum Öffnen des entsprechenden Dialogfelds klicken Sie auf die Schaltfläche Eigenschaftenseiten auf der Eigenschaftenbereichssymbolleiste.To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. Erfahrene Benutzer können die Eigenschaftenwerte im Eigenschaftenbereich festlegen.Advanced users can set property values directly in the Properties pane.

Verwenden Sie den Eigenschaftenbereich, um Folgendes durchzuführen:Use the Properties pane to:

  • Festlegen von Eigenschaften für das aktuell ausgewählte Element auf der Entwurfsoberfläche.Set properties for the currently selected item on the design surface. Einige Eigenschaften stellen eine Dropdownliste mit Werten bereit.Some properties provide a drop-down list of values. Sie können den Wert auch direkt in die Zelle eingeben.You can also type the value directly in the cell. Einige Eigenschaften enthalten eine Sammlung von Werten, die durch den Wert (Auflistung)angegeben wird.Some properties contain a collection of values, indicated by the value (Collection). Die meisten Eigenschaften können einen Ausdruck akzeptieren; komplexe Ausdrücke werden durch die angegebenen <Ausdruck >.Most properties can accept an expression; complex expressions are indicated by the value <Expression>. Klicken Sie auf <Ausdruck > So öffnen die Ausdruck (Dialogfeld).Click <Expression> to open the Expression dialog box. Weitere Informationen finden Sie unter Expression Dialog Box.For more information, see Expression Dialog Box.

  • Verwenden Sie die Schaltflächen in der Symbolleiste des Eigenschaftenbereichs, um das Raster von Kategoriesicht in alphabetische Sicht zu ändern.Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. In der Kategoriesicht müssen Sie möglicherweise eine Kategorie erweitern, um alle Eigenschaften darunter zu sehen.In category view, you may need to expand a category to see all the properties under it. Zum Öffnen des Dialogfelds „Eigenschaften“ für ein Element klicken Sie in der Symbolleiste auf die Schaltfläche Eigenschaftenseiten , oder klicken Sie mit der rechten Maustaste auf das Element, und klicken Sie anschließend auf Eigenschaften.To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • Legen Sie Eigenschaften für das aktuell ausgewählte Gruppenmitglied im Gruppierungsbereich fest.Set properties for the currently selected group member in the Grouping pane. Mit Gruppenmitgliedseigenschaften können Sie steuern, wie statische Gruppenkopf- und -fußzeilen für die einzelnen Gruppeninstanzen wiederholt werden.Group member properties help control how static group header and footer rows repeat for each group instance. Weitere Informationen finden Sie unter Anzeigen von Kopf- und Fußzeilen einer Gruppe (Berichts-Generator und SSRS).For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

    Klicken Sie im Menü Ansicht auf Eigenschaftenfenster, um das Eigenschaftenfenster anzuzeigen.To display the Properties pane, from the View menu, click Properties Window. Sie können die Verankerung dieses Bereichs aufheben und ihn an eine andere Stelle im SQL Server Data ToolsSQL Server Data Tools-Fenster verschieben oder auf der Entwurfsoberfläche als Ansicht im Registerkartenformat anzeigen.You can undock this pane and move it to another area of the SQL Server Data ToolsSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

Projektmappen-Explorer Solution Explorer

Der Projektmappen-Explorer ist eine Standardkomponente von Visual StudioVisual Studio , die alle Elemente im Projekt anzeigt.Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. Für ein Berichtsserverprojekt umfasst er Ordner zum Organisieren von freigegebenen Datenquellen, freigegebenen Datasets, Berichten und Ressourcen.For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. Berichtselemente werden automatisch alphabetisch sortiert, wenn Sie die Projektmappendatei für ein Projekt öffnen.Folder items are automatically alphabetized when you open the solution file. Um Elementeigenschaften im Eigenschaftenbereich anzuzeigen, wählen Sie das Element aus.To view item properties in the Properties pane, select the item.

Ausgabe Output

Im Ausgabefenster werden Verarbeitungsfehler angezeigt, wenn Sie einen Bericht in der Vorschau anzeigen, und Veröffentlichungsfehler, wenn Sie einen Bericht oder eine freigegebene Datenquelle bereitstellen.The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

Verwenden Sie die Ausgabe- und Dokumentgliederungsfenster, um Fehler in Ausdrücken zu debuggen.Use the Output and the Document Outline windows to help debug errors in expressions.

Dokumentgliederung Document Outline

Im Dokumentgliederungsfenster wird eine hierarchische Liste aller Berichtselemente angezeigt, die Teil der Berichtsdefinition sind.The Document Outline window displays a hierarchical list of all report items in the report definition. Zum Öffnen des Dokumentgliederungsbereichs zeigen Sie im Menü Ansicht auf Weitere Fenster , und klicken Sie dann auf Dokumentfenster.To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

Verwenden Sie den Dokumentgliederungsbereich, um Textfelder und andere Berichtselemente nach dem Namen zu identifizieren.Use the Document Outline pane to help identify text boxes and other report items by name. Wenn Sie ein Element in der Dokumentgliederung auswählen, wird das Element auch auf der Entwurfsoberfläche ausgewählt.When you select an item in the Document Outline, the item is also selected on the Design Surface.

Aufgabenliste Task List

Im Fenster Aufgabenliste MicrosoftMicrosoft werden Erstellungsfehler für nicht unterstützte Funktionen angezeigt, wenn Sie einen Bericht aus einer anderen Anwendung wie Access importieren.The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

Entwurfsansicht des Berichts-Designers Report Designer Design View

Wenn Sie ein Berichtsserverprojekt erstellen, wird der Berichts-Designer standardmäßig in der Entwurfsansicht geöffnet und die Entwurfsoberfläche angezeigt.By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. Die Entwurfsoberfläche enthält standardmäßig den Berichtstext sowie den Berichtshintergrund.By default, the design surface displays the report body and the report background.

Das Hintergrund-Kontextmenü enthält Optionen zum Hinzufügen einer Kopf- und Fußzeile. Im Ansicht-Menü finden Sie ein Lineal und den Bereich für die Gruppierung.The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

Verwenden Sie das Zoomsteuerelement, um die Berichtsanzeige zu vergrößern oder zu verkleinern.Use the zoom control to increase or decrease the magnification of the report.

Um einen Bericht zu entwerfen, können Sie Berichtselemente aus der Toolbox auf die Entwurfsoberfläche ziehen. Im Anschluss können Sie ihre Eigenschaften konfigurieren und ihre Anordnung im Bericht ändern.To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

Berichts-Designer-Vorschau Report Designer Preview

Verwenden Sie die Vorschau, um einen Bericht auszuführen und den gerenderten Bericht im Berichts-Viewer anzuzeigen.Use Preview to run the report and view the rendered report in the report viewer. Mit Vorschau werden Berichtsdaten lokal zwischengespeichert.Preview caches report data locally. Sie können auch Konfigurationseigenschaften festlegen, um den Bericht in der Debugansicht auszuführen (über einen Browser).You can also set configuration properties to run the report in debug view, using a browser.

Wenn Sie einen Bericht in der Vorschau anzeigen, wird vom Berichts-Designer eine Verbindung mit den Berichtsdatenquellen hergestellt und dann werden die Datasetabfragen ausgeführt, die Daten im Cache des lokalen Computers gespeichert, der Bericht verarbeitet, um Daten und Layout zu kombinieren, und der Bericht schließlich gerendert.When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. Sie können den Bericht auf der Registerkarte Vorschau anzeigen oder Projekteigenschaften festlegen, um den Bericht im Debugmodus direkt in einem Browser anzuzeigen.You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • Anzeigen einer Vorschau für parametrisierte Berichte.Previewing Parameterized Reports. Wenn Sie eine Vorschau eines Berichts anzeigen, wird der Bericht automatisch verarbeitet, wenn alle Berichtsparameter über gültige Standardwerte verfügen.When you preview a report, the report is processed automatically if all report parameters have valid default values. Wenn ein oder mehrere Berichtsparameter über keinen gültigen Standardwert verfügen, müssen Sie für jeden nicht zugewiesenen Parameter einen Wert auswählen und dann in der Symbolleiste des Berichts auf Bericht anzeigenklicken.If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • Verstehen des lokalen Datencaches Wenn Sie einen Bericht in der Vorschau anzeigen, werden vom Berichtsprozessor alle Datasetabfragen im Bericht mithilfe der aktuellen Parameterstandardwerte ausgeführt, und die Ergebnisse werden als lokale Datencachedatei (.rdl.data) gespeichert.Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. Wenn Sie keine Änderungen an den Datasetabfragen des Berichts oder an den Berichtsparametern vornehmen, können Sie mit dem Entwerfen Ihres Berichts fortfahren, ohne diese Daten erneut abzurufen.You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • Anzeigen des Berichts in der Vorschau mithilfe des Konfigurations-Managers und Debuggen.Previewing the Report using Configuration Manager and Debug. In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)definieren Sie über Projekteigenschaften, wie Sie die Berichte bereitstellen und debuggen möchten.In SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. Diese Eigenschaften gelten für alle Berichte und freigegebenen Datenquellen im Projekt.These properties apply to all reports and shared data sources in the project. Klicken Sie zum Festlegen der Projekteigenschaften im Menü Projekt auf Eigenschaften.To set the project properties, from the Project menu, click Properties. Verwenden Sie diese Einstellungen, um Ihre Berichte zu testen und sie auf dem Berichtsserver zu veröffentlichen.Use these settings to test your reports and publish them to the report server.

  • Überwachen des Ausgabebereichs für Fehlermeldungen.Monitoring the Output Pane for Error Messages. Wenn Sie eine Vorschau für einen Bericht anzeigen und vom Berichtsprozessor ein Problem entdeckt wird, werden Fehlermeldungen in den Ausgabebereich geschrieben.When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

Berichts-Designer-Menüs Report Designer Menus

Wenn in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT)ein Berichts-Designer-Projekt aktiviert ist, werden der Hauptsymbolleiste die folgenden Symbolleisten hinzugefügt.When a Report Designer project is active in SQL Server Data Tools (SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. Die Berichts-Designer-Menüs sind nur in der Entwurfsansicht sichtbar.The Report Designer menus are visible only when in Design view.

Menü 'Format' Format Menu

Wenn Sie auf der Entwurfsoberfläche ein Element auswählen, enthält das Menü Format die folgenden Optionen:When you select an item on the design surface, the Format menu contains the following options:

  • Vordergrundfarbe Wählen Sie eine Textfarbe aus.Foreground Color Select a text color. Die Standardtextfarbe ist Schwarz.Black is the default text color.

  • Hintergrundfarbe Wählen Sie eine Hintergrundfarbe für Textfelder und Datenregionen aus.Background Color Select a background color for your text boxes and data regions.

  • Schriftart Geben Sie an, ob der Text fett, kursiv oder unterstrichen ist.Font Specify whether the text is bold, italic, or underlined.

  • Im Blocksatz ausrichten Geben Sie an, ob der Text rechtsbündig, linksbündig oder zentriert ausgerichtet ist.Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • Ausrichten Geben Sie an, wie ausgewählte Objekte innerhalb des Berichts in Relation zueinander ausgerichtet werden.Align Specify how the selected objects are aligned in relation to one another within the report.

  • Größe angleichen Gleichen Sie die Größe der ausgewählten Objekte innerhalb des Berichts an.Make Same Size Adjust the size of the selected objects within the report.

  • Horizontaler Abstand Gleichen Sie den horizontalen Abstand zwischen ausgewählten Objekten innerhalb des Berichts an.Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • Vertikaler Abstand Gleichen Sie den vertikalen Abstand zwischen ausgewählten Objekten innerhalb des Berichts an.Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • Auf Formular zentrieren Zentrieren Sie das ausgewählte Objekt vertikal und horizontal im Verhältnis zum Fenster des Berichts-Designers.Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • Reihenfolge Verschieben Sie ausgewählte Objekte in den Hintergrund oder den Vordergrund.Order Move selected objects into the background or foreground.

Menü 'Bericht' Report Menu

Wenn sich der Fokus auf der Berichtsentwurfsoberfläche befindet, enthält das Menü Bericht die folgenden Optionen:When the report design surface has focus, the Report menu contains the following options:

  • Berichtseigenschaften Wählen Sie diese Option aus, um das Dialogfeld Berichtseigenschaften zu öffnen.Report Properties Select to open the Report Properties dialog box. In diesem Dialogfeld können Sie die allgemeinen Berichtseigenschaften, wie den Namen des Autors und den Rasterabstand zuweisen, und Sie können Eigenschaften für das Berichtslayout, wie die Anzahl der Spalten und die Seitengröße angeben.In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. Sie können darüber hinaus benutzerdefinierten Code, Verweise auf Assemblys und Klassen sowie die Namen der Datenausgabeelemente, Datentransformationen und Datenschemas einschließen.You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • Sicht Schalten Sie hiermit zwischen den zwei Berichts-Designer-Registerkarten um: Entwurf und Vorschau.View Switch between the two Report Designer tabs: Design and Preview.

  • Seitenkopf Hiermit können Sie dem Bericht einen Seitenkopf hinzufügen oder den Seitenkopf löschen.Page Header Add or delete a page header to the report. Wenn Sie einen Seitenkopf löschen, werden alle Elemente im Seitenkopf gelöscht.When you delete a page header, all items in the page header are deleted.

  • Seitenfuß Hiermit können Sie dem Bericht einen Seitenfuß hinzufügen oder den Seitenfuß löschen.Page Footer Add or delete a page footer to the report. Wenn Sie einen Seitenfuß löschen, werden alle Elemente im Seitenfuß gelöscht.When you delete a page footer, all items in the page footer are deleted.

  • Gruppierungsbereich Dient zum Ein- oder Ausblenden des Gruppierungsbereichs.Grouping Pane Show or hide the Grouping pane.

Menü 'Ansicht' View Menu

Verwenden Sie das Menü Ansicht , um die Berichts-Designer-Fenster und Symbolleisten anzuzeigen.Use the View menu to display Report Designer windows and toolbars

  • Fehlerliste Verwenden Sie diese Option, um Fehler anzuzeigen, die beim Veröffentlichen oder Anzeigen eines Berichts in der Vorschau erkannt wurden.Error List Use this option to display errors detected when publishing or previewing a report.

  • Ausgabe Verwenden Sie diese Option, um Fehler anzuzeigen, die bei der Veröffentlichung oder Verarbeitung eines Berichts entdeckt wurden, oder um weitere Informationen zu Ausdrucksfehlern anzuzeigen, wenn ein Bericht den Text „#Fehler“ anzeigt.Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • Eigenschaftenfenster Verwenden Sie diese Option, um die Eigenschaftenwerte für das gerade ausgewählte Berichtselement auf der Entwurfsoberfläche anzuzeigen.Properties Window Use this option to display the property values for the currently selected report item on the design surface. Zum Anzeigen von Eigenschaften für geschachtelte Berichtselemente müssen Sie mehrfach auf ein Berichtselement klicken, um durch die Hierarchie des Berichtselements und seiner geschachtelten Elemente zu blättern.To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. Überprüfen Sie den Namen des Elements, das im Eigenschaftenbereich ganz oben angezeigt wird, um festzustellen, für welches Element des Berichts die Eigenschaften angezeigt werden.Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • Toolbox Verwenden Sie diese Option, um die Toolbox anzuzeigen.Toolbox Use this option to display the Toolbox.

  • Weitere Fenster Verwenden Sie diese Option, um den folgenden Bereich anzuzeigen:Other Windows Use this option to display the following pane:

    • Dokumentgliederung Verwenden Sie diese Option, um eine hierarchische Ansicht der Berichtselemente und Auflistungen der Textfelder in einem Bericht anzuzeigen.Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • Symbolleisten Verwenden Sie diese Option, um Symbolleisten anzuzeigen, die Berichts-Designer-Funktionen unterstützen, einschließlich Berichtsrahmen und Berichtsformatierung.Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. Weitere Informationen zum finden Sie unter Berichts-Designer-Symbolleisten.For more information, see Report Designer Toolbars.

  • Berichtsdaten Verwenden Sie diese Option, um den Berichtsdatenbereich anzuzeigen, in dem Sie Berichtsparameter, Datenquellen, Datasets und Bilder hinzufügen können.Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

Menü 'Projekt' Project Menu

Verwenden Sie das Menü Projekt , um freigegebene Datenquellen und Berichte in einem Projekt zu verwalten.Use the Project menu to manage shared data sources and reports in a project. Wenn Sie dem Projekt Elemente hinzufügen oder Elemente daraus entfernen, wird die hierarchische Anzeige der Projektelemente im Projektmappen-Explorer automatisch aktualisiert.When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • Neues Element hinzufügen Fügt dem Projekt eine neue freigegebene Datenquelle oder einen neuen Bericht hinzu.Add New Item Add a new shared data source or new report to the project.

  • Vorhandenes Element hinzufügen Fügt dem Projekt eine vorhandene freigegebene Datenquelle oder einen vorhandenen Bericht hinzu.Add Existing Item Add an existing shared data source or an existing report to the project.

  • Berichte importieren Importiert Berichte aus einer anderen Anwendung, z. B. Microsoft Access.Import Reports Import reports from another application, for example, Microsoft Access.

  • Aus Projekt ausschließen Schließt Elemente aus dem Projekt aus.Exclude from Project Exclude items from the project. Diese Option löscht das Element nicht aus dem Dateisystem.This option does not delete the item from your file system.

  • Alle Dateien anzeigen Zeigt alle Dateien in einem Projekt an.Show All Files Show all files in a project.

  • Projekt-Toolboxelemente aktualisieren Aktualisiert den Toolboxcache, wenn Sie neue benutzerdefinierte Berichtselemente im Projekt installieren.Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • Eigenschaften Öffnet das Dialogfeld Eigenschaftenseiten für dieses Projekt.Properties Open the Property Pages dialog box for this project. Weitere Informationen finden Sie auf den Eigenschaftsseiten für Projekt (Dialogfeld).For more information, see Project Property Pages Dialog Box.

Berichts-Designer-Symbolleisten Report Designer Toolbars

Beim Entwerfen von Berichten stellt Berichts-Designer die folgenden spezialisierten Symbolleisten bereit:Report Designer provides the following specialized toolbars to use when designing reports:

  • Bericht Hiermit können Sie einen Seitenkopf oder -fuß hinzufügen, Berichtseigenschaften festlegen, das Lineal oder den Gruppierungsbereich umschalten oder zoomen, um die Ansicht des Berichts zu wechseln.Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • Berichtsrahmen Hiermit können Sie die Farbe, den Stil und die Breite aller ausgewählten Linien sowie die Rahmen für alle ausgewählten Berichtselemente festlegen.Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • Berichtsformatierung Hiermit können Sie das Format ausgewählter Berichtselemente festlegen.Report Formatting Set the format of selected report items. Über diese Symbolleiste können die folgenden Formatierungen für Textfelder geändert werden: Schrifteigenschaften und Textfarbe, Hintergrundfarbe und Textausrichtung.For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • Layout Hiermit können Sie die Zeichnungsreihenfolge von Berichtselementen und das Verbinden von Zellen innerhalb eines Datenbereichs festlegen.Layout Set the drawing order of report items and merging cells within a data region.

  • Standard Hiermit können Sie Projekte öffnen oder speichern, Fenster anzeigen und die Debug-Konfiguration auswählen.Standard Open or save projects, display windows, and select the Debug configuration.

    Steuern Sie über das Menü Ansicht , ob diese Symbolleisten angezeigt werden.Use the View menu to control whether to display these toolbars. Andere Visual StudioVisual Studio -Symbolleisten werden möglicherweise deaktiviert, wenn ihre Funktionalität nicht für Berichts-Designer-Funktionen gilt.Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

Quellcodeverwaltung Source Control

SQL Server Data ToolsSQL Server Data Tools kann in Quellen-Plug-Ins integriert werden. can integrate with source plug-ins. Verwenden Sie im Dialogfeld Optionen die Seiten zu Projekten und Projektmappen, um das Plug-In anzugeben und Einstellungen zu konfigurieren:Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

Benutzerdefinierte Berichtsvorlagen Custom Report Templates

Wenn Sie benutzerdefinierte Berichte als Vorlagen für neue Berichte verwenden möchten, kopieren Sie diese einfach in den Ordner ReportProject auf dem Computer mit SQL Server Data ToolsSQL Server Data Tools .To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which SQL Server Data ToolsSQL Server Data Tools is installed. Dieser Ordner befindet sich standardmäßig an folgendem Speicherort: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject.By default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. Wenn Sie dem Berichtsprojekt ein neues Element hinzufügen, wird der benutzerdefinierte Bericht im Vorlagenbereich angezeigt.When you add a new item to the report project, your custom report appears in the Templates pane.

Zudem können Sie dem Berichts-Assistenten benutzerdefinierte Stile hinzufügen.You can also add custom styles to the report wizard.

Befehlszeilenunterstützung für SQL Server-Datentools Command Line Support for SQL Server Data Tools

SQL Server Data ToolsSQL Server Data Toolsbasiert auf MicrosoftMicrosoft Visual StudioVisual Studio und der zugrunde liegenden Anwendung devenv.exe. and the underlying devenv.exe application. Bevor Sie diese Optionen verwenden können, müssen Sie für beide folgenden Elemente gültige Werte festlegen:Before you can use these options, you must set valid values for following two items:

  • Projekteigenschaften für OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder und TargetServerURL.Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • Mindestens ein Satz von Konfigurationseigenschaften, z. B. Debug oder Release.At least one set of configuration properties, for example, Debug or Release.

    Weitere Informationen finden Sie unter Publishing Data Sources and Reports.For more information, see Publishing Data Sources and Reports.

    Für ein Berichtsserverprojekt können Sie an der Befehlszeile die folgenden Optionen angeben:For a report server project, you can specify the following options from the command line:

  • /deploy Mit dieser Option stellen Sie mit den in einer Konfigurationsdatei angegebenen Projekteigenschaften Berichte bereit./deploy Deploy reports by using the project properties specified in a configuration file. Beispielsweise werden mit dem folgenden Befehl die in der Projektmappendatei Reports.sln angegebenen Berichte bereitgestellt, wobei die in den Projekteigenschaften angegebenen Einstellungen für die Releasekonfiguration verwendet werden:For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build Mit dieser Option erstellen Sie die Projektmappendatei, stellen diese jedoch nicht bereit./build Build the solution file, but do not deploy it. Beispielsweise werden mit dem folgenden Befehl die in der Projektmappendatei Reports.sln angegebenen Berichte erstellt, wobei die in den Projekteigenschaften angegebenen Einstellungen für die Debugkonfiguration verwendet werden:For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out Die durch Erstellen einer Projektmappe generierte Ausgabe wird in die angegebene Datei umgeleitet./out Redirect the output generated by building a solution to the specified file. Beispielsweise wird mit dem folgenden Befehl die Ausgabe des Builds im vorherigen Beispiel in die Datei mybuildlog.txt umgeleitet.For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Tastenkombinationen in Reporting Services Keyboard Shortcuts in Reporting Services

Verwenden Sie Tastenkombinationen für folgende Aktionen:Use keyboard shortcuts to:

  • Steuern von Fenstern und Modi in SQL Server Data ToolsSQL Server Data Tools:Control windows and modes in SQL Server Data ToolsSQL Server Data Tools:

    DescriptionDescription TastenkombinationKey Combination
    Erstellen des ausgewählten ProjektsBuild the selected project CTRL+UMSCHALT+BCTRL+SHIFT+B
    Anzeigen des EigenschaftenfenstersDisplay Properties window F4F4
    Anzeigen des DatenfenstersDisplay Data window STRG+ALT+DCTRL+Alt+D
    Beginnen mit dem DebuggenStart debugging F5F5
    Verschieben von einem geöffnetem Fenster zum nächstenMove from one open window to the next F6F6
  • Steuern von Elementen auf der Berichtsentwurfsoberfläche:Control items on the report design surface:

    DescriptionDescription TastenkombinationKey Combination
    Fokus von einem Berichtselement zum nächsten Berichtselement verschiebenMove focus from one report item to the next report item TABTAB
    Ausgewähltes Berichtselement verschiebenMove selected report item PfeiltastenArrow keys
    Ausgewähltes Berichtselement bewegenNudge selected report item STRG+PfeiltastenCTRL+Arrow keys
    Größe des ausgewählten Berichtselements vergrößern oder verkleinernIncrease or decrease the size of the selected report item STRG+UMSCHALT+PfeiltastenCTRL+SHIFT+Arrow keys
    In einem Textfeld den Cursor an den Anfang des sichtbaren Anzeigetexts verschiebenIn a text box, move cursor to the beginning of the display text that is visible STRG+POS1CTRL+HOME
    In einem Textfeld den Cursor an das Ende des sichtbaren Anzeigetexts verschiebenIn a text box, move cursor to the end of the display text that is visible STRG+ENDECTRL+END
    In einem Textfeld Text von der aktuellen Cursorposition bis zum Beginn des sichtbaren Anzeigetexts auswählenIn a text box, select text from the current cursor position to the beginning of the display text that is visible UMSCHALT+POS1SHIFT+HOME
    In einem Textfeld Text von der aktuellen Cursorposition bis zum Ende des sichtbaren Anzeigetexts auswählenIn a text box, select text from the current cursor position to the end of the display text that is visible UMSCHALT+ENDESHIFT+END
    In einem Textfeld Text von der aktuellen Cursorposition bis zum Beginn des Ausdrucks auswählenIn a text box, select text from the current cursor position to the beginning of the expression STRG+UMSCHALT+POS1CTRL+SHIFT+HOME
    In einem Textfeld Text von der aktuellen Cursorposition bis zum Ende des Ausdrucks auswählenIn a text box, select text from the current cursor position to the end of the expression STRG+UMSCHALT+ENDECTRL+SHIFT+END
    Das Kontextmenü für das ausgewählte Element öffnenOpen the shortcut menu for the selected report item SHIFT+F10+Eigenschaftentaste auf neueren TastaturenSHIFT+F10+Property Key on newer keyboards

Nächste SchritteNext steps

Herunterladen von SQL Server Datatools Projektmappen-Explorer Download SQL Server Data Tools Solution Explorer
Reporting Services-Berichte Reporting Services Reports
Report Definition Language Report Definition Language
Bereitstellung und Versionsunterstützung in SQL Server Data ToolsDeployment and Version Support in SQL Server Data Tools

Weiteren Fragen wenden?More questions? Versuchen Sie das Reporting Services-Forum stellenTry asking the Reporting Services forum