Tutorial: Hinzufügen eines Kreisdiagramms zu einem Bericht (Berichts-Generator)Tutorial: Add a Pie Chart to Your Report (Report Builder)

In diesem Tutorial erstellen Sie ein Kreisdiagramm in einem paginierten Reporting Services-Bericht.In this tutorial, you create pie chart in a Reporting Services paginated report. Sie fügen Prozentsätze hinzu und kombinieren kleine Slices zu einem einzelnen Slice.You add percentages and combine small slices into a single slice.

Kreis- und Ringdiagramme zeigen Daten als Teile des Ganzen an.Pie and doughnut charts display data as a proportion of the whole. Sie haben keine Achsen.They have no axes. Wenn Sie ein numerisches Feld zu einem Kreisdiagramm hinzufügen, berechnet das Diagramm den prozentualen Anteil jedes einzelnen Werts der Gesamtsumme.When you add a numeric field to a pie chart, the chart calculates the percentage of each value to the total.

Diese Abbildung zeigt das Kreisdiagramm, das Sie erstellen.This illustration shows the pie chart you will create.

Berichts-Generator-Kreisdiagramm-fertig

Wenn in einem Kreisdiagramm zu viele Datenpunkte vorhanden sind, können die Datenpunktbezeichnungen zu überfüllt sein, um sie zu lesen.If there are too many data points on a pie chart, your data point labels might be too crowded to read. Erwägen Sie in diesem Fall eine Anzahl von kleinen Slices zu einem größeren Slice zu kombinieren.In that case, consider combining a number of small slices into one larger slice. Kreisdiagramme sind besser lesbar, wenn Sie die Daten bereits zu einer kleineren Anzahl von Datenpunkten aggregiert haben.Pie charts are more readable when you have aggregated your data into a few data points.

Hinweis

In diesem Lernprogramm werden die Schritte für den Assistenten in zwei Verfahren zusammengefasst.In this tutorial, the steps for the wizard are consolidated into two procedures. Im ersten Tutorial dieser Reihe erhalten Sie detaillierte Anweisungen zum Navigieren zu einem Berichtsserver, Hinzufügen einer Datenquelle und Hinzufügen eines Datasets: Tutorial: Erstellen eines einfachen Tabellenberichts (Berichts-Generator).For step-by-step instructions about how to browse to a report server, add a data source, and add a dataset, see the first tutorial in this series: Tutorial: Creating a Basic Table Report (Report Builder).

Ungefähre Dauer dieses Lernprogramms: 10 MinutenEstimated time to complete this tutorial: 10 minutes

AnforderungenRequirements

Weitere Informationen zu den Anforderungen finden Sie unter Voraussetzungen für Tutorials (Berichts-Generator).For information about requirements, see Prerequisites for Tutorials (Report Builder).

1. Erstellen eines Kreisdiagramms im Diagramm-Assistenten1. Create a Pie Chart from the Chart Wizard

In diesem Abschnitt verwenden Sie den Diagramm-Assistenten, um ein eingebettetes Dataset zu erstellen, eine freigegebene Datenquelle auszuwählen, und ein Kreisdiagramm zu erstellen.In this section, you use the Chart Wizard to create an embedded dataset, choose a shared data source, and create a pie chart.

  1. Starten Sie den Berichts-Generator entweder von Ihrem Computer, über das Reporting ServicesReporting Services -Webportal oder über den integrierten SharePoint-Modus.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    Das Dialogfeld Neuer Bericht oder neues Dataset wird geöffnet.The New Report or Dataset dialog box opens.

    Wenn das Dialogfeld Neuer Bericht oder neues Dataset nicht angezeigt wird, wählen Sie im Menü Datei die Option Neu.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. Vergewissern Sie sich, dass im linken Bereich Neuer Bericht ausgewählt ist.In the left pane, verify that New Report is selected.

  3. Klicken Sie im rechten Bereich auf Diagramm-Assistent.In the right pane, click Chart Wizard.

  4. Klicken Sie auf der Seite Dataset auswählen auf Dataset erstellenund anschließend auf Weiter.On the Choose a dataset page, click Create a dataset, and then click Next.

  5. Wählen Sie auf der Seite Verbindung mit einer Datenquelle auswählen eine vorhandene Datenquelle aus, oder navigieren Sie zum Berichtsserver, und wählen Sie eine Datenquelle aus. Klicken Sie anschließend auf Weiter.On the Choose a connection to a data source page, select an existing data source or browse to the report server and select a data source, and then click Next. Möglicherweise müssen Benutzername und Kennwort eingegeben werden.You may need to enter a user name and password.

    Hinweis

    Welche Datenquelle Sie auswählen, ist unwichtig, solange Sie über ausreichende Berechtigungen verfügen.The data source you choose is unimportant, as long as you have adequate permissions. Aus der Datenquelle werden keine Daten abgerufen.You will not be getting data from the data source. Weitere Informationen finden Sie unter Alternative Methoden zum Herstellen einer Datenverbindung (Berichts-Generator).For more information, see Alternative Ways to Get a Data Connection (Report Builder).

  6. Klicken Sie auf der Seite Abfrage entwerfen auf Als Text bearbeiten.On the Design a Query page, click Edit as Text.

  7. Fügen Sie die folgende Abfrage in den Abfragebereich ein:Paste the following query into the query pane:

    Hinweis

    In diesem Tutorial sind die Datenwerte in der Abfrage enthalten, sodass keine externe Datenquelle benötigt wird.In this tutorial, the query contains the data values, so it does not need an external data source. Die Abfrage ist daher lang.This makes the query long. In einer Geschäftsumgebung wären die Daten nicht in der Abfrage enthalten.In a business environment, a query would not contain the data. Dieses Szenario dient nur zu Lernzwecken.This is for learning purposes only.

    SELECT 'Advanced Digital Camera' AS Product, CAST(254995.21 AS money) AS Sales  
    UNION SELECT 'Slim Digital Camera' AS Product, CAST(164499.04 AS money) AS Sales  
    UNION SELECT 'SLR Digital Camera' AS Product, CAST(782176.79 AS money) AS Sales  
    UNION SELECT 'Lens Adapter' AS Product, CAST(36333.08 AS money) AS Sales  
    UNION SELECT 'Macro Zoom Lens' AS Product, CAST(40199.3 AS money) AS Sales  
    UNION SELECT 'USB Cable' AS Product, CAST(53245.5 AS money) AS Sales  
    UNION SELECT 'Independent Filmmaker Camcorder' AS Product, CAST(452288.0 AS money) AS Sales  
    UNION SELECT 'Full Frame Digital Camera' AS Product, CAST(247250.85 AS money) AS Sales  
    
  8. (Optional) Klicken Sie auf die Schaltfläche „Ausführen“ ( ! ), um die Daten anzuzeigen, auf denen das Diagramm basiert.(Optional) Click the Run button (!) to see the data your chart will be based on.

  9. Klicken Sie auf Weiter.Click Next.

2. Auswählen des Diagrammtyps2. Choose the Chart Type

Sie können aus einer Vielzahl vordefinierter Diagrammtypen auswählen.You can choose from a variety of predefined chart types.

  1. Klicken Sie auf der Seite Diagrammtyp auswählen auf Kreisund anschließend auf Weiter.On the Choose a chart type page, click Pie, then click Next. Die Seite Diagrammfelder anordnen wird geöffnet.The Arrange chart fields page opens.

    Ziehen Sie auf der Seite Diagrammfelder anordnen das Feld „Product“ in den Bereich Kategorien .On the Arrange chart fields page, drag the Product field to the Categories pane. Kategorien definieren die Anzahl von Slices im Kreisdiagramm.Categories define the number of slices in the pie chart. In diesem Beispiel werden acht Slices verwendet, eines für jedes Produkt.In this example, there will be eight slices, one for each product.

  2. Ziehen Sie das Feld „Sales“ in den Bereich Werte .Drag the Sales field to the Values pane. Das Feld "Sales" stellt den Umsatz für die Unterkategorie dar.Sales represents the sales amount for the subcategory. Im Bereich Werte wird [Sum(Sales)] angezeigt, da im Diagramm der aggregierte Wert für die einzelnen Produkte angezeigt wird.The Values pane displays [Sum(Sales)] because the chart displays the aggregate for each product.

  3. Klicken Sie auf Weiter , um eine Vorschau anzuzeigen.Click Next to see a preview.

  4. Klicken Sie auf Fertig stellen.Click Finish.

    Das Diagramm wird der Entwurfsoberfläche hinzugefügt.The chart is added to the design surface. Die tatsächlichen Werte des Diagramms werden nicht angezeigt – es wird Product 1, Product 2 usw. angezeigt, um einen Überblick zu übermitteln, wie das Diagramm aussehen wird.You don't see the actual values of the pie chart -- you see Product 1, Product 2, etc., to give an idea of how the chart will look.

    Berichts-Generator-Kreisdiagramm-erster-Entwurf

  5. Klicken Sie auf das Diagramm, um die Diagrammziehpunkte anzuzeigen.Click the chart to display the chart handles. Ziehen Sie an der unteren rechten Ecke des Diagramms, um es zu vergrößern.Drag the bottom-right corner of the chart to make it bigger. Die Berichtsentwurfsoberfläche wird ebenso vergrößert, um genügend Platz für das Diagramm zu bieten.Note that the report design surface also gets bigger, to accommodate the chart size.

  6. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Im Bericht wird das Kreisdiagramm mit acht Slices angezeigt, eines für jedes Produkt.The report displays the pie chart with eight slices, one for each product. Nun können Sie die tatsächlichen Produkte sehen, und die Größe der Slices stellt den Umsatz für das jeweilige Produkt dar.Now you see the actual products and the size of each slice represents the sales for that product. Drei der Slices sind relativ dünn.Three of the slices are quite thin.

Berichts-Generator-Kreisdiagramm-erste-Vorschau

3. Anzeigen von Prozentsätzen in jedem Slice3. Display Percentages in Each Slice

Sie können für jeden Slice des Kreisdiagramms den Prozentsatz des Slices im Vergleich zum gesamten Kreis anzeigen.On each slice of the pie, you can display a percentage for this slice compared to the whole pie.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Klicken Sie mit der rechten Maustaste auf das Kreisdiagramm, und klicken Sie anschließend auf Datenbezeichnungen anzeigen.Right-click the pie chart and click Show Data Labels. Die Datenbezeichnungen werden im Diagramm angezeigt.The data labels appear on the chart.

  3. Klicken Sie mit der rechten Maustaste auf eine Bezeichnung, und klicken Sie anschließend auf Reihenbezeichnungseigenschaften.Right-click a label, then click Series Label Properties.

  4. Geben Sie #PERCENT für die Option Bezeichnungsdaten ein.In the Label data box, select #PERCENT.

  5. (Optional) Wenn Sie die Anzahl von Dezimalstellen in der Bezeichnung angeben möchten, tippen Sie im Feld Bezeichnungsdaten nach #PERCENT {Pn} ein, wobei n die Anzahl der anzuzeigenden Dezimalstellen darstellt.(Optional) To specify how many decimal places the label shows, in the Label data box after #PERCENT, type {Pn} where n is the number of decimal places to display. Geben Sie z.B. #PERCENT{P0} ein, um keine Dezimalstellen anzuzeigen.For example, to display no decimal places, type #PERCENT{P0}.

  6. Die UseValueAsLabel-Eigenschaft muss zum Anzeigen von Werten als Prozentsätze auf "False" festgelegt werden.To display values as percentages, the UseValueAsLabel property must be false. Klicken Sie auf Ja , wenn Sie im Dialogfeld Aktion bestätigenzum Festlegen dieses Werts aufgefordert werden.If you are prompted to set this value in the Confirm Action dialog, click Yes.

    Hinweis

    Die OptionZahlenformat im Dialogfeld Reihenbezeichnungseigenschaften hat beim Formatieren von Prozentwerten keinen Einfluss auf das Format.Number Format in the Series Label Properties dialog box has no effect when you format percentages. Hierdurch werden die Bezeichnungen als Prozentwerte formatiert, die eigentlichen Prozentwerte der einzelnen Slices eines Kreisdiagramms werden jedoch nicht berechnet.This formats the labels as percentages, but does not calculate the percentage of the pie that each slice represents.

  7. Klicken Sie auf OK.Click OK.

  8. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Im Bericht wird der Prozentsatz am gesamten Kreis für jeden Kreisslice angezeigt.The report displays the percentage of the whole for each pie slice.

Berichts-Generator-Kreisdiagramm-Vorschau-Prozente

4. Kombinieren von kleinen Slices zu einem Slice4. Combine Small Slices into One Slice

Drei der Slices im Kreis sind relativ klein.Three of the slices in the pie are quite small. Sie können mehrere kleine Slices zu einem größeren „Other“-Slice kombinieren, durch das alle drei Slices dargestellt werden.You can combine multiple small slices into one larger "Other" slice that represents all three.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Sollte das Fenster „Eigenschaften“ nicht angezeigt werden, können Sie es über die Registerkarte Ansicht > Gruppe Ein-/Ausblenden > Eigenschaften öffnen.If the Properties pane isn't showing, on the View tab > Show/Hide group > select Properties.

  3. Klicken Sie auf der Entwurfsoberfläche auf ein Segment des Kreisdiagramms.On the design surface, click on any slice of the pie chart. Die Eigenschaften für die Reihe werden im Bereich "Eigenschaften" angezeigt.The properties for the series are displayed in the Properties pane.

  4. Erweitern Sie im Abschnitt Allgemein den Knoten CustomAttributes .In the General section, expand the CustomAttributes node.

  5. Legen Sie die Eigenschaft CollectedStyle auf SingleSlicefest.Set the CollectedStyle property to SingleSlice.

    Berichts-Generator-Kreisdiagramm-einzelne-Slice-Eigenschaft

  6. Vergewissern Sie sich, dass die CollectedThreshold -Eigenschaft auf 5 festgelegt ist.Verify that the CollectedThreshold property is set to 5.

  7. Vergewissern Sie sich, dass die CollectedThresholdUsePercent -Eigenschaft auf TRUEfestgelegt ist.Verify that the CollectedThresholdUsePercent property is set to True.

  8. Klicken Sie auf der Registerkarte Stamm auf Ausführen , um eine Vorschau des Berichts anzuzeigen.On the Home tab, click Run to preview the report.

In der Legende wird die Kategorie „Other“ jetzt angezeigt.In the legend, you now see the category "Other". Im neuen Kreisslice werden alle Slices, die kleiner als 5 % waren, zu einem Slice kombiniert, das 6 % des gesamten Kreises darstellt.The new pie slice combines all the slices that were under 5% into one slice that is 6% of the whole pie.

Berichts-Generator-Kreisdiagramm-beginnt-bei-90

5. Beginnen der Kreisdiagrammwerte bei 0°5. Start pie chart values at the top

Standardmäßig beginnt bei Kreisdiagrammen der erste Wert im Dataset bei 90 Grad zur Oberseite des Kreises versetzt.By default in pie charts, the first value in the dataset starts at 90 degrees from the top of the pie. Dies wird im Kreisdiagramm in den vorherigen Abschnitten angezeigt.You see that in the pie chart in the previous sections.

In diesem Abschnitt reduzieren wir diesen Versatz auf 0°.In this section, we'll make the first value start at the top.

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Wählen Sie den Kreis selbst aus.Select the pie itself.

  3. Ändern Sie im Bereich „Eigenschaften“ unter Benutzerdefinierte Attributeden Eintrag PieStartAngle von 0 in 270.In the Properties pane, under Custom Attributes, change PieStartAngle from 0 to 270.

  4. Klicken Sie auf Ausführen , um den Bericht in der Vorschau anzuzeigen.Click Run to preview your report.

Jetzt sind die Segmente des Kreisdiagramms in alphabetischer Reihenfolge, beginnend am oberen Ende und endend mit dem Segment „Other“.Now the pie chart slices are in alphabetical order, starting at the top, and ending with the "Other" slice.

Berichts-Generator-Kreisdiagramm-Beginn-oben

6. Hinzufügen eines Berichtstitels6. Add a Report Title

Da das Kreisdiagramm die einzige Visualisierung im Bericht ist, muss für das Diagramm kein eigener Titel vergeben werden.Because the pie chart is the only visualization in the report, the chart doesn't need its own title. Der Berichtstitel reicht völlig aus.The report title will do.

  1. Wählen Sie im Diagramm das Feld „Diagrammtitel“ aus, und drücken Sie die Taste ENTF.In the chart, select the Chart Title box and press DELETE.

  2. Klicken Sie auf der Entwurfsoberfläche auf Zum Hinzufügen eines Titels klicken.n the design surface, click Click to add title.

  3. Geben Sie wie folgt Kamera- und Camcorderumsatzein, drücken Sie die EINGABETASTE, und geben Sie anschließend Als Prozentsatz des Gesamtumsatzesein:Type Camera and Camcorder Sales, press ENTER, and then type As a Percentage of Total Sales, so it looks like this:

    Kamera- und CamcorderumsatzCamera and Camcorder Sales

    Als Prozentsatz des GesamtumsatzesAs a Percentage of Total Sales

  4. Wählen Sie Kamera- und Camcorderumsatz, und klicken Sie auf der Registerkarte Stamm im Abschnitt Schriftart auf Fett.Select Camera and Camcorder Sales, and on the Home tab > Font section > click Bold.

  5. Markieren Sie As a Percentage of Total Sales (Als Prozentsatz des Gesamtumsatzes), und legen Sie auf der Registerkarte Stamm im Abschnitt Schriftart den Schriftgrad auf 10 fest.Select As a Percentage of Total Sales, and on the Home tab > Font section > set the font size to 10.

  6. (Optional) Das Textfeld "Titel" muss ggf. vergrößert werden, damit die beiden Textzeilen hineinpassen.(Optional) You may need to make the Title text box taller to accommodate the two lines of text.

    Dieser Titel wird am Anfang des Berichts angezeigt.This title will appear at the top of the report. Ist keine Kopfzeile definiert, erfüllen die Elemente über dem Berichtshauptteil die Funktion einer Berichtskopfzeile.When there is no page header defined, items at the top of the report body are the equivalent of a report header.

  7. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

7. Speichern des Berichts7. Save the Report

So speichern Sie den BerichtTo save the report

  1. Wechseln Sie zur Berichtsentwurfsansicht.Switch to report design view.

  2. Klicken Sie im Menü Datei auf Speichern.On the File menu, click Save.

  3. Geben Sie im Feld Nameden Namen Umsatz-Kreisdiagrammein.In Name, type Sales Pie Chart.

  4. Klicken Sie auf Speichern.Click Save.

Der Bericht wird auf dem Berichtsserver gespeichert.Your report is saved on the report server.

Next StepsNext Steps

Sie haben das Lernprogramm "Hinzufügen eines Kreisdiagramms zu einem Bericht" erfolgreich abgeschlossen.You have successfully completed the Adding a Pie Chart to Your Report tutorial. Weitere Informationen zu Diagrammen finden Sie unter Diagramme (Berichts-Generator und SSRS) und Sparklines und Datenbalken (Berichts-Generator und SSRS).To learn more about charts, see Charts (Report Builder and SSRS) and Sparklines and Data Bars (Report Builder and SSRS).

Weitere InformationenSee Also

Lernprogramme für den Berichts-GeneratorReport Builder Tutorials
Berichts-Generator in SQL ServerReport Builder in SQL Server