Lernprogramm: Erstellen eines einfachen Tabellenberichts (Berichts-Generator)Tutorial: Creating a Basic Table Report (Report Builder)

In diesem Lernprogramm erfahren Sie, wie Sie auf Grundlage von Beispielumsatzdaten einen einfachen Tabellenbericht erstellen.This tutorial teaches you to create a basic table report based on sample sales data. Die folgende Abbildung zeigt den Bericht, den Sie erstellen.The following illustration shows the report you will create.

SSRS_Tutorial_einfacher_Tabellenbericht

Ungefähre Dauer dieses Lernprogramms: 20 Minuten.Estimated time to complete this tutorial: 20 minutes.

AnforderungenRequirements

Weitere Informationen zu den Anforderungen finden Sie unter Voraussetzungen für Tutorials (Berichts-Generator).For more information about requirements, see Prerequisites for Tutorials (Report Builder).

1. Erstellen eines Berichts mithilfe eines Assistenten1. Create a Report using a wizard

Erstellen eines Tabellenberichts mithilfe des Tabellen- oder Matrixassistenten.Create a table report with the Table or Matrix wizard. Zwei Modi stehen zur Auswahl: Berichtsentwurf und Entwurf von freigegebenen Datasets.There are two modes: report design and shared dataset design. Im Berichtsentwurfsmodus legen Sie im Berichtsdatenbereich Daten und auf der Entwurfsoberfläche das Berichtslayout fest.In report design mode, you specify data in the Report Data pane and the report layout on the design surface. Im Entwurfsmodus für freigegebene Datasets erstellen Sie Datasetabfragen, die für andere Benutzer freigegeben werden.In shared dataset design mode, you create dataset queries to share with others. In diesem Lernprogramm verwenden Sie den Berichtsentwurfsmodus.In this tutorial, you will be using report design mode.

So erstellen Sie einen BerichtTo create a report

  1. Starten Sie den Berichts-Generator entweder von Ihrem Computer, über das Reporting ServicesReporting Services -Webportal oder über den integrierten SharePoint-Modus.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    Das Dialogfeld Neuer Bericht oder neues Dataset wird geöffnet.The New Report or Dataset dialog box opens.

    Wenn das Dialogfeld Neuer Bericht oder neues Dataset nicht angezeigt wird, wählen Sie im Menü Datei die Option Neu.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. Vergewissern Sie sich, dass im linken Bereich Neuer Bericht ausgewählt ist.In the left pane, verify that New Report is selected.

  3. Wählen Sie im rechten Bereich Tabellen- oder Matrix-Assistent.In the right pane, select Table or Matrix Wizard.

1a.1a. Angeben einer Datenverbindung im Tabellen-AssistentenSpecify a Data Connection in the Table Wizard

Eine Datenverbindung enthält die Informationen zum Herstellen einer Verbindung mit einer externen Datenquelle, z. B. einer SQL ServerSQL Server -Datenbank.A data connection contains the information to connect to an external data source such as a SQL ServerSQL Server database. Normalerweise erhalten Sie die Verbindungsinformationen und den zu verwendenden Anmeldeinformationstyp vom Datenquellenbesitzer.Usually, you get the connection information and the type of credentials to use from the data source owner. Sie können zum Angeben einer Datenverbindung eine freigegebene Datenquelle vom Berichtsserver verwenden oder eine eingebettete Datenquelle erstellen, die nur in diesem Bericht verwendet wird.To specify a data connection, you can use a shared data source from the report server or create an embedded data source that is used only in this report.

In diesem Lernprogramm verwenden Sie eine eingebettete Datenquelle.In this tutorial, you will use an embedded data source. Weitere Informationen zur Verwendung von freigegebenen Datenquellen finden Sie unter Alternative Verfahren zum Herstellen einer Datenverbindung (Berichts-Generator).To learn more about using a shared data sources, see Alternative Ways to Get a Data Connection (Report Builder).

So erstellen Sie eine eingebettete DatenquelleTo create an embedded data source

  1. Klicken Sie auf der Seite Dataset auswählen auf Dataset erstellenund anschließend auf Weiter.On the Choose a dataset page, select Create a dataset, and then click Next. Die Seite Verbindung mit einer Datenquelle auswählen wird geöffnet.The Choose a connection to a data source page opens.

  2. Klicken Sie auf Neu.Click New. Das Dialogfeld Datenquelleneigenschaften wird angezeigt.The Data Source Properties dialog box opens.

  3. Geben Sie im Feld Nameden Namen Product_Sales für die Datenquelle ein.In Name, type Product_Sales a name for the data source.

  4. Vergewissern Sie sich, dass unter Verbindungstyp auswählendie Option Microsoft SQL Server ausgewählt ist.In Select a connection type, verify that Microsoft SQL Server is selected.

  5. Geben Sie im Feld Verbindungszeichenfolge den folgenden Text ein, wobei <Servername> der Name einer SQL ServerSQL Server-Instanz ist:In Connection string, type the following text, where <servername> is the name of an instance of SQL ServerSQL Server:

    Data Source=<servername>  
    

    Da Sie eine Abfrage verwenden, die die Daten enthält, anstatt die Daten aus einer Datenbank abzurufen, enthält die Verbindungszeichenfolge den Datenbanknamen nicht.Because you will use a query that contains the data instead of retrieving the data from a database, the connection string does not include the database name. Weitere Informationen finden Sie unter Voraussetzungen für Lernprogramme (Berichts-Generator).For more information, see Prerequisites for Tutorials (Report Builder).

  6. Klicken Sie auf die Registerkarte Anmeldeinformationen . Geben Sie die für den Zugriff auf die externe Datenquelle benötigten Anmeldeinformationen ein.Click the Credentials tab. Enter the credentials that you need to access the external data source.

  7. Klicken Sie erneut auf die Registerkarte Allgemein.Click the General tab again. Klicken Sie auf Verbindung testen, um sicherzustellen, dass die Verbindung mit der Datenquelle hergestellt werden kann.To verify that you can connect to the data source, click Test Connection.

    Die Meldung "Die Verbindung wurde erfolgreich hergestellt" wird angezeigt.The message "Connection created successfully" appears.

  8. Klicken Sie auf OK.Click OK.

    Nun wird wieder die Seite Verbindung mit einer Datenquelle auswählen angezeigt, wobei Ihre neue Datenquelle ausgewählt ist.You are back on the Choose a connection to a data source page, with your new data source selected.

  9. Klicken Sie auf Weiter.Click Next.

1b.1b. Erstellen einer Abfrage im Tabellen-AssistentenCreate a Query in the Table Wizard

In einem Bericht können Sie ein freigegebenes Dataset mit einer vordefinierten Abfrage verwenden oder ein eingebettetes Dataset erstellen, das nur in diesem Bericht verwendet wird.In a report, you can use a shared dataset that has a predefined query, or you can create an embedded dataset for use only in this one report. In diesem Lernprogramm erstellen Sie ein eingebettetes Dataset.In this tutorial, you will create an embedded dataset.

Hinweis

In diesem Lernprogramm sind die Datenwerte in der Abfrage enthalten, sodass keine externe Datenquelle benötigt wird.In this tutorial, the query contains the data values, so that it does not need an external data source. Die Abfrage ist daher relativ lang.This makes the query quite long. In einer Geschäftsumgebung wären die Daten nicht in der Abfrage enthalten.In a business environment, a query would not contain the data. Dieses Szenario dient nur zu Lernzwecken.This is for learning purposes only.

So erstellen Sie eine AbfrageTo create a query

  1. Auf der Seite Abfrage entwerfen ist der relationale Abfrage-Designer geöffnet.On the Design a query page, the relational query designer is open. Für dieses Lernprogramm verwenden Sie den textbasierten Abfrage-Designer.For this tutorial, you will use the text-based query designer.

    Klicken Sie auf Als Text bearbeiten.Click Edit As Text. Der textbasierte Abfrage-Designer umfasst zwei Bereiche: den Abfragebereich und den Ergebnisbereich.The text-based query designer displays a query pane and a results pane.

  2. Fügen Sie die folgende Transact-SQLTransact-SQL -Abfrage in das leere obere Feld ein.Paste the following Transact-SQLTransact-SQL query into the blank upper box.

    SELECT CAST('2009-01-05' AS date) as SalesDate, 'Accessories' as Subcategory,   
       'Carrying Case' as Product, CAST(9924.60 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Accessories' as Subcategory,  
       'Tripod' as Product, CAST(1350.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-11' AS date) as SalesDate, 'Accessories' as Subcategory,  
       'Lens Adapter' as Product, CAST(1147.50 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Accessories' as Subcategory,  
       'Mini Battery Charger' as Product, CAST(1056.00 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Accessories' as Subcategory,  
       'Telephoto Conversion Lens' as Product, CAST(1380.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,'Accessories' as Subcategory,    
       'USB Cable' as Product, CAST(780.00 AS money) AS Sales, 26 as Quantity  
    UNION SELECT CAST('2009-01-08' AS date) as SalesDate, 'Accessories' as Subcategory,   
       'Budget Movie-Maker' as Product, CAST(3798.00 AS money) AS Sales, 9 as Quantity  
    UNION SELECT CAST('2009-01-09' AS date) as SalesDate, 'Camcorders' as Subcategory,   
       'Business Videographer' as Product, CAST(10400.00 AS money) AS Sales, 13 as Quantity  
    UNION SELECT CAST('2009-01-10' AS date) as SalesDate, 'Camcorders' as Subcategory,   
       'Social Videographer' as Product, CAST(3000.00 AS money) AS Sales, 60 as Quantity  
    UNION SELECT CAST('2009-01-11' AS date) as SalesDate,  'Digital' as Subcategory,   
       'Advanced Digital' as Product, CAST(7234.50 AS money) AS Sales, 39 as Quantity  
    UNION SELECT CAST('2009-01-07' AS date) as SalesDate,  'Digital' as Subcategory,   
       'Compact Digital' as Product, CAST(10836.00 AS money) AS Sales, 84 as Quantity  
    UNION SELECT CAST('2009-01-08' AS date) as SalesDate,  'Digital' as Subcategory,   
       'Consumer Digital' as Product, CAST(2550.00 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Digital' as Subcategory,   
       'Slim Digital' as Product, CAST(8357.80 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2009-01-09' AS date) as SalesDate, 'Digital SLR' as Subcategory,   
       'SLR Camera 35mm' as Product, CAST(18530.00 AS money) AS Sales, 34 as Quantity  
    UNION SELECT CAST('2009-01-07' AS date) as SalesDate, 'Digital SLR' as Subcategory,   
       'SLR Camera' as Product, CAST(26576.00 AS money) AS Sales, 88 as Quantity  
    
    
  3. Klicken Sie auf der Symbolleiste des Abfrage-Designers auf Ausführen ( ! ).On the query designer toolbar, click Run (!).

    Die Abfrage wird ausgeführt, und das Resultset für die Felder "SalesDate", "Subcategory", "Product", "Sales" und "Quantity" wird angezeigt.The query runs and displays the result set for the fields SalesDate, Subcategory, Product, Sales, and Quantity.

    Die Spaltenüberschriften im Resultset basieren auf den Namen in der Abfrage.In the result set, the column headings are based on the names in the query. Im Dataset werden die Spaltennamen zu Feldnamen und werden im Bericht gespeichert.In the dataset, the column headings become the field names, and are saved in the report. Nachdem Sie den Assistenten abgeschlossen haben, können Sie die Auflistung der Datasetfelder im Berichtsdatenbereich anzeigen.After you complete the wizard, you can use the Report Data pane to view the collection of dataset fields.

  4. Klicken Sie auf Weiter.Click Next.

1c.1c. Gruppieren von Daten im Tabellen-AssistentenOrganize Data into Groups in the Table Wizard

Durch das Auswählen von Feldern für die Gruppierung entwerfen Sie eine Tabelle mit Zeilen und Spalten, in denen Detaildaten und aggregierte Daten angezeigt werden.When you select fields to group on, you design a table that has rows and columns that display detail data and aggregated data.

So gruppieren Sie DatenTo organize data into groups

  1. Ziehen Sie auf der Seite Felder anordnen das Feld Product in Werte.On the Arrange fields page, drag Product to Values.

  2. Ziehen Sie „Quantity“ in Werte , und platzieren Sie es unter „Product“.Drag Quantity to Values and place below Product.

    "Quantity" wird automatisch von der Sum-Funktion aggregiert, dem Standardaggregat für numerische Felder.Quantity is automatically aggregated by the Sum function, the default aggregate for numeric fields. Der Wert ist "[Sum(Quantity)]".The value is [Sum(Quantity)].

    Wählen Sie den Pfeil neben „[Sum(Quantity)]“, um die anderen verfügbaren Aggregatfunktionen anzuzeigen.Select the arrow next to [Sum(Quantity)] to view the other aggregate functions available. Ändern Sie die Aggregatfunktion nicht.Do not change the aggregate function.

  3. Ziehen Sie „Sales“ in Werte , und fügen Sie dieses Feld unter „[Sum(Quantity)]“ ein.Drag Sales to Values and place below [Sum(Quantity)].

    "Sales" wird von der Sum-Funktion aggregiert.Sales is aggregated by the Sum function. Der Wert ist "[Sum(Sales)]".The value is [Sum(Sales)].

    In Schritt 1, 2 und 3 werden die Daten angegeben, die in der Tabelle angezeigt werden sollen.Steps 1, 2, and 3 specify the data to display in the table.

  4. Ziehen Sie „SalesDate“ in Zeilengruppen.Drag SalesDate to Row groups.

  5. Ziehen Sie „Subcategory“ in Zeilengruppen , und fügen Sie dieses Feld unter „SalesDate“ ein.Drag Subcategory to Row groups and place below SalesDate.

    Durch die Schritte 4 und 5 werden die Werte für die Felder zuerst nach Datum und dann nach Produktunterkategorie für dieses Datum geordnet.Steps 4 and 5 organize the values for the fields first by date, and then by product subcategory for that date.

  6. Klicken Sie auf Weiter.Click Next.

1d.1d. Hinzufügen von Teilergebnis- und Ergebniszeilen im Tabellen-AssistentenAdd Subtotal and Total Rows in the Table Wizard

Nachdem Sie Gruppen erstellt haben, können Sie Zeilen hinzufügen und formatieren, in denen Aggregatwerte für die Felder angezeigt werden.After you create groups, you can add and format rows on which to display aggregate values for the fields. Sie können auswählen, ob alle Daten angezeigt werden oder der Benutzer gruppierte Daten interaktiv erweitern und reduzieren kann.You can choose whether to show all the data or to let a user expand and collapse grouped data interactively.

So fügen Sie Teilergebnisse und Summen hinzuTo add subtotals and totals

  1. Vergewissern Sie sich auf der Seite Layout auswählen , dass unter Optionendie Option Teil- und Gesamtergebnisse anzeigen ausgewählt ist.On the Choose the layout page, under Options, verify that Show subtotals and grand totals is selected.

  2. Überprüfen Sie, ob Als Block, Teilergebnis unterhalb ausgewählt ist.Verify that Blocked, subtotal below is selected.

    Im Vorschaubereich des Assistenten wird eine Tabelle mit fünf Zeilen angezeigt.The wizard Preview pane displays a table with five rows. Bei der Ausführung des Berichts wird jede Zeile wie folgt angezeigt:When you run the report, each row will display in the following way:

    1. Die erste Zeile wird einmal wiederholt, damit Spaltenüberschriften in der Tabelle angezeigt werden.The first row will repeat once for the table to show column headings.

    2. Die zweite Zeile wird einmal für jedes Zeilenelement im Verkaufsauftrag wiederholt. In dieser Zeile werden Produktname, Bestellmenge und Zeilensumme angezeigt.The second row will repeat once for each line item in the sales order and display the product name, order quantity, and line total.

    3. Die dritte Zeile wird einmal für jeden Verkaufsauftrag wiederholt. In dieser Zeile werden die Teilergebnisse für jeden Auftrag angezeigt.The third row will repeat once for each sales order to display subtotals per order.

    4. Die vierte Zeile wird einmal für jedes Bestelldatum wiederholt. In ihr werden Zwischensummen pro Tag angezeigt.The fourth row will repeat once for each order date to display the subtotals per day.

    5. Die fünfte Zeile wird einmal wiederholt, damit Gesamtsummen in der Tabelle angezeigt werden.The fifth row will repeat once for the table to display the grand totals.

  3. Deaktivieren Sie die Option Gruppen erweitern/reduzieren.Clear the option Expand/collapse groups. In diesem Lernprogramm enthält der erstellte Bericht keine Drilldownfunktion, mit der ein Benutzer eine übergeordnete Gruppenhierarchie einblenden kann, um untergeordnete Gruppenzeilen und Detailzeilen anzuzeigen.In this tutorial, the report you create does not use the drilldown feature that lets a user expand a parent group hierarchy to display child group rows and detail rows.

  4. Klicken Sie auf Weiter , um eine Vorschau der Tabelle anzuzeigen, und anschließend auf Fertig stellen.Click Next to preview the table, then click Finish.

Die Tabelle wird der Entwurfsoberfläche hinzugefügt.The table is added to the design surface. Die Tabelle enthält 5 Spalten und 5 Zeilen.The table has 5 columns and 5 rows. Im Bereich "Zeilengruppen" werden drei Zeilengruppen angezeigt: "SalesDate", "Subcategory" und "Details".The Row Groups pane shows three row groups: SalesDate, Subcategory, and Details. Detaildaten sind alle Daten, die von der Datasetabfrage abgerufen werden.Detail data is all the data that is retrieved by the dataset query.

2. Formatieren von Daten als Währung2. Format Data as Currency

Die Zusammenfassungsdaten für das Feld "Sales" werden standardmäßig als eine Zahl im Standardzahlenformat angezeigt.By default, the summary data for the Sales field displays a general number. Formatieren Sie das Feld, um die Zahl als Währung anzuzeigen.Format it to display the number as currency.

So formatieren Sie ein WährungsfeldTo format a currency field

  1. Damit formatierte Textfelder und Platzhaltertext als Beispielwerte in der Entwurfsansicht angezeigt werden, klicken Sie auf der Registerkarte Home in der Gruppe Zahl auf den Pfeil neben dem Symbol Platzhalterformate > Beispielwerte.To see formatted text boxes and placeholder text as sample values in Design View, on the Home tab, in the Number group, click the arrow next to the Placeholder Styles icon > Sample Values.

  2. Klicken Sie auf die Zelle in der zweiten Zeile (unter der Zeile mit den Spaltenüberschriften) in der Spalte "Sales", und ziehen Sie den Mauszeiger nach unten, um alle Zellen auszuwählen, die [Sum(Sales)]enthalten.Click the cell in the second row (under the column headings row) in the Sales column and drag down to select all cells that contain [Sum(Sales)].

  3. Klicken Sie auf der Registerkarte Stamm in der Gruppe Zahl auf die Schaltfläche Währung .On the Home tab, in the Number group, click the Currency button. Die Zellen ändern sich, um die formatierte Währung anzuzeigen.The cells change to show the formatted currency.

    Wenn Sie das Gebietsschema „Deutsch (Deutschland)“ verwenden, lautet der Standardbeispieltext [12,345.00€].If your regional setting is English (United States), the default sample text is [$12,345.00]. Wenn Sie keinen Beispielwährungswert sehen, klicken Sie auf der Registerkarte Home in der Gruppe Zahl auf den Pfeil neben dem Symbol Platzhalterformate > Beispielwerte.If you do not see an example currency value, on the Home tab, in the Number group, click the arrow next to the Placeholder Styles icon > Sample Values.

  4. Klicken Sie auf Ausführen , um den Bericht in der Vorschau anzuzeigen.Click Run to preview your report.

Die Zusammenfassungswerte für "Sales" werden als Währung angezeigt.The summary values for Sales display as currency.

3. Formatieren von Daten als Datum3. Format Data as Date

Im Feld „SalesDate“ werden standardmäßig sowohl Datum als auch Uhrzeit angezeigt.By default, the SalesDate field displays both date and time. Durch entsprechende Formatierung kann auch nur das Datum angezeigt werden.You can format them to display only the date.

So formatieren Sie ein Datumsfeld als StandardformatTo format a date field as the default format

  1. Klicken Sie auf Entwurf , um zur Entwurfsansicht zurückzukehren.Click Design to return to design view.

  2. Klicken Sie auf die Zelle, die [SalesDate]enthält.Click the cell that contains [SalesDate].

  3. Klicken Sie auf dem Menüband auf der Registerkarte Stamm in der Gruppe Zahl auf den Pfeil und wählen Sie Datumaus.On the Ribbon, on the Home tab, in the Number group, click the arrow and select Date.

    In der Zelle wird das Beispieldatum [31.01.2000] angezeigt.The cell displays the example date [1/31/2000]. Wenn Sie kein Beispieldatum sehen, klicken Sie auf der Registerkarte Home in der Gruppe Zahl auf den Pfeil neben dem Symbol Platzhalterformate und wählen Sie Beispielwerte aus.If you do not see an example date, on the Home tab, in the Number group, click the arrow next to the Placeholder Styles icon > Sample Values.

  4. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

Die "SalesDate"-Werte werden im Standarddatumsformat angezeigt.The SalesDate values display in the default date format.

So ändern Sie das Datumsformat in ein benutzerdefiniertes FormatTo change the date format to a custom format

  1. Klicken Sie auf Entwurf , um zur Entwurfsansicht zurückzukehren.Click Design to return to design view.

  2. Wählen Sie die Zelle, die [SalesDate]enthält.Select the cell that contains [SalesDate].

  3. Klicken Sie auf der Registerkarte Stamm in der Gruppe Zahl auf den Pfeil in der Ecke unten rechts, um das Dialogfeld zu öffnen.On the Home tab, in the Number group, click the arrow in the lower-right corner to open the dialog box.

    Das Dialogfeld Textfeldeigenschaften wird geöffnet.The Text Box Properties dialog box opens.

  4. Prüfen Sie im Bereich Kategorie, ob Datum gewählt ist.In the Category pane, verify that Date is selected.

  5. Wählen Sie im Bereich Typ die Option 31. Januar 2000aus.In the Type pane, select January 31, 2000.

  6. Klicken Sie auf OK.Click OK.

    Die Zelle zeigt das Beispieldatum an: [31. Januar 2000] .The cell displays the example date [January 31, 2000].

  7. Klicken Sie auf Ausführen , um den Bericht in der Vorschau anzuzeigen.Click Run to preview your report.

Der Wert von „SalesDate“ wird mit dem Namen des Monats anstelle der Zahl für den Monat angezeigt.The SalesDate value displays the name of the month instead of the number for the month.

4. Ändern der Spaltenbreite4. Change Column Widths

Standardmäßig enthält jede Zelle in einer Tabelle ein Textfeld.By default, each cell in a table contains a text box. Textfelder werden beim Rendern der Seite entsprechend dem anzuzeigenden Text vertikal erweitert.A text box expands vertically to accommodate text when the page is rendered. Im gerenderten Bericht werden alle Zeilen auf die Höhe des größten gerenderten Textfelds in der Zeile vergrößert.In the rendered report, each row expands to the height of the tallest rendered text box in the row. Die Höhe der Zeile auf der Entwurfsoberfläche hat keinen Einfluss auf die Höhe der Zeile im gerenderten Bericht.The height of the row on the design surface has no affect on the height of the row in the rendered report.

Um die Höhe der Zeilen zu reduzieren, vergrößern Sie die Spaltenbreite, sodass der erwartete Inhalt der Textfelder in der Spalte in einer Zeile untergebracht werden kann.To reduce the amount of vertical space each row takes, expand the column width to accommodate the expected contents of the text boxes in the column on one line.

So ändern Sie die Breite von TabellenspaltenTo change the width of table columns

  1. Klicken Sie auf Entwurf , um zur Entwurfsansicht zurückzukehren.Click Design to return to design view.

  2. Klicken Sie auf die Tabelle, damit die Spalten- und Zeilenhandles über und neben der Tabelle angezeigt werden.Click the table so that column and row handles appear above and next to the table.

    Die grauen Balken oberhalb und neben der Tabelle stellen die Spalten- und Zeilenhandles dar.The gray bars along the top and side of the table are the column and row handles.

  3. Zeigen Sie auf die Zeile zwischen Spaltenhandles, sodass sich der Cursor in einen Doppelpfeil ändert.Point to the line between column handles so that the cursor changes into a double arrow. Ziehen Sie die Spalten auf die gewünschte Breite.Drag the columns to the width you want. Beispiel: Erweitern Sie die Spalte für Produkt, damit der Produktname auf einer Zeile angezeigt wird.For example, expand the column for Product so that the product name displays on one line.

  4. Klicken Sie auf Ausführen , um den Bericht in der Vorschau anzuzeigen.Click Run to preview your report.

5. Hinzufügen eines Berichtstitels5. Add a Report Title

Ein Berichtstitel wird oben im Bericht angezeigt.A report title appears at the top of the report. Sie können den Berichtstitel in eine Berichtskopfzeile einfügen oder, wenn der Bericht keine Kopfzeile enthält, in einem Textfeld am oberen Rand des Berichtshauptteils.You can place the report title in a report header or if the report does not use one, in a text box at the top of the report body. In diesem Lernprogramm verwenden Sie das Textfeld, das automatisch am oberen Rand des Berichtshauptteils platziert wird.In this tutorial, you will use the text box that is automatically placed at the top of the report body.

Die Darstellung des Texts kann weiter verbessert werden, indem andere Schriftschnitte, Größen und Farben für Ausdrücke und einzelne Zeichen des Texts angewendet werden.The text can be further enhanced by applying different font styles, sizes, and colors to phrases and individual characters of the text. Weitere Informationen finden Sie unter Formatieren von Text in einem Textfeld (Berichts-Generator und SSRS).For more information, see Format Text in a Text Box (Report Builder and SSRS).

So fügen Sie einen Berichtstitel hinzuTo add a report title

  1. Klicken Sie auf der Entwurfsoberfläche auf Zum Hinzufügen eines Titels klicken.On the design surface, click Click to add title.

  2. Geben Sie Product Salesein, und klicken Sie anschließend außerhalb des Textfelds.Type Product Sales, and then click outside the text box.

  3. Klicken Sie mit der rechten Maustaste auf das Textfeld, das Product Sales enthält, und klicken Sie auf Textfeldeigenschaften.Right-click the text box that contains Product Sales and click Text Box Properties.

  4. Klicken Sie im Dialogfeld Textfeldeigenschaften auf Schriftart.In the Text Box Properties dialog box, click Font.

  5. Wählen Sie in der Liste Schriftgrad den Eintrag 18ptaus.In the Size list, select 18pt.

  6. Wählen Sie in der Liste Farbe die Option Kornblumenblauaus.In the Color list, select Cornflower Blue.

  7. Wählen Sie Fettaus.Select Bold.

  8. Klicken Sie auf OK.Click OK.

6. Speichern des Berichts6. Save the Report

Speichern Sie den Bericht auf einem Berichtsserver oder auf Ihrem Computer.Save the report to a report server or your computer. Wenn Sie den Bericht nicht auf dem Berichtsserver speichern, ist eine Reihe von Reporting ServicesReporting Services -Funktionen nicht verfügbar, z. B. Berichtsteile und Unterberichte.If you do not save the report to the report server, a number of Reporting ServicesReporting Services features such as report parts and subreports are not available.

So speichern Sie den Bericht auf einem BerichtsserverTo save the report on a report server

  1. Klicken Sie auf Datei > Speichern als.Click File > Save As.

  2. Klicken Sie auf Letzte Sites und Server.Click Recent Sites and Servers.

  3. Wählen Sie den Namen des Berichtsservers aus, auf dem Sie zum Speichern von Berichten berechtigt sind, oder geben Sie ihn ein.Select or type the name of the report server where you have permission to save reports.

    Die Meldung "Verbindung mit Berichtsserver wird hergestellt" wird angezeigt.The message "Connecting to report server" appears. Nachdem die Verbindung hergestellt wurde, sehen Sie den Inhalt des Berichtsordners, den der Berichtsserveradministrator als Standardspeicherort für Berichte angegeben hat.When the connection is complete, you see the contents of the report folder that the report server administrator specified as the default location for reports.

  4. In Name, ersetzen Sie Unbenannt mit Product_Sales.In Name, replace Untitled with Product_Sales.

  5. Klicken Sie auf Speichern.Click Save.

Der Bericht wird auf dem Berichtsserver gespeichert.The report is saved to the report server. Der Name des Berichtsservers, mit dem Sie verbunden sind, wird in der Statusleiste unten im Fenster angezeigt.The name of report server that you are connected to appears in the status bar at the bottom of the window.

So speichern Sie den Bericht auf dem ComputerTo save the report on your computer

  1. Klicken Sie auf Datei > Speichern als.Click File > Save As.

  2. Klicken Sie auf Desktop, Eigene Dokumenteoder Computer, und navigieren Sie zu dem Ordner, in dem Sie den Bericht speichern möchten.Click Desktop, My Documents, or My computer, and browse to the folder where you want to save the report.

  3. In Name, ersetzen Sie Unbenannt durch Product Sales.In Name, replace Untitled with Product Sales.

  4. Klicken Sie auf Speichern.Click Save.

7. Exportieren des Berichts7. Export the Report

Berichte können in verschiedene Formate exportiert werden, z.B. Microsoft Excel- und CSV-Dateien.Reports can be exported to different formats such Microsoft Excel and comma separated value (CSV) files. Weitere Informationen finden Sie unter Exportieren von Berichten (Berichts-Generator und SSRS)kennen.For more information, see Export Reports (Report Builder and SSRS).

In diesem Lernprogramm exportieren Sie den Bericht nach Excel, und Sie legen eine Eigenschaft für den Bericht fest, um einen benutzerdefinierten Namen für das Arbeitsmappenregister anzugeben.In this tutorial, you will export the report to Excel and set a property on the report to provide a custom name for the workbook tab.

So geben Sie den Namen des Arbeitsmappenregisters anTo specify the workbook tab name

  1. Klicken Sie auf Entwurf , um zur Entwurfsansicht zurückzukehren.Click Design to return to design view.

  2. Klicken Sie auf die Entwurfsoberfläche außerhalb des Berichts.Click anywhere on the design surface, outside the report.

  3. Suchen Sie im Bereich Eigenschaften nach der InitialPageName-Eigenschaft und geben Sie Product Sales Excelein.In the Properties pane, locate the InitialPageName property and type Product Sales Excel.

    Hinweis

    Klicken Sie auf der Registerkarte Ansicht auf Eigenschaften, falls der Bereich "Eigenschaften" nicht angezeigt wird.If the Properties pane is not visible, on the View tab, select Properties.
    Wenn eine Eigenschaft im Bereich Eigenschaften nicht angezeigt wird, versuchen Sie, die Alphabetisch Schaltfläche oben am Bereich auszuwählen, um alle Eigenschaften alphabetisch zu sortieren.If you don't see a property in the Properties pane, try selecting the Alphabetical button at the top of the pane to order all the properties alphabetically.

So exportieren Sie einen Bericht nach ExcelTo export a report to Excel

  1. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

  2. Klicken Sie im Menüband auf Exportieren > Excel.On the ribbon, click Export > Excel.

    Der Bericht öffnet sich.The opens.

  3. Navigieren Sie im Dialogfeld Speichern unter zu dem Verzeichnis, in dem die Datei gespeichert werden soll.In Save As dialog box, browse to where you want to save the file.

  4. Geben Sie im Textfeld Dateiname den Namen Product_Sales_Excelein.In the File name box, type Product_Sales_Excel.

  5. Vergewissern Sie sich, dass der Dateityp Excel (*.xlsx) ist.Verify that the file type is Excel (*.xlsx).

  6. Klicken Sie auf Speichern.Click Save.

So zeigen Sie den Bericht in Excel anTo view the report in Excel

  1. Öffnen Sie den Ordner, in dem Sie die Arbeitsmappe speichern, und doppelklicken Sie auf Product_Sales_Excel.xlsx.Open the folder where you save the workbook and double-click Product_Sales_Excel.xlsx.

  2. Überprüfen Sie, ob der Name des Arbeitsmappenregisters Product Sales Excellautet.Verify that the name of the workbook tab is Product Sales Excel.

Next StepsNext Steps

Damit ist die exemplarische Vorgehensweise für das Erstellen eines einfachen Tabellenberichts abgeschlossen.This concludes the walkthrough for how to create a basic table report. Weitere Informationen zu Tabellen finden Sie unter Tabellen, Matrizen und Listen (Berichts-Generator und SSRS).For more information about tables, see Tables, Matrices, and Lists (Report Builder and SSRS).

Weitere InformationenSee Also

Lernprogramme für den Berichts-GeneratorReport Builder Tutorials
Berichts-Generator in SQL ServerReport Builder in SQL Server