Lernprogramm: Kartenbericht (Berichts-Generator)Tutorial: Map Report (Report Builder)

In diesem Berichts-GeneratorReport Builder -Tutorial erfahren Sie mehr über die Kartenfunktionen, mit denen Sie Daten vor einem geografischen Hintergrund in einem paginierten Reporting ServicesReporting Services -Bericht anzeigen können.In this Berichts-GeneratorReport Builder tutorial, you learn about map features you can use to display data on a geographic background in an Reporting ServicesReporting Services paginated report.

Karten basieren auf räumlichen Daten, die in der Regel aus Punkten, Linien und Polygonen bestehen.Maps are based on spatial data that typically consists of points, lines, and polygons. Ein Polygon kann z. B. den Umriss eines Countys darstellen, eine Linie eine Straße und ein Punkt die Position eines Orts.For example, a polygon can represent the outline of a county, a line can represent a road, and a point can represent the location of a city. Jeder räumliche Datentyp wird auf einer separaten Kartenebene als Satz von Kartenelementen angezeigt.Each type of spatial data is displayed on a separate map layer as a set of map elements.

Geben Sie zum Verändern der Darstellung von Kartenelementen ein Feld mit Werten an, durch die die Kartenelemente mit analytischen Daten aus einem Dataset verglichen werden.To vary the appearance of map elements, you specify a field that has values that match the map elements with analytical data from a dataset. Sie können auch Regeln definieren, durch die Farbe, Größe oder andere Eigenschaften basierend auf Datenbereichen verändert werden.You can also define rules that vary color, size, or other properties based on ranges of data.

Berichts-Generator-Karte-fertig-nur-Karte

In diesem Tutorial erstellen Sie einen Kartenbericht, in dem Geschäftsstandorte in den Countys des Bundesstaats New York angezeigt werden.In this tutorial, you build a map report that displays store locations in New York state counties.

Hinweis

In diesem Lernprogramm werden die Schritte für den Assistenten in zwei Verfahren zusammengefasst: ein Verfahren zum Erstellen des Datasets und ein Verfahren zum Erstellen einer Tabelle.In this tutorial, the steps for the wizard are consolidated into two procedures: one to create the dataset and one to create a table. Das erste Tutorial dieser Reihe enthält Schrittanleitungen zum Navigieren zu einem Berichtsserver, zum Auswählen einer Datenquelle, zum Erstellen eines Datasets und zum Ausführen des Assistenten: Tutorial: Erstellen eines einfachen Tabellenberichts (Berichts-Generator).For step-by-step instructions about how to browse to a report server, choose a data source, create a dataset, and run the wizard, see the first tutorial in this series: Tutorial: Creating a Basic Table Report (Report Builder).

Ungefähre Dauer dieses Lernprogramms: 30 MinutenEstimated time to complete this tutorial: 30 minutes.

AnforderungenRequirements

Der Berichtsserver muss für dieses Tutorial für die Unterstützung von Bing Maps als Hintergrund konfiguriert werden.For this tutorial, the report server must be configured to support Bing maps as a background. Weitere Informationen finden Sie unter Planen der Unterstützung für Kartenberichte.For more information, see Plan for Map Report Support.

Weitere Informationen zu weiteren Voraussetzungen finden Sie unter Voraussetzungen für Tutorials (Berichts-Generator).For information about other requirements, see Prerequisites for Tutorials (Report Builder).

1. Erstellen einer Karte mit einer Polygonebene im Karten-Assistenten1. Create a Map with a Polygon Layer from the Map Wizard

In diesem Abschnitt fügen Sie dem Bericht eine Karte aus dem Kartenkatalog hinzu.In this section, you add a map to your report from the map gallery. Die Karte enthält eine Ebene, auf der die Countys im Bundesstaat New York angezeigt werden.The map has one layer that displays the counties in New York state. Die Form jedes Countys ist ein Polygon, das auf eingebetteten räumlichen Daten in der Karte aus dem Kartenkatalog basiert.The shape of each county is a polygon based on spatial data that is embedded in the map from the map gallery.

So fügen Sie mit dem Karten-Assistenten eine Karte in einem neuen Bericht hinzuTo add a map with the map wizard in a new report

  1. Starten Sie den Berichts-Generator entweder von Ihrem Computer, über das Reporting ServicesReporting Services -Webportal oder über den integrierten SharePoint-Modus.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    Das Dialogfeld Neuer Bericht oder neues Dataset wird geöffnet.The New Report or Dataset dialog box opens.

    Wenn das Dialogfeld Neuer Bericht oder neues Dataset nicht angezeigt wird, wählen Sie im Menü Datei die Option Neu.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. Vergewissern Sie sich, dass im linken Bereich Neuer Bericht ausgewählt ist.In the left pane, verify that New Report is selected.

  3. Klicken Sie im rechten Bereich auf Karten-Assistent.In the right pane, click Map Wizard.

  4. Überprüfen Sie, ob die Option Kartenkatalog auf der Seite Quelle räumlicher Daten auswählen ausgewählt ist.On the Choose a source of spatial data page, verify that Map gallery is selected.

  5. Erweitern Sie im Kartenkatalog unter USA den Bereich States by County, und klicken Sie auf New York.In the Map Gallery box, expand States by County under USA, and click New York.

    Im Bereich "Kartenvorschau" wird die Karte der Countys in New York angezeigt.The Map Preview pane displays the New York county map.

    Berichts-Generator-Karte-Countys-New York

  6. Klicken Sie auf Weiter.Click Next.

  7. Übernehmen Sie auf der Seite Optionen für räumliche Daten und Kartenansicht auswählen die Standardwerte, und klicken Sie auf Weiter.On the Choose spatial data and map view options page, accept the defaults and click Next.

    Standardmäßig werden Kartenelemente aus einem Kartenkatalog automatisch in die Berichtsdefinition eingebettet.By default, map elements from a map gallery are automatically embedded in the report definition.

  8. Überprüfen Sie, ob auf der Seite Kartenvisualisierung auswählen der Eintrag Standardkarte ausgewählt ist, und klicken Sie auf Weiter.On the Choose map visualization page, verify Basic Map is selected, and click Next.

  9. Aktivieren Sie auf der Seite Farbdesign und Datenvisualisierung auswählen die Option Bezeichnungen anzeigen .On the Choose color theme and data visualization page, select the Display labels option.

  10. Falls aktiviert, deaktivieren Sie die Option Einfarbige Karte .If it is selected, clear the Single color map option.

  11. Klicken Sie in der Dropdownliste Datenfeld auf #COUNTYNAME.From the Data field drop-down list, click #COUNTYNAME. Im Kartenvorschaubereich im Assistenten werden die folgenden Elemente angezeigt:The Map Preview pane in the wizard displays the following items:

    • Ein Titel mit dem Text KartentitelA title with the text Map Title.

    • Eine Karte der Countys in New York, in der jedes County mit einer anderen Farbe dargestellt und der Name des Countys angezeigt wird, sofern er über den Countybereich passtA map that displays counties in New York where each county is a different color and the county name appears wherever it fits over the county area.

    • Eine Legende, die einen Titel und eine Liste von Elementen von 1 bis 5 enthält.A legend that contains a title and a list of items 1 through 5.

    • Eine Farbskala, die die Werte von 0 bis 160 und keine Farbe enthält.A color scale that contains values 0 to 160 and no color.

    • Eine Entfernungsskala, auf der Kilometer (km) und Meilen (mi) angezeigt werdenA distance scale that displays kilometers (km) and miles (mi).

    Berichts-Generator-Karte-Farbschema-wählen

  12. Klicken Sie auf Fertig stellen.Click Finish.

    Die Karte wird der Entwurfsoberfläche hinzugefügt.The map is added to the design surface.

  13. Markieren Sie den Text „Kartentitel“, geben Sie Umsatz nach Filiale ein, und drücken Sie die EINGABETASTE.Select the "Map Title" text and type Sales by Store > ENTER.

  14. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenenanzuzeigen.Double-click the map to display the Map Layers Pane. Im Bereich Kartenebenen wird eine Polygonebene, PolygonLayer1, vom Ebenentyp Eingebettetangezeigt.The Map Layers Pane shows one polygon layer, PolygonLayer1, of layer type Embedded. Jedes County ist ein eingebettetes Kartenelement auf dieser Ebene.Each county is an embedded map element on this layer.

    Hinweis

    Wenn Sie den Bereich Kartenebenen nicht sehen, wird er möglicherweise außerhalb der aktuellen Ansicht angezeigt.If you don't see the Map Layers pane, it might be displayed outside your current view. Verwenden Sie die Bildlaufleiste am unteren Rand des Entwurfsansichtsfensters, um die Ansicht zu ändern.Use the scroll bar at the bottom of the Design view window to change your view. Deaktivieren Sie alternativ auf der Registerkarte Ansicht die Option Berichtsdaten , um den Anzeigebereich für die Entwurfsoberfläche zu vergrößern.Alternatively, in the View tab, clear the Report Data option to provide more design surface area.

  15. Klicken Sie auf den Pfeil neben „PolygonLayer1“ und anschließend auf Polygoneigenschaften.Select the arrow next to PolygonLayer1 > Polygon properties.

  16. Ändern Sie auf der Registerkarte Schriftart die Farbe zu Mattes Grau.On the Font tab, change the color to Dim Gray.

  17. Klicken Sie auf der Registerkarte Home auf Ausführen, um eine Vorschau des Berichts anzuzeigen.On the Home tab > Run to preview the report.

    Berichts-Generator-Karte-erste-Vorschau

Im gerenderten Bericht werden der Berichtstitel, der Kartentitel, die Karte und die Entfernungsskala angezeigt.The rendered report displays the map title, the map, and the distance scale. Die Countys befinden sich auf einer Polygonebene der Karte.The counties are on a map polygon layer. Alle Countys werden als Polygone mit unterschiedlichen Farben aus einer Farbpalette dargestellt, die Farben sind jedoch keinen Daten zugeordnet.Each county is a polygon that varies by color from a color palette, but the colors are not associated with any data. Auf der Entfernungsskala werden Entfernungen sowohl in Kilometern als auch in Meilen angezeigt.The distance scale displays distances in both kilometers and miles.

Die Kartenlegende und die Farbskala werden noch nicht angezeigt, da den Countys noch keine analytischen Daten zugeordnet sind.The map legend and color scale do not yet appear because there is no analytical data associated with each county. Sie fügen später in diesem Lernprogramm analytische Daten hinzu.You will add analytical data later in this tutorial.

2. Hinzufügen einer Kartenpunktebene, um Geschäftsstandorte anzuzeigen2. Add a Map Point Layer to Display Store Locations

In diesem Abschnitt fügen Sie mithilfe des Kartenebenen-Assistenten eine Punktebene hinzu, die den Standort von Geschäften anzeigt.In this section, you use the map layer wizard to add a point layer that displays the locations of stores.

Hinweis

In diesem Tutorial sind die Datenwerte in der Abfrage enthalten, sodass keine externe Datenquelle benötigt wird.In this tutorial, the query contains the data values, so it does not need an external data source. Die Abfrage ist daher relativ lang.This makes the query quite long. In einer Geschäftsumgebung wären die Daten nicht in der Abfrage enthalten.In a business environment, a query would not contain the data. Dieses Szenario dient nur zu Lernzwecken.This is for learning purposes only.

So fügen Sie eine Punktebene auf Grundlage eines SQL Server-Abfrage nach räumlichen Daten hinzuTo add a point layer based on a SQL Server spatial query

  1. Klicken Sie auf die Registerkarte Ausführen auf Entwurf, um wieder zur Entwurfsansicht zurück zu wechseln.On the Run tab > Design to switch back to Design view.

  2. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layers pane. Klicken Sie in auf der Symbolleiste auf die Schaltfläche Assistent für neue Ebenen rs_IconMapLayerWizard.On the toolbar, click the New layer wizard button rs_IconMapLayerWizard.

    Berichts-Generator-Karte-Symbol-des-Assistent-für-neue-Ebene

  3. Wählen Sie auf der Seite Quelle räumlicher Daten auswählen den Eintrag SQL Server-Abfrage nach räumlichen Datenaus, und klicken Sie auf Weiter.On the Choose a source of spatial data page, select SQL Server spatial query, and click Next.

  4. Überprüfen Sie, ob die Option Dataset mit räumlichen SQL Server-Daten auswählen auf Neues Dataset mit räumlichen SQL Server-Daten hinzufügen > Weiter.On the Choose a dataset with SQL Server spatial data page, click Add a new dataset with SQL Server spatial data > Next.

  5. Wählen Sie auf der Seite Verbindung mit einer SQL Server-Datenquelle für räumliche Daten auswählen eine vorhandene Datenquelle aus, oder navigieren Sie zum Berichtsserver, und wählen Sie eine Datenquelle aus.On the Choose a connection to a SQL Server spatial data source page, select an existing data source or browse to the report server and select a data source.

    Hinweis

    Welche Datenquelle Sie auswählen, ist unwichtig, solange Sie über ausreichende Berechtigungen verfügen.The data source you choose is unimportant, as long as you have adequate permissions. Aus der Datenquelle werden keine Daten abgerufen.You will not be getting data from the data source. Weitere Informationen finden Sie unter Alternative Methoden zum Herstellen einer Datenverbindung (Berichts-Generator).For more information, see Alternative Ways to Get a Data Connection (Report Builder).

  6. Klicken Sie auf Weiter.Click Next.

  7. Klicken Sie auf der Seite Abfrage entwerfen auf Als Text bearbeiten.On the Design a Query page, click Edit as Text.

  8. Kopieren Sie den folgenden Text, und fügen Sie ihn in den Abfragebereich ein:Copy the following text and paste it in the query pane:

    Select 114 as StoreKey, 'Contoso Albany Store' as StoreName, 1125 as SellingArea, 'Albany' as City, 'Albany' as County,   
     CAST(1000000 as money) as Sales, CAST('POINT(-73.7472924218681 42.6564617079878)' as geography) AS SpatialLocation  
    UNION ALL SELECT 115 AS StoreKey, 'Contoso New York No.1 Store' AS  StoreName, 500 as SellingArea, 'New York' AS City, 'New York City' as County,  
     CAST('2000000' as money) as Sales, CAST('POINT(-73.9922069374483 40.7549638237402)' as geography) AS SpatialLocation  
    UNION ALL Select 116 as StoreKey, 'Contoso Rochester No.1 Store' as StoreName, 462 as SellingArea, 'Rochester' as City,  'Monroe' as County,    
     CAST(3000000 as money) as Sales, CAST('POINT(-77.624041566786 43.1547066024338)' as geography)  AS SpatialLocation  
    UNION ALL Select 117 as StoreKey, 'Contoso New York No.2 Store' as StoreName, 700 as SellingArea, 'New York' as City,'New York City' as County,    
      CAST(4000000 as money) as Sales, CAST('POINT(-73.9712488 40.7830603)' as geography) AS SpatialLocation  
    UNION ALL Select 118 as StoreKey, 'Contoso Syracuse Store' as StoreName, 680 as SellingArea, 'Syracuse' as City, 'Onondaga' as County,  
     CAST(5000000 as money) as Sales, CAST('POINT(-76.1349120532546 43.0610223535974)' as geography) AS SpatialLocation  
    UNION ALL Select 120 as StoreKey, 'Contoso Plattsburgh Store' as StoreName, 560 as SellingArea, 'Plattsburgh' as City,  'Clinton' as County,  
     CAST(6000000 as money) as Sales, CAST('POINT(-73.4728622833178 44.7028831413324)' as geography) AS SpatialLocation  
    UNION ALL Select 121 as StoreKey, 'Contoso Brooklyn Store' as StoreName, 1125 as SellingArea, 'Brooklyn' as City, 'New York City' as County,  
     CAST(7000000 as money) as Sales, CAST('POINT (-73.9638533447143 40.6785123489351)' as geography) AS SpatialLocation  
    UNION ALL Select 122 as StoreKey, 'Contoso Oswego Store' as StoreName, 500 as SellingArea, 'Oswego' as City, 'Oswego' as County,    
     CAST(8000000 as money) as Sales, CAST('POINT(-76.4602850815536 43.4353224527794)' as geography) AS SpatialLocation  
    UNION ALL Select 123 as StoreKey, 'Contoso Ithaca Store' as StoreName, 460 as SellingArea, 'Ithaca' as City, 'Tompkins' as County,  
     CAST(9000000 as money) as Sales, CAST('POINT(-76.5001866085881 42.4310489934743)' as geography) AS SpatialLocation  
    UNION ALL Select 124 as StoreKey, 'Contoso Buffalo Store' as StoreName, 700 as SellingArea, 'Buffalo' as City, 'Erie' as County,    
     CAST(100000 as money) as Sales, CAST('POINT(-78.8784 42.8864)' as geography) AS SpatialLocation  
    UNION ALL Select 125 as StoreKey, 'Contoso Queens Store' as StoreName, 700 as SellingArea,'Queens' as City, 'New York City' as County,  
     CAST(500000 as money) as Sales, CAST('POINT(-73.7930979029883 40.7152781765927)' as geography) AS SpatialLocation  
    UNION ALL Select 126 as StoreKey, 'Contoso Elmira Store' as StoreName, 680 as SellingArea, 'Elmira' as City, 'Chemung' as County,  
     CAST(800000 as money) as Sales, CAST('POINT(-76.7397414783301 42.0736492742663)' as geography) AS SpatialLocation  
    UNION ALL Select 127 as StoreKey, 'Contoso Poestenkill Store' as StoreName, 455 as SellingArea, 'Poestenkill' as City, 'Rensselaer' as County,    
    CAST(1500000 as money) as Sales, CAST('POINT(-73.5626737425063 42.6940551238618)' as geography) AS SpatialLocation  
    
  9. Klicken Sie auf der Symbolleiste des Abfrage-Designers auf Ausführen (!).On the query designer toolbar, click Run (!).

    Das Resultset enthält sieben Spalten mit einem Satz von Geschäften im Bundesstaat New York, die Verbrauchsgüter verkaufen.The result set contains seven columns representing a set of stores in New York State that sell consumer goods. Im Folgenden finden Sie eine Liste mit Erklärungen für die Spalten, die nicht selbsterklärend sind:Here's a list, with explanations for the ones that may not be obvious:

    • StoreKey: ein Geschäftsbezeichner.StoreKey: A store identifier.
    • StoreNameStoreName.
    • SellingArea: die für eine Produktauslage zur Verfügung stehende Fläche, von 455 sq ft bis 1125 sq ft.SellingArea: The area available for product display, ranging from 455 square feet to 1125 square feet.
    • CityCity.
    • CountyCounty.
    • Sales: Gesamtumsatz.Sales: Total sales.
    • SpatialLocation: Standort, angegeben in Längen- und Breitengrad.SpatialLocation: Location in longitude and latitude.

    Berichts-Generator-Abfrage-entwerfen

  10. Klicken Sie auf Weiter.Click Next.

    Das Berichtsdataset mit dem Namen "DataSet1" wird für Sie erstellt.The report dataset named DataSet1 is created for you. Nachdem Sie den Assistenten abgeschlossen haben, wird im Bereich „Berichtsdaten“ die Feldersammlung angezeigt.After you complete the wizard, you can see its field collection in the Report Data pane.

  11. Überprüfen Sie auf der Seite Optionen für räumliche Daten und Kartenansicht auswählen , ob für Räumliches Feld der Wert SpatialLocation und für Ebenentyp der Wert Punktausgewählt ist.On the Choose a spatial data and map view options page, verify that the Spatial field is SpatialLocation and that the Layer type is Point. Übernehmen Sie die anderen Standardwerte auf dieser Seite.Accept the other defaults on this page.

    In der Kartensicht werden Kreise angezeigt, um den Standort jedes Geschäfts zu markieren.The map view displays circles to mark the location of each store.

  12. Klicken Sie auf Weiter.Click Next.

  13. Klicken Sie auf der Seite „Kartenvisualisierung auswählen“ auf Blasendiagrammkarte , um einen Kartentyp zu erhalten, der Marker anzeigt, die je nach Daten in der Größe variieren.On the Choose map visualization page, click Bubble Map for a map type that displays markers that vary in size, according to the data. Klicken Sie auf Weiter.Click Next.

  14. Klicken Sie auf der Seite Analytisches Dataset auswählen auf DataSet1 und anschließend auf Weiter.On the Choose the analytical dataset page, click DataSet1, and click Next. Dieses Dataset enthält sowohl analytische Daten als auch räumliche Daten, die auf der neuen Punktebene angezeigt werden.This dataset contains both analytical data and spatial data that will be displayed on the new point layer.

  15. Aktivieren Sie auf der Seite Farbdesign und Datenvisualisierung auswählen die Option Blasengrößen zum Anzeigen von Daten verwenden.On the Choose color theme and data visualization page, select Use bubble sizes to visualize data.

  16. Wählen Sie unter Datenfeld [Sum(SellingArea)] aus, um die Blasengröße entsprechend der Größe der Ausstellfläche für die Produkte zu variieren.In Data field, select [Sum(SellingArea)] to vary bubble size by the size of the area a store sets aside to display the products.

  17. Wählen Sie Bezeichnungen anzeigenund unter Datenfeld [City]aus.Select Display labels, and in Data field, select [City].

  18. Klicken Sie auf Fertig stellen.Click Finish.

    Die Kartenebene wird dem Bericht hinzugefügt.The map layer is added to the report. Auf der Legende werden Blasengrößen basierend auf den SellingArea-Werten angezeigt.The legend displays bubble sizes based on SellingArea values.

  19. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layer pane. Im Bereich Kartenebenen wird eine neue Ebene PointLayer1 mit dem räumlichen Datenquellentyp DataRegionangezeigt.The Map Layer pane displays a new layer, PointLayer1, with spatial data source type DataRegion.

  20. Fügen Sie einen Legendentitel hinzu.Add a legend title. Wählen Sie in der Legende den Text Titelaus, geben Sie Auslagefläche in Quadratfuß ein und drücken Sie die EINGABETASTE.In the legend, select the text Title, type Display Area (sq. ft.) and press ENTER.

  21. Klicken Sie im Bereich Kartenebenenauf den Pfeil neben PointLayer1, und klicken Sie anschließend auf Punkteigenschaften.In the Map Layers Pane, click the arrow next to PointLayer1, and then click Point Properties.

    Berichts-Generator-Karte-Punkteigenschaften

  22. Ändern Sie auf der Registerkarte Schriftart den Schriftschnitt auf Fett und die Schriftgröße auf 10 pt.On the Font tab, make the style Bold and the size 10pt.

    Berichts-Generator-Karte-Punkteigenschaften-Schriftart

  23. Wählen Sie auf der Registerkarte Allgemein als Platzierung die Einstellung Untenaus.On the General tab, select Bottom for Placement.

  24. Klicken Sie auf OK.Click OK.

  25. Klicken Sie auf Ausführen , um eine Vorschau des Berichts anzuzeigen.Click Run to preview the report.

    Berichts-Generator-Karte-Städtenamen

    Auf der Karte werden die Standorte von Geschäften im Bundesstaat New York angezeigt.The map displays the locations of stores in New York state. Die Markergröße jedes Geschäftes basiert auf der Auslagefläche.The marker size for each store is based on the display area. Fünf Bereiche wurden automatisch für die Aufstellfläche berechnet.Five ranges of display area were automatically calculated for you.

3. Hinzufügen einer Kartenlinienebene, um eine Route anzuzeigen3. Add a Map Line Layer to Display a Route

Fügen Sie mithilfe des Kartenebenen-Assistenten eine Kartenebene hinzu, die eine Route zwischen zwei Geschäften anzeigt.Use the map layer wizard to add a map layer that displays a route between two stores. In diesem Lernprogramm wird der Weg für drei Geschäftsstandorte erstellt.In this tutorial, the path is created from three store locations. In einer Geschäftsanwendung könnte es sich bei dem Weg um die beste Route zwischen Geschäften handeln.In a business application, the path might be the best route between stores.

So fügen Sie der Karte eine Linienebene hinzuTo add a line layer to map

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layer pane. Klicken Sie in auf der Symbolleiste auf die Schaltfläche Assistent für neue Ebenen rs_IconMapLayerWizard.On the toolbar, click the New layer wizard button rs_IconMapLayerWizard.

  3. Wählen Sie auf der Seite Quelle räumlicher Daten auswählen den Eintrag SQL Server-Abfrage nach räumlichen Daten aus, und klicken Sie auf Weiter.On the Choose a source of spatial data page, select SQL Server spatial query and click Next.

  4. Klicken Sie auf der Seite Dataset mit räumlichen SQL Server-Daten auswählen auf Neues Dataset mit räumlichen SQL Server-Daten hinzufügen anschließend auf Weiter.On the Choose a dataset with SQL Server spatial data page, click Add a new dataset with SQL Server spatial data and click Next.

  5. Wählen Sie unter Verbindung mit einer SQL Server-Datenquelle für räumliche Daten auswählendie Datenquelle, die Sie im ersten Verfahren verwendet haben.On the Choose a connection to a SQL Server spatial data source, select the data source that you used in the first procedure.

  6. Klicken Sie auf Weiter.Click Next.

  7. Klicken Sie auf der Seite Abfrage entwerfen auf Als Text bearbeiten.On the Design a Query page, click Edit as Text. Der Abfrage-Designer wechselt in den textbasierten Modus.The query designer switches to text-based mode.

  8. Fügen Sie den folgenden Text in den Abfragebereich ein:Paste the following text in the query pane:

    SELECT N'Path' AS Name, CAST('LINESTRING(  
       -76.5001866085881 42.4310489934743,  
       -76.4602850815536 43.4353224527794,  
       -73.4728622833178 44.7028831413324)' AS geography) as Route  
    
  9. Klicken Sie auf Weiter.Click Next.

    Auf der Karte wird ein Weg angezeigt, der drei Geschäfte verbindet.A path appears on the map that connects three stores.

  10. Überprüfen Sie auf der Seite Optionen für räumliche Daten und Kartenansicht auswählen , ob für Räumliches Feld der Wert Route und für Ebenentyp der Wert Linieausgewählt ist.On the Choose spatial data and map view options page, verify that the Spatial field is Route and that the Layer type is Line. Übernehmen Sie die anderen Standardwerte.Accept the other defaults.

    In der Kartensicht wird ein Weg von einem Geschäft im nördlichen Teil des Bundesstaats New York zu einem Geschäft im südlichen Teil des Bundesstaats New York angezeigt.The map view displays a path from a store in the northern part of New York state to a store in the southern part of New York state.

  11. Klicken Sie auf Weiter.Click Next.

  12. Klicken Sie auf der Seite Kartenvisualisierung auswählen auf Standardkarte (Linien) und anschließend auf Weiter.On the Choose map visualization page, click Basic Line Map, and then click Next.

  13. Aktivieren Sie unter Farbdesign und Datenvisualisierung auswählendie Option Einfarbige Karte.On the Choose color theme and data visualization, select the option Single color map. Der Weg wird mit einer einzelnen Farbe angezeigt, die auf dem ausgewählten Design basiert.The path appears as a single color based on the selected theme.

  14. Klicken Sie auf Fertig stellen.Click Finish.

    Berichts-Generator-Karte-Linie

    In der Karte wird eine neue Linienebene mit dem räumlichem Datenquellentyp DataRegionangezeigt.The map displays a new line layer with spatial data source type DataRegion. In diesem Beispiel stammen die räumlichen Daten aus einem Dataset, aber der Linie sind keine analytischen Daten zugeordnet.In this example, the spatial data comes from a dataset but no analytical data is associated with the line.

Anpassen des ZoomsAdjust the Zoom

  1. Sollte nicht der gesamte Bundesstaat New York angezeigt werden, können Sie den Zoom anpassen.If you can't see the whole state of New York, you can adjust the zoom. Die MapViewport -Eigenschaften für die ausgewählte Karte finden Sie im Bereich „Eigenschaften“.With the map selected, in the Properties pane you see MapViewport properties.

  2. Erweitern Sie den Abschnitt Ansicht , und erweitern Sie anschließend Ansicht , um die Eigenschaft Zoom anzuzeigen.Expand the View section, then expand View so you can see the Zoom property. Legen Sie hierfür 125fest.Set it to 125.

    Berichts-Generator-Karte-Zoom

    Dies ist der Prozentwert für den Zoom.This is the zoom percentage. Wenn dieser 125 % beträgt, sollte der gesamte Bundesstaat angezeigt werden.At 125% you should see the whole state.

4. Hinzufügen eines Bing Maps-Kachelhintergrunds4. Add a Bing Maps Tile Background

In diesem Abschnitt fügen Sie eine Kartenebene hinzu, die einen Bing Maps-Kachelhintergrund anzeigt.In this section, you add a map layer that displays a Bing Maps tile background.

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layer pane. Klicken Sie auf der Symbolleiste auf Ebene hinzufügen rs_IconMapAddLayer.On the toolbar, click Add Layer rs_IconMapAddLayer.

  3. Klicken Sie in der Dropdownliste auf Kachelebene.From the drop-down list, click Tile Layer.

    Die letzte Ebene im Bereich Kartenebene ist TileLayer1.The last layer in the Map Layer pane is TileLayer1. Standardmäßig zeigt die Kachelebene das Straßenkartenformat an.By default, the tile layer displays the road map style.

    Hinweis

    Sie können auch im Assistenten auf der Seite Optionen für räumliche Daten und Kartenansicht auswählen eine Kachelebene hinzufügen.In the wizard, you can also add a tile layer on the Choose spatial data and map view options page. Wählen Sie dazu Bing Maps-Hintergrund für diese Kartenansicht hinzufügenaus.To do this, select Add a Bing Maps background for this map view. In einem gerenderten Bericht zeigt der Kachelhintergrund Bing Maps-Kacheln für den aktuellen Kartenviewport-Mittelpunkt und die aktuelle Zoomstufe an.In a rendered report, the tile background displays Bing Maps tiles for the current map viewport center and zoom level.

  4. Klicken Sie auf den Pfeil neben „TileLayer1“ und anschließend auf Kacheleigenschaften.Click the arrow next to TileLayer1 > Tile Properties.

  5. Wählen Sie auf der Registerkarte Allgemein unter Typdie Option Luftbildaus.On the General tab, under Type, select Aerial. Das Luftbild enthält keinen Text.The aerial view does not contain text.

    Berichts-Generator-Karte-Bing-Luftbild

  6. Klicken Sie auf OK.Click OK.

5. Transparente Darstellung einer Ebene5. Make a Layer Transparent

In diesem Abschnitt passen Sie die Reihenfolge und Transparenz der Ebene an, um die Elemente auf einer anderen Ebenen durchscheinen zu lassen und den gewünschten Transparenzeffekt zu erzielen.In this section, to let the items on one layer show through another layer, you adjust the order and transparency of the layers for the effect that you want. Beginnen Sie mit PolygonLayer1, der ersten Ebene, die Sie erstellt haben.You start with the first layer you created, PolygonLayer1.

  1. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layer pane.

  2. Klicken Sie auf den Pfeil neben „PolygonLayer1“ und auf Ebenendaten.Click the arrow next to PolygonLayer1 > Layer Data. Das Dialogfeld Polygonebeneneigenschaften von Karten wird geöffnet.The Map Polygon Layer Properties dialog box opens.

  3. Geben Sie auf der Registerkarte Sichtbarkeit unter Transparenz (Prozent) 30ein.On the Visibility tab, under Transparency (percent), type 30.

  4. Klicken Sie auf OK.Click OK.

    Auf der Entwurfsoberfläche werden die Countys halbtransparent dargestellt.The design surface displays the counties as semi-transparent.

    Berichts-Generator-Karte-Transparenz

6. Verändern der Countyfarbe basierend auf Umsätzen6. Vary County Color Based on Sales

Jedes County in der Polygonebene hat eine andere Farbe, da der Berichtsprozessor automatisch auf der Grundlage des Designs, das Sie auf der letzten Seite des Karten-Assistenten ausgewählt haben, einen Farbwert aus der Farbpalette zuweist.Each county on the polygon layer has a different color because the report processor automatically assigns a color value from the color palette based on the theme that you chose on the last page of the map wizard.

In diesem Abschnitt geben Sie eine Farbregel an, um für jedes County bestimmte Farben einem Bereich von Geschäftsumsätzen zuzuordnen.In this section, you specify a color rule to associate specific colors with a range of store sales for each county. Die Farben rot, gelb und grün geben relativ hohe, mittlere bzw. niedrige Umsätze an.The colors red-yellow-green indicate relative high-middle-low sales. Formatieren Sie die Farbskala, um Währungswerte anzuzeigen.Format the color scale to show currency. Zeigen Sie die Jahresumsatzbereiche in einer neuen Legende an.Display the annual sales ranges in a new legend. Verwenden Sie für Countys ohne Geschäfte keine Farbe, um anzuzeigen, dass keine zugeordneten Daten vorliegen.For counties that do not contain stores, use no color to show that there is no associated data.

6a.6a. Erstellen einer Beziehung zwischen räumlichen und analytischen DatenBuild a Relationship between Spatial and Analytical Data

Um die Countys anhand analytischer Daten farblich zu unterscheiden, müssen Sie zuerst die analytischen Daten den räumlichen Daten zuordnen.To vary the county shapes by color based on analytical data, you first need to associate the analytical data with the spatial data. In diesem Lernprogramm verwenden Sie zu diesem Zweck den Countynamen.In this tutorial, you will use the county name to match on.

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layers pane.

  3. Klicken Sie auf den Pfeil neben PolygonLayer1 und anschließend auf Ebenendaten.Click the arrow next to PolygonLayer1, then click Layer Data. Das Dialogfeld Polygonebeneneigenschaften von Karten wird geöffnet.The Map Polygon Layer Properties dialog box opens.

  4. Wählen Sie auf der Registerkarte Analytische Daten unter Analytisches DatasetDataSet1 aus.On the Analytical data tab, under Analytical dataset, select DataSet1. Dieses Dataset wurde vom Assistenten erstellt, als Sie die Abfrage räumlicher Daten für die Countys erstellt haben.This dataset was created by the wizard when you created the spatial data query for the counties.

  5. Klicken Sie unter Abzugleichende Felderauf Hinzufügen.Under Fields to match on, click Add. Eine neue Zeile wird hinzugefügt.A new row is added.

  6. Klicken Sie unter Aus räumlichem Datasetauf COUNTYNAME.Under From spatial dataset, click COUNTYNAME.

  7. Klicken Sie unter Aus analytischem Datasetauf [County].Under From analytical dataset, click [County].

    Berichts-Generator-Karte-Countys-Farben

  8. Klicken Sie auf OK.Click OK.

  9. Zeigen Sie eine Vorschau des Berichts an.Preview the report.

    Berichts-Generator-Karte-County-hervorheben

Durch die Angabe eines Übereinstimmungsfelds aus der räumlichen Datenquelle und aus dem analytischen Dataset kann der Berichtsprozessor analytische Daten auf Grundlage der Kartenelemente gruppieren.By specifying a match field from the spatial data source and from the analytical dataset, you enable the report processor to group analytical data based on the map elements. Bei einem datengebundenen Kartenelement wird eine erfolgreiche Übereinstimmung für die von Ihnen angegebenen Werte erzielt.A data-bound map element has a successful match for the values that you specified.

Jedem County mit einem Geschäft ist eine Farbe zugeordnet, die auf der Farbpalette für das im Assistenten ausgewählte Format basiert.Each county that contains a store has a color that is based on the color palette for the style that you chose in the wizard. Die anderen Countys werden grau dargestellt.The other counties are gray.

6b.6b. Festlegen von Farbregeln für PolygoneSpecify Color Rules for Polygons

Zum Erstellen einer Regel, die die Farbe jedes Countys basierend auf dem Geschäftsumsatz verändert, müssen Sie die Bereichswerte, die Anzahl anzuzeigender Einteilungen innerhalb dieses Bereichs und die zu verwendenden Farben angeben.To create a rule that varies the color of each county based store sales, you must specify the range values, the number of divisions within that range that you want to display, and the colors to use.

So geben Sie Farbregeln für alle Polygone mit zugeordneten Daten anTo specify color rules for all polygons that have associated data

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Klicken Sie auf den Pfeil neben PolygonLayer1 und anschließend auf Regel für die Polygonfarbe.Click the arrow next to PolygonLayer1, then click Polygon Color Rule. Das Dialogfeld Farbregeleigenschaften der Karte wird geöffnet.The Map Color Rules Properties dialog box opens. Beachten Sie, dass die Farbregeloption Daten mithilfe der Farbpalette anzeigen ausgewählt ist.Notice that the color rule option Visualize data by using color palette is selected. Diese Option wurde vom Assistenten festgelegt.This option was set by the wizard.

  3. Aktivieren Sie Daten mithilfe von Farbbereichen anzeigen.Select Visualize data by using color ranges. Die Palettenoption wird durch die Optionen für Startfarbe, mittlere Farbe und Endfarbe ersetzt.The palette option is replaced by start color, middle color, and end color options.

  4. Definieren Sie Bereichswerte für die Umsätze pro County.Define range values for sales per county. Wählen Sie unter Datenfeldden Eintrag [Sum(Sales)]in der Dropdownliste aus.In Data field, from the drop-down list, select [Sum(Sales)].

  5. Ändern Sie den Ausdruck wie folgt, um das Format zur Anzeige der Währung in Tausendern zu ändern: =Sum(Fields!Sales.Value)/1000To change the format to display currency in thousands, change the expression to the following: =Sum(Fields!Sales.Value)/1000

  6. Ändern Sie Startfarbe in Rot.Change Start color to Red.

  7. Ändern Sie Endfarbe in Grün.Change End color to Green.

    Rot stellt niedrige Umsatzwerte dar, Gelb stellt mittlere Umsatzwerte dar, und Grün stellt hohe Umsatzwerte dar.Red represents low sales values, Yellow represents middle sales values, and Green represents high sales values. Der Berichtsprozessor berechnet einen Bereich von Farben auf der Grundlage dieser Werte und der Optionen, die Sie auf der Seite Verteilung auswählen.The report processor calculates a range of colors based on these values and the options that you choose on the Distribution page.

    Berichts-Generator-Karte-County-Farbregeln

  8. Klicken Sie auf Verteilung.Click Distribution.

  9. Überprüfen Sie, ob der Verteilungstyp Optimallautet.Verify that the distribution type is Optimal. Für den Ausdruck aus Schritt 5 werden die Werte durch die optimale Verteilung in Teilbereiche aufgeteilt, deren Elementanzahl und Umfang jeweils gleich sind.For the expression from step 5, optimal distribution divides the values into subranges that balance the number of items in each range and the span for each range.

  10. Übernehmen Sie die Standardwerte für andere Optionen auf dieser Seite.Accept the default values for other options on this page. Wenn Sie den optimalen Verteilungstyp auswählen, wird die Anzahl der Teilbereiche bei der Berichtausführung berechnet.When you select the optimal distribution type, the number of subranges are calculated when the report runs.

  11. Klicken Sie auf Legende.Click Legend.

  12. Überprüfen Sie, ob unter Farbskalaoptionender Wert In Farbskala anzeigen ausgewählt ist.In Color scale options, verify that Show in color scale is selected.

  13. Wählen Sie unter In dieser Legende anzeigenin der Dropdownliste die Leerzeile aus.In Show in this legend, from the drop-down list, select the blank line. Zurzeit zeigen Sie die Farbbereiche nur in der Farbskala an.For now, you will show the color ranges only in the color scale.

  14. Klicken Sie auf OK.Click OK.

  15. Zeigen Sie eine Vorschau des Berichts an.Preview the report.

    Berichts-Generator-Karte-County-Farbregel-Vorschau

    Auf der Farbskala werden vier Farben angezeigt: rot, orange, gelb und grün.The color scale displays four colors: red, orange, yellow, and green. Jede Farbe stellt einen Umsatzbereich dar, der automatisch auf Grundlage der Umsätze nach County berechnet wird.Each color represents a sales range that is automatically calculated based on the sales by county.

6c.6c. Formatieren der Daten in der Farbskala als WährungFormat the Data in the Color Scale as Currency

Für Daten wird standardmäßig ein allgemeines Format verwendet.By default, data has a general format. In diesem Abschnitt wenden Sie benutzerdefinierte Formate an.In this section, you apply custom formats.

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Wählen Sie die Farbskala aus.Select the color scale. Klicken Sie auf der Registerkarte Home im Abschnitt Zahl auf Währung.On the Home tab > Number section, , click Currency.

  3. Klicken Sie im Abschnitt Zahl zweimal auf die Schaltfläche Dezimalstelle verringern .Still in the Number section, click the Decrease Decimal button two times.

    Die Farbskala zeigt für jeden Bereich den Jahresumsatz im Währungsformat an.The color scale displays annual sales in currency format for each range.

6d.6d. Hinzufügen eines LegendentitelsAdd a Legend Title

  1. Bei ausgewählter Farbskala werden im Eigenschaftenbereich die Eigenschaften für MapColorScaleangezeigt.With the color scale still selected, in the Properties pane you see properties for MapColorScale.

  2. Erweitern Sie den Abschnitt „Titel“, und geben Sie die Beschriftungseigenschaft Umsatz in Tausendein.Expand the Title section, and in the Caption property, type Sales (Thousands).

  3. Ändern Sie die Eigenschaft „TextColor“ in Weiß.Change the TextColor property to White.

    Berichts-Generator-Karte-Farbskala-Titel

  4. Zeigen Sie eine Vorschau des Berichts an.Preview the report.

Die Countys mit zugeordneten Geschäften und Umsätzen werden entsprechend den Farbregeln angezeigt.The counties that have associated stores and sales display according to the color rules. Countys ohne Umsätze ist keine Farbe zugeordnet.Counties that have no sales have no color.

6f.6f. Ändern der Farbe für Countys ohne DatenChange Color for Counties with No Data

Sie können die Standardanzeigeoptionen für alle Kartenelemente auf einer Ebene festlegen.You can set the default display options for all map elements on a layer. Farbregeln haben Vorrang vor diesen Anzeigeoptionen.Color rules take precedence over these display options.

So legen Sie die Anzeigeeigenschaften für alle Elemente auf einer Ebene festTo set the display properties for all elements on a layer

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layer pane.

  3. Klicken Sie in „PolygonLayer1“ auf den Pfeil nach unten und anschließend auf Polygoneigenschaften.Click the down arrow on PolygonLayer1, and then click Polygon Properties.

    Berichts-Generator-Karte-Polygonebeneneigenschaften

    Das Dialogfeld Polygoneigenschaften von Karten wird geöffnet.The Map Polygon Properties dialog box opens. Bevor regelbasierte Anzeigeoptionen angewendet werden, gelten in diesem Dialogfeld festgelegte Anzeigeoptionen für alle Polygone auf der Ebene.Display options set in this dialog box apply to all polygons on the layer before rule-based display options are applied.

  4. Vergewissern Sie sich auf der Registerkarte Ausfüllen , dass der Füllstil Einfarbiglautet.On the Fill tab, verify that the fill style is Solid. festgelegt ist. Farbverläufe und Muster gelten für alle Farben.Gradients and patterns apply to all colors.

  5. Wählen Sie unter Farbedie Option Helles Stahlblauaus.In Color, select Light Steel Blue.

  6. Klicken Sie auf OK.Click OK.

  7. Zeigen Sie eine Vorschau des Berichts an.Preview the report.

Countys ohne zugeordnete Daten werden graublau dargestellt.Counties with no associated data display as gray-blue. Nur Countys, denen analytische Daten zugeordnet sind, werden in den Farben im Bereich zwischen Rot und Grün der angegebenen Farbregeln angezeigt.Only counties with associated analytical data have the Red through Green colors from the color rules that you specified.

7. Hinzufügen eines benutzerdefinierten Punkts7. Add a Custom Point

In diesem Abschnitt geben Sie einen Punkt an, und verwenden den Markertyp Stern , um ein neues, noch nicht gebautes Geschäft darzustellen.To represent a new store that has not yet been built, in this section you specify a point with the Star marker type.

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Doppelklicken Sie auf die Karte, um den Bereich Kartenebenen anzuzeigen.Double-click the map to display the Map Layer pane. Klicken Sie auf der Symbolleiste auf Ebene hinzufügen rs_IconMapAddLayer und anschließend auf Punktebene.On the toolbar, click Add Layer rs_IconMapAddLayer, then click Point Layer.

    Der Karte wird eine neue Punktebene hinzugefügt.A new point layer is added to the map. Standardmäßig verfügt die Punktebene über den räumlichen Datentyp Eingebettet.By default, the point layer has spatial data type Embedded.

  3. Klicken Sie auf den Pfeil unter „PointLayer2“ und anschließend auf Punkt hinzufügen.Click the arrow on PointLayer2 > Add Point.

  4. Bewegen Sie den Zeiger über den Kartenviewport.Move the pointer over the map viewport. Der Cursor verändert sich zu einem Fadenkreuz.The cursor changes to crosshairs.

  5. Klicken Sie auf den Ort auf der Karte, an dem Sie einen Punkt hinzufügen möchten.Click the location on the map where you want to add a point. Klicken Sie für dieses Tutorial auf eine Position im County Oneida.In this tutorial, click a location in Oneida county. Der Ebene wird an der Stelle, auf die Sie geklickt haben, ein durch einen Kreis markierter Punkt hinzugefügt.A point marked by a circle is added to the layer at the spot where you clicked. Standardmäßig ist der Punkt ausgewählt.By default, the point is selected.

    Berichts-Generator-Karte-benutzerdefinierter-Punkt

  6. Klicken Sie mit der rechten Maustaste auf den hinzugefügten Punkt, und klicken Sie anschließend auf Eigenschaften für eingebettete Punkte.Right-click the point you added, and then click Embedded Point Properties.

  7. Wählen Sie Punktoptionen für diese Ebene überschreibenaus.Select Override point options for this layer. Im Dialogfeld werden weitere Seiten angezeigt.Additional pages appear in the dialog box. Hier festgelegte Werte haben Vorrang vor Anzeigeoptionen für die Ebene oder für Farbregeln.Values that you set here take precedence over display options for the layer or for color rules.

    Berichts-Generator-Karte-benutzerdefinierter-Punkt-allgemein

  8. Wählen Sie auf der Registerkarte Marker unter Markertypden Wert Sternaus.On the Marker tab, for Marker type, select Star.

  9. Ändern Sie die Markergröße in 18 pt.Change Marker size to 18pt.

  10. Geben Sie auf der Registerkarte Bezeichnungen unter Bezeichnungstext Neues Geschäftein.On the Labels tab, in Label text, type New Store.

  11. Klicken Sie unter Platzierungauf Oben.In Placement, click Top.

  12. Ändern Sie auf der Registerkarte Schriftart die Schriftgröße in 10 pt und den Schriftschnitt in Fett.On the Font tab, make the font size 10pt and Bold.

    Berichts-Generator-Karte-benutzerdefinierter-Punkt-Schriftart

  13. Klicken Sie auf OK.Click OK.

  14. Zeigen Sie eine Vorschau des Berichts an.Preview the report.

Die Bezeichnung wird über dem Geschäftsstandort angezeigt.The label appears above the store location.

Berichts-Generator-Karte-benutzerdefinierter-Punkt-neues-Geschäft

8. Zentrieren und Skalieren der Karte8. Center and Resize the Map

In diesem Abschnitt erfahren Sie sowohl, wie Sie den Mittelpunkt der Karte ändern, als auch einen weiteren Weg, um den Zoomfaktor zu ändern.In this section, you learn to change the map center, and another way to change the zoom level.

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Klicken Sie mit der rechten Maustaste auf die Karte, und klicken Sie anschließend auf Viewporteigenschaften.Select the map, then right-click and click Viewport Properties.

  3. Stellen Sie auf der Registerkarte Zentrieren und zoomen sicher, dass die Option Mittelpunkt und Zoomstufe für Ansicht festlegen ausgewählt ist.On the Center and Zoom tab, make sure Set a view center and zoom level is selected.

  4. Legen Sie die Einstellung Zoomfaktor (Prozent) auf 125fest.Set Zoom level (percent) to 125.

  5. Klicken Sie auf OK.Click OK.

  6. Klicken Sie auf die Karte, und ziehen Sie sie, um sie an der gewünschten Stelle zu zentrieren.Click the map, and drag to center it where you want it.

  7. Sie können den Zoomfaktor auch mithilfe des Mausrads ändern.You can also use the mouse wheel to change the zoom level.

  8. Zeigen Sie eine Vorschau des Berichts an.Preview the report.

In der Entwurfsansicht basieren die Karte auf der Anzeigeoberfläche und die Ansicht auf Beispieldaten.In Design view, the map on the display surface and the view is based on sample data. Im gerenderten Bericht wird die Kartenansicht in der angegebenen Ansicht zentriert.In the rendered report, the map view is centered on the view that you specified.

9. Hinzufügen eines Berichtstitels9. Add a Report Title

  1. Wechseln Sie in die Entwurfsansicht.Switch to Design view.

  2. Klicken Sie auf der Entwurfsoberfläche auf Zum Hinzufügen eines Titels klicken.On the design surface, click Click to add title.

  3. Geben Sie Umsätze in den Geschäften in New York ein, und klicken Sie anschließend auf den Bereich außerhalb des Textfelds.Type Sales in New York Stores and then click outside the text box.

Dieser Titel wird am Anfang des Berichts angezeigt.This title will appear at the top of the report. Elemente über dem Berichtshauptteil entsprechen einer Berichtskopfzeile, wenn keine Seitenkopfzeile definiert ist.Items at the top of the report body when there is no page header defined are the equivalent of a report header.

10. Speichern des Berichts10. Save the Report

  1. Klicken Sie in der Entwurfsansicht oder in einer Vorschau auf Datei und anschließend auf Speichern unter.In Design view or Preview, on the File menu > Save As.

  2. Geben Sie im Feld Nameden Namen Umsätze der Geschäfte in New Yorkein.In Name, type Store Sales in New York.

  3. Speichern Sie den Bericht auf Ihrem lokalen Computer oder auf einem Reporting ServicesReporting Services -Server.Save it to your local computer or to a Reporting ServicesReporting Services server.

  4. Klicken Sie auf Speichern.Click Save.

Wenn Sie den Bericht auf einem Berichtsserver speichern, können Sie ihn dort auch anzeigen.If you save it to a report server, you can view it there.

Berichts-Generator-Karte-im-Portal

Next StepsNext Steps

Damit ist die exemplarische Vorgehensweise für das Hinzufügen einer Karte zum Bericht abgeschlossen.This concludes the walkthrough for how to add a map to your report.

Weitere Informationen finden Sie unter Karten (Berichts-Generator und SSRS).For more information, see Maps (Report Builder and SSRS).

Weitere InformationenSee Also

Tutorials (Berichts-Generator)Report Builder tutorials
Berichts-Generator in SQL ServerReport Builder in SQL Server
Karten-Assistent und Kartenebenen-Assistent (Berichts-Generator und SSRS)Map Wizard and Map Layer Wizard (Report Builder and SSRS)
Unterschiedliche Polygon-, Linien- und Punktanzeigen bei der Verwendung von Regeln und analytischen Daten (Berichts-Generator und SSRS)Vary Polygon, Line, and Point Display by Rules and Analytical Data (Report Builder and SSRS)