Problembehandlung bei Verzögerungen nach der ersten Anmeldung nach einer erzwungenen Kennwortänderung
In diesem Artikel wird beschrieben, wie Sie ein Problem mit dem Rückschreiben von Kennwörtern beheben, wenn ein Benutzer gezwungen ist, sein Kennwort bei der ersten Anmeldung zu ändern.
Problembeschreibung
Nachdem ein Benutzer bei der ersten Anmeldung eine erforderliche Kennwortänderung vornimmt, wird diese Warnmeldung angezeigt:
Ihr Kennwort wurde erfolgreich aktualisiert, aber unsere Server benötigen etwas Zeit, um nachzuholen. Versuchen Sie, sich innerhalb weniger Minuten erneut anzumelden.
Ursache
Wenn ein Benutzer gezwungen ist, sein Kennwort bei der ersten Anmeldung Azure Active Directory (Azure AD) zu ändern, akzeptiert der Kennwortrückschreibvorgang das temporäre Kennwort für die Anmeldung, und der Benutzer wird aufgefordert, ein neues Kennwort anzugeben. Das Kennwortrückschreiben versucht, das Kennwort lokal zu ändern, und wartet dann. Wenn das lokale Update erfolgreich ist, versucht das Kennwortrückschreiben, das Kennwort in Azure AD zu ändern. Während eines Kennwortänderungsvorgangs überprüft das Kennwortrückschreiben das aktuelle Kennwort und stellt dann das neue Kennwort bereit, das im entsprechenden Verzeichnis aktualisiert werden soll.
Ein Timing-Problem kann jedoch zu dieser Warnung führen, wenn der Versuch, sich unmittelbar nach dem Zurücksetzen des lokalen Active Directory-Kennworts anzumelden, auftritt. This issue occurs if the user has the User must change password at next logon option selected, and the domain authentication is configured for Pass-through Authentication (PTA).
In diesem Szenario versucht der Benutzer, sich anzumelden, bevor die Kennworthashsynchronisierung die Synchronisierung des temporären Kennworts mit Azure AD beendet. Da PTA jedoch konfiguriert ist, wird die Authentifizierung an das lokale Active Directory umgeleitet. Der Benutzer kann sich jetzt erfolgreich bei Azure AD anmelden und wird dann gezwungen, das Kennwort bei der ersten Anmeldung zu ändern. Wenn die Kennwortänderung erfolgreich ist, aktualisiert das Kennwortrückschreiben das neue Kennwort im lokalen Active Directory und in Azure AD. Die Anmeldenachricht besagt jedoch: "Unsere Server benötigen etwas Zeit, um nachzuholen." Dies liegt daran, dass das temporäre Kennwort nicht mit dem aktuellen Kennwort in Azure AD übereinstimmte.
Lösung
Nachdem ein Active Directory-Administrator das Kennwort lokal zurückgesetzt hat, dauert Azure AD Verbinden mindestens zwei Minuten, um das temporäre Kennwort mit Azure AD zu synchronisieren. Um zu vermeiden, dass diese Warnmeldung angezeigt wird, muss der Benutzer mindestens zwei Minuten warten, um sich anzumelden und das Kennwort zu aktualisieren. Dadurch wird Zeit für die Kennworthashsynchronisierung zum Synchronisieren des temporären Kennworts bereitgestellt.