Problembehandlung beim Fehlercode "PublicIPAddressCannotBeDeleted", "InUseSubnetCannotBeDeleted" oder "InUseNetworkSecurityGroupCannotBeDeleted"

In diesem Artikel wird erläutert, wie Sie den Oder-Fehler identifizieren und beheben, der PublicIPAddressCannotBeDeleted``InUseSubnetCannotBeDeleted``InUseNetworkSecurityGroupCannotBeDeleted auftritt, wenn Sie versuchen, einen Microsoft Azure Kubernetes Service (AKS)-Cluster zu löschen.

Problembeschreibung

Wenn Sie versuchen, einen AKS-Cluster zu löschen, wird eine der folgenden Fehlermeldungen angezeigt:

  • Für den PublicIPAddressCannotBeDeleted Fehlercode:

    {

    message: "Public IP address "/providers/Microsoft.Network/publicIPAddresses/ can not be deleted since it is still allocated to resource "/providers/Microsoft.Network/loadBalancers/kubernetes/frontendIPConfigurations/" . Um die öffentliche IP zu löschen, trennen Sie die Zuordnung/Trennung der öffentlichen IP-Adresse von der Ressource."

    }

  • Für den InUseSubnetCannotBeDeleted Fehlercode:

    {

    message: "Subnet aks-subnet is in use by "/Microsoft.Network/networkInterfaces/|providers| Microsoft.Compute|virtualMachineScaleSets|vmss|virtualMachines|1|networkInterfaces|aks-worker-vmss/ipConfigurations/ipconfig1 und kann nicht gelöscht werden. Um das Subnetz zu löschen, löschen Sie alle Ressourcen innerhalb des Subnetzes."

    }

  • Für den InUseNetworkSecurityGroupCannotBeDeleted Fehlercode:

    {

    Meldung: "Netzwerksicherheitsgruppe "/Microsoft.Network/networkSecurityGroups/test" kann nicht gelöscht werden, da sie von den folgenden Ressourcen verwendet wird: "/Microsoft.Network/virtualNetworks/test/subnets/test". Um die Netzwerksicherheitsgruppe zu löschen, entfernen Sie die Zuordnung zu den Ressourcen."

    }

Ursache

Der AKS-Cluster ist einem Subnetz, einer Netzwerksicherheitsgruppe (Network Security Group, NSG) oder einer bestimmten öffentlichen IP-Adresse zugeordnet, die derzeit verwendet wird. Diese Zuordnung verhindert, dass Sie den Cluster löschen.

Lösung

Wenn das Problem weiterhin besteht, öffnen Sie ein neues Supportticket.