Problembehandlung bei der Ausnahme "Cloud Service (classic) InvalidModel"
Wichtig
Cloud Services (klassisch) ist für neue Kunden veraltet und wird am 31. August 2024 für alle Kunden eingestellt. Für neue Bereitstellungen sollte das neue Azure Resource Manager-basierte Bereitstellungsmodell Azure Cloud Services (erweiterter Support) verwendet werden.
Dieser Artikel hilft Ihnen bei der Problembehandlung bei einer InvalidModel- oder BadRequest-Ausnahme, die bei der Bereitstellung von Azure-Clouddiensten auftritt.
Ursache
Eine InvalidModel- oder BadRequest-Ausnahme wurde während der Bereitstellung aufgrund eines Konflikts zwischen Dienstkonfiguration und Definitionsdatei ausgelöst.
Lösung
Überprüfen Sie die Dienstkonfigurationsdateien (CSCFG) und die Dienstdefinitionsdateien (CSDEF), damit alle Parameter korrekt eingegeben werden.
Verwenden Sie das Azure Cloud Services -Konfigurationsschema (CSCFG-Datei) und das klassische Azure Cloud Services-Definitionsschema (CSDEF-Datei) als Verweise für die Korrektur jeder Datei.