Problembehandlung für Ausnahmen bei der Wiederverwendung von Cloud-Dienstrollen (klassisch)

Wichtig

Cloud Services (klassisch) ist für neue Kunden veraltet und wird am 31. August 2024 für alle Kunden eingestellt. Für neue Bereitstellungen sollte das neue Azure Resource Manager-basierte Bereitstellungsmodell Azure Cloud Services (erweiterter Support) verwendet werden.

Dieser Artikel hilft Ihnen bei der Problembehandlung von UpdateDeploymentRoleRecycleThresholdReached-Ausnahmen, die während der Bereitstellung von Clouddiensten auftreten.

Problembeschreibung

Ihre Dienstrolleninstanzen wurden während eines Updates oder Upgrades kontinuierlich wiederverwendet. Das Update oder Upgrade mit Ihren Konfigurationseinstellungen verhinderte die Ausführung der Rolleninstanzen.

Die folgende Meldung wird angezeigt:

Ihre Rolleninstanzen wurden während eines Update- oder Upgradevorgangs mehrmals wiederverwendet. Dies gibt an, dass die neue Version Ihres Diensts oder die Konfigurationseinstellungen, die Sie beim Konfigurieren des Diensts angegeben haben, verhindern, dass die Rolleninstanzen ausgeführt werden. Vergewissern Sie sich, dass der Code keine unbehandelten Ausnahmen auslöst und ob die Konfigurationseinstellungen korrekt sind, und starten Sie dann einen weiteren Aktualisierungs- oder Upgradevorgang.

Ursache

Eine UpdateDeploymentRoleRecycleThresholdReached-Ausnahme bedeutet, dass die Rolleninstanzen des Clouddiensts während eines Updates eine Weile wiederverwendet wurden.

Weitere Informationen zu unbehandelten Rollen ausnahmen finden Sie unter allgemeine Probleme, die dazu führen, dass Azure Cloud Service (klassische) Rollen wiederverwendet werden.

Lösung

Führen Sie einen der folgenden Schritte durch, um dieses Problem zu beheben:

  • Löschen Sie den Bereitstellungsplatz, aus dem die Rollen wiederverwendet werden. Führen Sie dann eine neue Bereitstellung in einem leeren Steckplatz aus.

  • Erstellen Sie eine neue Clouddienstinstanz, stellen Sie sie bereit, und aktualisieren Sie den kanonischen Namen des Diensts (CName).

Was geschieht, wenn Sie die IP-Adresse, die Ihrem vorhandenen Bereitstellungsplatz zugeordnet ist, nicht verlieren möchten? Führen Sie dann die folgenden Schritte aus, um die Adresse zu reservieren und freizugeben. Weitere Informationen finden Sie unter Reservierte IP-Adressen für Cloud Services & Virtuelle Computer.

  1. Reservieren Sie die IP-Adresse des vorhandenen Bereitstellungsplatzes.

  2. Geben Sie die zugeordnete reservierte IP-Adresse frei.

  3. Löschen Sie den Bereitstellungsplatz.

  4. Erstellen Sie eine neue Bereitstellung für diesen Slot.

  5. Ordnen Sie die erforderliche reservierte IP-Adresse diesem Clouddienst-Slot zu.