Problembehandlung bei Windows-VM-Betriebssystemstartfehlern

In diesem Artikel wird erläutert, warum eine Windows-VM nicht gestartet werden kann und wie Sie das Problem lösen können.

Problembeschreibung

Wenn Sie den Screenshot des virtuellen Computers (VM) ziehen, zeigt der Screenshot die Meldung, dass die Startpartition nicht gefunden wurde:

Boot failure. Reboot and Select proper Boot device or Insert Boot Media in selected Boot device

Bildschirm "Startfehler"

Ursachen

Für diesen Fehler gibt es mehrere Ursachen:

  • Das Betriebssystem kann nicht gestartet werden, da die Partition, auf der sich der BcD (Boot Configuration Data)-Speicher befindet, inaktiv ist.
  • Das Betriebssystem kann aufgrund von BCD Corruption nicht gestartet werden.
  • Das Betriebssystem kann nicht gestartet werden, weil der Startsektor nicht gefunden wurde.

Lösung

Tipp

Wenn Sie eine aktuelle Sicherung des virtuellen Computers haben, versuchen Sie möglicherweise, den virtuellen Computer aus der Sicherung wiederherzustellen, um das Startproblem zu beheben.

Übersicht über das Verfahren

  1. Erstellen und Zugreifen auf eine virtuelle Reparatur-VM.
  2. Stellen Sie sicher, dass die Betriebssystempartition aktiv ist.
  3. Beheben Sie den fehlenden Verweis auf den BCD-Speicher.
  4. Erstellen Sie den virtuellen Computer neu.

Hinweis

Wenn dieser Fehler auftritt, ist das Gastbetriebssystem nicht funktionsfähig. Behandeln Sie dieses Problem im Offlinemodus, um dieses Problem zu beheben.

Erstellen und Zugreifen auf einen virtuellen Reparatur-COMPUTER

  1. Verwenden Sie die Schritte 1 bis 3 der VM-Reparaturbefehle, um einen virtuellen Computer reparieren vorzubereiten.
  2. Stellen Sie mithilfe der Remotedesktopverbindung eine Verbindung mit dem virtuellen Computer "Reparieren" herzustellen.

Überprüfen, ob die Betriebssystempartition aktiv ist

Hinweis

Diese Risikominderung gilt nur für virtuelle Computer der Generation 1. Virtuelle Computer der Generation 2 (mit UEFI) verwenden keine aktive Partition.

Überprüfen Sie, ob die Betriebssystempartition, die den BCD-Speicher für den Datenträger enthält, als aktiv gekennzeichnet ist.

  1. Öffnen Sie eine Eingabeaufforderung mit erhöhten Rechten, und öffnen Sie das DISKPART-Tool.

    diskpart

  2. Listen Sie die Datenträger auf dem System auf, suchen Sie nach hinzugefügten Datenträgern, und wählen Sie den neuen Datenträger aus. In diesem Beispiel ist der neue Datenträger Datenträger 1.

    list disk
    sel disk 1
    

    Datenträger 1

  3. Listen Sie alle Partitionen auf dem Datenträger auf, und wählen Sie dann die Partition aus, die Sie überprüfen möchten. In der Regel sind vom System verwaltete Partitionen kleiner und ca. 350 MB groß. In der folgenden Abbildung ist diese Partition Partition 1.

    list partition
    sel partition 1
    

    Partition 1

  4. Überprüfen Sie den Status der Partition. In unserem Beispiel ist Partition 1 nicht aktiv.

    detail partition

    Detailpartition

    1. Wenn die Partition nicht aktiv ist:

      1. Legen Sie das Flag "Aktiv" fest, und überprüfen Sie dann erneut, ob die Änderung ordnungsgemäß durchgeführt wurde.

        active
        detail partition
        

        Active-Flag

  5. Beenden Sie nun das DISKPART-Tool.

    exit

Beheben des fehlenden Verweises im BCD-Speicher

  1. Öffnen Sie eine CMD mit erhöhten Rechten, und führen Sie CHKDSK auf dem Datenträger aus.

    chkdsk <DRIVE LETTER>: /f

  2. Erfassen Sie die aktuellen Starteinrichtungsinformationen, und dokumentieren Sie sie, notieren Sie sich den Bezeichner der aktiven Partition.

    1. Für virtuelle Computer der Generation 1:

      bcdedit /store <drive letter>:\boot\bcd /enum

      1. Wenn dieser Befehl aufgrund nicht gefundener Fehler nicht gefunden wird, wechseln Sie zur \boot\bcd folgenden Gegenmaßnahmen.

      2. Notieren Sie sich den Bezeichner des Windows-Startladeladefelds. Dieser Bezeichner ist der Bezeichner mit dem \windows\system32\winload.efi Pfad.

        Ausgleich 2 – Windows-ID 1

    2. Für virtuelle Computer der Generation 2:

      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /enum

      1. Wenn dieser Fehler aufgrund nicht gefunden wird, wechseln Sie zur \boot\bcd folgenden Gegenmaßnahmen.

      2. Notieren Sie sich den Bezeichner des Windows-Startladeladefelds. Dies ist der \windows\system32\winload.efi Pfad.

        Ausgleich 2 – Windows-ID 2

  3. Führen Sie die folgenden Befehle aus:

    1. Für virtuelle Computer der Generation 1:

      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {bootmgr} device partition=<BCD FOLDER - DRIVE LETTER>:
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {bootmgr} integrityservices enable
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} device partition=<WINDOWS FOLDER - DRIVE LETTER>:
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} integrityservices enable
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} recoveryenabled Off
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} osdevice partition=<WINDOWS FOLDER - DRIVE LETTER>:
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} bootstatuspolicy IgnoreAllFailures
      

      Hinweis

      Falls die VHD über eine einzelne Partition verfügt und sich sowohl der #A0 als auch der #A1 auf demselben Volume befinden, und wenn das oben beschriebene Setup nicht funktioniert hat, versuchen Sie, die Partitionswerte durch *boot _zu ersetzen.

      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {bootmgr} device boot
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {bootmgr} integrityservices enable
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} device boot
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} integrityservices enable
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} recoveryenabled Off
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} osdevice boot
      bcdedit /store <BCD FOLDER - DRIVE LETTER>:\boot\bcd /set {<IDENTIFIER>} bootstatuspolicy IgnoreAllFailures
      
    2. Für _ Generation 2* VM:

      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {bootmgr} device partition=<Volume Letter of EFI System Partition>:
      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {bootmgr} integrityservices enable
      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {<IDENTIFIER>} device partition=<WINDOWS FOLDER - DRIVE LETTER>:
      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {<IDENTIFIER>} integrityservices enable
      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {<IDENTIFIER>} recoveryenabled Off
      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {<IDENTIFIER>} osdevice partition=<WINDOWS FOLDER - DRIVE LETTER>:
      bcdedit /store <Volume Letter of EFI System Partition>:EFI\Microsoft\boot\bcd /set {<IDENTIFIER>} bootstatuspolicy IgnoreAllFailures
      

Neuerstellen des virtuellen Computers

Verwenden Sie Schritt 5 der VM-Reparaturbefehle, um den virtuellen Computer neu zu erstellen.

Nächste Schritte

Wenn Sie die Ursache des Problems immer noch nicht ermitteln können und weitere Hilfe benötigen, können Sie ein Supportticket beim Microsoft Customer Support öffnen.

Wenn Sie zu irgendeinem Zeitpunkt in diesem Artikel weitere Hilfe benötigen, können Sie sich an die Azure-Experten in den MSDN Azure- und Stack Overflow-Foren wenden. Alternativ können Sie einen Azure-Supportvorfall melden. Wechseln Sie zur Azure-Supportwebsite,und wählen Sie "Support erhalten" aus. Informationen zur Verwendung der Unterstützung von Azure finden Sie in den häufig gestellten Fragen zum Microsoft Azure-Support.