Problembehandlung für einen allgemeinen RdP-Fehler in Azure VM

In diesem Artikel wird ein allgemeiner Fehler beschrieben, der möglicherweise auftritt, wenn Sie eine Remotedesktopprotokollverbindung (RDP) mit einem virtuellen Windows-Computer (VM) in Azure herstellen.

Problembeschreibung

Wenn Sie eine RDP-Verbindung mit einer Fenster-VM in Azure herstellen, wird möglicherweise die folgende allgemeine Fehlermeldung angezeigt:

Remotedesktop kann aus einem der folgenden Gründe keine Verbindung mit dem Remotecomputer herstellen:

  1. Remotezugriff auf den Server ist nicht aktiviert

  2. Der Remotecomputer ist deaktiviert

  3. Der Remotecomputer ist im Netzwerk nicht verfügbar

Stellen Sie sicher, dass der Remotecomputer aktiviert und mit dem Netzwerk verbunden ist und dass der Remotezugriff aktiviert ist.

Ursache

Dieses Problem kann aus den folgenden Ursachen auftreten:

Ursache 1

Die Komponente RDP ist wie folgt deaktiviert:

  • Auf Komponentenebene
  • Auf Listenerebene
  • Auf dem Terminalserver
  • Auf der Remotedesktopsitzungshostrolle

Ursache 2

Remotedesktopdienste (TermService) werden nicht ausgeführt.

Ursache 3

Der RDP-Listener ist falsch konfiguriert.

Lösung

Bevor Sie diese Schritte ausführen, erstellen Sie eine Momentaufnahme des Betriebssystemdatenträgers des betroffenen virtuellen Computers als Sicherung. Um dieses Problem zu beheben, verwenden Sie serielles Steuerelement, oder reparieren Sie den virtuellen Computer offline.

Serielle Konsole

Schritt 1: Öffnen der CMD-Instanz in der Konsole "Serial"

  1. Greifen Sie auf die serielle Konsole zu, indem Sie "Support & Troubleshooting Serial console > (Preview) " auswählen. Wenn das Feature auf dem virtuellen Computer aktiviert ist, können Sie den virtuellen Computer erfolgreich verbinden.

  2. Erstellen Sie einen neuen Kanal für eine CMD-Instanz. Geben Sie CMD ein, um den Kanal zu starten, um den Kanalnamen zu erhalten.

  3. Wechseln Sie zu dem Kanal, auf dem die CMD-Instanz ausgeführt wird, in diesem Fall sollte es Kanal 1 sein.

    ch -si 1
    

Schritt 2: Überprüfen Sie die Werte der RDP-Registrierungsschlüssel:

  1. Überprüfen Sie, ob das RDP durch Gruppenpolizistes deaktiviert ist.

    REM Get the group policy setting
    reg query "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v fDenyTSConnections
    

    Wenn die Gruppenrichtlinie besagt, dass RDP deaktiviert ist (fDenyTSConnections-Wert 0x1), führen Sie den folgenden Befehl aus, um den Dienst "TermService" zu aktivieren. Wenn der Registrierungsschlüssel nicht gefunden wird, ist keine Gruppenrichtlinie zum Deaktivieren des RdP konfiguriert. Sie können mit dem nächsten Schritt wechseln.

    REM update the fDenyTSConnections value to enable TermService service
    reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v fDenyTSConnections /t REG_DWORD /d 0 /f
    

    Hinweis

    In diesem Schritt wird der Dienst "TermService" vorübergehend aktiviert. Die Änderung wird zurückgesetzt, wenn die Gruppenrichtlinieneinstellungen aktualisiert werden. Um das Problem zu beheben, müssen Sie überprüfen, ob der Dienst TermService durch die lokale Gruppenrichtlinie oder die Domänengruppenrichtlinie deaktiviert ist, und dann die Richtlinieneinstellungen entsprechend aktualisieren.

  2. Überprüfen Sie die aktuelle Remoteverbindungskonfiguration.

    REM Get the local remote connection setting
    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections
    

    Wenn der Befehl eine 0x1, lässt der virtuelle Computer keine Remoteverbindung zu. Lassen Sie dann die Remoteverbindung mit dem folgenden Befehl zu:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 0 /f
    
  3. Überprüfen Sie die aktuelle Konfiguration des Terminalservers.

    REM Get the local remote connection setting
    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v TSEnabled
    

    Wenn der Befehl 0 zurückgibt, ist der Terminalserver deaktiviert. Aktivieren Sie dann den Terminalserver wie folgt:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v TSEnabled /t REG_DWORD /d 1 /f
    
  4. Das Terminalservermodul wird auf den Drainmodus festgelegt, wenn sich der Server in einer Terminalserverfarm (RDS oder Citrix) befindet. Überprüfen Sie den aktuellen Modus des Terminalservermoduls.

    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v TSServerDrainMode
    

    Wenn der Befehl "1" zurückgibt, wird das Terminalservermodul auf den Drainmodus festgelegt. Legen Sie dann das Modul wie folgt auf den Arbeitsmodus ein:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v TSServerDrainMode /t REG_DWORD /d 0 /f
    
  5. Überprüfen Sie, ob Sie eine Verbindung mit dem Terminalserver herstellen können.

    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v TSUserEnabled
    

    Wenn der Befehl 1 zurückgibt, können Sie keine Verbindung mit dem Terminalserver herstellen. Aktivieren Sie dann die Verbindung wie folgt:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v TSUserEnabled /t REG_DWORD /d 0 /f
    
  6. Überprüfen Sie die aktuelle Konfiguration des RDP-Listeners.

    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp" /v fEnableWinStation
    

    Wenn der Befehl 0 zurückgibt, ist der LISTENER FÜR DIEP deaktiviert. Aktivieren Sie dann den Listener wie folgt:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp" /v fEnableWinStation /t REG_DWORD /d 1 /f
    
  7. Überprüfen Sie, ob Sie eine Verbindung mit dem RDP-Listener herstellen können.

    reg query "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp" /v fLogonDisabled
    

    Wenn der Befehl 1 zurückgibt, können Sie keine Verbindung mit dem RDP-Listener herstellen. Aktivieren Sie dann die Verbindung wie folgt:

    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\Winstations\RDP-Tcp" /v fLogonDisabled /t REG_DWORD /d 0 /f
    
  8. Starten Sie den virtuellen Computer neu.

  9. Beenden Sie die CMD-Instanz exit durch Eingabe, und drücken Sie dann zweimal die EINGABETASTE.

  10. Starten Sie den virtuellen Computer neu, indem Sie restart ihn eingeben, und stellen Sie dann eine Verbindung mit dem virtuellen Computer herzustellen.

Wenn das Problem weiterhin besteht, wechseln Sie zu Schritt 2.

Schritt 2: Aktivieren von Remotedesktopdiensten

Weitere Informationen finden Sie unter Remotedesktopdienste starten nicht auf einer Azure-VM.

Schritt 3: Zurücksetzen des RDP-Listeners

Weitere Informationen finden Sie unter Remotedesktop, der in Azure VM häufig getrennt wird.

Offlinereparatur

Schritt 1: Aktivieren von Remotedesktop

  1. Fügen Sie den Betriebssystemdatenträger an einen Wiederherstellungs-VM an.

  2. Starten Sie eine Remotedesktopverbindung mit der Wiederherstellungs-VM.

  3. Stellen Sie sicher, dass der Datenträger in der Datenträgerverwaltungskonsole als Online gekennzeichnet ist. Notieren Sie sich den Laufwerkbuchstaben, der dem angeschlossenen Betriebssystemdatenträger zugewiesen ist.

  4. Starten Sie eine Remotedesktopverbindung mit der Wiederherstellungs-VM.

  5. Öffnen Sie eine Eingabeaufforderungssitzung mit erhöhten Rechten (Als Administrator ausführen). Führen Sie die folgenden Skripts aus. In diesem Skript wird davon ausgegangen, dass der Laufwerkbuchstabe, der dem angeschlossenen Betriebssystemdatenträger zugewiesen ist, F ist. Ersetzen Sie diesen Laufwerkbuchstaben durch den entsprechenden Wert für Ihren virtuellen Computer.

    reg load HKLM\BROKENSYSTEM F:\windows\system32\config\SYSTEM.hiv 
    reg load HKLM\BROKENSOFTWARE F:\windows\system32\config\SOFTWARE.hiv 
    
    REM Ensure that Terminal Server is enabled 
    
    reg add "HKLM\BROKENSYSTEM\ControlSet001\control\Terminal Server" /v TSEnabled /t REG_DWORD /d 1 /f 
    reg add "HKLM\BROKENSYSTEM\ControlSet002\control\Terminal Server" /v TSEnabled /t REG_DWORD /d 1 /f 
    
    REM Ensure Terminal Service is not set to Drain mode 
    reg add "HKLM\BROKENSYSTEM\ControlSet001\control\Terminal Server" /v TSServerDrainMode /t REG_DWORD /d 0 /f 
    reg add "HKLM\BROKENSYSTEM\ControlSet002\control\Terminal Server" /v TSServerDrainMode /t REG_DWORD /d 0 /f 
    
    REM Ensure Terminal Service has logon enabled 
    reg add "HKLM\BROKENSYSTEM\ControlSet001\control\Terminal Server" /v TSUserEnabled /t REG_DWORD /d 0 /f 
    reg add "HKLM\BROKENSYSTEM\ControlSet002\control\Terminal Server" /v TSUserEnabled /t REG_DWORD /d 0 /f 
    
    REM Ensure the RDP Listener is not disabled 
    reg add "HKLM\BROKENSYSTEM\ControlSet001\control\Terminal Server\Winstations\RDP-Tcp" /v fEnableWinStation /t REG_DWORD /d 1 /f 
    reg add "HKLM\BROKENSYSTEM\ControlSet002\control\Terminal Server\Winstations\RDP-Tcp" /v fEnableWinStation /t REG_DWORD /d 1 /f 
    
    REM Ensure the RDP Listener accepts logons 
    reg add "HKLM\BROKENSYSTEM\ControlSet001\control\Terminal Server\Winstations\RDP-Tcp" /v fLogonDisabled /t REG_DWORD /d 0 /f 
    reg add "HKLM\BROKENSYSTEM\ControlSet002\control\Terminal Server\Winstations\RDP-Tcp" /v fLogonDisabled /t REG_DWORD /d 0 /f 
    
    REM RDP component is enabled 
    reg add "HKLM\BROKENSYSTEM\ControlSet001\control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 0 /f 
    reg add "HKLM\BROKENSYSTEM\ControlSet002\control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 0 /f 
    reg add "HKLM\BROKENSOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v fDenyTSConnections /t REG_DWORD /d 0 /f 
    
    reg unload HKLM\BROKENSYSTEM 
    reg unload HKLM\BROKENSOFTWARE 
    
  6. Wenn der virtuelle Computer einer Domäne beigetreten ist, überprüfen Sie den folgenden Registrierungsschlüssel, um zu überprüfen, ob eine Gruppenrichtlinie vorhanden ist, die RDP deaktiviert.

    HKLM\BROKENSOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fDenyTSConnectionS
    

    Wenn dieser Schlüsselwert auf 1 festgelegt ist, bedeutet dies, dass RDP von der Richtlinie deaktiviert wird. Um Remotedesktop über die Gruppenrichtlinienrichtlinie zu aktivieren, ändern Sie die folgende Richtlinie vom Domänencontroller:

    Computerkonfiguration\Richtlinien\Administrative Vorlagen:

    Richtliniendefinitionen\Windows-Komponenten\Remotedesktopdienste\Remotedesktopsitzungshost\Verbindungen\Remoteverbindung für Benutzer mithilfe von Remotedesktopdiensten zulassen

  7. Trennen Sie den Datenträger vom virtuellen Computer.

  8. Erstellen Sie einen neuen virtuellen Computer auf dem Datenträger.

Wenn das Problem weiterhin besteht, wechseln Sie zu Schritt 2.

Schritt 2: Aktivieren von Remotedesktopdiensten

Weitere Informationen finden Sie unter Remotedesktopdienste starten nicht auf einer Azure-VM.

Schritt 3: Zurücksetzen des RDP-Listeners

Weitere Informationen finden Sie unter Remotedesktop, der in Azure VM häufig getrennt wird.

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